收集 A10 網路負載平衡器記錄檔
剖析器版本:7.0
本文說明如何使用 Bindplane 代理程式,將 A10 Network Load Balancer 記錄擷取至 Google Security Operations。
A10 Networks 提供應用程式推送控制器 (ADC) 和負載平衡器,可最佳化及保護應用程式流量。A10 Thunder 系列支援伺服器負載平衡、SSL 卸載、DDoS 防護和網頁應用程式防火牆功能。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 A10 負載平衡器之間的網路連線
- 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
- A10 負載平衡器 CLI 的特殊存取權 (管理員憑證)
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
bindplane-ingest)。 - 「服務帳戶說明」:輸入說明 (例如
Bindplane agent log ingestion)。
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 上的/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存路徑相符。 - 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。設定匯出工具時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」 > 「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」 > 「設定檔」。
複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟命令提示字元或 PowerShell。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
安裝 Linux
- 開啟具有根層級或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/a10_lb: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: A10_LOAD_BALANCER raw_log_field: body service: pipelines: logs/a10_to_chronicle: receivers: - udplog exporters: - chronicle/a10_lb
設定參數
替換下列預留位置:
接收器設定:
listen_address:要監聽的 IP 位址和通訊埠:0.0.0.0:在所有介面上監聽 (建議)- 通訊埠
514是標準的系統記錄通訊埠 (在 Linux 上需要根層級權限;如果沒有根層級權限,請使用1514)
Exporter 設定:
creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:從 Google SecOps 控制台複製的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會在這個值前面加上chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。project:依序前往「IAM 與管理」>「設定」,然後將<PROJECT_NUMBER>替換為專案編號。endpoint:維持設為chronicle.googleapis.com。
舊版 Ingestion API 匯出工具
如果您使用方式 2 的擷取驗證檔案,請將
exporters區塊替換成下列內容。將creds_file_path設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/a10_lb: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: A10_LOAD_BALANCER raw_log_field: body
儲存設定檔
- 編輯完畢後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」>「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector檢查記錄是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R鍵,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector檢查記錄是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
在 A10 負載平衡器上設定系統記錄轉送功能
- 使用 SSH 用戶端,建立與 A10 負載平衡器的 SSH 連線。
執行下列指令,進入設定模式:
config執行下列指令,設定遠端系統記錄檔伺服器:
logging host <BINDPLANE_IP> <PORT>- 將
<BINDPLANE_IP>替換為 Bindplane 代理程式主機的 IP 位址 (例如192.168.1.100)。 - 將
<PORT>替換為在 Bindplane 接收器中設定的通訊埠 (例如514)。
- 將
執行下列指令,設定嚴重性等級:
logging level information執行下列指令,確認 syslog 記錄功能已啟用:
logging enable儲存設定,確保重新啟動後仍會保留:
write memory完整的 CLI 設定範例:
config logging host 192.168.1.100 514 logging level information logging enable write memory
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
dns |
additional.fields.dns.value.string_value |
這個值取自 grok 模式擷取的 dns 欄位。 |
dns_server |
additional.fields.dns_server.value.string_value |
這個值取自 grok 模式擷取的 dns_server 欄位。 |
gslb |
additional.fields.gslb.value.string_value |
這個值取自 grok 模式擷取的 gslb 欄位。 |
host_name |
principal.hostnameprincipal.asset.hostname |
這個值取自 grok 模式擷取的 host_name 欄位。 |
httpmethod |
network.http.method |
這個值取自 grok 模式擷取的 httpmethod 欄位。 |
partion_id |
additional.fields.partion_id.value.string_value |
這個值取自 grok 模式擷取的 partion_id 欄位。 |
prin_ip |
principal.ipprincipal.asset.ip |
這個值取自 grok 模式擷取的 prin_ip 欄位。 |
prin_mac |
principal.mac |
這個值取自 grok 模式擷取的 prin_mac 欄位,並移除點,每兩個字元插入半形冒號。 |
prin_port |
principal.port |
這個值取自 grok 模式擷取的 prin_port 欄位,並轉換為整數。 |
proto |
network.ip_protocol |
這個值取自 grok 模式擷取的 proto 欄位。如果 message 欄位包含 UDP,值會設為 UDP。 |
sessionid |
network.session_id |
這個值取自 grok 模式擷取的 sessionid 欄位。 |
status_code |
network.http.response_code |
這個值取自 grok 模式擷取的 status_code 欄位,並轉換為整數。 |
tar_ip |
target.iptarget.asset.ip |
這個值取自 grok 模式擷取的 tar_ip 欄位。 |
tar_mac |
target.mac |
這個值取自 grok 模式擷取的 tar_mac 欄位,系統會移除點號,並在每兩個字元之間插入冒號。 |
tar_port |
target.port |
這個值取自 grok 模式擷取的 tar_port 欄位,並轉換為整數。 |
time |
metadata.event_timestamp.seconds |
系統會使用多種可能的日期格式,從 grok 模式擷取的 time 欄位剖析值。 |
url |
target.url |
這個值取自 grok 模式擷取的 url 欄位。 |
user |
principal.user.userid |
這個值取自 grok 模式擷取的 user 欄位。 |
| 不適用 | metadata.event_type |
由剖析器邏輯根據主體和目標資訊的存在與否決定: - NETWORK_CONNECTION:如果主體和目標資訊都存在。- STATUS_UPDATE:如果只有主要資訊。- GENERIC_EVENT:其他情況。 |
| 不適用 | metadata.log_type |
硬式編碼為 A10_LOAD_BALANCER。 |
| 不適用 | network.application_protocol |
如果 proto 欄位為 HTTP,請設為 HTTP。 |
dhost |
event.idm.read_only_udm.target.hostname |
從變更記錄對應 |
inter_host |
event.idm.read_only_udm.observer.hostname |
從變更記錄對應 |
virtualserver |
event.idm.read_only_udm.intermediary.hostname |
從變更記錄對應 |
Script_name |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
len |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
seq_id |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
desc |
event.idm.read_only_udm.metadata.description |
從變更記錄對應 |
target_user |
event.idm.read_only_udm.target.user.userid |
從變更記錄對應 |
rule_name |
event.idm.read_only_udm.security_result.rule_name |
從變更記錄對應 |
vendor_severity |
event.idm.read_only_udm.security_result.severity |
從變更記錄對應 |
facility |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
proxy_machine_ip |
event.idm.read_only_udm.intermediary.ip 和 event.idm.read_only_udm.intermediary.asset.ip |
從變更記錄對應 |
event_dt |
event.idm.read_only_udm.metadata.event_timestamp |
從變更記錄對應 |
prin_host |
principal.hostname |
從變更記錄對應 |
app |
target.application |
從變更記錄對應 |
device_version |
metadata.product_version |
從變更記錄對應 |
device_vendor |
metadata.vendor_name |
從變更記錄對應 |
device_product |
metadata.product_name |
從變更記錄對應 |
event_name" and "device_event_class_id |
metadata.product_event_type |
從變更記錄對應 |
severity |
security_result.severity |
從變更記錄對應 |
src |
principal.ip |
從變更記錄對應 |
spt |
principal.port |
從變更記錄對應 |
dst |
target.ip |
從變更記錄對應 |
dpt |
target.port |
從變更記錄對應 |
msg |
metadata.description |
從變更記錄對應 |
suser |
principal.user.user_display_name |
從變更記錄對應 |
act" and "cn1 |
additional.fields |
從變更記錄對應 |
app_proto |
network.application_protocol |
從變更記錄對應 |
tls_version |
network.tls.version |
從變更記錄對應 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。