Collect OpenText Access Manager (formerly NetIQ Access Manager) logs
This document explains how to ingest OpenText Access Manager (formerly known as NetIQ Access Manager) logs to Google Security Operations using Bindplane.
OpenText Access Manager is an on-premises identity and access management solution that provides single sign-on (SSO), multi-factor authentication, federation, and policy-based access control for web applications and services. It acts as a secure gateway between users and protected resources, enforcing authentication and authorization policies across enterprise environments.
Before you begin
Make sure you have the following prerequisites:
- A Google SecOps instance.
- A host running Windows 2016 or later or a Linux host with
systemd. - Network connectivity: If running behind a proxy, ensure firewall ports are open per the Bindplane agent requirements.
- Privileged access to the OpenText Access Manager Administration Console.
Get Google SecOps ingestion authentication file
- Sign in to the Google SecOps console.
- Go to SIEM Settings > Collection Agents.
- Download the Ingestion Authentication File.
- Save the file securely on the system where Bindplane will be installed.
Get Google SecOps customer ID
- Sign in to the Google SecOps console.
- Go to SIEM Settings > Profile.
- Copy and save the Customer ID from the Organization Details section.
Install the Bindplane agent
Install the Bindplane agent on your Windows or Linux operating system according to the following instructions.
Windows Installation
- Open the Command Prompt or PowerShell as an administrator.
Run the following command:
msiexec /i "[https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi](https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi)" /quiet
Linux Installation
- Open a terminal with root or sudo privileges.
Run the following command:
sudo sh -c "$(curl -fsSlL [https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh](https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh))" install_unix.sh
Additional Installation Resources
For additional installation options, consult this installation guide.
Configure the Bindplane Agent to ingest Syslog and send to Google SecOps
Access the configuration file:
- Locate the
config.yamlfile. Typically, it's in the/opt/observiq-otel-collectordirectory on Linux or in the installation directory on Windows. - Open the file using a text editor (for example,
nano,vi, or Notepad).
- Locate the
Edit the
config.yamlfile as follows:receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/chronicle_w_labels: compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: NETIQ_ACCESS_MANAGER raw_log_field: body ingestion_labels: service: pipelines: logs/source0__chronicle_w_labels-0: receivers: - tcplog exporters: - chronicle/chronicle_w_labels
- Replace the port and IP address as required in your infrastructure.
- Replace
<customer_id>with the actual Customer ID. - Update
/path/to/ingestion-authentication-file.jsonto the file path where the authentication file was saved in the previous steps.
Restart the Bindplane agent to apply the changes
To restart the Bindplane agent in Linux, run the following command:
sudo systemctl restart observiq-otel-collectorTo restart the Bindplane agent in Windows, you can either use the Services console or enter the following command:
net stop observiq-otel-collector && net start observiq-otel-collector
Configure OpenText Access Manager syslog forwarding
- Sign in to the OpenText Access Manager Administration Console.
- Go to Auditing > Syslog.
- Select the Enable Syslog checkbox.
- Provide the following configuration details:
- Syslog Server Address: Enter the IP address of the Bindplane agent host.
- Port: Enter
514. - Facility: Select the appropriate syslog facility (for example, LOCAL0).
- In the Audit Events section, select the event categories to forward:
- Authentication events
- Authorization events
- Administration events
- System events
- Click Apply to save the syslog configuration.
UDM mapping table
| Log Field | UDM Mapping | Logic |
|---|---|---|
version |
about.resource.attribute.labels |
Merged |
_field |
additional.fields |
Merged |
I |
extensions.auth.type |
Mapped: "002E0505","002E001E","002E0046" → AUTHTYPE_UNSPECIFIED, "002E0007","002E000C"... |
host_name |
intermediary.hostname |
Directly mapped |
D |
metadata.description |
Directly mapped |
stringValue3 |
metadata.description |
Directly mapped |
timestamp |
metadata.event_timestamp |
Parsed as RFC3339 |
I |
metadata.event_type |
Mapped: "002E0505","002E001E","002E0046" → USER_LOGIN, 002E0525 → `NETWORK_UNCATEGORIZ... |
has_principal |
metadata.event_type |
Mapped: true → NETWORK_CONNECTION, true → STATUS_UPDATE |
has_user |
metadata.event_type |
Mapped: true → USER_UNCATEGORIZED |
id_sub_event |
metadata.product_event_type |
Directly mapped |
I |
metadata.product_log_id |
Directly mapped |
eventId |
metadata.product_log_id |
Directly mapped |
event_id |
metadata.product_log_id |
Directly mapped |
product |
metadata.product_name |
Directly mapped |
product_version |
metadata.product_version |
Directly mapped |
vendor |
metadata.vendor_name |
Directly mapped |
T |
network.http.user_agent |
Directly mapped |
L |
network.session_id |
Directly mapped |
subTarget |
network.session_id |
Directly mapped |
F |
principal.application |
Directly mapped |
appName |
principal.application |
Directly mapped |
host |
principal.asset.hostname |
Directly mapped |
host_name |
principal.asset.hostname |
Directly mapped |
originator |
principal.asset.hostname |
Directly mapped |
src_ip |
principal.asset.ip |
Merged |
host |
principal.hostname |
Directly mapped |
host_name |
principal.hostname |
Directly mapped |
originator |
principal.hostname |
Directly mapped |
src_ip |
principal.ip |
Merged |
stringValue1 |
principal.user.userid |
Directly mapped |
I |
security_result.action |
Mapped: "002E0505","002E001E","002E0046" → security_action, 002E0525 → `security_actio... |
security_action |
security_result.action |
Merged |
name |
security_result.action_details |
Directly mapped |
g_label |
security_result.detection_fields |
Merged |
h_label |
security_result.detection_fields |
Merged |
impersonatee_session_id_label |
security_result.detection_fields |
Merged |
m_label |
security_result.detection_fields |
Merged |
v_label |
security_result.detection_fields |
Merged |
priority |
security_result.priority_details |
Directly mapped |
A |
security_result.rule_id |
Directly mapped |
severity |
security_result.severity_details |
Mapped values (5 total, e.g. 1 → TRACE, 2 → DEBUG, 4 → INFO) |
result |
security_result.summary |
Directly mapped |
process_name |
target.application |
Directly mapped |
dst_ip |
target.asset.ip |
Merged |
dst_ip |
target.ip |
Merged |
B |
target.resource.id |
Directly mapped |
O |
target.resource.name |
Directly mapped |
Y |
target.url |
Directly mapped |
_group_identifier |
target.user.group_identifiers |
Merged |
U |
target.user.userid |
Directly mapped |
device_name |
target.user.userid |
Directly mapped |
| N/A | extensions.auth.type |
Constant: AUTHTYPE_UNSPECIFIED |
| N/A | metadata.event_type |
Constant: USER_LOGIN |
| N/A | metadata.product_name |
Constant: Netiq_Access_Manager |
| N/A | metadata.vendor_name |
Constant: Netiq |
| N/A | security_result.severity_details |
Constant: TRACE |
Need more help? Get answers from Community members and Google SecOps professionals.