收集 Absolute Secure Endpoint 記錄

剖析器版本:2.0

支援的服務:

本文說明如何使用 Bindplane 代理程式,將 Absolute Secure Endpoint (舊稱 Absolute Data & Device Security) 記錄擷取至 Google Security Operations。剖析器會從 SIEM 連接器記錄中,擷取 SYSLOG + 或 KV (CEF) 格式的欄位。這個剖析器會使用 grok 模式來識別及擷取欄位,然後根據 kv_pair 或 cef 資料是否存在,使用條件邏輯將擷取的欄位對應至 UDM 結構定義。系統會根據識別出的欄位和值,套用特定對應和轉換,處理狀態心跳訊號和安全性事件資料。

事前準備

請確認您符合下列必要條件:

  • Google SecOps 執行個體
  • 搭載 systemd 的 Windows 2016 以上版本或 Linux 主機,用於執行 Bindplane 代理程式
  • Windows Server (2012 以上版本),用於代管 Absolute SIEM Connector 服務
  • 在託管 SIEM 連接器的 Windows Server 上,安裝 Microsoft .NET Framework 4.0 以上版本
  • 具備 Absolute Secure Endpoint 控制台的特殊權限存取權,並啟用 SIEM 整合功能
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:在 2027 年 7 月 20 日停用 Ingestion API 前,請繼續使用擷取驗證檔案 (選項 2)。
  1. 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 請提供下列設定詳細資料:
    • 服務帳戶名稱:輸入帳戶名稱 (例如 bindplane-ingest)。
    • 「服務帳戶說明」:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存路徑相符。
  12. 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。設定匯出工具時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM Settings」 > 「Collection Agents」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」。
  3. 複製並儲存「機構詳細資料」部分的客戶 ID。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟命令提示字元或 PowerShell。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    

Linux 安裝

  1. 開啟具有根層級或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    

其他安裝資源

如需其他安裝選項,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps

  1. 請按照下列步驟存取設定檔:

    • 開啟 config.yaml 檔案:Linux 上的 /opt/observiq-otel-collector/config.yaml,或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\config.yaml。
    • 使用文字編輯器 (例如 nano、vi 或記事本) 開啟檔案。
  2. 按照下列方式編輯 config.yaml 檔案:

    receivers:
      udplog:
        # Replace the port and IP address as required
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/chronicle_w_labels:
        protocol: https
        endpoint: chronicle.googleapis.com
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        # Replace with your actual customer ID
        customer_id: '<CUSTOMER_ID>'
        # Adjust the path to the service account key file you saved in Option 1
        creds_file_path: '/path/to/secops-key.json'
        compression: gzip
        log_type: 'ABSOLUTE'
        raw_log_field: body
        # Add optional ingestion labels for better organization
        ingestion_labels:
    
    service:
      pipelines:
        logs/source0__chronicle_w_labels-0:
          receivers:
            - udplog
          exporters:
            - chronicle/chronicle_w_labels
    
    • 請根據基礎架構需求,替換通訊埠和 IP 位址。
    • 將 <LOCATION> 替換為 Google SecOps 執行個體的區域。匯出工具會以這個值做為 chronicle.googleapis.com 的前置字元。
    • 將 <PROJECT_NUMBER> 替換為「IAM 與管理」>「設定」中的專案編號。
    • 將 <CUSTOMER_ID> 替換為實際的客戶 ID。
    • 將 /path/to/secops-key.json 更新為服務帳戶金鑰檔案 (選項 1) 的儲存路徑。

舊版擷取 API 匯出工具

  • 如果您使用選項 2 的擷取驗證檔案,請將 exporters 區塊替換為下列內容。將 creds_file_path 設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/chronicle_w_labels:
        compression: gzip
        # Adjust the path to the ingestion authentication file you downloaded in Option 2
        creds_file_path: '/path/to/ingestion-authentication-file.json'
        customer_id: '<CUSTOMER_ID>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: 'ABSOLUTE'
        raw_log_field: body
        ingestion_labels:
    

重新啟動 Bindplane 代理程式,套用變更

  1. 如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
  2. 如要在 Windows 中重新啟動 Bindplane 代理程式,可以使用「服務」控制台,也可以輸入下列指令:

    net stop observiq-otel-collector && net start observiq-otel-collector
    

在 Windows Server 上安裝 Absolute SIEM 連接器

Absolute SIEM Connector 是一項 Windows 服務,可從 Absolute Monitoring Center 擷取警示事件資料,並透過 CEF 格式的 syslog 轉送。SIEM 連接器以 MSI 安裝程式的形式提供,Absolute Customer Center 的 Absolute Data & Device Security (DDS) Professional 和 Premium 客戶可免費下載。

  1. 登入 Absolute Secure Endpoint 控制台 (https://cc.absolute.com/)。
  2. 前往「Customer Center」或「Downloads」部分。
  3. 下載 Absolute SIEM Connector MSI 安裝程式。
  4. 將安裝程式轉移至 Windows Server。
  5. 以管理員身分在 Windows Server 上執行安裝程式。
  6. 按照安裝精靈的指示完成安裝。
  7. 記下安裝目錄 (通常是 C:\Program Files\Absolute Software\Absolute SIEM Connector)。

在 Absolute Secure Endpoint 控制台中啟用 SIEM 整合功能

SIEM 連接器必須先在 Absolute Secure Endpoint Console 中啟用 SIEM 整合,才能擷取事件。

  1. 登入 Absolute Secure Endpoint 控制台 (https://cc.absolute.com/)。
  2. 前往「設定」或「管理」部分。
  3. 前往「SIEM Integration」設定。
  4. 按一下「啟用 SIEM 整合」,或將 SIEM 整合設定切換為「開啟」。
  5. 選取要轉送至 SIEM 的事件類型。
    • 您也可以選取「所有事件類型」,轉送所有可用的記錄。
  6. 按一下「Save」或「Apply」套用設定。

設定 Absolute SIEM 連接器

安裝 SIEM 連接器並在控制台啟用 SIEM 整合功能後,請按照下列步驟設定連接器,將事件傳送至 Bindplane 代理程式:

  1. 在安裝 Absolute SIEM Connector 的 Windows Server 上,開啟 Absolute SIEM Connector 設定工具。
    • 您可以在「開始」選單的「Absolute Software」下方,或安裝目錄中找到這項資訊。
  2. 提供下列設定詳細資料:
    • Syslog 伺服器主機:輸入 Bindplane 代理程式主機的 IP 位址或主機名稱。
    • 「Syslog Server Port」(Syslog 伺服器連接埠):輸入 514 (或在 Bindplane 中設定的連接埠)。
    • 「Protocol」(通訊協定):依據 Bindplane 設定選取「UDP」或「TCP」。
    • 格式:確認已選取「CEF」(通用事件格式)。
    • 更新間隔:設定連接器從 Absolute 擷取事件的頻率。最短為 2 分鐘,最長為 1,440 分鐘或 24 小時。預設值為 60 分鐘。
    • 時區:事件會以世界標準時間時區傳輸,確保各系統之間的一致性。
  3. 按一下 [儲存]。
  4. 啟動或重新啟動 Absolute SIEM Connector 服務:
    • 開啟「服務」 (services.msc)。
    • 選取「Absolute SIEM Connector」服務。
    • 按一下「開始」或「重新啟動」。

UDM 對應表

記錄欄位 UDM 對應 邏輯
pid about.process.pid 直接對應
hostname intermediary.hostname 直接對應
dvc_ip intermediary.ip 已合併
Alert Time metadata.event_timestamp 剖析為 RFC3339
date metadata.event_timestamp 已剖析為 yyyy-MM-dd HH:mm:ss UTC
event_type metadata.event_type 直接對應
eventType metadata.product_event_type 直接對應
event_class metadata.product_event_type 直接對應
device_version metadata.product_version 直接對應
Serial Number principal.asset.asset_id 直接對應
Computer Name principal.hostname 直接對應
actorName principal.hostname 直接對應
objectName principal.hostname 直接對應
objectID principal.resource.product_object_id 直接對應
objectType principal.resource.resource_type 直接對應
roles principal.user.attribute.roles 已合併
actorID principal.user.product_object_id 直接對應
actorName principal.user.userid 直接對應
Condition security_result.description 直接對應
esn_label security_result.detection_fields 已合併
kv_pair security_result.detection_fields 對應:ESN → esn_label
verb security_result.summary 直接對應
Alert ID security_result.threat_id 直接對應
Alert Name security_result.threat_name 直接對應
field_ target.resource.attribute.labels 已合併
不適用 metadata.event_type 常數:GENERIC_EVENT
不適用 metadata.product_name 常數:ABSOLUTE_PLATFORM
不適用 metadata.vendor_name 常數:ABSOLUTE

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。