收集 AIDE (Advanced Intrusion Detection Environment) 記錄
剖析器版本:1.0
本文說明如何使用 Bindplane,將 AIDE (Advanced Intrusion Detection Environment) 記錄檔擷取至 Google Security Operations。AIDE 是檔案完整性監控工具,可偵測 Linux/Unix 系統上的檔案變更。
事前準備
請確認您符合下列必要條件:
- Google SecOps 執行個體
- 執行 AIDE 0.18 以上版本的 Linux 主機 (支援 JSON 格式)
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- AIDE 設定檔的特殊存取權
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 請提供下列設定詳細資料:
- 服務帳戶名稱:輸入帳戶名稱 (例如
bindplane-ingest)。 - 「服務帳戶說明」:輸入說明 (例如
Bindplane agent log ingestion)。
- 服務帳戶名稱:輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 為/opt/observiq-otel-collector/ingestion-auth.json,Windows 為C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存檔案的路徑相符。 - 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。設定匯出工具時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「收集代理程式」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」 > 「設定檔」。
- 複製並儲存「機構詳細資料」專區中的「客戶 ID」。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Linux 作業系統上安裝 Bindplane 代理程式。
Linux 安裝
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
其他安裝資源
如需其他安裝選項,請參閱這份安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
存取設定檔:
- 找出
config.yaml檔案。在 Linux 上,這個檔案通常位於/opt/observiq-otel-collector/目錄。 - 使用文字編輯器 (例如
nano或vi) 開啟檔案。
- 找出
按照下列方式編輯
config.yaml檔案:receivers: udplog: # Replace the port and IP address as required listen_address: "0.0.0.0:514" exporters: chronicle/chronicle_w_labels: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: <CUSTOMER_ID> endpoint: chronicle.googleapis.com # Add optional ingestion labels for better organization log_type: 'AIDE' raw_log_field: body ingestion_labels: service: pipelines: logs/source0__chronicle_w_labels-0: receivers: - udplog exporters: - chronicle/chronicle_w_labels- 請根據基礎架構需求,替換通訊埠和 IP 位址。
- 將
<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會在這個值前面加上chronicle.googleapis.com。 - 將
<PROJECT_NUMBER>替換為「IAM 與管理」>「設定」中的專案編號。 - 將
<CUSTOMER_ID>替換為實際的客戶 ID。 - 將
/path/to/ingestion-authentication-file.json更新為服務帳戶金鑰檔案 (選項 1) 在步驟 1 中儲存的檔案路徑。
舊版 Ingestion API 匯出工具
如果您使用方式 2 的擷取驗證檔案,請將
exporters區塊替換成下列內容。將creds_file_path設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/chronicle_w_labels: compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: <CUSTOMER_ID> endpoint: malachiteingestion-pa.googleapis.com # Add optional ingestion labels for better organization log_type: 'AIDE' raw_log_field: body ingestion_labels:
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector
在 AIDE 上設定 Syslog 轉送
開啟 AIDE 設定檔:
sudo vi /etc/aide/aide.conf前往報表部分。
新增下列設定:
- report_level:輸入
list_entries。 - report_format:輸入
json(適用於 AIDE 0.18 以上版本) 或plain。 - report_url:輸入
syslog:authpriv。
設定範例:
```ini report_level=list_entries report_format=json report_url=syslog:authpriv ```- report_level:輸入
儲存設定。
設定 rsyslog,將 AIDE 記錄轉送至 Bindplane 代理。開啟 rsyslog 設定:
sudo vi /etc/rsyslog.d/aide-forward.conf新增下列設定,將
authpriv設施記錄轉送至 Bindplane 代理程式:authpriv.* @<BINDPLANE_AGENT_IP>:514- 將
<BINDPLANE_AGENT_IP>替換為 Bindplane 代理程式主機的 IP 位址。 - 使用
@進行 UDP 轉送,或使用@@進行 TCP 轉送。
- 將
重新啟動 rsyslog:
sudo systemctl restart rsyslog如果是全新安裝,請初始化 AIDE 資料庫:
sudo aide --init sudo mv /var/lib/aide/aide.db.new /var/lib/aide/aide.db測試設定:
sudo aide --check使用 cron 設定自動檢查:
sudo crontab -e新增下列指令行,每天凌晨 4 點 5 分執行 AIDE:
05 4 * * * root /usr/sbin/aide --check
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
added_label |
principal.asset.attribute.labels |
已合併 |
changed_label |
principal.asset.attribute.labels |
已合併 |
old_acl_label |
principal.asset.attribute.labels |
已合併 |
old_md5_label |
principal.asset.attribute.labels |
已合併 |
old_perms_label |
principal.asset.attribute.labels |
已合併 |
old_sha256_label |
principal.asset.attribute.labels |
已合併 |
old_ts_label |
principal.asset.attribute.labels |
已合併 |
removed_label |
principal.asset.attribute.labels |
已合併 |
total_label |
principal.asset.attribute.labels |
已合併 |
file_path |
principal.file.full_path |
直接對應 |
path |
principal.file.full_path |
直接對應 |
old_size |
principal.file.size |
直接對應 |
host |
principal.hostname |
直接對應 |
sr |
security_result |
已合併 |
new_acl_label |
target.asset.attribute.labels |
已合併 |
new_md5_label |
target.asset.attribute.labels |
已合併 |
new_perms_label |
target.asset.attribute.labels |
已合併 |
new_sha256_label |
target.asset.attribute.labels |
已合併 |
new_ts_label |
target.asset.attribute.labels |
已合併 |
path |
target.file.full_path |
直接對應 |
new_size |
target.file.size |
直接對應 |
| 不適用 | metadata.event_type |
常數:GENERIC_EVENT |
| 不適用 | metadata.product_name |
常數:AIDE |
| 不適用 | metadata.vendor_name |
常數:AIDE |
| 不適用 | principal.application |
常數:aide |
| 不適用 | principal.file.size |
常數:sizedata |
| 不適用 | target.file.size |
常數:sizedata_target |
total_files", "added_files", "removed_files", "changed_files", "old_timestamp", "old_perms", "old_sha256", "old_md5", and "old_acl |
principal.asset.attribute.labels |
從變更記錄對應 |
new_timestamp", "new_perms", "new_sha256", "new_md5", and "new_acl |
target.asset.attribute.labels |
從變更記錄對應 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。