收集 Airlock Digital 應用程式許可清單記錄

剖析器版本:1.0

支援的服務:

本文說明如何使用 Bindplane 代理程式,將 Airlock Digital Application Allowlisting 記錄擷取至 Google Security Operations。

Airlock Digital 是應用程式許可清單和執行控管平台,可在端點強制執行預設拒絕安全性模型,確保只有受信任的應用程式、指令碼和程序可以執行。這個平台提供精細的政策控管機制,可控管檔案、路徑、發布者和父項程序,並提供完整的稽核追蹤記錄,方便管理法規遵循和威脅。Airlock Digital 會產生執行事件、封鎖執行、政策變更和管理動作的記錄,並可使用 syslog、CEF、JSON 或 HTTP(S) 轉送至 SIEM 解決方案。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Airlock Digital 伺服器之間的網路連線
  • 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
  • 具有管理員存取權的 Airlock Digital 伺服器 (內部部署或雲端)
  • Airlock Digital 4.7 以上版本 (支援 syslog 外部記錄)

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
  1. 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 提供下列設定詳細資料:
    • 服務帳戶名稱:輸入帳戶名稱 (例如 bindplane-ingest)。
    • 「服務帳戶說明」:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存路徑相符。
  12. 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。設定匯出工具時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」 > 「設定檔」。
  3. 複製並儲存「機構詳細資料」部分的客戶 ID。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟命令提示字元或 PowerShell。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」。

安裝 Linux

  1. 開啟具有根層級或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為「active (running)」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      tcplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/airlock_digital:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: AIRLOCK_DIGITAL
        raw_log_field: body
    
    service:
      pipelines:
        logs/airlock_digital:
          receivers:
            - tcplog
          exporters:
            - chronicle/airlock_digital
    

設定參數

替換下列預留位置:

  • 接收器設定:

    • tcplog:依通訊協定區分的接收端類型:
      • udplog (適用於 UDP syslog)
      • tcplog (適用於 TCP syslog)
      • syslog 適用於 RFC 3164/5424 syslog
    • 0.0.0.0:要監聽的 IP 位址:
      • 0.0.0.0:在所有介面上監聽 (建議)
      • 監聽單一介面的特定 IP 位址
    • 514:要監聽的通訊埠編號 (例如 514、1514、6514)
  • 匯出工具設定:

    • <customer_id>:先前步驟中的客戶 ID
    • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會以這個值做為 chronicle.googleapis.com 的前置字元。如需完整清單,請參閱「區域性端點」。
    • project:依序前往「IAM 與管理」>「設定」,然後將 <PROJECT_NUMBER> 替換為專案編號。
    • endpoint:請將此值設為 chronicle.googleapis.com。
    • 根據平台,將 creds_file_path 調整為服務帳戶 JSON 金鑰檔案的路徑 (選項 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json

舊版擷取 API 匯出工具

  • 如果您使用方式 2 的擷取驗證檔案,請將 exporters 區塊替換成下列內容。將 creds_file_path 設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/airlock_digital:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: AIRLOCK_DIGITAL
        raw_log_field: body
    

儲存設定檔

  • 編輯完畢後,請儲存檔案:
    • Linux:依序按下 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,套用變更

  • 如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務是否正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 查看記錄檔是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列任一選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
      4. 確認服務是否正在執行:

        sc query observiq-otel-collector
        
      5. 查看記錄檔是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

設定 Airlock Digital 外部記錄

設定 Airlock Digital Server,透過系統記錄檔將記錄轉送至 Bindplane 代理程式。Airlock Digital 支援多種外部記錄格式,包括 Generic Syslog、CEF、JSON、HTTP(S) 和 GELF。

  1. 使用管理員帳戶登入 Airlock Digital Server Console。
  2. 依序前往「系統」 >「外部記錄」。
  3. 按一下「新增」,建立新的外部記錄設定。
  4. 在「Logging Type」下拉式選單中,選取「Generic Syslog」。

  5. 提供下列設定詳細資料:

    • 伺服器位址:輸入 Bindplane 代理程式主機的 IP 位址或主機名稱 (例如 192.168.1.100)
    • 通訊埠:輸入 514 (或在 Bindplane 代理程式中設定的通訊埠)
    • 通訊協定:選取「TCP」
  6. 在「Log Categories」(記錄類別) 部分,選取要轉送的事件類型:

    • 執行事件 (封鎖和允許的執行作業)
    • 政策異動
    • 管理動作
    • 代理事件
    • 伺服器活動
  7. 按一下「儲存」,套用外部記錄設定。

  8. 檢查 Bindplane 代理程式記錄或查看 Airlock Digital Server Console 中的「外部記錄」狀態,確認記錄是否已轉送。

如要進一步瞭解 Airlock Digital SIEM 整合,請參閱 Airlock Digital SIEM 整合頁面。

UDM 對應表

記錄欄位 UDM 對應 邏輯
event_type extensions.auth.type 對應:ServerActivityMessage → SSO
product_event_type extensions.auth.type 對應:(?i)Login → SSO
task extensions.auth.type 對應:Login → AUTHTYPE_UNSPECIFIED,Logout → AUTHTYPE_UNSPECIFIED
intermediary_hostname intermediary.hostname 直接對應
description metadata.description 直接對應
metadata_description metadata.description 直接對應
event_timestamp metadata.event_timestamp 剖析為 yyyy-MM-dd HH:mm:ss.SSS
ingestion_time metadata.event_timestamp 已剖析為 RFC 3339
event_type metadata.event_type 對應:FileActivityMessage → STATUS_UPDATE、ServerActivityMessage → USER_LOGIN、`Se...
has_principal metadata.event_type 對應:true → FILE_UNCATEGORIZED
product_event_type metadata.event_type 對應:(?i)Login → USER_LOGIN
task metadata.event_type 對應:Login → USER_LOGIN、Logout → USER_LOGOUT
event_type metadata.product_event_type 直接對應
product_event_type metadata.product_event_type 直接對應
checkpoint metadata.product_log_id 直接對應
browser network.http.user_agent 直接對應
netdomain principal.administrative_domain 直接對應
asset_category principal.asset.category 直接對應
hostname principal.asset.hostname 直接對應
srcip principal.asset.ip 已合併
software principal.asset.software 已合併
hostname principal.hostname 直接對應
principal_hostname principal.hostname 直接對應
srcip principal.ip 已合併
process_file_path principal.process.file.full_path 直接對應
file_md5 principal.process.file.md5 直接對應
process_file_name principal.process.file.names 已合併
file_sha256 principal.process.file.sha256 直接對應
parent_process_file principal.process.parent_process.file.full_path 直接對應
principal_user_userid principal.user.userid 直接對應
description security_result.action 對應:Invalid login attempt → security_result_action
metadata_description security_result.action 對應:logged in success → security_result_action
security_result_action security_result.action 已合併
file_sha128_label security_result.detection_fields 已合併
policyname_label security_result.detection_fields 已合併
policyver_label security_result.detection_fields 已合併
ppolicy_label security_result.detection_fields 已合併
sha128_label security_result.detection_fields 已合併
sha384_label security_result.detection_fields 已合併
sha512_label security_result.detection_fields 已合併
type_label security_result.detection_fields 已合併
source_file src.file.full_path 直接對應
source_file_name src.file.full_path 直接對應
filename target.file.full_path 直接對應
sha256 target.file.sha256 直接對應
commandline target.process.command_line 直接對應
filename target.process.file.full_path 直接對應
InstanceURL target.url 直接對應
principal_user_userid target.user.userid 直接對應
user target.user.userid 直接對應
不適用 extensions.auth.type 常數:AUTHTYPE_UNSPECIFIED
不適用 metadata.event_type 常數:USER_LOGIN
不適用 metadata.product_name 常數:Airlock Digital
不適用 metadata.vendor_name 常數:Airlock Digital

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。