收集 Alcatel 交換器記錄

剖析器版本:1.0

支援:

本文說明如何使用 Bindplane 代理程式,將 Alcatel 交換器記錄擷取至 Google Security Operations。

Alcatel-Lucent Enterprise OmniSwitch 是一系列可堆疊的區域網路交換器,提供網路存取、安全性政策強制執行,以及統一的有線/無線管理。交換器會產生系統記錄訊息,涵蓋驗證事件、介面狀態變更、VLAN 作業和 CLI 指令。

事前準備

請確認您符合下列必要條件:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Alcatel 交換器之間的網路連線
  • 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
  • Alcatel 交換器的特殊權限憑證 (管理員存取權)

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
  1. 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 請提供下列設定詳細資料:
    • 服務帳戶名稱:輸入帳戶名稱 (例如 bindplane-ingest)。
    • 服務帳戶說明:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 為 /opt/observiq-otel-collector/ingestion-auth.json,Windows 為 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存檔案的路徑相符。
  12. 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。匯出工具設定時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM Settings」 > 「Collection Agents」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」 > 「設定檔」。
  3. 複製並儲存「機構詳細資料」部分的客戶 ID。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟「命令提示字元」或「PowerShell」。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」。

Linux 安裝

  1. 開啟具有 root 或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為「active (running)」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/alcatel_switch:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: ALCATEL_SWITCH
        raw_log_field: body
    
    service:
      pipelines:
        logs/alcatel_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/alcatel_switch
    

設定參數

請替換下列預留位置:

  • 接收器設定:

    • listen_address:要監聽的 IP 位址和通訊埠:
      • 0.0.0.0:在所有介面上監聽 (建議)
      • 通訊埠 514 是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用 1514)
  • 匯出工具設定:

    • creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:從 Google SecOps 控制台複製的客戶 ID
    • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會在這個值前面加上 chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。
    • project:依序前往「IAM 與管理」>「設定」,然後將 <PROJECT_NUMBER> 替換為專案編號。
    • endpoint:維持設為 chronicle.googleapis.com。

舊版 Ingestion API 匯出工具

  • 如果您使用選項 2 的擷取驗證檔案,請將 exporters 區塊替換為下列內容。將 creds_file_path 設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/alcatel_switch:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: ALCATEL_SWITCH
        raw_log_field: body
    

儲存設定檔

  • 編輯完畢後,請儲存檔案:
    • Linux:依序按下 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,套用變更

  • 如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 查看記錄檔是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列任一選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R 鍵,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
      4. 確認服務是否正在執行:

        sc query observiq-otel-collector
        
      5. 查看記錄檔是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

在 Alcatel 交換器上設定系統記錄匯出功能

  1. 使用 SSH 或控制台傳輸線連線至交換器。
  2. 使用「管理員」憑證登入。
  3. 進入全域設定模式:

    enable
    configure terminal
    
  4. 設定 Bindplane (syslog) 伺服器 IP 位址:

    swlog output socket <BINDPLANE_IP>
    
    • 將 <BINDPLANE_IP> 替換為 Bindplane 代理程式 IP 位址。
  5. 啟用記錄到系統記錄伺服器:

    swlog remote enable
    
  6. 設定記錄層級:

    swlog console level info
    
  7. 啟用指令記錄功能:

    command-log enable
    
  8. 儲存啟動設定的變更:

    write memory
    

UDM 對應表

記錄欄位 UDM 對應 邏輯
1.1.1.1 principal.ipprincipal.asset.ip 從記錄訊息中擷取。
1.1.1.2 target.iptarget.asset.ip 從記錄訊息中擷取。
1.1.2.7 target.iptarget.asset.ip 從記錄訊息中擷取。
1035 target.port 從記錄訊息中擷取。
2266 additional.fields.value.string_value 從記錄訊息擷取並對應為 vlan。
3036 principal.port 從記錄訊息中擷取。
59300 target.port 從記錄訊息中擷取。
60588 target.port 從記錄訊息中擷取。
997 principal.resource.attribute.labels.value 從記錄訊息中擷取,並對應為 limit。
A6450-L2-K4B-01 principal.application 從記錄訊息中擷取。
A6450-L2-X1B-02-01 principal.application 從記錄訊息中擷取。
A6450-L2-X2A-01-01 principal.application 從記錄訊息中擷取。
A6450-L2-X4B-02-01 principal.application 從記錄訊息中擷取。
A6900-L3-LTX0A principal.application 從記錄訊息中擷取。
Accepted keyboard-interactive/pam security_result.summary 擷取的 sec_summary 欄位部分。
b8:53:ac:6e:c9:bc principal.mac 從記錄訊息中擷取。
BRIDGE(10) additional.fields.value.string_value 從記錄訊息擷取,並對應為 id_protocol。
CLI log, security_result.summary 擷取的 sec_summary 欄位部分。
cmd: show configuration snapshot all, security_result.detection_fields.value 從記錄訊息中擷取,並對應為 cmd。
Connection reset by 1.1.2.7 port 60505 security_result.summary 從記錄訊息中擷取。
Dec 7 14:28:40 metadata.event_timestamp.secondsmetadata.event_timestamp.nanos 從 ts 欄位剖析。
Dec 8 04:21:22 metadata.event_timestamp.secondsmetadata.event_timestamp.nanos 從 ts 欄位剖析。
Dec 9 20:08:29 metadata.event_timestamp.secondsmetadata.event_timestamp.nanos 從 ts 欄位剖析。
Dec 9 20:51:34 metadata.event_timestamp.secondsmetadata.event_timestamp.nanos 從 ts 欄位剖析。
Dec 11 10:18:30 metadata.event_timestamp.secondsmetadata.event_timestamp.nanos 從 ts 欄位剖析。
Dec 17 02:14:22 metadata.event_timestamp.secondsmetadata.event_timestamp.nanos 從 ts 欄位剖析。
Dec 19 10:27:33 metadata.event_timestamp.secondsmetadata.event_timestamp.nanos 從 ts 欄位剖析。
Did not receive identification string from 1.1.2.7 port 60588 security_result.summary 從記錄訊息中擷取。
esmSetRateLimit: Txing additional.fields.value.string_value 從記錄訊息中擷取,並對應為 esm_set_rate_limit。
Feb 15 16:29:29 metadata.event_timestamp.secondsmetadata.event_timestamp.nanos 從 ts 欄位剖析。
Feb 16 11:08:45 metadata.event_timestamp.secondsmetadata.event_timestamp.nanos 從 ts 欄位剖析。
Feb 16 11:08:49 metadata.event_timestamp.secondsmetadata.event_timestamp.nanos 從 ts 欄位剖析。
flashManager FlashMgr Main info(5) flashMgrValidateImage_exec: valid security_result.summary 從記錄訊息中擷取。
for ncmadmin from 1.1.1.2 port 59300 ssh2 security_result.summary 擷取的 sec_summary 欄位部分。
from port 3036 to port 1035 security_result.summary 擷取的「sec_summary」欄位部分內容。
IVDELCSW03 principal.hostnameprincipal.asset.hostname 如果 principal_ip 不是 IP 位址,則從記錄訊息中擷取。
IP-HELPER(22) additional.fields.value.string_value 從記錄訊息中擷取,並對應為 id_protocol。
Jan 16 02:14:13 metadata.event_timestamp.secondsmetadata.event_timestamp.nanos 從 ts 欄位剖析。
LLDP(42) additional.fields.value.string_value 從記錄訊息擷取,並對應為 id_protocol。
limit=997, principal.resource.attribute.labels.value 從記錄訊息擷取,並對應為 limit。
limitType=1 principal.resource.attribute.labels.value 從記錄訊息擷取,並對應為 limitType。
lldpProcessLocationIdTLV: Error, LLDP-MED Civic Address LCI len 39 invalid, tlvL security_result.summary 從記錄訊息中擷取。
Mac Movement for MacAddr: a0:29:19:c0:55:18 security_result.summary 從記錄訊息中擷取。
MacAddr: a0:29:19:c0:55:18 principal.mac 從記錄訊息中擷取。
ncmadmin principal.user.userid 從記錄訊息中擷取。
OS6360 principal.hostnameprincipal.asset.hostname 如果 principal_ip 不是 IP 位址,則從記錄訊息中擷取。
result: SUCCESS security_result.detection_fields.value 從記錄訊息擷取並對應為 result。
SES CMD info(5) security_result.summary 擷取的 sec_summaryfield 部分。
STACK-MANAGER principal.application 從記錄訊息中擷取。
Stack Port A MAC Frames TX/RX Enabled security_result.summary 從記錄訊息中擷取。
STP(11) additional.fields.value.string_value 從記錄訊息擷取,並對應為 id_protocol。
SWCONSOLE-L2-K0A-01 target.hostnametarget.asset.hostname 從記錄訊息中擷取。
trafficType=2, principal.resource.attribute.labels.value 從記錄訊息中擷取,並對應為「類型」traffic。
user: ncmadmin security_result.summary 擷取的 sec_summary 欄位部分。
zslot=0, principal.resource.attribute.labels.value 從記錄訊息中擷取,並對應為 zslot。
- additional.fields.key 硬式編碼值:id_protocol
- additional.fields.key 硬式編碼值:esm_set_rate_limit
- additional.fields.key 硬式編碼值:vlan
- metadata.event_type 如果沒有其他相符類型,則設為 GENERIC_EVENT。
- metadata.product_name 硬式編碼值:Alcatel Switch
- metadata.vendor_name 硬式編碼值:ALCATEL SWITCH
- network.application_protocol 當 id_protocol 與 ssh 相符時 (不區分大小寫),設為 SSH。
- principal.resource.attribute.labels.key 硬式編碼值:limit
- principal.resource.attribute.labels.key 硬式編碼值:trafficType
- principal.resource.attribute.labels.key 硬式編碼值:limitType
- principal.resource.attribute.labels.key 硬式編碼值:zslot
- security_result.detection_fields.key 硬式編碼值:cmd
- security_result.detection_fields.key 硬式編碼值:result
- security_result.severity 當 prod_severity 與 info 相符時 (不區分大小寫),設為 INFORMATIONAL。

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。