收集 Ansible AWX 記錄

剖析器版本:1.0

支援:

本文說明如何使用 Bindplane,將 Ansible AWX 記錄擷取至 Google Security Operations。Ansible AWX 是開放原始碼網頁應用程式,為 Ansible 提供使用者介面、REST API 和工作引擎。團隊可以透過這個平台,集中管理整個組織的自動化工作手冊、庫存、憑證和排定的工作。剖析器會從 JSON 格式的 Ansible AWX 記錄擷取欄位,並將這些值對應至統合資料模型 (UDM)。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體。
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機。
  • 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式需求開啟。
  • 具備 Ansible AWX 管理主控台的特殊存取權和管理員權限。

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
  1. 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 提供下列設定詳細資料:
    • 服務帳戶名稱:輸入帳戶名稱 (例如 bindplane-ingest)。
    • 「服務帳戶說明」:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存路徑相符。
  12. 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。設定匯出工具時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM Settings」 > 「Collection Agents」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」 > 「設定檔」。
  3. 複製並儲存「機構詳細資料」部分的客戶 ID。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟命令提示字元或 PowerShell。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    

Linux 安裝

  1. 開啟具有根層級或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    

其他安裝資源

如需其他安裝選項,請參閱這份安裝指南。

設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps

  1. 存取設定檔:

    • 找出 config.yaml 檔案。通常位於 Linux 的 /observiq-otel-collector/ 目錄,或 Windows 的安裝目錄。
    • 使用文字編輯器 (例如 nano、vi 或記事本) 開啟檔案。
  2. 按照下列方式編輯 config.yaml 檔案:

    receivers:
      udplog:
        # Replace the port and IP address as required
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/ansible_awx:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        # Adjust the path to the credentials file you downloaded in Step 1
        creds_file_path: '/path/to/ingestion-authentication-file.json'
        # Replace with your actual customer ID from Step 2
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: 'ANSIBLE_AWX'
        raw_log_field: body
    
    service:
      pipelines:
        logs/ansible_awx:
          receivers:
            - udplog
          exporters:
            - chronicle/ansible_awx
    
  • 視基礎架構需求更換連接埠和 IP 位址。
  • 將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會在這個值前面加上 chronicle.googleapis.com。
  • 將 <PROJECT_NUMBER> 替換為「IAM 與管理」>「設定」中的專案編號。
  • 將 <customer_id> 替換為實際的客戶 ID。
  • 將 /path/to/ingestion-authentication-file.json 更新為服務帳戶金鑰檔案 (選項 1) 的儲存路徑,該檔案位於「取得 Bindplane 代理程式的 Google SecOps 憑證」一節。

舊版擷取 API 匯出工具

  • 如果您使用方式 2 的擷取驗證檔案,請將 exporters 區塊替換成下列內容。將 creds_file_path 設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/ansible_awx:
        compression: gzip
        # Adjust the path to the credentials file you downloaded in Step 1
        creds_file_path: '/path/to/ingestion-authentication-file.json'
        # Replace with your actual customer ID from Step 2
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: 'ANSIBLE_AWX'
        raw_log_field: body
    

重新啟動 Bindplane 代理程式,套用變更

如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:

  1. 執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
  2. 確認服務正在執行:

    sudo systemctl status observiq-otel-collector
    
  3. 檢查記錄是否有錯誤:

    sudo journalctl -u observiq-otel-collector -f
    

如要在 Windows 重新啟動 Bindplane 代理程式,請按照下列步驟操作:

  1. 您可以選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:
    net stop observiq-otel-collector && net start observiq-otel-collector
    
    • 服務控制台:
      1. 按下 Win+R,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
  2. 確認服務是否正在執行:

    sc query observiq-otel-collector
    
  3. 查看記錄檔是否有錯誤:

    type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
    

在 Ansible AWX 設定外部記錄

  1. 登入 Ansible AWX 網頁介面。
  2. 前往左側導覽列的「設定」。
  3. 選取「系統」部分下方的「記錄設定」。
  4. 按一下「Logging settings」(記錄設定) 頁面底部的「Edit」(編輯)。
  5. 請提供下列設定詳細資料:
    • Logging 匯總工具:輸入 Bindplane 代理程式主機的 IP 位址 (例如 192.168.1.100)。
    • Logging Aggregator Port:輸入 Bindplane 代理程式通訊埠編號 (例如 514)。
    • 記錄匯總器類型:從下拉式選單中選取「其他」。
    • 記錄匯總工具使用者名稱:留白 (syslog 不需要)。
    • Logging Aggregator Password/Token:留空 (syslog 不需要)。
    • Logging Aggregator Protocol:選取「UDP」。
    • 「記錄匯總工具層級門檻」:選取「INFO」或偏好的記錄層級。
    • 啟用外部記錄功能:切換至「開啟」。
    • Loggers to Send Data to the Log Aggregator Form:選取相關記錄類型:
      • awx - 一般伺服器記錄
      • activity_stream - 記錄 AdWords Express 物件的變更
      • job_events - Ansible 回呼模組資料
      • system_tracking - 系統事實和設定資料
    • Log System Tracking Facts Individually:切換為「OFF」 (預設)。
  6. 按一下「儲存」即可套用設定。
  7. 點選「測試」,驗證與 Bindplane 代理程式的連線。

UDM 對應表

記錄欄位 UDM 對應 邏輯
logger_name intermediary.application 直接對應
RenderedMessage metadata.description 直接對應
description metadata.description 直接對應
event1 metadata.description 直接對應
message metadata.description 直接對應
timestamp metadata.event_timestamp 剖析為 yyyy-MM-ddTHH:mm:ss.SSSZ
principal_present metadata.event_type 對應:true → STATUS_UPDATE
target_present metadata.event_type 對應:true → NETWORK_CONNECTION
user_present metadata.event_type 對應:true → USER_UNCATEGORIZED
event1_data.uuid metadata.product_log_id 直接對應
Properties.Method network.http.method 直接對應
agent.type observer.application 直接對應
agent.id observer.asset_id 直接對應
agent.type observer.asset_id 直接對應
agent.hostname observer.hostname 直接對應
ephemeral_id_label observer.labels 已合併
agent.version observer.platform_version 直接對應
agent.name observer.user.userid 直接對應
Properties.applicationName principal.application 直接對應
Properties.MachineName principal.asset.asset_id 直接對應
Properties.Host principal.asset.hostname 直接對應
event1_data.remote_addr principal.asset.hostname 直接對應
principal_device principal.asset.hostname 直接對應
principal_hostname principal.asset.hostname 直接對應
Properties.ClientIP principal.asset.ip 已合併
ip_address principal.asset.ip 已合併
principal_ip principal.asset.ip 已合併
src_ip principal.asset.ip 已合併
Properties.Host principal.hostname 直接對應
event1_data.remote_addr principal.hostname 直接對應
principal_device principal.hostname 直接對應
principal_hostname principal.hostname 直接對應
Properties.ClientIP principal.ip 已合併
ip_address principal.ip 已合併
principal_ip principal.ip 已合併
src_ip principal.ip 已合併
src_port principal.port 直接對應
event1_data.task_path principal.process.file.full_path 直接對應
process_pid principal.process.pid 直接對應
availability_zone principal.resource.attribute.labels 已合併
connectionid_label principal.resource.attribute.labels 已合併
endpointname_label principal.resource.attribute.labels 已合併
machine_type principal.resource.attribute.labels 已合併
provider principal.resource.attribute.labels 已合併
cloud.instance.name principal.resource.name 直接對應
cloud.instance.id principal.resource.product_object_id 直接對應
Properties.UserName principal.user.userid 直接對應
user_name principal.user.userid 直接對應
event1_display security_result.description 直接對應
ca_id_label security_result.detection_fields 已合併
cf_component_label security_result.detection_fields 已合併
container_hash_label security_result.detection_fields 已合併
container_image_label security_result.detection_fields 已合併
container_name_label security_result.detection_fields 已合併
messagetemplate_label security_result.detection_fields 已合併
parent_uuid_label security_result.detection_fields 已合併
requestid_label security_result.detection_fields 已合併
requestpath_label security_result.detection_fields 已合併
serviceNowId_label security_result.detection_fields 已合併
sourcecontext_label security_result.detection_fields 已合併
stream_label security_result.detection_fields 已合併
task_label security_result.detection_fields 已合併
task_uuid_label security_result.detection_fields 已合併
threadid_label security_result.detection_fields 已合併
wf_env_label security_result.detection_fields 已合併
wf_id_label security_result.detection_fields 已合併
level security_result.severity 對應:"DEBUG", "INFO", "AUDIT" → INFORMATIONAL、WARNING → MEDIUM
level security_result.severity_details 直接對應
log security_result.summary 直接對應
host.fqdn target.administrative_domain 直接對應
host.id target.asset.asset_id 直接對應
codename_label target.asset.attribute.labels 已合併
json_data target.asset.attribute.labels 對應:host.*os.*platform → codename_label,host.*os.*platform → os_name_label
os_name_label target.asset.attribute.labels 已合併
hardware target.asset.hardware 已合併
json_data target.asset.hardware 已對應:host.*os.*platform → hardware
host.hostname target.asset.hostname 直接對應
kubernetes.host target.asset.hostname 直接對應
target_device target.asset.hostname 直接對應
ips target.asset.ip 已合併
json_data target.asset.ip 對應:host.*os.*platform → ips
target_ip target.asset.ip 已合併
kubernetes.docker_id target.asset_id 直接對應
host.hostname target.hostname 直接對應
kubernetes.host target.hostname 直接對應
target_device target.hostname 直接對應
target_ip target.ip 已合併
json_data target.mac 對應:host.*os.*platform → macs
macs target.mac 已合併
kubernetes.namespace_name target.namespace 直接對應
json_data target.platform 對應:host.*os.*platform → LINUX
host.os.kernel target.platform_patch_level 直接對應
host.os.version target.platform_version 直接對應
io_instance_label target.resource.attribute.labels 已合併
io_name_label target.resource.attribute.labels 已合併
pod_id_label target.resource.attribute.labels 已合併
pod_template_hash_label target.resource.attribute.labels 已合併
cluster_name target.resource.name 直接對應
不適用 metadata.event_type 常數:NETWORK_CONNECTION
不適用 metadata.product_name 常數:ANSIBLE_AWX
不適用 metadata.vendor_name 常數:ANSIBLE_AWX
不適用 network.ip_protocol 常數:TCP
不適用 principal.resource.resource_type 常數:VIRTUAL_MACHINE
不適用 security_result.severity 常數:INFORMATIONAL
不適用 target.platform 常數:LINUX

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。