收集 Appian Cloud 記錄

剖析器版本:4.0

支援的服務:

本文說明如何使用 Bindplane 代理程式,將 Appian Cloud 記錄檔擷取至 Google Security Operations。

Appian Cloud 是低程式碼自動化平台,可讓機構建構企業應用程式和工作流程。記錄檔串流功能可透過 IPsec VPN 連線,提供 Appian Cloud 環境的稽核和安全性事件記錄。

事前準備

請確認您符合下列必要條件:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • Appian Cloud 的 Professional 或 Signature 授權
  • Appian 環境網址記錄
  • Appian Cloud 與要部署 Bindplane 代理程式的環境之間的 IPsec VPN

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:在 2027 年 7 月 20 日停用 Ingestion API 前,請繼續使用擷取驗證檔案 (選項 2)。
  1. 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 提供下列設定詳細資料:
    • 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如 bindplane-ingest)。
    • 服務帳戶說明:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 為 /opt/observiq-otel-collector/ingestion-auth.json,Windows 為 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存檔案的路徑相符。
  12. 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。設定匯出工具時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」 > 「設定檔」。
  3. 複製並儲存「機構詳細資料」部分的客戶 ID。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟「命令提示字元」或「PowerShell」。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」。

Linux 安裝

  1. 開啟具有 root 或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為「active (running)」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      tcplog:
        listen_address: "0.0.0.0:6514"
    
    exporters:
      chronicle/appian_cloud:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: APPIAN_CLOUD
        raw_log_field: body
    
    service:
      pipelines:
        logs/appian_to_chronicle:
          receivers:
            - tcplog
          exporters:
            - chronicle/appian_cloud
    

設定參數

替換下列預留位置:

  • 接收器設定:

    • listen_address:要監聽的 IP 位址和通訊埠:
      • 0.0.0.0 在所有介面接聽電話 (建議)
      • 建議使用通訊埠 6514 串流 Appian Cloud 記錄檔
  • Exporter 設定:

    • creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:從 Google SecOps 控制台複製的客戶 ID
    • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會在這個值前面加上 chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。
    • project:依序前往「IAM 與管理」>「設定」,然後將 <PROJECT_NUMBER> 替換為專案編號。
    • endpoint:維持設為 chronicle.googleapis.com。

舊版 Ingestion API 匯出工具

  • 如果您使用方式 2 的擷取驗證檔案,請將 exporters 區塊替換成下列內容。將 creds_file_path 設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/appian_cloud:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: APPIAN_CLOUD
        raw_log_field: body
    

儲存設定檔

  • 編輯完畢後,請儲存檔案:
    • Linux:依序按下 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依序點選「檔案」 > 「儲存」

重新啟動 Bindplane 代理程式,套用變更

  • 如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 檢查記錄是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列任一選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R 鍵,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
      4. 確認服務正在執行:

        sc query observiq-otel-collector
        
      5. 查看記錄檔是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

啟用 Appian Cloud 的記錄串流功能

  1. 向 Appian 開立支援案件,主旨為「Enable Log Streaming」(啟用記錄串流),並提供下列詳細資料:
    • 環境網址
    • 所需網路路徑,例如 IPsec VPN
    • Bindplane 代理程式 IP 位址
    • Bindplane 代理程式 TCP 通訊埠編號 (例如 6514)
  2. Appian 支援團隊會安排維護期間並部署設定。

UDM 對應表

記錄欄位 UDM 對應 邏輯
available_heap_space_label additional.fields 已合併
cpu_core_count_label additional.fields 已合併
daemon_thread_count_label additional.fields 已合併
data_store_label additional.fields 已合併
devicetimestamp_label additional.fields 已合併
entity_label additional.fields 已合併
execute_time_label additional.fields 已合併
load_average_label additional.fields 已合併
operation_name_label additional.fields 已合併
operation_type_label additional.fields 已合併
permanent_generation_available_label additional.fields 已合併
permanent_generation_used_label additional.fields 已合併
prepare_time_label additional.fields 已合併
retcode_label additional.fields 已合併
session_count_label additional.fields 已合併
tenured_collection_count_label additional.fields 已合併
tenured_collection_time_label additional.fields 已合併
tenured_generation_available_label additional.fields 已合併
tenured_generation_usage_after_collection_label additional.fields 已合併
tenured_generation_used_label additional.fields 已合併
thread_label additional.fields 已合併
total_swap_space_label additional.fields 已合併
total_system_memory_label additional.fields 已合併
total_thread_count_label additional.fields 已合併
transform_time_label additional.fields 已合併
used_heap_space_label additional.fields 已合併
used_swap_space_label additional.fields 已合併
used_system_memory_label additional.fields 已合併
young_cllection_time_label additional.fields 已合併
young_collection_count_label additional.fields 已合併
has_principal_user extensions.auth.type 已對應:true → AUTHTYPE_UNSPECIFIED
src_host intermediary.hostname 直接對應
src_ip intermediary.ip 已合併
time metadata.event_timestamp 剖析為 yyyy-MM-dd HH:mm:ss
event_type metadata.event_type 直接對應
device metadata.product_event_type 直接對應
product_type metadata.product_event_type 直接對應
http_method network.http.method 直接對應
useragent network.http.parsed_user_agent 已重新命名/對應
useragent network.http.user_agent 直接對應
connectionid network.session_id 直接對應
sessionID network.session_id 直接對應
session_id network.session_id 直接對應
domain principal.administrative_domain 直接對應
application principal.application 直接對應
host principal.asset.hostname 直接對應
hostname principal.asset.hostname 直接對應
IpAddress principal.asset.ip 已合併
host principal.hostname 直接對應
hostname principal.hostname 直接對應
IpAddress principal.ip 已合併
src_port principal.port 直接對應
process_id principal.process.pid 直接對應
url principal.url 直接對應
roles principal.user.attribute.roles 已合併
companyname principal.user.company_name 直接對應
email principal.user.email_addresses 已合併
user_id principal.user.email_addresses 對應:N/A → user_id
modified_by_uuid principal.user.product_object_id 直接對應
user principal.user.product_object_id 直接對應
modified_by_username principal.user.userid 直接對應
userId principal.user.userid 直接對應
user_id principal.user.userid 直接對應
username2 principal.user.userid 直接對應
versionDetails security_result.about.platform_version 直接對應
outcome_result security_result.action 已合併
security_result_action security_result.action 已合併
act security_result.action_details 直接對應
status security_result.action_details 直接對應
sec_result_category security_result.category 已合併
category security_result.category_details 已合併
desc security_result.description 直接對應
details security_result.description 直接對應
details_label security_result.detection_fields 已合併
endpoint_label security_result.detection_fields 已合併
execution_count_label security_result.detection_fields 已合併
maximum_execution_time_label security_result.detection_fields 已合併
maximum_response_size_label security_result.detection_fields 已合併
maximum_response_time_label security_result.detection_fields 已合併
mean_execution_time_label security_result.detection_fields 已合併
mean_response_size_label security_result.detection_fields 已合併
minimum_execution_time_label security_result.detection_fields 已合併
minimum_response_size_label security_result.detection_fields 已合併
model_label security_result.detection_fields 已合併
rolesAllow_label security_result.detection_fields 已合併
sqlcmd_label security_result.detection_fields 已合併
status_code_1xx_count_label security_result.detection_fields 已合併
status_code_2xx_count_label security_result.detection_fields 已合併
status_code_3xx_count_label security_result.detection_fields 已合併
status_code_4xx_count_label security_result.detection_fields 已合併
status_code_5xx_count_label security_result.detection_fields 已合併
type_label security_result.detection_fields 已合併
uuid_label security_result.detection_fields 已合併
severity security_result.severity 已對應:"INFORMATIONAL","INFORMATION","INFO" → INFORMATIONAL、"WARNING", "MEDIUM" → `M...
detail security_result.severity_details 直接對應
action1 security_result.summary 直接對應
msg security_result.summary 直接對應
object security_result.summary 直接對應
operation_detail security_result.summary 直接對應
reason security_result.summary 直接對應
summary security_result.summary 直接對應
server_host target.asset.hostname 直接對應
tar_host target.asset.hostname 直接對應
src_ip1 target.asset.ip 已合併
hash target.file.md5 直接對應
document_name target.file.names 已合併
server_host target.hostname 直接對應
tar_host target.hostname 直接對應
src_ip1 target.ip 已合併
commandline target.process.command_line 直接對應
action_label target.resource.attribute.labels 已合併
environment_label target.resource.attribute.labels 已合併
filters_label target.resource.attribute.labels 已合併
new_value_label target.resource.attribute.labels 已合併
original_value_label target.resource.attribute.labels 已合併
page_group_invoved_label target.resource.attribute.labels 已合併
page_involved_label target.resource.attribute.labels 已合併
record_identifier_label target.resource.attribute.labels 已合併
record_type_name_label target.resource.attribute.labels 已合併
record_type_url_stub_label target.resource.attribute.labels 已合併
setting_new_value_label target.resource.attribute.labels 已合併
setting_old_value_label target.resource.attribute.labels 已合併
site_involved_label target.resource.attribute.labels 已合併
site_url_stub_label target.resource.attribute.labels 已合併
view_label target.resource.attribute.labels 已合併
database target.resource.name 直接對應
property target.resource.name 直接對應
record_type_name target.resource.name 直接對應
resourcename target.resource.name 直接對應
site_involved target.resource.name 直接對應
id target.resource.product_object_id 直接對應
oid target.resource.product_object_id 直接對應
queryid target.resource.product_object_id 直接對應
sessionID target.resource.product_object_id 直接對應
transactionId target.resource.product_object_id 直接對應
action target.resource.resource_subtype 直接對應
name target.resource.resource_subtype 直接對應
user_uuid target.user.product_object_id 直接對應
username1 target.user.userid 直接對應
不適用 extensions.auth.type 常數:AUTHTYPE_UNSPECIFIED
不適用 metadata.event_type 常數:GENERIC_EVENT
不適用 metadata.log_type 常數:APPIAN_CLOUD
不適用 metadata.product_name 常數:Cloud Platform
不適用 metadata.vendor_name 常數:Appian
不適用 security_result.severity 常數:INFORMATIONAL
sessionID event.idm.read_only_udm.network.session_id 從變更記錄對應
transactionId event.idm.read_only_udm.target.resource.product_object_id 從變更記錄對應
versionDetails event.idm.read_only_udm.security_result.about.platform_version 從變更記錄對應
application event.idm.read_only_udm.principal.application 從變更記錄對應
IpAddress event.idm.read_only_udm.principal.ip 從變更記錄對應
IpAddress event.idm.read_only_udm.principal.asset.ip 從變更記錄對應
userId event.idm.read_only_udm.principal.user.userid 從變更記錄對應
rolesAllow event.idm.read_only_udm.additional.fields 從變更記錄對應
userRole event.idm.read_only_udm.additional.fields 從變更記錄對應
status event.idm.read_only_udm.section_result.action_details 從變更記錄對應
resourcename event.idm.read_only_udm.target.resource.name 從變更記錄對應
commandline event.idm.read_only_udm.target.process.command_line 從變更記錄對應
devicetimestamp event.idm.read_only_udm.additional.fields 從變更記錄對應
email event.idm.read_only_udm.principal.user.email_addresses 從變更記錄對應
document_name target.files.names 從變更記錄對應
msg" and "reason security_result.summary 從變更記錄對應
original_value", "setting_new_value", "setting_old_value", and "new_value target.resource.attribute.labels 從變更記錄對應
page_involved", "site_involved", and "page_group_involved target.resource.attribute.labels 從變更記錄對應
total_thread_count", "daemon_thread_count", used_heap_space", "available_heap_space", "tenured_generation_usage_after_collection", "tenured_generation_used", "tenured_generation_available", "permanent_generation_used", and "permanent_generation_available additional.fields 從變更記錄對應
young_collection_count", "young_cllection_time", "tenured_collection_count", "tenured_collection_time", "cpu_core_count", "total_system_memory", "used_system_memory", "total_swap_space", "used_swap_space", "load_average", and "session_count additional.fields 從變更記錄對應
record_identifier", "record_type_url_stub", "view", "filters", "environment", and "site_url_stub target.resource.attribute.labels 從變更記錄對應
data_store", "entity", and "operation_type additional.fields 從變更記錄對應
operation_name", "prepare_time", "transform_time", and "execute_time additional.fields 從變更記錄對應
connectionid network.session.id 從變更記錄對應
minimum_execution_time", "execution_count", "status_code_1xx_count", "status_code_2xx_count", "status_code_3xx_count", "status_code_4xx_count", "status_code_5xx_count", "minimum_response_size", "maximum_response_time", "maximum_response_size", "mean_execution_time", and "maximum_response_size security_result.detection_fields 從變更記錄對應

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。