收集 Aruba AirWave 日志
解析器版本:2.0
本文档介绍了如何使用 Bindplane 代理将 Aruba AirWave 日志注入到 Google Security Operations。
Aruba AirWave 是由 HPE Aruba Networking 开发的本地无线管理平台。它为有线和无线网络基础设施(包括接入点、控制器和交换机)提供集中监控、配置和问题排查功能。AirWave 会生成事件日志、审核日志和 RAPIDS(恶意接入点检测软件)提醒,用于捕获网络操作、管理操作和安全性事件。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 Aruba AirWave 服务器之间的网络连接
- 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于开放状态
- 使用管理员凭据对 Aruba AirWave 管理平台进行特权访问
- AirWave 服务器和 Bindplane 代理主机之间打开的 UDP 端口 514
获取 Bindplane 代理的 Google SecOps 凭证
如需向 Google SecOps 验证 Bindplane 代理,请选择以下方法之一:
- 新部署:使用 Chronicle API(选项 1)。
- 旧版部署:继续使用数据注入身份验证文件(方法 2),直到 Ingestion API 于 2027 年 7 月 20 日停用。
方法 1:为 Chronicle API 创建服务账号(推荐)
- 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
- 前往 IAM 和管理 > 服务账号。
- 点击创建服务账号。
- 提供以下配置详细信息:
- 服务账号名称:输入账号的名称(例如
bindplane-ingest)。 - 服务账号说明:输入说明(例如
Bindplane agent log ingestion)。
- 服务账号名称:输入账号的名称(例如
- 点击创建并继续。
- 在向此服务账号授予对项目的访问权限部分,点击选择角色,然后选择 Chronicle Editor。
- 点击继续,然后点击完成。
- 点击您创建的服务账号,然后前往密钥标签页。
- 依次点击添加密钥 > 创建新密钥。
- 选择 JSON,然后点击创建。密钥文件会下载到您的计算机上。
- 将密钥文件另存为 Bindplane 收集器目录(Linux 上的
/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)中的ingestion-auth.json,或更新config.yaml中的creds_file_path以匹配您保存该文件的路径。 - 前往 IAM 和管理 > 设置,然后复制项目编号。您需要此信息才能配置导出器。
方法 2:下载数据注入身份验证文件(旧版)
- 登录 Google SecOps 控制台。
- 前往 SIEM 设置> 收集代理。
- 下载数据注入身份验证文件。
- 将文件安全地保存在将要安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 前往 SIEM 设置 > 个人资料。
复制并保存组织详细信息部分中的客户 ID。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符或 PowerShell。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector该服务应显示为 RUNNING。
Linux 安装
- 打开具有 root 或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector该服务应显示为有效(正在运行)。
其他安装资源
如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 Syslog 并发送到 Google SecOps
找到配置文件
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/aruba_airwave: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: ARUBA_AIRWAVE raw_log_field: body service: pipelines: logs/aruba_airwave: receivers: - udplog exporters: - chronicle/aruba_airwave
配置参数
替换以下占位符:
接收器配置:
udplog:基于协议的接收器类型:udplog(适用于 UDP syslog)tcplog(适用于 TCP syslog)- 针对 RFC 3164/5424 syslog 的
syslog
0.0.0.0:要监听的 IP 地址:0.0.0.0,以监听所有接口(推荐)- 在某个接口上监听的特定 IP 地址
514:要监听的端口号(例如514、1514、6514)
导出器配置:
<customer_id>:上一步中的客户 IDlocation:将<LOCATION>替换为 Google SecOps 实例所在的区域(例如us、europe或asia-southeast1)。导出工具会在此值前面加上chronicle.googleapis.com。如需查看完整列表,请参阅区域级端点。project:将<PROJECT_NUMBER>替换为 IAM 和管理 > 设置中的项目编号。endpoint:保持设置为chronicle.googleapis.com。- 根据平台,将
creds_file_path调整为服务账号 JSON 密钥文件的路径(选项 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
旧版提取 API
如果您使用选项 2 中的提取身份验证文件,请将
exporters代码块替换为以下内容。将creds_file_path设置为数据注入身份验证文件的路径,如果您的实例位于美国境外,请将malachiteingestion-pa.googleapis.com替换为您的区域端点(例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/aruba_airwave: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: ARUBA_AIRWAVE raw_log_field: body
保存配置文件
- 修改后,保存文件:
- Linux:依次按
Ctrl+O、Enter和Ctrl+X - Windows:依次点击文件 > 保存
- Linux:依次按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志中的错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:
以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服务控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry 收集器。
- 右键点击并选择重启。
验证服务是否正在运行:
sc query observiq-otel-collector检查日志中的错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按
配置 Aruba AirWave syslog 转发
使用内置的外部日志记录功能,将 Aruba AirWave Management Platform 配置为将事件和审核日志转发到 Bindplane 代理。
- 登录 Aruba AirWave 管理平台网页界面。
- 依次前往 AMP 设置 > 常规。
- 向下滚动到 External Logging(外部日志记录)部分。
- 在 Syslog 服务器字段中,输入 Bindplane 代理主机(例如
192.168.1.100)的 IP 地址。 在 Syslog 端口字段中,输入
514。在包含事件日志消息下拉菜单中,选择是。
在事件日志功能下拉菜单中,选择一个功能标识符(例如
local0)。在包含审核日志消息下拉菜单中,选择是。
在审核日志设施下拉菜单中,选择与事件日志设施不同的设施标识符(例如
local1)。点击发送测试消息,验证 syslog 服务器是否收到来自 AirWave 的测试消息。
点击保存。
如需了解详情,请参阅 Aruba AirWave 查看 Syslog 消息文档。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
column3_label |
additional.fields |
已合并 |
version_label |
additional.fields |
已合并 |
inter_host |
intermediary.asset.hostname |
直接映射 |
inter_host |
intermediary.hostname |
直接映射 |
description |
metadata.description |
直接映射 |
entry.eap_friendly_name |
metadata.description |
已重命名/映射 |
msg |
metadata.description |
直接映射 |
datestamp |
metadata.event_timestamp |
已解析为 MMM dd HH:mm:ss |
entry.timestamp |
metadata.event_timestamp |
解析为 MM/dd/yyyy HH:mm:ss.SSS |
has_principal |
metadata.event_type |
已映射:true → NETWORK_CONNECTION、true → STATUS_UPDATE |
session_status |
metadata.event_type |
已映射:opened → USER_LOGIN,closed → USER_LOGOUT |
device_event_class_id |
metadata.product_event_type |
直接映射 |
event_name_1 |
metadata.product_event_type |
直接映射 |
device_product |
metadata.product_name |
直接映射 |
entry.event_source |
metadata.product_name |
直接映射 |
device_version |
metadata.product_version |
直接映射 |
device_vendor |
metadata.vendor_name |
直接映射 |
domain |
principal.administrative_domain |
直接映射 |
hostname |
principal.asset.hostname |
直接映射 |
column4 |
principal.asset.ip |
已合并 |
hostname |
principal.hostname |
直接映射 |
column4 |
principal.ip |
已合并 |
entry.client_ip |
principal.ip |
已合并 |
prin_ip |
principal.ip |
已合并 |
entry.calling_station_id |
principal.mac |
已合并 |
pid1 |
principal.process.pid |
直接映射 |
nas_port_label |
principal.user.attribute.labels |
已合并 |
credentials |
principal.user.user_display_name |
已重命名/已映射 |
entry.user_name |
principal.user.userid |
已重命名/映射 |
suser |
principal.user.userid |
直接映射 |
user_id |
principal.user.userid |
已重命名/已映射 |
sr_category |
security_result.category |
已合并 |
severity_value |
security_result.severity |
已映射:"1", "2", "3" → INFORMATIONAL、4 → ERROR、5 → CRITICAL |
scan_type |
security_result.summary |
直接映射 |
target_hostname |
target.asset.hostname |
直接映射 |
entry.nas_id |
target.hostname |
已重命名/映射 |
target_hostname |
target.hostname |
直接映射 |
target_name |
target.hostname |
已重命名/已映射 |
entry.nas_ip |
target.ip |
已合并 |
target_ip |
target.ip |
已合并 |
mac_address |
target.mac |
已合并 |
target_resource |
target.resource.id |
直接映射 |
column6 |
target.resource.name |
直接映射 |
username |
target.user.user_display_name |
直接映射 |
client_friendly_name |
target.user.userid |
已重命名/映射 |
| 不适用 | extensions.auth.type |
常量:AUTHTYPE_UNSPECIFIED |
| 不适用 | metadata.event_type |
常量:GENERIC_EVENT |
| 不适用 | metadata.product_event_type |
常量:Access-Request |
| 不适用 | security_result.severity |
常量:INFORMATIONAL |
更新日志
需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。