收集 SentinelOne Attivo (舊稱 Attivo Networks) 記錄
剖析器版本:9.0
本文說明如何使用 Bindplane,將 SentinelOne Attivo (舊稱 Attivo Networks) 記錄檔擷取至 Google Security Operations。
SentinelOne Attivo 是詐騙技術平台,可偵測網路內威脅、側向移動和憑證式攻擊。這項服務會在整個環境中部署誘餌,偵測繞過周邊防禦機制的攻擊者。Attivo 會透過 syslog 轉送偵測事件和警示。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體。
- 搭載 systemd 的 Windows 2016 以上版本或 Linux 主機。
- 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式需求開啟。
- SentinelOne Attivo BOTsink 管理主控台的特殊權限存取權。
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 服務帳戶名稱:輸入帳戶名稱 (例如
bindplane-ingest)。 - 「服務帳戶說明」:輸入說明 (例如
Bindplane agent log ingestion)。
- 服務帳戶名稱:輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 上的/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存路徑相符。 - 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。設定匯出工具時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」 > 「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」(SIEM 設定) >「Profile」(設定檔)。
- 複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟命令提示字元或 PowerShell。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
Linux 安裝
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
其他安裝資源
如需其他安裝選項,請參閱這份安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
存取設定檔:
- 找出
config.yaml檔案。通常位於 Linux 的/observiq-otel-collector/目錄,或 Windows 的安裝目錄。 - 使用文字編輯器 (例如
nano、vi或記事本) 開啟檔案。
- 找出
按照下列方式編輯
config.yaml檔案:receivers: tcplog: # Replace the port and IP address as required listen_address: "0.0.0.0:514" exporters: chronicle/chronicle_w_labels: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: <your_customer_id> endpoint: chronicle.googleapis.com # Add optional ingestion labels for better organization log_type: 'ATTIVO' raw_log_field: body ingestion_labels: service: pipelines: logs/source0__chronicle_w_labels-0: receivers: - tcplog exporters: - chronicle/chronicle_w_labels
- 請根據基礎架構需求,替換通訊埠和 IP 位址。
- 將
<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會在這個值前面加上chronicle.googleapis.com。 - 將
<PROJECT_NUMBER>替換為「IAM 與管理」>「設定」中的專案編號。 - 將
<your_customer_id>替換為實際的客戶 ID。 - 將
/path/to/ingestion-authentication-file.json更新為服務帳戶金鑰檔案 (選項 1) 在步驟 1 中儲存的檔案路徑。
舊版擷取 API 匯出工具
如果您使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/chronicle_w_labels: compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: <your_customer_id> endpoint: malachiteingestion-pa.googleapis.com # Add optional ingestion labels for better organization log_type: 'ATTIVO' raw_log_field: body ingestion_labels:
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請按照下列步驟操作:
執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務是否正在執行:
sudo systemctl status observiq-otel-collector檢查記錄是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請按照下列步驟操作:
您可以選擇下列其中一個選項:
- 以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector- 服務控制台:
- 按下
Win+R鍵,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
- 按下
確認服務正在執行:
sc query observiq-otel-collector檢查記錄是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
設定 SentinelOne Attivo 系統記錄轉送
建立 CEF syslog 設定檔
- 登入 Attivo BOTsink 管理控制台。
- 依序前往「Administration」>「Management」>「Syslog」。
- 按一下「新增」,建立新的系統記錄設定檔。
- 輸入設定檔的描述性名稱 (例如
SecOps-CEF)。 - 將「Event Forwarding」(事件轉送) 設為「Enabled」(啟用)。
- 選取「CEF」做為「Message Format」。
- 設定事件的嚴重性對應:
- 非常高:選取「緊急」。
- 高:選取「重大」。
- 媒介:選取「快訊」。
- 低:選取「警告」。
- 極低:選取「資訊」。
- 按一下「Save」儲存系統記錄設定檔。
新增 Syslog 伺服器連線
- 在您建立的系統記錄設定檔中,按一下「Add New Connection」。
- 請提供下列連線詳細資料:
- 伺服器名稱:輸入連線的描述性名稱 (例如
Bindplane-Agent)。 - 「設定檔名稱」:選取上一節建立的 CEF Syslog 設定檔。
- IP 位址:輸入 Bindplane 代理程式主機的 IP 位址 (例如
192.168.1.100)。 - 通訊埠:輸入
514(或您設定的 Bindplane 代理程式通訊埠)。 - 「通訊協定」:選取「TCP」。
- 伺服器名稱:輸入連線的描述性名稱 (例如
- 點選「Test Connection」,確認 BOTsink 可連至 Bindplane 代理程式。
- 按一下 [儲存]。
確認系統記錄傳送
- 設定 Syslog 轉送後,請觸發測試警報或等待偵測事件。
在 Bindplane 代理程式主機上,確認是否收到記錄:
sudo journalctl -u observiq-otel-collector -f
詳情請參閱 SentinelOne Attivo 說明文件。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
src |
principal.ip |
值取自「src」欄位。 |
dst |
target.ip |
值取自「dst」欄位。 |
spt |
principal.port |
從 spt 取得值並轉換為整數。 |
dpt |
target.port |
從 dpt 取得值並轉換為整數。 |
shost |
principal.hostname |
值取自「shost」欄位。 |
dhost |
target.hostname |
取自「dhost」欄位的值。 |
suser |
principal.user.userid |
值取自「suser」欄位。 |
duser |
target.user.userid |
取自「duser」欄位的值。 |
msg |
metadata.description |
取自「msg」欄位的值。 |
cat |
security_result.category_details |
取自 cat (CEF 類別) 欄位的值。 |
act |
security_result.action_details |
值取自 act (動作) 欄位。 |
severity |
security_result.severity |
從 CEF 嚴重程度對應:1-3 -> 低、4-6 -> 中、7-8 -> 高、9-10 -> 危急。 |
deviceEventClassId |
metadata.product_event_type |
取自「deviceEventClassId」欄位的值。 |
name |
security_result.summary |
值取自 CEF name 欄位 (事件名稱)。 |
deviceVendor |
metadata.vendor_name |
取自「deviceVendor」欄位的值。通常設為「Attivo Networks」。 |
deviceProduct |
metadata.product_name |
值取自「deviceProduct」欄位。通常設為「BOTsink」。 |
deviceVersion |
metadata.product_version |
值取自「deviceVersion」欄位。 |
metadata.event_type |
預設為「GENERIC_EVENT」。如果來源和目的地 IP 存在,請設為「NETWORK_CONNECTION」。如果只有主體資訊,請設為「STATUS_UPDATE」。 | |
metadata.log_type |
設為「ATTIVO」。 | |
VLANID |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
Forwarder_IP |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
VTSummaryResult |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
WebRootReputation |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
Forwarder |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
Target_IP_Ports |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
TargetIP_List |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
Dest_UserName |
event.idm.read_only_udm.target.user.userid |
從變更記錄對應 |
Attacker_IP_Domain |
event.idm.read_only_udm.principal.administrative_domain |
從變更記錄對應 |
attacker_ip |
event.idm.read_only_udm.principal.ip 和 event.idm.read_only_udm.principal.asset.ip |
從變更記錄對應 |
detail_target_ip |
event.idm.read_only_udm.principal.ip 和 event.idm.read_only_udm.principal.asset.ip |
從變更記錄對應 |
target_host |
event.idm.read_only_udm.target.hostname |
從變更記錄對應 |
target_ip |
event.idm.read_only_udm.target.ip 和 event.idm.read_only_udm.target.asset.ip |
從變更記錄對應 |
target_os |
event.idm.read_only_udm.target.platform_version |
從變更記錄對應 |
description |
event.idm.read_only_udm.metadata.description |
從變更記錄對應 |
detail_source_ip |
event.idm.read_only_udm.observer.ip |
從變更記錄對應 |
phase |
event.idm.read_only_udm.security_result.category_details |
從變更記錄對應 |
Attacker_HostName |
event.idm.read_only_udm.principal.hostname |
從變更記錄對應 |
Attacker_MAC |
event.idm.read_only_udm.principal.mac |
從變更記錄對應 |
Attacker_UserNames |
event.idm.read_only_udm.principal.user.user_display_name |
從變更記錄對應 |
Source_Device_Name |
event.idm.read_only_udm.observer.hostname |
從變更記錄對應 |
Attivo_AlertID |
event.idm.read_only_udm.metadata.product_log_id |
從變更記錄對應 |
MITRE_Technique_Name |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
MITRE_Tactic_Name |
event.idm.read_only_udm.security_result.rule_name |
從變更記錄對應 |
severity |
event.idm.read_only_udm.security_result.severity |
從變更記錄對應 |
Target_Ports |
event.idm.read_only_udm.target.port |
從變更記錄對應 |
Target_IP_Domain |
event.idm.read_only_udm.target.administrative_domain |
從變更記錄對應 |
Alert.subject |
metadata.description |
從變更記錄對應 |
Alert.body |
metadata.description |
從變更記錄對應 |
Alert.app |
principal.application |
從變更記錄對應 |
Alert.dest_ip |
target.ip |
從變更記錄對應 |
Alert.dest_host |
target.hostname |
從變更記錄對應 |
Alert.src_hostname |
principal.hostname |
從變更記錄對應 |
Alert.src_ip_domain |
principal.domain.name |
從變更記錄對應 |
Alert.dest_ip_domain |
target.domain.name |
從變更記錄對應 |
Alert.id |
metadata.product_log_id |
從變更記錄對應 |
Alert.des_os |
target.asset.platform_software.platform_version |
從變更記錄對應 |
Alert.src_ip |
principal.ip |
從變更記錄對應 |
Alert.src_mac |
prinicipal.mac |
從變更記錄對應 |
Alert.bootsink_ip |
intermediary.ip |
從變更記錄對應 |
Alert.forwarder" and "Alert.service |
additional.fields |
從變更記錄對應 |
techinque_id |
security_result.attack_details.tactics.id |
從變更記錄對應 |
techinque_name |
security_result.attack_details.tactics.name |
從變更記錄對應 |
Alert.severity |
security_result.severity |
從變更記錄對應 |
Alert.src_category |
security_result.threat_name |
從變更記錄對應 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。