收集 Barracuda CloudGen Firewall 記錄

剖析器版本:2.0

支援:

本文說明如何使用 Bindplane 代理程式,將 Barracuda CloudGen Firewall 記錄檔擷取至 Google Security Operations。

Barracuda CloudGen Firewall 是新一代防火牆,可透過 Syslog 串流功能,為網路流量、安全性事件、驗證和系統作業產生 syslog 訊息。

事前準備

請確認您符合下列必要條件:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Barracuda CloudGen 防火牆之間的網路連線
  • 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
  • Barracuda Firewall Control Center 的管理員權限

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
  1. 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 請提供下列設定詳細資料:
    • 服務帳戶名稱:輸入帳戶名稱 (例如 bindplane-ingest)。
    • 服務帳戶說明:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 為 /opt/observiq-otel-collector/ingestion-auth.json,Windows 為 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存檔案的路徑相符。
  12. 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。匯出工具設定時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」 > 「設定檔」。
  3. 複製並儲存「機構詳細資料」部分的客戶 ID。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟命令提示字元或 PowerShell。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」。

安裝 Linux

  1. 開啟具有 root 或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為「active (running)」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/barracuda_cloudgen_firewall:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: BARRACUDA_CLOUDGEN_FIREWALL
        raw_log_field: body
    
    service:
      pipelines:
        logs/barracuda_cloudgen_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/barracuda_cloudgen_firewall
    

設定參數

請替換下列預留位置:

  • 接收器設定:

    • listen_address:要監聽的 IP 位址和通訊埠:
      • 0.0.0.0:在所有介面上監聽 (建議)
      • 通訊埠 514 是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用 1514)
  • 匯出工具設定:

    • creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:從 Google SecOps 控制台複製的客戶 ID
    • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會以這個值做為 chronicle.googleapis.com 的前置字元。如需完整清單,請參閱「區域性端點」。
    • project:依序前往「IAM 與管理」>「設定」,然後將 <PROJECT_NUMBER> 替換為專案編號。
    • endpoint:請將此值設為 chronicle.googleapis.com。

舊版擷取 API 匯出工具

  • 如果您使用選項 2 的擷取驗證檔案,請將 exporters 區塊替換為下列內容。將 creds_file_path 設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/barracuda_cloudgen_firewall:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: BARRACUDA_CLOUDGEN_FIREWALL
        raw_log_field: body
    

儲存設定檔

  • 編輯完畢後,請儲存檔案:
    • Linux:依序按下 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依序點選「檔案」 > 「儲存」

重新啟動 Bindplane 代理程式,套用變更

  • 如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 查看記錄檔是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R 鍵,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
      4. 確認服務正在執行:

        sc query observiq-otel-collector
        
      5. 檢查記錄是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

為 Barracuda CloudGen Firewall 啟用系統記錄串流

  1. 在 Box 層級登入 Barracuda Firewall Control Center。
  2. 依序前往「Configuration」>「Full Configuration」>「Box」>「Infrastructure Services」>「Syslog Streaming」。
  3. 按一下「鎖頭」圖示,即可啟用編輯功能。
  4. 將「Enable Syslog Streaming」切換為「Yes」。
  5. 依序點選「傳送變更」 > 「啟用」。

設定 Barracuda CloudGen Firewall 的記錄資料篩選器

  1. 依序前往「Configuration」 >「Full Configuration」 >「Box」 >「Infrastructure Services」 >「Syslog Streaming」。
  2. 選取「Logdata Filters」(記錄資料篩選器)。
  3. 按一下「設定模式」選單,然後選取「切換至進階檢視畫面」。
  4. 按一下「鎖頭」圖示,即可啟用編輯功能。
  5. 按一下「新增」即可新增項目。
  6. 在「篩選器」對話方塊中,提供不重複的名稱。
  7. 按一下 [確定]。
  8. 在「受影響的 Box 記錄資料」部分,選取「透過系統記錄傳送的記錄」。
  9. 按一下「資料選取」旁的「新增」。
  10. 為群組提供不重複的名稱。
  11. 按一下 [確定]。
  12. 從「資料選取」或特定類別中選取下列項目,以便記錄:
    • Auth-All
    • Config-All
    • Control-All
    • Event-All
    • Firewall-All
    • Network-All
    • Settings-All
    • SSH-All
    • System-All
  13. 從「Message Types」(訊息類型) 或特定嚴重性中選取下列項目,以便記錄:
    • Panic
    • Security
    • Fatal
    • Error
    • Warning
    • Notice
  14. 按一下 [確定]。
  15. 依序點選「傳送變更」「啟用」。

設定 Barracuda CloudGen Firewall 的記錄串流目的地

  1. 依序前往「Configuration」>「Full Configuration」>「Box」>「Infrastructure Services」>「Syslog Streaming」。
  2. 選取「Logstream Destinations」。
  3. 按一下「設定模式」選單,然後選取「切換至進階檢視」。
  4. 按一下「鎖頭」圖示,即可啟用編輯功能。
  5. 按一下「新增」即可新增項目。
  6. 為目的地提供不重複的名稱。
  7. 按一下 [確定]。
  8. 選取新建立的記錄串流目的地。
  9. 按一下「Explicit IP」。
  10. 提供下列設定詳細資料:
    • 目的地 IP 位址:輸入 Bindplane 代理程式 IP 位址。
    • 「Destination Port」(目標通訊埠):輸入 Bindplane 代理程式通訊埠號碼。
    • Transmission Mode:選取「UDP」。
  11. 按一下 [確定]。
  12. 依序點選「傳送變更」「啟用」。

設定 Barracuda CloudGen Firewall 的記錄資料串流

  1. 依序前往「Configuration」>「Full Configuration」>「Box」>「Infrastructure Services」>「Syslog Streaming」。
  2. 選取「Logdata Streams」。
  3. 按一下「設定模式」選單,然後選取「切換至進階檢視畫面」。
  4. 按一下「鎖頭」圖示,即可啟用編輯功能。
  5. 按一下「新增」即可新增項目。
  6. 為設定提供專屬名稱。
  7. 按一下 [確定]。
  8. 將「Active Streams」設為「Yes」。
  9. 將「Log Destinations」(記錄檔目的地) 設為先前建立的目的地。
  10. 將「記錄篩選器」設為先前建立的篩選器。
  11. 按一下 [確定]。
  12. 依序點選「傳送變更」「啟用」。

UDM 對應表

記錄欄位 UDM 對應 邏輯
connection_type_label additional.fields 已合併
details_label additional.fields 已合併
id_label additional.fields 已合併
process_name_label additional.fields 已合併
desc metadata.description 直接對應
has_principal metadata.event_type 已對應:true → NETWORK_CONNECTION、true → STATUS_UPDATE
has_user metadata.event_type 已對應:true → USER_UNCATEGORIZED
host principal.asset.hostname 直接對應
column13 principal.asset.ip 已合併
src_ip principal.asset.ip 已合併
host principal.hostname 直接對應
column13 principal.ip 已合併
src_ip principal.ip 已合併
column6 principal.mac 已合併
column5 principal.port 已重新命名/對應
src_port principal.port 直接對應
_action security_result.action 已合併
action security_result.action 已對應:Allow → _action
action security_result.action_details 直接對應
severity security_result.severity 對應:INFO → INFORMATIONAL、WARNING → MEDIUM、BLOCK → ERROR
severity security_result.severity_details 直接對應
tar_app target.application 直接對應
column14 target.asset.ip 已合併
column7 target.asset.ip 已合併
dst_ip target.asset.ip 已合併
column14 target.ip 已合併
column7 target.ip 已合併
dst_ip target.ip 已合併
mac target.mac 已合併
column8 target.port 已重新命名/對應
dst_port target.port 已重新命名/對應
product_id target.process.pid 直接對應
user_id target.user.userid 直接對應
不適用 metadata.event_type 常數:NETWORK_CONNECTION
不適用 metadata.product_name 常數:BARRACUDA CLOUDGEN FIREWALL
不適用 metadata.vendor_name 常數:BARRACUDA CLOUDGEN FIREWALL
不適用 security_result.severity 常數:INFORMATIONAL
server event.idm.read_only_udm.additional.fields 從變更記錄對應
service event.idm.read_only_udm.additional.fields 從變更記錄對應
box event.idm.read_only_udm.additional.fields 從變更記錄對應
startport event.idm.read_only_udm.additional.fields 從變更記錄對應
endport event.idm.read_only_udm.additional.fields 從變更記錄對應
request_type event.idm.read_only_udm.additional.fields 從變更記錄對應
request_key event.idm.read_only_udm.additional.fields 從變更記錄對應
syslogpriority event.idm.read_only_udm.additional.fields 從變更記錄對應
peer event.idm.read_only_udm.principal.ip 和 event.idm.read_only_udm.principal.asset.ip 從變更記錄對應
origin event.idm.read_only_udm.principal.application 從變更記錄對應
desc event.idm.read_only_udm.metadata.description 從變更記錄對應
principal_user_id event.idm.read_only_udm.principal.user.userid 從變更記錄對應
cn_data event.idm.read_only_udm.principal.user.group_identifiers 從變更記錄對應
src_port event.idm.read_only_udm.principal.port 從變更記錄對應
column1 event.idm.read_only_udm.additional.fields 從變更記錄對應
column3 event.idm.read_only_udm.additional.fields 從變更記錄對應
column9 event.idm.read_only_udm.additional.fields 從變更記錄對應
column12 event.idm.read_only_udm.security_result.rule_id 從變更記錄對應
column4 event.idm.read_only_udm.principal.ip 和 event.idm.read_only_udm.principal.asset.ip 從變更記錄對應
column2 event.idm.read_only_udm.network.ip_protocol 從變更記錄對應
ts_timestamp event.idm.read_only_udm.metadata.event_timestamp 從變更記錄對應

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。