收集 BloxOne Threat Defense 記錄
剖析器版本:8.0
本文說明如何使用 Bindplane 代理程式,將 BloxOne Threat Defense 記錄檔擷取至 Google Security Operations。
Infoblox BloxOne Threat Defense 是一項雲端管理的 DNS 安全防護服務,可針對 DNS 查詢、威脅情報事件和政策動作,以 CEF 格式產生系統記錄訊息。剖析器會將欄位正規化,並對應至統合式資料模型 (UDM)。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理與 Infoblox BloxOne 平台之間的網路連線
- 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
- Infoblox 入口網站的特殊存取權
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 請提供下列設定詳細資料:
- 服務帳戶名稱:輸入帳戶名稱 (例如
bindplane-ingest)。 - 服務帳戶說明:輸入說明 (例如
Bindplane agent log ingestion)。
- 服務帳戶名稱:輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 為/opt/observiq-otel-collector/ingestion-auth.json,Windows 為C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存檔案的路徑相符。 - 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。匯出工具設定時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」 > 「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「設定檔」。
複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟命令提示字元或 PowerShell。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/bloxone: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: BLOXONE raw_log_field: body service: pipelines: logs/bloxone_to_chronicle: receivers: - udplog exporters: - chronicle/bloxone
設定參數
替換下列預留位置:
接收器設定:
listen_address:要監聽的 IP 位址和通訊埠:0.0.0.0:在所有介面上監聽 (建議)- 通訊埠
514是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用1514)
Exporter 設定:
creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:從 Google SecOps 控制台複製的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會以這個值做為chronicle.googleapis.com的前置字元。如需完整清單,請參閱「區域性端點」。project:將<PROJECT_NUMBER>替換為「IAM 與管理」>「設定」中的專案編號。endpoint:維持設為chronicle.googleapis.com。
舊版擷取 API 匯出工具
如果您使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/bloxone: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: BLOXONE raw_log_field: body
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」>「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector檢查記錄是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector檢查記錄是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
在 Infoblox BloxOne 中設定系統記錄檔
- 登入 Infoblox 入口網站。
- 依序前往「Configure」>「Administration」>「Data Connector」。
- 選取「目的地設定」分頁標籤。
- 依序點選「建立」 > 「Syslog」。
- 提供下列設定詳細資料:
- 名稱:提供描述性名稱 (例如 Google SecOps 收集器)。
- 說明:提供簡短說明。
- 狀態:選取「啟用」。
- 標記:按一下「新增」,然後指定下列項目,將鍵與目的地建立關聯:
- KEY:輸入金鑰的描述性名稱。
- VALUE:輸入鍵的值。
- 格式:選取「CEF」。
- 「Protocol」(通訊協定):選取「UDP」或「TCP」(視 Bindplane 代理程式設定而定)。
- FQDN/IP:輸入 Bindplane 代理程式 IP 位址。
- 「Port」(通訊埠):輸入 Bindplane 代理程式通訊埠 (UDP 預設為
514)。
- 按一下「Save & Close」。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
additional_list.key |
這個欄位會在迴圈中用於疊代 additional_list 陣列,並根據 key 欄位的值擷取資料。不會直接對應至 UDM。 |
|
additional_list.value |
principal.location.region_latitude、principal.location.region_longitude、target.location.region_latitude、target.location.region_longitude |
這個欄位會與 additional_list.key 搭配使用,從 additional_list 陣列中擷取特定值。擷取及對應值的邏輯取決於對應的 key。例如:- 如果 additional_list.key 為 intel:source:ip:geoIP:location,請使用 grok 擷取經緯度值,並分別對應至 principal.location.region_latitude 和 principal.location.region_longitude。:如果 additional_list.key 為 intel:destination:ip:geoIP:location,請使用 grok 擷取經緯度值,並分別對應至 target.location.region_latitude 和 target.location.region_longitude。 |
additional_string.key |
與 additional_list.key 類似,這個欄位會在迴圈中用於疊代 additional_string 陣列,並根據 key 值擷取資料。不會直接對應至 UDM。 |
|
additional_string.value |
additional.fields.value.string_value,principal.location.country_or_region,target.location.country_or_region,src.ip,src.port,src.hostname,network.ip_protocol |
與 additional_string.key 搭配使用,從 additional_string 陣列中擷取值。對應值的邏輯取決於對應的 key。例如:- 如果 additional_string.key 為 intel:source:ip:ip2asn:start_ip、intel:source:ip:ip2asn:finish_ip、intel:destination:ip:ip2asn:start_ip 或 intel:destination:ip:ip2asn:finish_ip,請使用對應的鍵將值對應至 additional.fields.value.string_value。:如果 additional_string.key 為 intel:source:ip:geoIP:country,請將值對應至 principal.location.country_or_region。:如果 additional_string.key 為 intel:destination:ip:geoIP:country,請將值對應至 target.location.country_or_region。:如果 additional_string.key 為 log:source:ip,請將值對應至 src.ip。- 如果 additional_string.key 為 log:source:port,請將值轉換為整數,然後對應至 src.port。:如果 additional_string.key 為 log:source:hostname,請將值對應至 src.hostname。:如果 additional_string.key 為 log:cdh:input:protocol,請將值轉換為大寫,然後對應至 network.ip_protocol。 |
app_category |
security_result.category_details |
直接對應。 |
confidence |
security_result.confidence |
根據下列邏輯對應: - 如果 confidence 為 LOW,則對應至 LOW_CONFIDENCE。- 如果 confidence 為 MEDIUM,則對應至 MEDIUM_CONFIDENCE。- 如果 confidence 為 HIGH,則對應至 HIGH_CONFIDENCE。 |
country |
principal.location.name |
直接對應,但僅限 raw.infobloxb1region 為空白時。 |
device |
principal.ip、principal.asset.ip |
直接對應,但僅限 raw.dvc 為空白時。 |
dhcp_fingerprint |
security_result.detection_fields.value |
直接對應至 dhcp_fingerprint 鍵。 |
dns_view |
security_result.detection_fields.value |
直接對應至 dns_view 鍵。 |
endpoint_groups |
security_result.detection_fields.value |
直接對應至 endpoint_groups 鍵。 |
event_time |
metadata.event_timestamp.seconds |
系統會將其剖析為 ISO8601 時間戳記,並擷取秒數值。只有在 timestamp 欄位空白時才會使用。 |
feed_name |
principal.resource.name |
feed_name 對應至 principal.resource.name。 |
feed_type |
principal.resource.attribute.labels.value |
直接對應至 feed_type 鍵。 |
mac_address |
principal.mac |
轉換為小寫後直接對應。 |
network |
principal.hostname、principal.asset.hostname |
直接對應,但前提是 raw.dvchost 和 raw.dvc 皆為空白。 |
os_version |
principal.platform_version |
直接對應。 |
policy_action |
security_result.action_details、security_result.action |
policy_action 直接對應至 security_result.action_details。security_result.action 是根據下列邏輯衍生而來:- 如果 policy_action 為 Redirect 或 Log,則對應至 ALLOW。- 如果 policy_action 為 BLOCK,則對應至 BLOCK。 |
policy_name |
security_result.detection_fields.value |
直接對應至 policy_name 鍵。 |
qname |
network.dns.questions.name |
直接對應。 |
qtype |
network.dns.questions.type |
根據下列邏輯對應: - 如果 qtype 為 A,則對應至 1 (轉換為不帶正負號的整數)。- 如果 qtype 為 PTR,則對應至 12 (轉換為不帶正負號的整數)。 |
raw.act |
security_result.action_details |
直接對應。 |
raw.app |
network.application_protocol |
轉換為大寫後直接對應。 |
raw.deviceeventclassid |
metadata.product_event_type |
與 raw.name 串連 (以 - 分隔),並對應至 metadata.product_event_type。 |
raw.devicevendor |
metadata.vendor_name |
直接對應。 |
raw.deviceproduct |
metadata.product_name |
直接對應。 |
raw.deviceversion |
metadata.product_version |
直接對應。 |
raw.deviceseverity |
security_result.severity_details、security_result.severity |
raw.deviceseverity 會直接對應至 security_result.severity_details。security_result.severity 是根據下列邏輯衍生而來:- 如果 raw.deviceseverity 位於 [0、1、2、3],則對應至 LOW。- If raw.deviceseverity is in [4, 5, 6], map to MEDIUM.- 如果 raw.deviceseverity 介於 [7, 8],則對應至 HIGH。- 如果 raw.deviceseverity 介於 [9, 10],則對應至 CRITICAL。 |
raw.dvc |
principal.ip、principal.asset.ip |
直接對應。 |
raw.dvchost |
principal.hostname、principal.asset.hostname |
直接對應,但僅限不等於 raw.dvc 的情況。 |
raw.infobloxb1connectiontype |
additional.fields.value.string_value |
直接對應至 infobloxb1connectiontype 鍵。 |
raw.infobloxb1ophname |
observer.hostname、observer.asset.hostname |
直接對應。 |
raw.infobloxb1ophipaddress |
observer.ip |
直接對應。 |
raw.infobloxb1policyname |
security_result.detection_fields.value |
直接對應至鍵 infobloxb1policyname。 |
raw.infobloxdnsqclass |
dns_question.class、dns_answer.class |
根據 dns_query_class_mapping.include 檔案中定義的對照表,衍生 dns_question.class 和 dns_answer.class。 |
raw.infobloxdnsqtype |
dns_question.type、dns_answer.type |
根據 dns_record_type.include 檔案中定義的對照表衍生 dns_question.type 和 dns_answer.type。 |
raw.infobloxdnsrcode |
network.dns.response_code |
根據 dns_response_code.include 檔案中定義的對照表,衍生 network.dns.response_code。 |
raw.infobloxpolicyid |
security_result.detection_fields.value |
直接對應至 infobloxpolicyid 鍵。 |
raw.msg |
metadata.description |
移除開頭和結尾的引號後,raw.msg 會直接對應至 metadata.description。 |
raw.name |
metadata.product_event_type |
與 raw.deviceeventclassid 串連 (以 - 分隔),並對應至 metadata.product_event_type。 |
rcode |
security_result.detection_fields.value、network.dns.response_code |
rcode 會直接對應至 security_result.detection_fields.value,並使用鍵 rcode。如果 rcode 為 NXDOMAIN,則 network.dns.response_code 會設為 3 (轉換為不帶正負號的整數)。 |
rdata |
network.dns.answers.data |
直接對應。 |
rip |
target.ip、target.asset.ip |
直接對應。 |
severity |
security_result.severity |
對應邏輯如下: - 如果 severity 為 INFO (不區分大小寫),則對應至 INFORMATIONAL。- 如果 severity 為 HIGH,則對應至 HIGH。 |
tclass |
security_result.detection_fields.value |
直接對應至鍵 tclass。 |
threat_indicator |
security_result.detection_fields.value |
直接對應至 threat_indicator 鍵。 |
timestamp |
metadata.event_timestamp.seconds |
剖析為 ISO8601 時間戳記,並擷取秒數值。 |
user |
principal.user.user_display_name |
直接對應。 |
user_groups |
security_result.detection_fields.value |
直接對應至鍵 user_groups。 |
| 不適用 | principal.resource.resource_subtype |
如果 feed_name 不為空白,請設為 Feed。 |
| 不適用 | metadata.log_type |
設為 BLOXONE。 |
| 不適用 | additional.fields.key |
根據對應的 raw 欄位,設為 infobloxancount、infobloxarcount、infobloxb1connectiontype、infobloxnscount、intel:destination:ip:ip2asn:finish_ip、intel:destination:ip:ip2asn:start_ip、intel:source:ip:ip2asn:finish_ip 或 intel:source:ip:ip2asn:start_ip。 |
| 不適用 | metadata.event_type |
如果 has_principal 為 true,請設為 STATUS_UPDATE,否則請設為 GENERIC_EVENT。 |
| 不適用 | network.dns.questions.type |
A 記錄設為 1,PTR 記錄設為 12,並轉換為不帶正負號的整數。 |
| 不適用 | network.dns.answers.name、network.dns.answers.type、network.dns.answers.class |
透過剖析 DNS 回應字串,從 raw.msg 擷取。 |
| 不適用 | intermediary.hostname、intermediary.ip、intermediary.asset.ip |
透過剖析 DNS 回應字串,從 raw.msg 擷取。 |
intermediaryhost |
intermediary.hostname |
從變更記錄對應 |
app_name |
principal.application |
從變更記錄對應 |
endpoint_groups", "user_groups", "dns_view", "dhcp_fingerprint", "policy_name", "tclass", "tproperty", "threat_indicator", "category", and "rcode |
security_result.detection_fields |
從變更記錄對應 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。