收集 Broadcom CA PAM 日志
解析器版本: 1.0
本文档介绍了如何使用 Bindplane 将 Broadcom CA Privileged Access Manager 日志注入 Google Security Operations。Broadcom CA Privileged Access Manager (PAM) 是一种企业级特权访问管理解决方案,用于控制、监控和审核特权用户对关键系统的访问。它在混合环境中提供凭据保管、会话记录和访问政策执行功能。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例。
- 搭载 systemd 的 Windows 2016 或更高版本或 Linux 主机。
- 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于打开状态。
- 对 Broadcom Privileged Access Management 网页界面的特权访问权限。
获取 Bindplane 代理的 Google SecOps 凭据
如需向 Google SecOps 验证 Bindplane 代理的身份,请选择以下方法之一:
- 新部署:使用 Chronicle API(方法 1)。
- 旧版部署:继续使用注入身份验证文件(方法 2),直到注入 API 于 2027 年 7 月 20 日停用为止。
方法 1:为 Chronicle API 创建服务帐号(推荐)
- 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
- 依次前往 IAM 和管理 > 服务账号。
- 点击创建服务账号 。
- 提供以下配置详细信息:
- 服务账号名称:输入账号的名称(例如
bindplane-ingest)。 - 服务账号说明:输入说明(例如
Bindplane agent log ingestion)。
- 服务账号名称:输入账号的名称(例如
- 点击创建并继续 。
- 在向此服务帐号授予对项目的访问权限 部分,点击选择角色 ,然后选择 Chronicle Editor 。
- 点击继续 ,然后点击完成 。
- 点击您创建的服务帐号,然后前往密钥 标签页。
- 依次点击添加密钥 > 创建新密钥。
- 选择 JSON ,然后点击创建 。密钥文件会下载到您的计算机上。
- 将密钥文件另存为 Bindplane 收集器目录中的
ingestion-auth.json(在 Linux 上为/opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或者更新creds_file_path在config.yaml中以与您保存该文件的路径匹配。 - 依次前往 IAM 和管理 > 设置 ,然后复制项目编号 。您需要此编号进行导出器配置。
方法 2:下载注入身份验证文件(旧版)
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
- 下载注入身份验证文件 。
- 将该文件安全地保存在将安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 个人资料。
- 从组织详细信息 部分复制并保存客户 ID 。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符 或 PowerShell 。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
Linux 安装
- 打开具有根权限或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
其他安装资源
如需了解其他安装选项,请参阅安装指南。
将 Bindplane 代理配置为注入 syslog 并发送到 Google SecOps
访问配置文件:
- 找到
config.yaml文件。通常,该文件位于 Linux 上的/observiq-otel-collector/目录中,或位于 Windows 上的安装目录中。 - 使用文本编辑器(例如
nano、vi或记事本)打开该文件。
- 找到
按如下方式修改
config.yaml文件:receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/broadcom_ca_pam: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/path/to/ingestion-authentication-file.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: BROADCOM_CA_PAM raw_log_field: body ingestion_labels: service: pipelines: logs/broadcom_ca_pam: receivers: - tcplog exporters: - chronicle/broadcom_ca_pam
- 根据基础架构中的需要替换端口和 IP 地址。
- 将
<LOCATION>替换为 Google SecOps 实例的区域(例如us、europe或asia-southeast1)。导出器会使用此值为chronicle.googleapis.com添加前缀。 - 将
<PROJECT_NUMBER>替换为 IAM 和管理 > 设置 中的项目编号。 - 将
<customer_id>替换为实际客户 ID。 - 将
/path/to/ingestion-authentication-file.json更新为在 获取 Bindplane 代理的 Google SecOps 凭据 部分中保存服务帐号密钥文件(方法 1)的路径。
旧版注入 API 导出器
如果您使用方法 2 中的注入身份验证文件,请将
exporters代码块替换为以下内容。将creds_file_path设置为注入身份验证文件的路径,并且如果您的实例位于美国境外,请将malachiteingestion-pa.googleapis.com替换为您的 区域端点(例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/broadcom_ca_pam: compression: gzip creds_file_path: '/path/to/ingestion-authentication-file.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: BROADCOM_CA_PAM raw_log_field: body ingestion_labels:
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请执行以下操作:
运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志中的错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请执行以下操作:
请从下列选项中选择一项:
- 以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector- 服务控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry Collector 。
- 右键点击并选择重启 。
- 按
验证服务是否正在运行:
sc query observiq-otel-collector检查日志中的错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
在 Broadcom CA PAM 上配置远程 syslog
- 登录 Privileged Access Management 网页界面。
- 依次前往配置 > 日志 > Syslog。
- 选择 Syslog Enabled (启用 Syslog)切换开关。
- 从消息格式 列表中选择 Space Delimited (空格分隔)。
- 点击添加服务器 。
在新行中提供以下配置详细信息:
- 服务器:输入 Bindplane 代理 IP 地址(例如
192.168.1.100)。 - 端口:输入
514(或您配置的 Bindplane 代理端口)。如果将端口留空,则默认值为514。 - 协议:选择 TCP。
- 服务器:输入 Bindplane 代理 IP 地址(例如
点击更新 以保存设置。
通过检查 Bindplane 代理日志,验证日志是否正在发送。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
UserGroup_label |
additional.fields |
已合并 |
access_protocol |
metadata.access_protocol |
直接映射 |
Details |
metadata.description |
直接映射 |
has_principal |
metadata.event_type |
已映射:true → SCAN_UNCATEGORIZED,true → STATUS_UPDATE |
has_user |
metadata.event_type |
已映射:true → USER_UNCATEGORIZED |
host |
principal.asset.hostname |
直接映射 |
host |
principal.hostname |
直接映射 |
NatIP |
principal.nat_ip |
已合并 |
Port |
principal.port |
直接映射 |
pid |
principal.process.pid |
直接映射 |
DeviceName |
principal.resource.name |
直接映射 |
User |
principal.user.userid |
直接映射 |
sec_res |
security_result |
已合并 |
detection_fields |
security_result.detection_fields |
已合并 |
Service_App |
target.application |
直接映射 |
Address |
target.asset.hostname |
直接映射 |
Address |
target.hostname |
直接映射 |
| 不适用 | metadata.event_type |
常量:SCAN_UNCATEGORIZED |
| 不适用 | metadata.product_name |
常量:Broadcom CA Pam |
| 不适用 | metadata.vendor_name |
常量:Broadcom |
更新日志
需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。