收集 Check Point EDR 記錄

剖析器版本:20.0

支援的服務:

本文說明如何使用 Bindplane 代理程式,將 Check Point EDR (SandBlast) 記錄擷取至 Google Security Operations。

Check Point EDR 會產生端點威脅偵測、程序活動、檔案事件和網路連線的記錄。剖析器會擷取 CEF 和鍵/值欄位,並對應至統合式資料模型 (UDM)。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Check Point 設備之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • 透過 SandBlast 取得 Check Point 設備的特殊存取權

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:在 2027 年 7 月 20 日停用 Ingestion API 前,請繼續使用擷取驗證檔案 (選項 2)。
  1. 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 請提供下列設定詳細資料:
    • 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如 bindplane-ingest)。
    • 「服務帳戶說明」:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存路徑相符。
  12. 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。設定匯出工具時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM Settings」 > 「Collection Agents」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」 > 「設定檔」。
  3. 複製並儲存「機構詳細資料」部分的客戶 ID。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟命令提示字元或 PowerShell。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」。

Linux 安裝

  1. 開啟具有根層級或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為「active (running)」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    

    Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/checkpoint_edr:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: CHECKPOINT_EDR
        raw_log_field: body
    
    service:
      pipelines:
        logs/checkpoint_edr_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/checkpoint_edr
    

設定參數

請替換下列預留位置:

  • 接收器設定:

    • listen_address:要監聽的 IP 位址和通訊埠:
      • 0.0.0.0 在所有介面接聽電話 (建議)
      • 通訊埠 514 是標準的系統記錄通訊埠 (在 Linux 上需要根層級權限;如果沒有根層級權限,請使用 1514)
  • 匯出工具設定:

    • creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:從 Google SecOps 控制台複製的客戶 ID
    • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會在這個值前面加上 chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。
    • project:將 <PROJECT_NUMBER> 替換為「IAM 與管理」>「設定」中的專案編號。
    • endpoint:維持設為 chronicle.googleapis.com。

舊版 Ingestion API 匯出工具

  • 如果您使用選項 2 的擷取驗證檔案,請將 exporters 區塊替換為下列內容。將 creds_file_path 設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/checkpoint_edr:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: CHECKPOINT_EDR
        raw_log_field: body
    

儲存設定檔

  • 編輯完成後,請儲存檔案:
    • Linux:依序按下 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依序點選「檔案」 > 「儲存」

重新啟動 Bindplane 代理程式,套用變更

  • 如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 檢查記錄是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
      4. 確認服務是否正在執行:

        sc query observiq-otel-collector
        
      5. 查看記錄檔是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

在 Check Point 1500 Appliance Series 中設定系統記錄

  1. 登入 Checkpoint 裝置。
  2. 依序前往「Logs & Monitoring」 >「Log Servers」 >「Syslog Servers」。
  3. 按一下 [設定]。
  4. 提供下列設定詳細資料:
    • 「通訊協定」:選取「UDP」。
    • Name:輸入描述性名稱。
    • IP 位址:輸入 Bindplane 代理程式 IP 位址。
    • Port:輸入 Bindplane 代理程式通訊埠編號。
    • 選取「啟用」記錄伺服器。
    • 選取要轉送的記錄:系統記錄和安全性記錄。
  5. 按一下「套用」。

UDM 對應表

記錄欄位 UDM 對應 邏輯
action event.idm.read_only_udm.security_result.action 直接從 action CEF 欄位對應。
action_comment event.idm.read_only_udm.additional.fields[<N>].key:action_comment
event.idm.read_only_udm.additional.fields[<N>].value.string_value:action_comment 的值
直接從 action_comment 欄位對應。
action_details event.idm.read_only_udm.security_result.action_details 直接從 action_details CEF 欄位對應。
additional_info event.idm.read_only_udm.additional.fields[<N>].key:additional_info
event.idm.read_only_udm.additional.fields[<N>].value.string_value:additional_info 的值
直接從「additional_info」欄位對應。
am_update_proxy event.idm.read_only_udm.intermediary.domain.name 直接從 am_update_proxy 欄位對應。
am_update_source event.idm.read_only_udm.target.url 直接從「am_update_source」欄位對應。
client_version event.idm.read_only_udm.metadata.product_version 直接從 client_version 欄位對應。
cn1 event.idm.read_only_udm.security_result.severity 從 cn1 CEF 欄位對應,並轉換為 UDM 嚴重性值 (CRITICAL、HIGH、MEDIUM、LOW、INFO)。
cs1 event.idm.read_only_udm.additional.fields[<N>].key:Connectivity State
event.idm.read_only_udm.additional.fields[<N>].value.string_value:cs1 的值
直接從 cs1 欄位對應。
description event.idm.read_only_udm.metadata.description 直接從 description CEF 欄位對應。
deviceDirection event.idm.read_only_udm.network.direction 從「deviceDirection」欄位對應。0 的值會對應至 INBOUND,其他值則不會對應。
deviceFacility event.idm.read_only_udm.additional.fields[<N>].key:deviceFacility
event.idm.read_only_udm.additional.fields[<N>].value.string_value:deviceFacility 的值
直接從 deviceFacility 欄位對應。
dst event.idm.read_only_udm.network.target.ip 當 event_type 為 Firewall 時,直接從 dst 欄位對應。
engine_ver event.idm.read_only_udm.additional.fields[<N>].key:engine_ver
event.idm.read_only_udm.additional.fields[<N>].value.string_value:engine_ver 的值
直接從「engine_ver」欄位對應。
ep_rule_id event.idm.read_only_udm.firewall.firewall_rule_id 當 event_type 為 Firewall 時,直接從 ep_rule_id 欄位對應。
event_type event.idm.read_only_udm.metadata.product_event_type 直接從 event_type CEF 欄位對應。
failed_updates event.idm.read_only_udm.additional.fields[<N>].key:failed_updates
event.idm.read_only_udm.additional.fields[<N>].value.string_value:failed_updates 的值
直接從「failed_updates」欄位對應。
file_md5 event.idm.read_only_udm.source_file.hash_md5 當 event_type 為 TE Event 時,直接從 file_md5 欄位對應。
file_name event.idm.read_only_udm.source_file.file_name 當 event_type 為 TE Event 時,直接從 file_name 欄位對應。
file_sha1 event.idm.read_only_udm.source_file.hash_sha1 當 event_type 為 TE Event 時,直接從 file_sha1 欄位對應。
file_sha256 event.idm.read_only_udm.source_file.hash_sha256 當 event_type 為 TE Event 時,直接從 file_sha256 欄位對應。
host_type event.idm.read_only_udm.principal.asset.type 從「host_type」欄位對應。Desktop 會轉換為 WORKSTATION,然後值會轉換為大寫。
ifdir event.idm.read_only_udm.network.direction 直接從 ifdir 欄位對應,且當 event_type 為 Firewall 時,會轉換為大寫。
installed_products event.idm.read_only_udm.principal.asset.software.name 直接從「installed_products」欄位對應。
is_scanned sec_res.detection_fields[<N>].key:is_scanned
sec_res.detection_fields[<N>].value:is_scanned 的值
直接從 is_scanned 欄位對應。
local_time event.idm.read_only_udm.additional.fields[<N>].key:local_time
event.idm.read_only_udm.additional.fields[<N>].value.string_value:local_time 的值
直接從 local_time 欄位對應。
log_type event.idm.read_only_udm.metadata.log_type 直接從 log_type 欄位對應。
loguid event.idm.read_only_udm.metadata.product_log_id 直接從 loguid 欄位對應。
machine_guid event.idm.read_only_udm.principal.asset.product_object_id 直接從 machine_guid 欄位對應。
media_authorized event.idm.read_only_udm.additional.fields[<N>].key:media_authorized
event.idm.read_only_udm.additional.fields[<N>].value.string_value:media_authorized 的值
直接從 media_authorized 欄位對應。
media_class_id event.idm.read_only_udm.additional.fields[<N>].key:media_class_id
event.idm.read_only_udm.additional.fields[<N>].value.string_value:media_class_id 的值
直接從 media_class_id 欄位對應。
media_description event.idm.read_only_udm.additional.fields[<N>].key:media_description
event.idm.read_only_udm.additional.fields[<N>].value.string_value:media_description 的值
直接從「media_description」欄位對應。
media_encrypted event.idm.read_only_udm.additional.fields[<N>].key:media_encrypted
event.idm.read_only_udm.additional.fields[<N>].value.string_value:media_encrypted 的值
直接從「media_encrypted」欄位對應。
media_manufacturer event.idm.read_only_udm.additional.fields[<N>].key:media_manufacturer
event.idm.read_only_udm.additional.fields[<N>].value.string_value:media_manufacturer 的值
直接從「media_manufacturer」欄位對應。
media_type event.idm.read_only_udm.additional.fields[<N>].key:media_type
event.idm.read_only_udm.additional.fields[<N>].value.string_value:media_type 的值
直接從 media_type 欄位對應。
msg event.idm.read_only_udm.metadata.description 直接從 msg CEF 欄位對應。
origin event.idm.read_only_udm.about.ip 直接從 origin CEF 欄位對應。
os_name event.idm.read_only_udm.additional.fields[<N>].key:os_name
event.idm.read_only_udm.additional.fields[<N>].value.string_value:os_name 的值
直接從 os_name 欄位對應。
os_version event.idm.read_only_udm.principal.asset.platform_software.platform_version 直接從 os_version 欄位對應。
policy_date event.idm.read_only_udm.additional.fields[<N>].key:policy_date
event.idm.read_only_udm.additional.fields[<N>].value.string_value:policy_date 的值
直接從 policy_date 欄位對應。
policy_guid event.idm.read_only_udm.principal.resource.product_object_id 直接從「policy_guid」欄位對應。
policy_name event.idm.read_only_udm.principal.resource.name 直接從 policy_name 欄位對應。
policy_number event.idm.read_only_udm.principal.resource.product_object_id 直接從「policy_number」欄位對應。
policy_type event.idm.read_only_udm.additional.fields[<N>].key:policy_type
event.idm.read_only_udm.additional.fields[<N>].value.string_value:policy_type 的值
直接從 policy_type 欄位對應。
policy_version event.idm.read_only_udm.additional.fields[<N>].key:policy_version
event.idm.read_only_udm.additional.fields[<N>].value.string_value:policy_version 的值
直接從 policy_version 欄位對應。
product event.idm.read_only_udm.metadata.product_name 直接從 product CEF 欄位對應。
proto event.idm.read_only_udm.network.protocol 當 event_type 為 Firewall 時,直接從 proto 欄位對應。
reading_data_access event.idm.read_only_udm.additional.fields[<N>].key:reading_data_access
event.idm.read_only_udm.additional.fields[<N>].value.string_value:reading_data_access 的值
直接從 reading_data_access 欄位對應。
requestClientApplication event.idm.read_only_udm.network.http.user_agent 直接從「requestClientApplication」欄位對應。
result event.idm.read_only_udm.security_result.summary 直接從 result 欄位對應。
rt event.idm.read_only_udm.metadata.event_timestamp.seconds 從 rt 欄位對應,除以 1000,並將整數部分視為秒。
rule_name event.idm.read_only_udm.firewall.firewall_rule 當 event_type 為 Firewall 時,直接從 rule_name 欄位對應。
s_port event.idm.read_only_udm.network.client.port 當 event_type 為 Firewall 時,直接從 s_port 欄位對應。
sequencenum event.idm.read_only_udm.additional.fields[<N>].key:sequencenum
event.idm.read_only_udm.additional.fields[<N>].value.string_value:sequencenum 的值
直接從「sequencenum」欄位對應。
service event.idm.read_only_udm.network.target.port 當 event_type 為 Firewall 時,直接從 service 欄位對應。
severity event.idm.read_only_udm.security_result.severity 從 severity 欄位對應,並轉換為 UDM 嚴重性值 (CRITICAL、HIGH、MEDIUM、LOW、INFO)。
shost event.idm.read_only_udm.principal.hostname 直接從 shost CEF 欄位對應。
sig_ver event.idm.read_only_udm.additional.fields[<N>].key:sig_ver
event.idm.read_only_udm.additional.fields[<N>].value.string_value:sig_ver 的值
直接從「sig_ver」欄位對應。
src event.idm.read_only_udm.principal.ip 直接從 src CEF 欄位對應。
src_machine_name event.idm.read_only_udm.principal.hostname 如果 event_type 為空白,則直接從 src_machine_name 欄位對應。
subject event.idm.read_only_udm.task.task_name 如果 event_type 為空,則直接從 subject 欄位對應。
suser event.idm.read_only_udm.principal.user.user_display_name 直接從 suser CEF 欄位對應。
time event.idm.read_only_udm.metadata.event_timestamp.seconds 直接從 time 欄位對應,並轉換為 Unix Epoch 紀元時間 (以秒為單位)。
user_name event.idm.read_only_udm.principal.user.email_addresses 直接從 user_name CEF 欄位對應。
user_sid event.idm.read_only_udm.principal.user.windows_sid 直接從「user_sid」欄位對應。
version event.idm.read_only_udm.additional.fields[<N>].key:version
event.idm.read_only_udm.additional.fields[<N>].value.string_value:version 的值
直接從「version」欄位對應。
writing_data_access event.idm.read_only_udm.additional.fields[<N>].key:writing_data_access
event.idm.read_only_udm.additional.fields[<N>].value.string_value:writing_data_access 的值
直接從 writing_data_access 欄位對應。
不適用 event.idm.read_only_udm.metadata.event_type 如果原始記錄中沒有 principal.ip、principal.hostname 或 principal.mac,請設為 GENERIC_EVENT,否則設為 STATUS_UPDATE。
不適用 event.idm.read_only_udm.metadata.vendor_name 常數值:Check Point。
不適用 event.idm.read_only_udm.metadata.log_type 常數值:CHECKPOINT_EDR。
不適用 event.idm.read_only_udm.principal.asset.platform_software.platform 如果 os_name 包含 WINDOWS 或 Windows,請設為 WINDOWS。
不適用 event.idm.read_only_udm.network.http.user_agent 如果存在 requestClientApplication,請設為 Check Point Endpoint Security Client。
不適用 event.edr.data_source 常數值:message 不含 CEF 時為 CHECKPOINT_SANDBLAST。
operation event.idm.read_only_udm.metadata.product_event_type 從變更記錄對應
administrator event.idm.read_only_udm.principal.user.userid 從變更記錄對應
client_ip event.idm.read_only_udm.target.ip 和 event.idm.read_only_udm.target.asset.ip 從變更記錄對應
objectname event.idm.read_only_udm.target.resource.name 從變更記錄對應
objecttype event.idm.read_only_udm.target.resource.attribute.labels 從變更記錄對應
Name event.idm.read_only_udm.target.resource.attribute.labels 從變更記錄對應
guid1 event.idm.read_only_udm.target.resource.attribute.labels 從變更記錄對應
guid2 event.idm.read_only_udm.target.resource.attribute.labels 從變更記錄對應
guid3 event.idm.read_only_udm.target.resource.attribute.labels 從變更記錄對應
guid4 event.idm.read_only_udm.target.resource.attribute.labels 從變更記錄對應
exclusionName1 event.idm.read_only_udm.target.resource.attribute.labels 從變更記錄對應
exclusionName4 event.idm.read_only_udm.target.resource.attribute.labels 從變更記錄對應
action event.idm.read_only_udm.security_result_action 從變更記錄對應
session_uid event.idm.read_only_udm.network.session_id 從變更記錄對應
origin event.idm.read_only_udm.principal.ip 和 event.idm.read_only_udm.principal.asset.ip 從變更記錄對應
Icon event.idm.read_only_udm.additional.fields 從變更記錄對應
flags event.idm.read_only_udm.additional.fields 從變更記錄對應
originsicname event.idm.read_only_udm.additional.fields 從變更記錄對應
advanced_changes event.idm.read_only_udm.additional.fields 從變更記錄對應
sendtotrackerasadvancedauditlog event.idm.read_only_udm.additional.fields 從變更記錄對應
ExclusionName event.idm.read_only_udm.principal.file.full_path 從變更記錄對應
id event.idm.read_only_udm.about.resource.product_object_id 從變更記錄對應
program_file event.idm.read_only_udm.about.file.full_path 從變更記錄對應
exclusionName2 event.idm.read_only_udm.security_result.about.url 從變更記錄對應
exclusionName3 event.idm.read_only_udm.security_result.about.file.full_path 從變更記錄對應
auth event.idm.read_only_udm.about.url 從變更記錄對應
uid event.idm.read_only_udm.target.resource.product_object_id 從變更記錄對應
src_machine_name event.idm.read_only_udm.principal.hostname 和 event.idm.read_only_udm.principal.asset.hostname 從變更記錄對應
src_user_name event.idm.read_only_udm.principal.user.userid 從變更記錄對應
src event.idm.read_only_udm.principal.ip 和 event.idm.read_only_udm.principal.asset.ip 從變更記錄對應
dst event.idm.read_only_udm.target.ip 和 event.idm.read_only_udm.target.asset.ip 從變更記錄對應
process_exe_path event.idm.read_only_udm.principal.process.file.full_path 從變更記錄對應
appi_name event.idm.read_only_udm.target.hostname 和 event.idm.read_only_udm.target.asset.hostname 從變更記錄對應
matched_category event.idm.read_only_udm.security_result.category_details 從變更記錄對應
reason event.idm.read_only_udm.security_result.summary 從變更記錄對應
protection_name event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
protection_type event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
usercheck_incident_uid event.idm.read_only_udm.additional.fields 從變更記錄對應
tenant_id event.idm.read_only_udm.additional.fields 從變更記錄對應
exclusion_engine_type event.idm.read_only_udm.additional.fields 從變更記錄對應
exclusion_type event.idm.read_only_udm.additional.fields 從變更記錄對應
virtual_groups event.idm.read_only_udm.additional.fields 從變更記錄對應
client_name event.idm.read_only_udm.target.resource.attribute.labels 從變更記錄對應
client_ip event.edr.network.target_ip 從變更記錄對應
origin event.edr.network.target_ip 從變更記錄對應
subject event.edr.task.task_name 從變更記錄對應
host_name event.edr.client.hostname 從變更記錄對應
ifdir event.edr.network.direction 從變更記錄對應

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。