收集 CipherTrust Manager 記錄
剖析器版本:18.0
支援的國家/地區:
Google SecOps
SIEM
本文說明如何使用 Bindplane 代理程式,將 CipherTrust Manager 記錄檔擷取至 Google Security Operations。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 CipherTrust Manager 之間的網路連線
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- CipherTrust Manager 網路主控台的特殊存取權
取得 Google SecOps 擷取驗證檔案
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「收集代理程式」。
- 下載擷取驗證檔案。
將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「設定檔」。
複製並儲存「機構詳細資料」部分中的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有根層級或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為有效 (執行中)。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /etc/bindplane-agent/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的所有內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/ciphertrust_manager: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: CIPHERTRUST_MANAGER raw_log_field: body service: pipelines: logs/ciphertrust_manager_to_chronicle: receivers: - udplog exporters: - chronicle/ciphertrust_manager
設定參數
替換下列預留位置:
接收器設定:
listen_address:要接聽的 IP 位址和通訊埠:0.0.0.0,監聽所有介面 (建議)- 通訊埠
514是標準的系統記錄通訊埠 (在 Linux 上需要根層級權限;非根層級權限請使用1514)
匯出工具設定:
creds_file_path:擷取驗證檔案的完整路徑:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:從 Google SecOps 控制台複製的客戶 IDendpoint:區域端點網址:- 美國:
malachiteingestion-pa.googleapis.com - 歐洲:
europe-malachiteingestion-pa.googleapis.com - 亞洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需完整清單,請參閱「區域端點」
- 美國:
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」>「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,以套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector檢查記錄中是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出 observIQ OpenTelemetry Collector。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector檢查記錄中是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
設定 CipherTrust Manager 的系統記錄
- 登入 CipherTrust Manager 網頁控制台。
- 依序前往「管理設定」>「通知」>「系統記錄」。
- 按一下「New Syslog Server」(新增系統記錄伺服器)。
- 請提供下列設定詳細資料:
- 主機:輸入 Bindplane 代理程式 IP 位址。
- 「Port」(通訊埠):輸入 Bindplane 代理程式通訊埠編號 (預設為 514)。
- 記錄格式:選取「RFC 5424」。
- 傳輸:選取「UDP」。
- 按一下 [儲存]。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
message |
about |
已對應:CEF → about |
deviceNtDomain |
about.administrative_domain |
已重新命名/對應 |
deviceExternalId |
about.asset.asset_id |
直接對應 |
device_product |
about.asset.asset_id |
直接對應 |
device_vendor |
about.asset.asset_id |
直接對應 |
fileHash |
about.file.full_path |
直接對應 |
filePath |
about.file.full_path |
已重新命名/對應 |
_hash |
about.file.sha256 |
已重新命名/對應 |
fileHash |
about.file.sha256 |
已重新命名/對應 |
fsize |
about.file.size |
已重新命名/對應 |
dvchost |
about.hostname |
已重新命名/對應 |
ips |
about.ip |
已合併 |
message |
about.ip |
已對應:CEF → ips |
dvc_mac |
about.mac |
已對應:slot → mac_address |
dvcmac |
about.mac |
已合併 |
mac_address |
about.mac |
已合併 |
message |
about.mac |
已對應:CEF → mac_address、CEF → dvcmac |
deviceTranslatedAddress |
about.nat_ip |
已合併 |
message |
about.nat_ip |
已對應:CEF → deviceTranslatedAddress |
Emne |
about.process.command_line |
直接對應 |
Path |
about.process.command_line |
直接對應 |
Subject |
about.process.command_line |
直接對應 |
deviceProcessName |
about.process.command_line |
已重新命名/對應 |
dvcpid |
about.process.pid |
已重新命名/對應 |
message |
about.resource.attribute.permissions |
已對應:CEF → permissions |
permissions |
about.resource.attribute.permissions |
已合併 |
Internal_label |
additional.fields |
已合併 |
additional_alias_alias_field |
additional.fields |
已合併 |
additional_alias_index_field |
additional.fields |
已合併 |
additional_alias_type_field |
additional.fields |
已合併 |
additional_cfp1 |
additional.fields |
已合併 |
additional_cfp2 |
additional.fields |
已合併 |
additional_cfp3 |
additional.fields |
已合併 |
additional_cfp4 |
additional.fields |
已合併 |
additional_cn1 |
additional.fields |
已合併 |
additional_cn2 |
additional.fields |
已合併 |
additional_cn3 |
additional.fields |
已合併 |
additional_cs1 |
additional.fields |
已合併 |
additional_cs2 |
additional.fields |
已合併 |
additional_cs3 |
additional.fields |
已合併 |
additional_cs4 |
additional.fields |
已合併 |
additional_cs5 |
additional.fields |
已合併 |
additional_cs6 |
additional.fields |
已合併 |
additional_cs7 |
additional.fields |
已合併 |
additional_devicePayloadId |
additional.fields |
已合併 |
additional_eventId |
additional.fields |
已合併 |
additional_flexString1 |
additional.fields |
已合併 |
additional_fname |
additional.fields |
已合併 |
algorithm_label |
additional.fields |
已合併 |
app_connector_type_label |
additional.fields |
已合併 |
assignSelfAsOwner_label |
additional.fields |
已合併 |
auth_domain_label |
additional.fields |
已合併 |
client_name_label |
additional.fields |
已合併 |
client_type_label |
additional.fields |
已合併 |
codeDesc_label |
additional.fields |
已合併 |
code_label |
additional.fields |
已合併 |
createdAt_label |
additional.fields |
已合併 |
cs2 |
additional.fields |
已對應:arc_test → additional_cs2 |
cs5_label |
additional.fields |
已合併 |
customAttributes_label |
additional.fields |
已合併 |
deatils_domain_id_label |
additional.fields |
已合併 |
details_user_metadata_current_domain_id_label |
additional.fields |
已合併 |
details_user_metadata_current_persistedData_label |
additional.fields |
已合併 |
details_user_metadata_current_persistedData_paging_label |
additional.fields |
已合併 |
domain_id_label |
additional.fields |
已合併 |
domain_label |
additional.fields |
已合併 |
emptyMaterial_label |
additional.fields |
已合併 |
feature_label |
additional.fields |
已合併 |
format_label |
additional.fields |
已合併 |
generateKeyId_label |
additional.fields |
已合併 |
idType_label |
additional.fields |
已合併 |
id_label |
additional.fields |
已合併 |
identifier_label |
additional.fields |
已合併 |
interfaceName_label |
additional.fields |
已合併 |
interfaceType_label |
additional.fields |
已合併 |
label_label |
additional.fields |
已合併 |
message |
additional.fields |
對應值 (共 71 個,例如 CEF → additional_eventId、CEF → `additional_devicePayloa... |
messageFormat_label |
additional.fields |
已合併 |
meta_label |
additional.fields |
已合併 |
objectType_label |
additional.fields |
已合併 |
ownerId_label |
additional.fields |
已合併 |
padded_label |
additional.fields |
已合併 |
permissions_label |
additional.fields |
已合併 |
record_type_id_label |
additional.fields |
已合併 |
refresh_token_counts_label |
additional.fields |
已合併 |
refresh_token_counts_no_label |
additional.fields |
已合併 |
refresh_token_counts_total_label |
additional.fields |
已合併 |
refresh_token_id_label |
additional.fields |
已合併 |
renew_refresh_token_label |
additional.fields |
已合併 |
requestId_label |
additional.fields |
已合併 |
requestIdentifierType_label |
additional.fields |
已合併 |
requestIdentifier_label |
additional.fields |
已合併 |
scope_label |
additional.fields |
已合併 |
service_label |
additional.fields |
已合併 |
switch_domain_id_label |
additional.fields |
已合併 |
undeletable_label |
additional.fields |
已合併 |
unexportable_label |
additional.fields |
已合併 |
version_label |
additional.fields |
已合併 |
xts_label |
additional.fields |
已合併 |
zone_id_label |
additional.fields |
已合併 |
details_grant_type |
extensions.auth.auth_details |
直接對應 |
logon_type_temp |
extensions.auth.mechanism |
已合併 |
message |
extensions.auth.mechanism |
已對應:CEF → logon_type_temp、Get User → logon_type_temp |
message |
intermediary |
已對應:CEF → intermediary |
proxy_ip |
intermediary.ip |
已合併 |
msg |
metadata.description |
已重新命名/對應 |
Generated |
metadata.event_timestamp |
已剖析為 yyyy-MM-ddTHH:mm:ss |
Received |
metadata.event_timestamp |
已剖析為 yyyy-MM-ddTHH:mm:ss |
event_time |
metadata.event_timestamp |
已剖析為 ISO8601 |
rt |
metadata.event_timestamp |
已剖析為 yyyy-MM-ddTHH:mm:ssZ |
syslog_timestamp |
metadata.event_timestamp |
已剖析為 MMM dd HH:mm:ss |
syslog_timestamp_with_year |
metadata.event_timestamp |
已剖析為 MMM dd HH:mm:ss yyyy |
cef_message |
metadata.event_type |
已對應:(Use Key/Update Key/Export Key) → USER_RESOURCE_UPDATE_CONTENT |
event_name |
metadata.event_type |
已對應:"LogSpyware","LogPredictiveMachineLearning" → SCAN_UNCATEGORIZED |
has_principal |
metadata.event_type |
已對應:true → NETWORK_CONNECTION |
has_user |
metadata.event_type |
已對應:true → USER_UNCATEGORIZED |
message |
metadata.event_type |
對應值 (共 12 個,例如 CEF → PROCESS_UNCATEGORIZED、CEF → SCAN_UNCATEGORIZED 等) |
device_event_class_id |
metadata.product_event_type |
直接對應 |
event_name |
metadata.product_event_type |
直接對應 |
externalId |
metadata.product_log_id |
直接對應 |
id |
metadata.product_log_id |
直接對應 |
uid |
metadata.product_log_id |
直接對應 |
device_product |
metadata.product_name |
直接對應 |
product |
metadata.product_name |
直接對應 |
product_name |
metadata.product_name |
直接對應 |
device_version |
metadata.product_version |
直接對應 |
device_vendor |
metadata.vendor_name |
已重新命名/對應 |
app_protocol_output |
network.application_protocol |
直接對應 |
deviceDirection |
network.direction |
已對應:0 → INBOUND、1 → OUTBOUND |
message |
network.direction |
已對應:CEF → INBOUND、CEF → OUTBOUND |
requestMethod |
network.http.method |
已重新命名/對應 |
requestClientApplication |
network.http.user_agent |
已重新命名/對應 |
ip_protocol_out |
network.ip_protocol |
直接對應 |
in |
network.received_bytes |
已重新命名/對應 |
out |
network.sent_bytes |
已重新命名/對應 |
sntdom |
principal.administrative_domain |
已重新命名/對應 |
sourceServiceName |
principal.application |
已重新命名/對應 |
syslog_host |
principal.asset.hostname |
直接對應 |
details_user_metadata_current_domain_name |
principal.domain.name |
直接對應 |
Group_name |
principal.group.group_display_name |
直接對應 |
Gruppenavn |
principal.group.group_display_name |
直接對應 |
Device_name |
principal.hostname |
直接對應 |
Enhetsnavn |
principal.hostname |
直接對應 |
shost |
principal.hostname |
已重新命名/對應 |
syslog_host |
principal.hostname |
直接對應 |
client_ip |
principal.ip |
已合併 |
message |
principal.ip |
已對應:CEF → principal_ip、CEF → shost、CEF → client_ip、`(SSL Handshake failed... |
principal_ip |
principal.ip |
已合併 |
shost |
principal.ip |
已合併 |
mac |
principal.mac |
已合併 |
message |
principal.mac |
已對應:CEF → mac |
message |
principal.nat_ip |
已對應:CEF → sourceTranslatedAddress |
sourceTranslatedAddress |
principal.nat_ip |
已合併 |
sourceTranslatedPort |
principal.nat_port |
已重新命名/對應 |
spt |
principal.port |
已重新命名/對應 |
sproc |
principal.process.command_line |
已重新命名/對應 |
spid |
principal.process.pid |
已重新命名/對應 |
acc_label |
principal.resource.attribute.labels |
已合併 |
acct_label |
principal.resource.attribute.labels |
已合併 |
iss_label |
principal.resource.attribute.labels |
已合併 |
jti_label |
principal.resource.attribute.labels |
已合併 |
message |
principal.resource.attribute.labels |
對應值 (共 5 個,例如 CEF → acct_label、CEF → acc_label、CEF → iss_label) |
sub_label |
principal.resource.attribute.labels |
已合併 |
message |
principal.user.attribute.roles |
已對應:CEF → principal_role |
principal_role |
principal.user.attribute.roles |
已合併 |
details_username |
principal.user.user_display_name |
直接對應 |
suser |
principal.user.user_display_name |
直接對應 |
username |
principal.user.user_display_name |
直接對應 |
details_user_id |
principal.user.userid |
直接對應 |
details_userid |
principal.user.userid |
直接對應 |
suid |
principal.user.userid |
已重新命名/對應 |
user_id |
principal.user.userid |
直接對應 |
username |
principal.user.userid |
直接對應 |
_security_result |
security_result |
已合併 |
message |
security_result |
已對應:CEF → security_result |
_action |
security_result.action |
已合併 |
act |
security_result.action |
已對應:accept → _action、deny → _action |
message |
security_result.action |
已對應:CEF → _action |
Action_Taken |
security_result.action_details |
直接對應 |
act |
security_result.action_details |
直接對應 |
details_errorMessage |
security_result.action_details |
直接對應 |
cat |
security_result.category_details |
已合併 |
message |
security_result.category_details |
已對應:CEF → cat |
Scan_Type |
security_result.description |
直接對應 |
Type |
security_result.description |
直接對應 |
message |
security_result.description |
直接對應 |
msg_data_2 |
security_result.description |
直接對應 |
infection_channel_label |
security_result.detection_fields |
已合併 |
message |
security_result.detection_fields |
對應值 (共 7 個,例如 CEF → operation_label、CEF → operasjon_label、CEF → `... |
operasjon_label |
security_result.detection_fields |
已合併 |
operation_label |
security_result.detection_fields |
已合併 |
permission_label |
security_result.detection_fields |
已合併 |
spyware_Grayware_Type_label |
security_result.detection_fields |
已合併 |
threat_probability_label |
security_result.detection_fields |
已合併 |
tillatelse_label |
security_result.detection_fields |
已合併 |
mwProfile |
security_result.rule_name |
直接對應 |
message |
security_result.severity |
已對應:CEF → LOW、CEF → MEDIUM、CEF → HIGH、CEF → CRITICAL |
severity |
security_result.severity |
對應:"0", "1", "2", "3", "LOW" → LOW、`"4", "5", "6", "MEDIUM", "SUBSTANTIAL", "INFO"... |
Result |
security_result.summary |
直接對應 |
appcategory |
security_result.summary |
直接對應 |
reason |
security_result.summary |
已重新命名/對應 |
success |
security_result.summary |
直接對應 |
Spyware |
security_result.threat_name |
直接對應 |
Unknown_Threat |
security_result.threat_name |
直接對應 |
Virus_Malware_Name |
security_result.threat_name |
直接對應 |
oldFilePath |
src.file.full_path |
已重新命名/對應 |
oldFileSize |
src.file.size |
已重新命名/對應 |
client_ip |
src.ip |
已合併 |
message |
src.ip |
已對應:CEF → client_ip |
message |
src.resource.attribute.permissions |
已對應:CEF → old_permissions |
old_permissions |
src.resource.attribute.permissions |
已合併 |
cust_client_id |
src.user.product_object_id |
直接對應 |
details_client_id |
src.user.product_object_id |
直接對應 |
dntdom |
target.administrative_domain |
已重新命名/對應 |
destinationServiceName |
target.application |
已重新命名/對應 |
service |
target.application |
直接對應 |
service_name |
target.application |
直接對應 |
application |
target.domain.name |
直接對應 |
details.size |
target.file.size |
已重新命名/對應 |
details.host |
target.hostname |
直接對應 |
target_hostname |
target.hostname |
直接對應 |
temp_dhost |
target.hostname |
直接對應 |
IPv6_Address |
target.ip |
已合併 |
dst_ip |
target.ip |
已合併 |
ipv6 |
target.ip |
已對應:- → IPv6_Address |
message |
target.ip |
已對應:CEF → dst_ip、CEF → IPv6_Address |
mac_address |
target.mac |
已合併 |
message |
target.mac |
已對應:CEF → mac_address |
destination_translated_address |
target.nat_ip |
已合併 |
message |
target.nat_ip |
已對應:CEF → destination_translated_address |
destinationTranslatedPort |
target.nat_port |
已重新命名/對應 |
details.port |
target.port |
已重新命名/對應 |
dpt |
target.port |
已重新命名/對應 |
dproc |
target.process.command_line |
已重新命名/對應 |
File_name |
target.process.file.full_path |
直接對應 |
Infected_Resource |
target.process.file.full_path |
直接對應 |
Object |
target.process.file.full_path |
直接對應 |
Objekt |
target.process.file.full_path |
直接對應 |
dpid |
target.process.pid |
已重新命名/對應 |
account_label |
target.resource.attribute.labels |
已合併 |
connection_label |
target.resource.attribute.labels |
已合併 |
message |
target.resource.attribute.labels |
對應值 (共 6 個,例如 CEF → resource_Type_label、CEF → name_label、CEF → `u... |
name_label |
target.resource.attribute.labels |
已合併 |
resource_Type_label |
target.resource.attribute.labels |
已合併 |
uri_label |
target.resource.attribute.labels |
已合併 |
usageMask_label |
target.resource.attribute.labels |
已合併 |
source |
target.resource.name |
直接對應 |
request |
target.url |
直接對應 |
message |
target.user.attribute.roles |
已對應:CEF → target_role |
target_role |
target.user.attribute.roles |
已合併 |
CustomerName |
target.user.user_display_name |
直接對應 |
temp_duser |
target.user.user_display_name |
直接對應 |
Bruker |
target.user.userid |
直接對應 |
User_value |
target.user.userid |
直接對應 |
temp_duid |
target.user.userid |
直接對應 |
| 不適用 | metadata.event_type |
常數:GENERIC_EVENT |
| 不適用 | network.direction |
常數:INBOUND |
| 不適用 | network.ip_protocol |
常數:UDP |
| 不適用 | security_result.severity |
常數:LOW |
details.host |
event.idm.read_only_udm.target.hostname |
從變更記錄對應 |
details.messageFormat |
event.idm.read_only_udm.additional.fields |
從變更記錄對應 |
details.transport |
event.idm.read_only_udm.network.ip_protocol |
從變更記錄對應 |
syslog_timestamp |
event.idm.read_only_udm.metadata.collected_timestamp |
從變更記錄對應 |
syslog_host |
event.idm.read_only_udm.principal.hostname 和 event.idm.read_only_udm.principal.asset.hostname |
從變更記錄對應 |
product |
event.idm.read_only_udm.metadata.product_name |
從變更記錄對應 |
details.errorMessage |
event.idm.read_only_udm.security_result.action_details |
從變更記錄對應 |
sev |
event.idm.read_only_udm.security_result.detection_fields |
從變更記錄對應 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。