收集 Cisco Secure Workload(以前称为 Tetration Analytics)日志

解析器版本: 3.0

支持:

本文档介绍了如何使用 Bindplane 代理将 Cisco Secure Workload(以前称为 Tetration Analytics)日志注入 Google Security Operations。

Cisco Secure Workload 是一种本地工作负载保护平台,可为数据中心和云工作负载提供微分段、应用依赖关系映射和合规性监控。它会生成有关政策违规、流量事件和安全事件的日志。该平台支持内置的 syslog 导出功能,可将提醒和流量数据转发给外部收集器。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 Cisco Secure Workload 集群之间的网络连接
  • 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于开放状态
  • 对 Cisco Secure Workload 集群具有特权访问权限,并具有管理员或站点管理员角色

获取 Bindplane 代理的 Google SecOps 凭据

如需对 Bindplane 代理进行 Google SecOps 身份验证,请选择以下方法之一:

  • 新部署:使用 Chronicle API(方法 1)。
  • 旧版部署:继续使用注入身份验证文件(方法 2),直到注入 API 于 2027 年 7 月 20 日停用为止。
  1. 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
  2. 依次前往 IAM 和管理 > 服务账号。
  3. 点击创建服务账号 。
  4. 提供以下配置详细信息:
    • 服务账号名称:输入账号的名称(例如 bindplane-ingest)。
    • 服务账号说明:输入说明(例如 Bindplane agent log ingestion)。
  5. 点击创建并继续 。
  6. 在向此服务帐号授予对项目的访问权限 部分,点击选择角色 ,然后选择 Chronicle Editor 。
  7. 点击继续 ,然后点击完成 。
  8. 点击您创建的服务帐号,然后前往密钥 标签页。
  9. 依次点击添加密钥 > 创建新密钥。
  10. 选择 JSON ,然后点击创建 。密钥文件会下载到您的计算机上。
  11. 将密钥文件另存为 Bindplane 收集器目录中的 ingestion-auth.json(在 Linux 上为 /opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或者更新 creds_file_path 在 config.yaml 中以与您保存该文件的路径匹配。
  12. 依次前往 IAM 和管理 > 设置 ,然后复制项目编号 。您需要此编号进行导出器配置。

方法 2:下载注入身份验证文件(旧版)

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 收集代理。
  3. 下载注入身份验证文件 。
  4. 将该文件安全地保存在将安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 个人资料。
  3. 从组织详细信息 部分复制并保存客户 ID 。

安装 Bindplane 代理

按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符 或 PowerShell 。
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

    该服务应显示为正在运行 。

Linux 安装

  1. 打开具有根权限或 sudo 权限的终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

    该服务应显示为活跃(正在运行) 。

其他安装资源

如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。

配置 Bindplane 代理以注入 syslog 并发送到 Google SecOps

找到配置文件

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • 将 config.yaml 的全部内容替换为以下配置:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/cisco_secure_workload:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: CISCO_SECURE_WORKLOAD
        raw_log_field: body
    
    service:
      pipelines:
        logs/cisco_secure_workload_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/cisco_secure_workload
    

配置参数

替换以下占位符:

  • 接收器配置:

    • listen_address:要监听的 IP 地址和端口:
      • 0.0.0.0 以监听所有接口(推荐)
      • 端口 514 是标准 syslog 端口(在 Linux 上需要 root 权限;对于非 root 用户,请使用 1514)
  • 导出器配置:

    • creds_file_path:服务帐号 JSON 密钥文件的完整路径(方法 1):
      • Linux: /opt/observiq-otel-collector/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:从 Google SecOps 控制台复制的客户 ID
    • location:将 <LOCATION> 替换为 Google SecOps 实例的区域(例如 us、europe 或 asia-southeast1)。导出器会以此值作为 chronicle.googleapis.com 的前缀。如需查看完整列表,请参阅区域级端点。
    • project:将 <PROJECT_NUMBER> 替换为 IAM 和管理 > 设置 中的项目编号。
    • endpoint:保持设置为 chronicle.googleapis.com。

旧版注入 API 导出器

  • 如果您使用方法 2 中的注入身份验证文件,请将 exporters 块替换为以下内容。将 creds_file_path 设置为注入身份验证文件的路径,并且如果您的实例位于美国境外,请将 malachiteingestion-pa.googleapis.com 替换为您的 区域级端点(例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/cisco_secure_workload:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: CISCO_SECURE_WORKLOAD
        raw_log_field: body
    

保存配置文件

  • 修改后,保存文件:
    • Linux:按 Ctrl+O,然后按 Enter,再按 Ctrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
    1. 验证服务是否正在运行:

      sudo systemctl status observiq-otel-collector
      
    2. 检查日志中的错误:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:

    • 以管理员身份运行命令提示符或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服务控制台:

      1. 按 Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry Collector 。
      3. 右键点击并选择重启 。
      4. 验证服务是否正在运行:

        sc query observiq-otel-collector
        
      5. 检查日志中的错误:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

配置 Cisco Secure Workload syslog 转发

  1. 登录 Cisco Secure Workload Web 控制台。
  2. 依次前往管理 > 外部集成 > Syslog。

  3. 点击创建新的 Syslog 导出 (或添加连接器 )。

  4. 提供以下配置详细信息:

    • 名称:输入名称(例如 chronicle-syslog-export)。
    • 主机:输入 Bindplane 代理主机的 IP 地址。
    • 端口:输入 514(或在 Bindplane 代理接收器中配置的端口)。
    • 协议:选择 UDP。
    • 设施:选择 local7 (或您首选的设施)。
    • 严重程度 :选择信息 或更低级别,以捕获所有事件。
  5. 点击保存 。

  6. 通过检查 Bindplane 代理日志中是否有传入的 syslog 消息,验证日志是否正在发送。

UDM 字段映射参考信息

日志字段 UDM 映射 逻辑
connection, event_name additional.fields 如果非空,则合并为标签
alert_time metadata.collected_timestamp 从纪元毫秒转换为时间戳
metadata.event_type 如果 has_principal 为 true,则设置为“NETWORK_FLOW”,否则设置为“GENERIC_EVENT”
root_scope_id metadata.product_deployment_id 直接复制值
type metadata.product_event_type 直接复制值
key_id metadata.product_log_id 直接复制值
metadata.product_name 设置为“SECURE WORKLOAD”
metadata.product_version 设置为“1”
metadata.vendor_name 设置为“CISCO”
alert_details_json.protocol network.ip_protocol 如果类型为 COMPLIANCE,则直接复制值
details.HostName principal.asset.hostname 如果类型为 ENFORCEMENT,则直接复制值
alert_details_json.constituent_flows.0.consumer_address, details.IP principal.asset.ip 如果类型为 COMPLIANCE,则取自 consumer_address,否则取自 details.IP,然后移除尾随空格及之后的内容
details.CurrentVersion principal.asset.platform_software.platform_version 如果类型为 ENFORCEMENT,则直接复制值
details.Bios principal.asset.software 如果类型为 ENFORCEMENT,则直接复制值
alert_details_json.time_range.0 principal.domain.first_seen_time 如果类型为 COMPLIANCE,则从纪元毫秒转换为时间戳
alert_details_json.time_range.1 principal.domain.last_seen_time 如果类型为 COMPLIANCE,则从纪元毫秒转换为时间戳
details.HostName principal.hostname 如果类型为 COMPLIANCE,则设置为“UNKNOWN”,否则如果类型为 ENFORCEMENT,则取自 details.HostName
alert_details_json.constituent_flows.0.consumer_address, details.IP principal.ip 如果类型为 COMPLIANCE,则取自 consumer_address,否则取自 details.IP,然后移除尾随空格及之后的内容
details.Platform principal.platform_version 如果类型为 ENFORCEMENT,则直接复制值
alert_details_json.provider_port principal.port 如果类型为 COMPLIANCE,则转换为整数
pid principal.process.pid 直接复制值
alert_details_json.provider_scope_ids, alert_details_json.provider_scope_names, alert_details_json.internal_trigger.label principal.resource.attribute.labels 如果类型为 COMPLIANCE,则合并为标签
alert_details_json.application_id principal.resource.product_object_id 如果类型为 COMPLIANCE,则直接复制值
details.AgentType principal.user.attribute.roles 如果类型为 ENFORCEMENT,则直接复制值
alert_details_json.policy_category security_result.category_details 如果类型为 COMPLIANCE,则从数组合并
alert_text security_result.description 直接复制值
alert_conf_id security_result.rule_id 如果类型为 COMPLIANCE,则直接复制值
alert_details_json.internal_trigger.rules.field security_result.rule_name 如果类型为 COMPLIANCE,则直接复制值
alert_details_json.internal_trigger.rules.type security_result.rule_type 如果类型为 COMPLIANCE,则直接复制值
severity security_result.severity 直接复制值
alert_details_json.policy_type security_result.summary 如果类型为 COMPLIANCE,则直接复制值
alert_details_json.constituent_flows.0.provider_address target.asset.ip 如果类型为 COMPLIANCE,则直接复制值
tenant_id target.group.product_object_id 如果非空或“0”,则直接复制值
target.hostname 设置为“UNKNOWN”
alert_details_json.constituent_flows.0.provider_address target.ip 如果类型为 COMPLIANCE,则直接复制值
alert_details_json.constituent_flows.0.consumer_port target.port 如果类型为 COMPLIANCE,则转换为整数
alert_details_json.consumer_scope_ids, alert_details_json.consumer_scope_names target.resource.attribute.labels 如果类型为 COMPLIANCE,则合并为标签

更新日志

查看此解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。