收集 Cisco VCS 日志
解析器版本: 2.0
本文档介绍了如何使用 Bindplane 将 Cisco VCS(视频通信服务)(通过 ExpressWay 控制)日志注入到 Google Security Operations。 解析器会从 Syslog 消息中提取字段,将其标准化为统一数据模型 (UDM),并根据提取的详细信息(例如 IP 地址、端口和操作)对事件类型进行分类。它可以处理各种日志格式,提取键值对,并将严重程度映射到标准化值以进行安全分析。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows 2016 或更高版本,或者具有
systemd的 Linux 主机 - 如果通过代理运行,则防火墙 端口 处于打开状态
- 对 Cisco ExpressWay 的特权访问权限
获取 Bindplane 代理的 Google SecOps 凭据
如需向 Google SecOps 验证 Bindplane 代理的身份,请选择以下方法之一:
- 新部署:使用 Chronicle API(方法 1)。
- 旧版部署:继续使用注入身份验证文件(方法 2),直到注入 API 于 2027 年 7 月 20 日停用为止。
方法 1:为 Chronicle API 创建服务帐号(推荐)
- 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
- 依次前往 IAM 和管理 > 服务账号。
- 点击创建服务账号 。
- 提供以下配置详细信息:
- 服务账号名称:输入账号的名称(例如
bindplane-ingest)。 - 服务账号说明:输入说明(例如
Bindplane agent log ingestion)。
- 服务账号名称:输入账号的名称(例如
- 点击创建并继续 。
- 在向此服务帐号授予对项目的访问权限 部分,点击选择角色 ,然后选择 Chronicle Editor 。
- 点击继续 ,然后点击完成 。
- 点击您创建的服务帐号,然后前往密钥 标签页。
- 点击添加密钥 > 创建新密钥。
- 选择 JSON ,然后点击创建 。密钥文件会下载到您的计算机。
- 将密钥文件另存为 Bindplane 收集器目录中的
ingestion-auth.json(在 Linux 上为/opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或者更新creds_file_path在config.yaml中以与您保存该文件的路径一致。 - 依次前往 IAM 和管理 > 设置 ,然后复制项目编号 。您需要此编号进行导出器配置。
方法 2:下载注入身份验证文件(旧版)
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
- 下载注入身份验证文件 。
- 将该文件安全地保存在将安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 个人资料。
- 从组织详细信息 部分复制并保存客户 ID 。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符 或 PowerShell 。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
Linux 安装
- 使用 root 或 sudo 权限打开终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
其他安装资源
如需了解其他安装选项,请参阅 安装指南。
配置 Bindplane 代理以注入 Syslog 并将其发送到 Google SecOps
- 访问配置文件:
- 找到
config.yaml文件。通常,该文件位于 Linux 上的/opt/observiq-otel-collector/目录或 Windows 上的安装目录中。 - 使用文本编辑器(例如
nano、vi或记事本)打开该文件。
- 找到
按如下方式修改
config.yaml文件:receivers: udplog: # Replace the port and IP address as required listen_address: "0.0.0.0:514" exporters: chronicle/chronicle_w_labels: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: <customer_id> endpoint: chronicle.googleapis.com # Add optional ingestion labels for better organization log_type: 'CISCO_VCS' raw_log_field: body ingestion_labels: service: pipelines: logs/source0__chronicle_w_labels-0: receivers: - udplog exporters: - chronicle/chronicle_w_labels- 根据基础架构的需要替换端口和 IP 地址。
- 将
<LOCATION>替换为 Google SecOps 实例的区域(例如us、europe或asia-southeast1)。导出器会使用此值为chronicle.googleapis.com添加前缀。 - 将
<PROJECT_NUMBER>替换为 IAM 和管理 > 设置 中的项目编号。 - 将
<customer_id>替换为实际客户 ID。 - 将
/path/to/ingestion-authentication-file.json更新为在 获取 Bindplane 代理的 Google SecOps 凭据 部分中保存服务帐号密钥文件(方法 1)的路径。
旧版注入 API 导出器
如果您使用方法 2 中的注入身份验证文件,请将
exporters代码块替换为以下内容。将creds_file_path设置为注入身份验证文件的路径,并且如果您的实例位于美国境外,请将malachiteingestion-pa.googleapis.com替换为您的 区域端点(例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/chronicle_w_labels: compression: gzip # Adjust the path to the credentials file you downloaded in Step 1 creds_file_path: '/path/to/ingestion-authentication-file.json' # Replace with your actual customer ID from Step 2 customer_id: <customer_id> endpoint: malachiteingestion-pa.googleapis.com # Add optional ingestion labels for better organization log_type: 'CISCO_VCS' raw_log_field: body ingestion_labels:
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart bindplane-agent如需在 Windows 中重启 Bindplane 代理,您可以使用服务 控制台,也可以输入以下命令:
net stop BindPlaneAgent && net start BindPlaneAgent
为 Cisco ExpressWay 配置 Syslog
- 登录 Cisco ExpressWay 网页界面。
- 依次前往维护 > 日志记录。
- 输入 Bindplane 代理 IP 地址作为远程 Syslog 服务器 。
- 点击选项 。
- 提供以下配置详细信息:
- 传输:选择 UDP。
- 端口:输入 Bindplane 代理端口号。
- 消息格式:选择 BSD,另一个可能的选项是 IETF。
- 按严重程度过滤:选择信息。
- 点击保存 。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
| 操作 | read_only_udm.security_result.action_details | 原始日志中 Action 字段的值。 |
| 代码 | read_only_udm.network.http.response_code | 原始日志中 Code 字段的值,转换为整数。当 Response-code 不存在时使用。 |
| 详细信息 | read_only_udm.security_result.description | 原始日志中 Detail 字段的值。 |
| 目标 IP | read_only_udm.target.ip | 原始日志中 Dst-ip 字段的值。当 Action 不是 Received 时使用。 |
| 目标端口 | read_only_udm.target.port | 原始日志中 Dst-port 字段的值,转换为整数。当 Action 不是 Received 时使用。 |
| 事件 | read_only_udm.metadata.product_event_type | 原始日志中 Event 字段的值。 |
| 级别 | read_only_udm.security_result.severity_details | 原始日志中 Level 字段的值。 |
| 级别 | read_only_udm.security_result.severity | 根据原始日志中 Level 字段的值进行映射: - 9、10、VERY-HIGH:CRITICAL - error、warning、7、8、HIGH:HIGH - notice、4、5、6、MEDIUM:MEDIUM - information、info、0、1、2、3、LOW:LOW |
| 本地 IP | read_only_udm.principal.ip | 原始日志中 Local-ip 字段的值。当 Action 不是 Received 时使用。 |
| 本地 IP | read_only_udm.target.ip | 原始日志中 Local-ip 字段的值。当 Action 是 Received 时使用。 |
| 本地端口 | read_only_udm.principal.port | 原始日志中 Local-port 字段的值,转换为整数。当 Action 不是 Received 时使用。 |
| 本地端口 | read_only_udm.target.port | 原始日志中 Local-port 字段的值,转换为整数。当 Action 是 Received 时使用。 |
| 方法 | read_only_udm.network.http.method | 原始日志中 Method 字段的值。 |
| 模块 | read_only_udm.additional.fields.value.string_value | 原始日志中 Module 字段的值。 |
| 节点 | read_only_udm.additional.fields.value.string_value | 原始日志中 Node 字段的值。 |
| 协议 | read_only_udm.network.ip_protocol | 原始日志中 Protocol 字段的值,使用 parse_ip_protocol.include 逻辑进行解析并映射到相应的 IP 协议名称。 |
| 响应代码 | read_only_udm.network.http.response_code | 原始日志中 Response-code 字段的值,转换为整数。 |
| 来源 IP | read_only_udm.principal.ip | 原始日志中 Src-ip 字段的值。当 Action 是 Received 时使用。 |
| 来源 IP | read_only_udm.principal.ip | 原始日志中 Src-ip 字段的值。当 Action 不是 Received 且 Local-ip 不存在时使用。 |
| 来源端口 | read_only_udm.principal.port | 原始日志中 Src-port 字段的值,转换为整数。当 Action 是 Received 时使用。 |
| 来源端口 | read_only_udm.principal.port | 原始日志中 Src-port 字段的值,转换为整数。当 Action 不是 Received 且 Local-port 不存在时使用。 |
| 应用 | read_only_udm.target.application | 原始日志中 application 字段的值。 |
| 说明 | read_only_udm.security_result.description | 原始日志中 description 字段的值。 |
| inner_msg | read_only_udm.security_result.description | 原始日志中 inner_msg 字段的值。当发生 inner_msg_grok_failure 时使用。 |
| principal_hostname | read_only_udm.principal.hostname | 原始日志中 principal_hostname 字段的值。 |
| 时间戳 | read_only_udm.metadata.event_timestamp.seconds | 从原始日志中的 timestamp 字段提取的纪元时间戳。 |
| 时间戳 | read_only_udm.events.timestamp.seconds | 从原始日志中的 timestamp 字段提取的纪元时间戳。 |
| read_only_udm.additional.fields.key | 硬编码值:Module、Node |
|
| read_only_udm.metadata.log_type | 硬编码值:CISCO_VCS |
|
| read_only_udm.metadata.product_name | 硬编码值:CISCO VCS |
|
| read_only_udm.metadata.vendor_name | 硬编码值:CISCO VCS |
|
| read_only_udm.metadata.event_type | 根据 Action、Src-ip、principal_hostname、Local-ip 和 Dst-ip 字段的值确定:- NETWORK_CONNECTION:如果(Action 为 Received 且 Local-ip 存在)或(Action 不是 Received 且 Dst-ip 存在)- STATUS_UPDATE:否则 |
更新日志
需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。