收集 Cisco VCS 記錄

剖析器版本:2.0

支援:

本文說明如何使用 Bindplane,將 Cisco VCS (透過 ExpressWay 控制) 記錄檔擷取至 Google Security Operations。剖析器會從系統記錄訊息中擷取欄位,並正規化為 Unified Data Model (UDM),然後根據擷取的詳細資料 (例如 IP 位址、通訊埠和動作) 分類事件類型。這項服務可處理各種記錄格式、擷取鍵/值組合,並將嚴重性等級對應至標準化值,以便進行安全性分析。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體
  • Windows 2016 以上版本,或搭載 systemd 的 Linux 主機
  • 如果是在 Proxy 後方執行,防火牆通訊埠已開啟
  • Cisco ExpressWay 的特殊存取權

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
  1. 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 提供下列設定詳細資料:
    • 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如 bindplane-ingest)。
    • 「服務帳戶說明」:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存路徑相符。
  12. 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。匯出工具設定時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」 > 「設定檔」。
  3. 複製並儲存「機構詳細資料」部分的客戶 ID。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟命令提示字元或 PowerShell。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    

Linux 安裝

  1. 開啟具有 root 或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    

其他安裝資源

如需其他安裝選項,請參閱安裝指南。

設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps

  1. 存取設定檔:
    • 找出 config.yaml 檔案。通常位於 Linux 的 /opt/observiq-otel-collector/ 目錄,或 Windows 的安裝目錄。
    • 使用文字編輯器 (例如 nano、vi 或記事本) 開啟檔案。
  2. 按照下列方式編輯 config.yaml 檔案:

    receivers:
        udplog:
            # Replace the port and IP address as required
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/chronicle_w_labels:
            protocol: https
            # Region of your instance, for example us, europe, asia-southeast1
            location: <LOCATION>
            # Project number of the Google Cloud project linked to the instance
            project: '<PROJECT_NUMBER>'
            compression: gzip
            # Adjust the path to the credentials file you downloaded in Step 1
            creds_file_path: '/path/to/ingestion-authentication-file.json'
            # Replace with your actual customer ID from Step 2
            customer_id: <customer_id>
            endpoint: chronicle.googleapis.com
            # Add optional ingestion labels for better organization
            log_type: 'CISCO_VCS'
            raw_log_field: body
            ingestion_labels:
    
    service:
        pipelines:
            logs/source0__chronicle_w_labels-0:
                receivers:
                    - udplog
                exporters:
                    - chronicle/chronicle_w_labels
    
    • 請根據基礎架構需求,替換通訊埠和 IP 位址。
    • 將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會在這個值前面加上 chronicle.googleapis.com。
    • 將 <PROJECT_NUMBER> 替換為「IAM 與管理」>「設定」中的專案編號。
    • 將 <customer_id> 替換為實際的客戶 ID。
    • 將 /path/to/ingestion-authentication-file.json 更新為服務帳戶金鑰檔案 (選項 1) 在「取得 Bindplane 代理程式的 Google SecOps 憑證」一節中儲存的路徑。

舊版擷取 API 匯出工具

  • 如果您使用選項 2 的擷取驗證檔案,請將 exporters 區塊替換為下列內容。將 creds_file_path 設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
        chronicle/chronicle_w_labels:
            compression: gzip
            # Adjust the path to the credentials file you downloaded in Step 1
            creds_file_path: '/path/to/ingestion-authentication-file.json'
            # Replace with your actual customer ID from Step 2
            customer_id: <customer_id>
            endpoint: malachiteingestion-pa.googleapis.com
            # Add optional ingestion labels for better organization
            log_type: 'CISCO_VCS'
            raw_log_field: body
            ingestion_labels:
    

重新啟動 Bindplane 代理程式,套用變更

  • 如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart bindplane-agent
    
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,可以使用「Services」控制台,或輸入下列指令:

    net stop BindPlaneAgent && net start BindPlaneAgent
    

設定 Cisco ExpressWay 的 Syslog

  1. 登入 Cisco ExpressWay 網頁版 UI。
  2. 依序前往「Maintenance」>「Logging」。
  3. 輸入 Bindplane 代理程式 IP 位址做為「遠端 syslog 伺服器」。
  4. 按一下「選項」。
  5. 請提供下列設定詳細資料:
    • Transport:選取「UDP」。
    • Port:輸入 Bindplane 代理程式通訊埠編號。
    • Message Format:選取「BSD」,另一個可能選項是「IETF」。
    • 依嚴重程度篩選:選取「資訊」。
  6. 按一下 [儲存]。

UDM 對應表

記錄欄位 UDM 對應 邏輯
動作 read_only_udm.security_result.action_details 原始記錄中 Action 欄位的值。
程式碼 read_only_udm.network.http.response_code 原始記錄中的 Code 欄位值,轉換為整數。在沒有 Response-code 時使用。
詳細資料 read_only_udm.security_result.description 原始記錄中 Detail 欄位的值。
Dst-ip read_only_udm.target.ip 原始記錄中 Dst-ip 欄位的值。當 Action 不是 Received 時使用。
Dst-port read_only_udm.target.port 原始記錄中的 Dst-port 欄位值,轉換為整數。當 Action 不是 Received 時使用。
事件 read_only_udm.metadata.product_event_type 原始記錄中的 Event 欄位值。
等級 read_only_udm.security_result.severity_details 原始記錄中的 Level 欄位值。
等級 read_only_udm.security_result.severity 根據原始記錄中 Level 欄位的值進行對應:
- 9、10、VERY-HIGH:重大
- error、warning、7、8、HIGH:高
- notice、4、5、6、MEDIUM:中
- information、info、0、1、2、3、LOW:低
Local-ip read_only_udm.principal.ip 原始記錄中 Local-ip 欄位的值。當 Action 不是 Received 時使用。
Local-ip read_only_udm.target.ip 原始記錄中的 Local-ip 欄位值。用於 Action 為 Received 的情況。
本機通訊埠 read_only_udm.principal.port 原始記錄中的 Local-port 欄位值,轉換為整數。當 Action 不是 Received 時使用。
本機通訊埠 read_only_udm.target.port 原始記錄中 Local-port 欄位的值,已轉換為整數。用於 Action 為 Received 的情況。
方法 read_only_udm.network.http.method 原始記錄中的 Method 欄位值。
單元 read_only_udm.additional.fields.value.string_value 原始記錄中的 Module 欄位值。
節點 read_only_udm.additional.fields.value.string_value 原始記錄中 Node 欄位的值。
通訊協定 read_only_udm.network.ip_protocol 原始記錄中 Protocol 欄位的值,已剖析並使用 parse_ip_protocol.include 邏輯對應至相應的 IP 通訊協定名稱。
回應代碼 read_only_udm.network.http.response_code 原始記錄中 Response-code 欄位的值,已轉換為整數。
Src-ip read_only_udm.principal.ip 原始記錄中 Src-ip 欄位的值。用於 Action 為 Received 的情況。
Src-ip read_only_udm.principal.ip 原始記錄中 Src-ip 欄位的值。當 Action 不是 Received 且沒有 Local-ip 時使用。
來源通訊埠 read_only_udm.principal.port 原始記錄中的 Src-port 欄位值,轉換為整數。用於 Action 為 Received 的情況。
來源通訊埠 read_only_udm.principal.port 原始記錄中 Src-port 欄位的值,已轉換為整數。當 Action 不是 Received 且沒有 Local-port 時使用。
調度應用程式資源 read_only_udm.target.application 原始記錄中 application 欄位的值。
說明 read_only_udm.security_result.description 原始記錄中 description 欄位的值。
inner_msg read_only_udm.security_result.description 原始記錄中 inner_msg 欄位的值。發生 inner_msg_grok_failure 時使用。
principal_hostname read_only_udm.principal.hostname 原始記錄中的 principal_hostname 欄位值。
時間戳記 read_only_udm.metadata.event_timestamp.seconds 從原始記錄的 timestamp 欄位擷取的 Epoch 時間戳記。
時間戳記 read_only_udm.events.timestamp.seconds 從原始記錄 timestamp 欄位擷取的 Epoch 時間戳記。
read_only_udm.additional.fields.key 硬式編碼值:Module、Node
read_only_udm.metadata.log_type 硬式編碼值:CISCO_VCS
read_only_udm.metadata.product_name 硬式編碼值:CISCO VCS
read_only_udm.metadata.vendor_name 硬式編碼值:CISCO VCS
read_only_udm.metadata.event_type 根據 Action、Src-ip、principal_hostname、Local-ip 和 Dst-ip 欄位的值決定:
- NETWORK_CONNECTION:如果 (Action 為 Received 且 Local-ip 存在) 或 (Action 不是 Received 且 Dst-ip 存在)
- STATUS_UPDATE:其他情況

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。