收集 Cloudian HyperStore 記錄

剖析器版本:2.0

支援的國家/地區:

本文說明如何使用 Bindplane 代理程式,將 Cloudian HyperStore 記錄檔擷取至 Google Security Operations。

剖析器會使用 grok 模式從 Cloudian HyperStore 系統記錄訊息中擷取欄位,包括時間戳記、IP 位址、使用者名稱和說明。並將擷取的欄位對應至統合式資料模型 (UDM),然後根據識別的活動設定適當的事件類型。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Cloudian HyperStore 系統之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • Cloudian HyperStore 的特殊存取權

取得 Google SecOps 擷取驗證檔案

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」
  3. 下載擷取驗證檔案
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」
  3. 複製並儲存「機構詳細資料」部分中的客戶 ID

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟「命令提示字元」或「PowerShell」
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」

Linux 安裝

  1. 開啟具有根層級或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為有效 (執行中)

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南

設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /etc/bindplane-agent/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • config.yaml 的所有內容替換為下列設定:

    receivers:
        udplog:
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/cloudian_hyperstore:
            compression: gzip
            creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
            customer_id: '<customer_id>'
            endpoint: malachiteingestion-pa.googleapis.com
            log_type: CLOUDIAN_HYPERSTORE
            raw_log_field: body
    
    service:
        pipelines:
            logs/cloudian_hyperstore_to_chronicle:
                receivers:
                    - udplog
                exporters:
                    - chronicle/cloudian_hyperstore
    

設定參數

替換下列預留位置:

  • 接收器設定:

    • listen_address:要接聽的 IP 位址和通訊埠:
      • 0.0.0.0,監聽所有介面 (建議)
      • 通訊埠 514 是標準的系統記錄通訊埠 (在 Linux 上需要根層級權限;非根層級權限請使用 1514)
  • 匯出工具設定:

    • creds_file_path:擷取驗證檔案的完整路徑:
      • Linux/etc/bindplane-agent/ingestion-auth.json
      • WindowsC:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:從 Google SecOps 控制台複製的客戶 ID
    • endpoint:區域端點網址:
      • 美國malachiteingestion-pa.googleapis.com
      • 歐洲europe-malachiteingestion-pa.googleapis.com
      • 亞洲asia-southeast1-malachiteingestion-pa.googleapis.com
      • 如需完整清單,請參閱「區域端點

儲存設定檔

  • 編輯完成後,請儲存檔案:
    • Linux:依序按下 Ctrl+OEnterCtrl+X
    • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,以套用變更

  • 如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 檢查記錄中是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出 observIQ OpenTelemetry Collector
      3. 按一下滑鼠右鍵,然後選取「重新啟動」
      4. 確認服務正在執行:

        sc query observiq-otel-collector
        
      5. 檢查記錄中是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

設定 Cloudian HyperStore 系統記錄檔

  1. 使用 CLI 登入 HyperStore Config Controller 節點。
  2. 執行下列 hsctl 指令:

    hsctl config set logging.syslog.remote.enabled=true
    hsctl config set logging.syslog.remote.host=<BINDPLANE_IP>
    hsctl config set logging.syslog.remote.protocol=<UDP_OR_TCP>
    hsctl config set logging.syslog.remote.port=<BINDPLANE_PORT>
    hsctl config apply ALL
    hsctl service restart s3 iam hyperstore firewall --nodes=ALL
    hsctl config set monitoring.agent.logging.level=INFO
    hsctl config apply monitoring
    
    • <BINDPLANE_IP> 替換為 Bindplane 代理程式 IP 位址。
    • <UDP_OR_TCP> 替換為 Bindplane 代理程式中設定的通訊協定。
    • <BINDPLANE_PORT> 替換為 Bindplane 代理程式的通訊埠號碼。

UDM 對應表

記錄欄位 UDM 對應 邏輯
description metadata.description 直接對應
datetime metadata.event_timestamp 已剖析為 RFC 3339
method network.http.method 已重新命名/對應
url network.http.referral_url 直接對應
status_code network.http.response_code 已重新命名/對應
session_id network.session_id 直接對應
application principal.application 直接對應
hostname principal.hostname 直接對應
source_ip principal.ip 已合併
request_id principal.process.pid 直接對應
target_ip target.ip 已合併
port target.port 已重新命名/對應
file_path target.process.file.full_path 直接對應
user target.user.user_display_name 直接對應
不適用 extensions.auth.type 常數:AUTHTYPE_UNSPECIFIED
不適用 metadata.event_type 常數:NETWORK_CONNECTION
不適用 metadata.product_name 常數:Cloudian Hyperstore
不適用 metadata.vendor_name 常數:Cloudian

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。