收集 Comforte SecurDPS 日志
解析器版本: 1.0
本文档介绍了如何使用 Bindplane 代理将 Comforte SecurDPS 日志注入 Google Security Operations。
Comforte SecurDPS 是一个数据保护平台,可为支付和交易处理环境中的敏感数据提供令牌化和加密。它会为数据保护操作、访问事件和政策执行操作生成审核日志。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 Comforte SecurDPS 服务器之间的网络连接
- 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于开放状态
- 对 Comforte SecurDPS 服务器的特权访问权限,并具有管理员权限
获取 Bindplane 代理的 Google SecOps 凭据
如需向 Google SecOps 验证 Bindplane 代理的身份,请选择以下方法之一:
- 新部署:使用 Chronicle API(方法 1)。
- 旧版部署:继续使用注入身份验证文件(方法 2),直到注入 API 于 2027 年 7 月 20 日停用为止。
方法 1:为 Chronicle API 创建服务帐号(推荐)
- 登录 Google Cloud Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
- 依次前往 IAM 和管理 > 服务账号。
- 点击创建服务账号 。
- 提供以下配置详细信息:
- 服务账号名称:输入账号的名称(例如
bindplane-ingest)。 - 服务账号说明:输入说明(例如
Bindplane agent log ingestion)。
- 服务账号名称:输入账号的名称(例如
- 点击创建并继续 。
- 在向此服务帐号授予对项目的访问权限 部分,点击选择角色 ,然后选择 Chronicle Editor 。
- 点击继续 ,然后点击完成 。
- 点击您创建的服务帐号,然后前往密钥 标签页。
- 依次点击添加密钥 > 创建新密钥。
- 选择 JSON ,然后点击创建 。密钥文件会下载到您的计算机上。
- 将密钥文件另存为 Bindplane 收集器目录中的
ingestion-auth.json(在 Linux 上为/opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或者更新creds_file_path在config.yaml中以与您保存该文件的路径匹配。 - 依次前往 IAM 和管理 > 设置 ,然后复制项目编号 。您需要此编号进行导出器配置。
方法 2:下载注入身份验证文件(旧版)
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
- 下载注入身份验证文件 。
- 将该文件安全地保存在将安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 个人资料。
从组织详细信息 部分复制并保存客户 ID 。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符 或 PowerShell 。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector该服务应显示为正在运行 。
Linux 安装
- 打开具有根权限或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector该服务应显示为活跃 (正在运行) 。
其他安装资源
如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps
找到配置文件
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/comforte_securdps: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: COMFORTE_SECURDPS raw_log_field: body ingestion_labels: env: production service: pipelines: logs/securdps_to_chronicle: receivers: - udplog exporters: - chronicle/comforte_securdps
配置参数
替换以下占位符:
接收器配置:
udplog:基于协议的接收器类型:- UDP syslog 的
udplog - TCP syslog 的
tcplog
- UDP syslog 的
0.0.0.0:要监听的 IP 地址:0.0.0.0,用于监听所有接口(推荐)- 用于监听一个接口的特定 IP 地址
514:要监听的端口号(例如514、1514、6514)
导出器配置:
comforte_securdps:导出器的说明性名称creds_file_path:服务帐号 JSON 密钥文件的完整路径(方法 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<customer_id>:上一步中的客户 IDlocation:将<LOCATION>替换为 Google SecOps 实例的区域(例如us、europe或asia-southeast1)。导出器会使用此值为chronicle.googleapis.com添加前缀。如需查看完整列表,请参阅区域级端点。project:将<PROJECT_NUMBER>替换为 IAM 和管理 > 设置 中的项目编号。endpoint:保持设置为chronicle.googleapis.com。COMFORTE_SECURDPS:日志类型,与 Chronicle 中显示的内容完全一致ingestion_labels:YAML 格式的可选标签(例如env: production)
流水线配置:
securdps_to_chronicle:流水线的说明性名称
旧版注入 API 导出器
如果您使用方法 2 中的注入身份验证文件,请将
exporters代码块替换为以下内容。将creds_file_path设置为注入身份验证文件的路径,并且如果您的实例位于美国境外,请将malachiteingestion-pa.googleapis.com替换为您的 区域级端点(例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/comforte_securdps: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: COMFORTE_SECURDPS raw_log_field: body ingestion_labels: env: production
保存配置文件
- 修改后,保存文件:
- Linux:按
Ctrl+O,然后按Enter,再按Ctrl+X - Windows:依次点击文件 > 保存
- Linux:按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志中的错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:
以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服务控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry Collector 。
- 右键点击并选择重启 。
验证服务是否正在运行:
sc query observiq-otel-collector检查日志中的错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按
配置 Comforte SecurDPS syslog 转发
- 使用管理员凭据登录 Comforte SecurDPS 管理控制台。
- 依次前往系统 > 配置 > 日志记录。
- 为审核日志启用 Syslog 转发 。
- 提供以下配置详细信息:
- Syslog 服务器:输入 Bindplane 代理主机(例如
192.168.1.100)的 IP 地址。 - 端口:输入
514(必须与 Bindplane 代理接收器端口匹配)。 - 协议:选择 UDP。
- 设施:选择 local0 或适合您环境的设施。
- 严重级别:选择信息或更低级别,以捕获所有审核事件。
- Syslog 服务器:输入 Bindplane 代理主机(例如
- 选择要转发的日志类别:
- 数据保护操作(令牌化、加密)
- 访问和身份验证事件
- 政策更改和管理操作
- 错误和警告事件
- 点击保存 以应用配置。
通过检查 Bindplane 代理日志,验证是否收到了 syslog 消息。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
| record.index、record.cribl_pipe | additional.fields | 与根据 record.index 和 record.cribl_pipe 创建的标签合并 |
| record.msg_data、description | metadata.description | 如果位于 JSON 分支中,则取自 record.msg_data,否则取自 description |
| metadata_event_type | metadata.event_type | 根据标志设置:如果 principal_mid_present 和 target_mid_present,则为 NETWORK_CONNECTION;如果 target_user_present,则为 USER_UNCATEGORIZED;如果 principal_mid_present,则为 STATUS_UPDATE;否则为 GENERIC_EVENT |
| record.sourcetype、prod_event_type | metadata.product_event_type | 如果位于 JSON 分支中,则取自 record.sourcetype,否则取自 prod_event_type |
| metadata.product_name | 设置为“Comforte SecureDPS” | |
| metadata.vendor_name | 设置为“COMFORTE_SECURDPS” | |
| 主机 | principal.asset.hostname | 如果不是 IP,则取自主机 |
| validated_host、principal_ip | principal.asset.ip | 如果主机是 JSON 分支中的 IP,则取自 validated_host,否则取自 principal_ip |
| 主机 | principal.hostname | 如果不是 IP,则取自主机 |
| validated_host、principal_ip | principal.ip | 如果主机是 JSON 分支中的 IP,则取自 validated_host,否则取自 principal_ip |
| principal_port | principal.port | 取自 principal_port,转换为整数 |
| record.facility、record.facilityName、_STRATEGY、_PROTECTS、_DENIEDPROTECTS、_REVEALS、_DENIEDREVEALS、_LOOKUPS、_INTERVAL | security_result.detection_fields | 与根据 record.facility、record.facilityName、_STRATEGY、_PROTECTS、_DENIEDPROTECTS、_REVEALS、_DENIEDREVEALS、_LOOKUPS、_INTERVAL 创建的标签合并 |
| sec_description | security_result.description | 取自 sec_description |
| record.severityName、severity | security_result.severity | 如果匹配 (?i)(info),则设置为 INFORMATIONAL;如果匹配 (?i)(warn),则设置为 WARNING;如果匹配 (?i)(error),则设置为 ERROR |
| record.severity、severity | security_result.severity_details | 如果位于 JSON 分支中,则取自 record.severity,否则取自 severity |
| 应用、_APPLICATION | target.application | 如果不为空,则取自 _APPLICATION,否则取自 app |
| _IPADDRESS | target.asset.ip | 取自 _IPADDRESS |
| sha_256_value | target.file.sha256 | 如果匹配十六进制模式,则取自 sha_256_value |
| _IPADDRESS | target.ip | 取自 _IPADDRESS |
| pid | target.process.pid | 取自 pid |
| sha256 | target.resource.attribute.labels | 如果 sha_256_value 不匹配十六进制模式,则与 sha256_label 合并 |
| _ZOSUSER | target.user.userid | 取自 _ZOSUSER |
更新日志
需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。