收集 Comforte SecurDPS 記錄
剖析器版本:1.0
本文說明如何使用 Bindplane 代理程式,將 Comforte SecurDPS 記錄擷取至 Google Security Operations。
Comforte SecurDPS 是資料保護平台,可為付款和交易處理環境中的機密資料提供權杖化和加密功能。並產生資料保護作業、存取事件和政策強制執行動作的稽核記錄。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 Comforte SecurDPS 伺服器之間的網路連線
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- 具備管理員權限的 Comforte SecurDPS 伺服器特殊存取權
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 服務帳戶名稱:輸入帳戶名稱 (例如
bindplane-ingest)。 - 服務帳戶說明:輸入說明 (例如
Bindplane agent log ingestion)。
- 服務帳戶名稱:輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 為/opt/observiq-otel-collector/ingestion-auth.json,Windows 為C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存檔案的路徑相符。 - 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。設定匯出工具時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「收集代理程式」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」 > 「設定檔」。
複製並儲存「機構詳細資料」專區中的「客戶 ID」。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟命令提示字元或 PowerShell。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有根層級或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/comforte_securdps: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: COMFORTE_SECURDPS raw_log_field: body ingestion_labels: env: production service: pipelines: logs/securdps_to_chronicle: receivers: - udplog exporters: - chronicle/comforte_securdps
設定參數
請替換下列預留位置:
接收器設定:
udplog:依通訊協定區分的接收端類型:- UDP syslog 的
udplog tcplog(適用於 TCP Syslog)
- UDP syslog 的
0.0.0.0:要接聽的 IP 位址:0.0.0.0在所有介面接聽電話 (建議)- 在一個介面上接聽的特定 IP 位址
514:要接聽的通訊埠號碼 (例如514、1514、6514)
Exporter 設定:
comforte_securdps:匯出工具的說明名稱creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<customer_id>:上一步取得的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會在這個值前面加上chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。project:依序前往「IAM 與管理」>「設定」,然後將<PROJECT_NUMBER>替換為專案編號。endpoint:請將此值設為chronicle.googleapis.com。COMFORTE_SECURDPS:記錄類型,與 Chronicle 中顯示的完全相同ingestion_labels:YAML 格式的選用標籤 (例如env: production)
管道設定:
securdps_to_chronicle::管道的說明名稱
舊版 Ingestion API 匯出工具
如果您使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/comforte_securdps: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: COMFORTE_SECURDPS raw_log_field: body ingestion_labels: env: production
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」 > 「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector檢查記錄是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列任一選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector查看記錄檔是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
設定 Comforte SecurDPS 系統記錄轉送
- 使用管理員憑證登入 Comforte SecurDPS 管理控制台。
- 依序前往「System」>「Configuration」>「Logging」。
- 啟用稽核記錄的系統記錄轉送功能。
- 提供下列設定詳細資料:
- Syslog Server:輸入 Bindplane 代理程式主機的 IP 位址 (例如
192.168.1.100)。 - 「Port」(通訊埠):輸入
514(必須與 Bindplane 代理接收器通訊埠相符)。 - 「通訊協定」:選取「UDP」。
- Facility:選取「local0」或適合您環境的設施。
- 嚴重性:選取「資訊」或更低等級,即可擷取所有稽核事件。
- Syslog Server:輸入 Bindplane 代理程式主機的 IP 位址 (例如
- 選取要轉送的記錄類別:
- 資料保護作業 (代碼化、加密)
- 存取和驗證事件
- 政策異動和管理措施
- 錯誤和警告事件
- 按一下「儲存」即可套用設定。
檢查 Bindplane 代理程式記錄,確認系統是否收到 Syslog 訊息。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
| record.index, record.cribl_pipe | additional.fields | 與從 record.index 和 record.cribl_pipe 建立的標籤合併 |
| record.msg_data, description | metadata.description | 如果位於 JSON 分支,則為 record.msg_data 中的值,否則為說明中的值 |
| metadata_event_type | metadata.event_type | 根據旗標設定:如果 principal_mid_present 和 target_mid_present 為 true,則為 NETWORK_CONNECTION;如果 target_user_present 為 true,則為 USER_UNCATEGORIZED;如果 principal_mid_present 為 true,則為 STATUS_UPDATE;否則為 GENERIC_EVENT |
| record.sourcetype, prod_event_type | metadata.product_event_type | 如果位於 JSON 分支,則為 record.sourcetype 的值,否則為 prod_event_type 的值 |
| metadata.product_name | 設為「Comforte SecureDPS」 | |
| metadata.vendor_name | 設為「COMFORTE_SECURDPS」 | |
| 主機 | principal.asset.hostname | 主機的值 (如果不是 IP) |
| validated_host、principal_ip | principal.asset.ip | 如果主機是 JSON 分支中的 IP,則為 validated_host 的值,否則為 principal_ip 的值 |
| 主機 | principal.hostname | 如果不是 IP,則取自主機的值 |
| validated_host、principal_ip | principal.ip | 如果主機是 JSON 分支中的 IP,則為 validated_host 的值,否則為 principal_ip 的值 |
| principal_port | principal.port | principal_port 的值,已轉換為整數 |
| record.facility、record.facilityName、_STRATEGY、_PROTECTS、_DENIEDPROTECTS、_REVEALS、_DENIEDREVEALS、_LOOKUPS、_INTERVAL | security_result.detection_fields | 與從 record.facility、record.facilityName、_STRATEGY、_PROTECTS、_DENIEDPROTECTS、_REVEALS、_DENIEDREVEALS、_LOOKUPS、_INTERVAL 建立的標籤合併 |
| sec_description | security_result.description | sec_description 的值 |
| record.severityName、severity | security_result.severity | 如果符合 (?i)(info),請設為 INFORMATIONAL;如果符合 (?i)(warn),請設為 WARNING;如果符合 (?i)(error),請設為 ERROR |
| record.severity, severity | security_result.severity_details | 如果位於 JSON 分支,則為 record.severity 的值,否則為 severity 的值 |
| app, _APPLICATION | target.application | 如果 _APPLICATION 有值,則使用該值,否則使用應用程式的值 |
| _IPADDRESS | target.asset.ip | _IPADDRESS 的值 |
| sha_256_value | target.file.sha256 | 如果符合十六進位模式,則為 sha_256_value 的值 |
| _IPADDRESS | target.ip | _IPADDRESS 的值 |
| pid | target.process.pid | pid 屬性的值 |
| sha256 | target.resource.attribute.labels | 如果 sha_256_value 不符合十六進位模式,則會與 sha256_label 合併 |
| _ZOSUSER | target.user.userid | _ZOSUSER 的值 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。