收集 Xcitium Endpoint Security 日志

解析器版本: 2.0

支持范围:

本文档介绍了如何使用 Bindplane 代理将 Xcitium Endpoint Security(以前称为 Comodo)日志注入到 Google Security Operations 中。

Xcitium Endpoint Security 是一个端点保护平台,它结合了防病毒、防火墙、入侵防御和遏制技术,可保护端点免受已知和未知威胁的侵害。它采用默认拒绝方法,并自动遏制来隔离无法识别的文件和进程,防止它们在分析时造成损害。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 Xcitium 管理的端点之间的网络连接
  • 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于打开状态
  • 对 Xcitium Endpoint Manager 控制台(以前称为 Comodo ITSM / ITarian)的特权访问权限
  • 在 Xcitium Endpoint Manager 中具有管理员角色,可修改配置文件和门户设置

获取 Bindplane 代理的 Google SecOps 凭据

如需向 Google SecOps 验证 Bindplane 代理的身份,请选择以下方法之一:

  • 新部署:使用 Chronicle API(方法 1)。
  • 旧版部署:继续使用注入身份验证文件(方法 2),直到注入 API 于 2027 年 7 月 20 日停用为止。
  1. 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
  2. 依次前往 IAM 和管理 > 服务账号。
  3. 点击创建服务账号 。
  4. 提供以下配置详细信息:
    • 服务账号名称:输入账号的名称(例如 bindplane-ingest)。
    • 服务账号说明:输入说明(例如 Bindplane agent log ingestion)。
  5. 点击创建并继续 。
  6. 在向此服务帐号授予对项目的访问权限 部分,点击选择角色 ,然后选择 Chronicle 编辑器 。
  7. 点击继续 ,然后点击完成 。
  8. 点击您创建的服务帐号,然后前往密钥 标签页。
  9. 点击添加密钥 > 创建新密钥。
  10. 选择 JSON ,然后点击创建 。密钥文件会下载到您的计算机上。
  11. 将密钥文件另存为 Bindplane 收集器目录中的 ingestion-auth.json(在 Linux 上为 /opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或者更新 creds_file_path 在 config.yaml 中以与您保存该文件的路径匹配。
  12. 依次前往 IAM 和管理 > 设置 ,然后复制项目编号 。您需要此编号进行导出器配置。

方法 2:下载注入身份验证文件(旧版)

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 收集代理。
  3. 下载注入身份验证文件 。
  4. 将该文件安全地保存在将安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 个人资料 。
  3. 从组织详细信息 部分复制并保存客户 ID 。

安装 Bindplane 代理

按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符 或 PowerShell 。
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

    该服务应显示为 RUNNING 。

Linux 安装

  1. 使用 root 或 sudo 权限打开终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

    该服务应显示为 active (running) 。

其他安装资源

如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。

配置 Bindplane 代理以注入 syslog 并发送到 Google SecOps

找到配置文件

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • 将 config.yaml 的全部内容替换为以下配置:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/comodo_av:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/path/to/ingestion-authentication-file.json'
        customer_id: 'your-customer-id'
        endpoint: chronicle.googleapis.com
        log_type: COMODO_AV
        raw_log_field: body
        ingestion_labels:
    
    service:
      pipelines:
        logs/comodo_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/comodo_av
    

配置参数

替换以下占位符:

  • 接收器配置:

    • listen_address:要监听的 IP 地址和端口。使用 0.0.0.0 监听所有接口。默认 syslog 端口为 514。
  • 导出器配置:

    • creds_file_path:服务帐号 JSON 密钥文件的完整路径(方法 1)。
      • Linux: /opt/observiq-otel-collector/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:Google SecOps 控制台中的客户 ID。
    • location:将 <LOCATION> 替换为 Google SecOps 实例的区域(例如 us、europe 或 asia-southeast1)。导出器会使用此值为 chronicle.googleapis.com 添加前缀。如需查看完整列表,请参阅区域级端点。
    • project:将 <PROJECT_NUMBER> 替换为 IAM 和管理 > 设置 中的项目编号。
    • endpoint:保持设置为 chronicle.googleapis.com。

旧版注入 API 导出器

  • 如果您使用方法 2 中的注入身份验证文件,请将 exporters 代码块替换为以下内容。将 creds_file_path 设置为注入身份验证文件的路径,如果您的实例位于美国境外,请将 malachiteingestion-pa.googleapis.com 替换为您的 区域级端点(例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/comodo_av:
        compression: gzip
        creds_file_path: '/path/to/ingestion-authentication-file.json'
        customer_id: 'your-customer-id'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: COMODO_AV
        raw_log_field: body
        ingestion_labels:
    

保存配置文件

  • 修改后,保存文件:

    • Linux:依次按 Ctrl+O、Enter 和 Ctrl+X。
    • Windows:依次点击文件 > 保存。

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
    1. 验证服务是否正在运行:

      sudo systemctl status observiq-otel-collector
      
    2. 检查日志中是否存在错误:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:

    • 以管理员身份运行命令提示符或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服务控制台:

      1. 按 Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry Collector 。
      3. 右键点击并选择重启 。
      4. 验证服务是否正在运行:

        sc query observiq-otel-collector
        
      5. 检查日志中是否存在错误:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

配置 Xcitium Endpoint Security syslog 转发

Xcitium Endpoint Manager 提供两个级别的 syslog 转发。请同时配置这两个级别,以确保全面覆盖日志。

配置端点级 syslog 转发(Xcitium Client - Security 日志)

  1. 登录 Xcitium Endpoint Manager 控制台。
  2. 依次前往配置模板 > 配置文件。
  3. 点击要修改的 Windows 配置文件,或创建新配置文件。
  4. 依次点击添加配置文件部分 > 日志记录设置。
  5. 在 Xcitium Client - Security 部分中,启用写入 Syslog 服务器 。
  6. 提供以下配置详细信息:
    • 主机:输入 Bindplane 代理主机的主机名或 IP 地址。
    • 端口:输入在 Bindplane 代理中配置的端口号(例如 514)。
  7. (可选)启用写入日志文件(CEF 格式) ,以保留通用事件格式的日志本地副本。
  8. 在通信客户端 部分中,启用写入 Syslog 服务器 。
  9. 提供以下配置详细信息:
    • 主机:输入 Bindplane 代理主机的主机名或 IP 地址。
    • 端口:输入在 Bindplane 代理中配置的端口号(例如 514)。
  10. 选择要收集日志的事件类型:
    • 监控日志
    • 脚本日志
    • 操作系统补丁日志
    • 第三方应用更新日志
    • 应用安装日志
    • 卸载日志
    • 事件检测和响应 (EDR) 代理通信日志
    • Xcitium Client - Security (XCS) 通信日志
    • 远程控制通信日志
    • 运维日志
  11. 点击保存 。

配置门户级 syslog 转发(审核日志)

  1. 登录 Xcitium Endpoint Manager 控制台。
  2. 依次前往设置 > 门户设置 > 日志记录设置。
  3. 点击修改 。
  4. 启用写入 syslog 服务器 。
  5. 提供以下配置详细信息:
    • 主机:输入 Bindplane 代理主机的主机名或 IP 地址。
    • 端口:输入在 Bindplane 代理中配置的端口号(例如 514)。
  6. 点击保存 。

如需了解详情,请参阅 Xcitium Endpoint Manager 日志记录设置文档 和 配置审核日志设置。

UDM 映射表

日志字段 UDM 映射 逻辑
event_type metadata.event_type 已重命名/映射
data5 principal.application 直接映射
data3 principal.asset.platform_software.platform_version 直接映射
dvchost principal.hostname 直接映射
dvc principal.ip 已合并
data4 principal.user.product_object_id 直接映射
filePath target.file.full_path 直接映射
fname target.process.parent_process.file.full_path 直接映射
suser target.user.userid 直接映射
不适用 metadata.product_name 常量:COMODO_AV
不适用 metadata.vendor_name 常量:COMODO
不适用 principal.ip 常量:dvc

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。