收集 CrushFTP 記錄

剖析器版本:1.0

支援的國家/地區:

本文說明如何使用 Bindplane 代理程式,將 CrushFTP 記錄檔擷取至 Google Security Operations。

CrushFTP 是企業檔案傳輸伺服器,可產生檔案傳輸、使用者驗證和系統事件的系統記錄訊息。剖析器會擷取欄位,並將其對應至統合式資料模型 (UDM)。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 CrushFTP 伺服器之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • CrushFTP 網頁 UI 的特殊存取權

取得 Google SecOps 擷取驗證檔案

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」
  3. 下載擷取驗證檔案
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」
  3. 複製並儲存「機構詳細資料」部分中的客戶 ID

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟「命令提示字元」或「PowerShell」
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」

Linux 安裝

  1. 開啟具有根層級或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為有效 (執行中)

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南

設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /etc/bindplane-agent/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • config.yaml 的所有內容替換為下列設定:

    receivers:
        udplog:
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/crushftp:
            compression: gzip
            creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
            customer_id: '<customer_id>'
            endpoint: malachiteingestion-pa.googleapis.com
            log_type: CRUSHFTP
            raw_log_field: body
    
    service:
        pipelines:
            logs/crushftp_to_chronicle:
                receivers:
                    - udplog
                exporters:
                    - chronicle/crushftp
    

設定參數

替換下列預留位置:

  • 接收器設定:

    • listen_address:要接聽的 IP 位址和通訊埠:
      • 0.0.0.0,監聽所有介面 (建議)
      • 通訊埠 514 是標準的系統記錄通訊埠 (在 Linux 上需要根層級權限;非根層級權限請使用 1514)
  • 匯出工具設定:

    • creds_file_path:擷取驗證檔案的完整路徑:
      • Linux/etc/bindplane-agent/ingestion-auth.json
      • WindowsC:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:從 Google SecOps 控制台複製的客戶 ID
    • endpoint:區域端點網址:
      • 美國malachiteingestion-pa.googleapis.com
      • 歐洲europe-malachiteingestion-pa.googleapis.com
      • 亞洲asia-southeast1-malachiteingestion-pa.googleapis.com
      • 如需完整清單,請參閱「區域端點

儲存設定檔

  • 編輯完成後,請儲存檔案:
    • Linux:依序按下 Ctrl+OEnterCtrl+X
    • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,以套用變更

  • 如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 檢查記錄中是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出 observIQ OpenTelemetry Collector
      3. 按一下滑鼠右鍵,然後選取「重新啟動」
      4. 確認服務正在執行:

        sc query observiq-otel-collector
        
      5. 檢查記錄中是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

設定 CrushFTP 系統記錄檔

  1. 登入 CrushFTP 網頁版 UI。
  2. 依序前往「偏好設定」>「記錄」>「系統記錄」部分。
  3. 請提供下列設定詳細資料:
    • 勾選「啟用」核取方塊。
    • 主機:輸入 Bindplane 代理程式 IP 位址。
    • 「Port」(通訊埠):輸入 Bindplane 代理程式通訊埠編號。
    • 通訊協定:選取 UDP (或 TCP,視 Bindplane 設定而定)。
    • 記錄供應商:選取「SysLog」
  4. 按一下「儲存設定」

UDM 對應表

記錄欄位 UDM 對應 邏輯
exists_label additional.fields 已合併
msg metadata.description 直接對應
timestamp metadata.event_timestamp 已剖析為 MM/dd/yyyy HH:mm:ss.SSS
has_principal metadata.event_type 對應:trueNETWORK_CONNECTIONtrueFILE_UNCATEGORIZEDtrueSTATUS_UPDATE
prod_event_type metadata.product_event_type 直接對應
http_method network.http.method 直接對應
Response_code network.http.response_code 已重新命名/對應
sessionid network.session_id 直接對應
src_ip principal.asset.ip 已合併
group principal.group.group_display_name 直接對應
src_host principal.hostname 直接對應
src_ip principal.ip 已合併
src_port principal.port 已重新命名/對應
email principal.user.email_addresses 已對應:^.+@.+$email
owner principal.user.userid 直接對應
Description security_result.description 直接對應
http_version_label security_result.detection_fields 已合併
domainname target.asset.hostname 直接對應
target_ip target.asset.ip 已合併
url target.file.full_path 直接對應
name target.file.names 已合併
size target.file.size 已重新命名/對應
domainname target.hostname 直接對應
target_ip target.ip 已合併
target_port target.port 已重新命名/對應
modified_label target.resource.attribute.labels 已合併
permissions_label target.resource.attribute.labels 已合併
privs_label target.resource.attribute.labels 已合併
target_url target.url 直接對應
不適用 metadata.event_type 常數:GENERIC_EVENT
不適用 metadata.product_name 常數:CrushFTP
不適用 metadata.vendor_name 常數:CrushFTP

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。