收集 Cyolo OT 日志

解析器版本:3.0

支持:

本文档介绍了如何使用 Bindplane 代理将 Cyolo Secure Remote Access for OT 日志注入到 Google Security Operations。

Cyolo 为运营技术 (OT) 环境提供安全的远程访问。该平台会针对访问事件、身份验证和会话活动生成 syslog 消息。解析器会提取字段并将其映射到统一数据模型 (UDM)。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 Cyolo 平台之间的网络连接
  • 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于开放状态
  • 对 Cyolo 管理控制台的特权访问权限

获取 Bindplane 代理的 Google SecOps 凭证

如需向 Google SecOps 验证 Bindplane 代理的身份,请选择以下方法之一:

  • 新部署:使用 Chronicle API(选项 1)。
  • 旧版部署:继续使用提取身份验证文件(方法 2),直到提取 API 于 2027 年 7 月 20 日停用。
  1. 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
  2. 前往 IAM 和管理 > 服务账号。
  3. 点击创建服务账号。
  4. 提供以下配置详细信息:
    • 服务账号名称:输入账号的名称(例如 bindplane-ingest)。
    • 服务账号说明:输入说明(例如 Bindplane agent log ingestion)。
  5. 点击创建并继续。
  6. 在向此服务账号授予对项目的访问权限部分,点击选择角色,然后选择 Chronicle Editor。
  7. 点击继续,然后点击完成。
  8. 点击您创建的服务账号,然后前往密钥标签页。
  9. 依次点击添加密钥 > 创建新密钥。
  10. 选择 JSON,然后点击创建。密钥文件会下载到您的计算机上。
  11. 将密钥文件另存为 Bindplane 收集器目录(Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)中的 ingestion-auth.json,或更新 config.yaml 中的 creds_file_path 以匹配您保存该文件的路径。
  12. 前往 IAM 和管理 > 设置,然后复制项目编号。您需要此信息才能配置导出器。

方法 2:下载数据注入身份验证文件(旧版)

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 收集代理。
  3. 下载数据注入身份验证文件。
  4. 将文件安全地保存在将安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 前往 SIEM 设置 > 个人资料。
  3. 从组织详细信息部分复制并保存客户 ID。

安装 Bindplane 代理

按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符或 PowerShell。
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

    该服务应显示为 RUNNING。

Linux 安装

  1. 打开具有 root 或 sudo 权限的终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

    该服务应显示为 active (running)。

其他安装资源

如需了解其他安装选项和问题排查,请参阅 Bindplane 代理安装指南。

配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps

找到配置文件

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • 将 config.yaml 的全部内容替换为以下配置:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/cyolo_ot:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: CYOLO_OT
        raw_log_field: body
    
    service:
      pipelines:
        logs/cyolo_ot_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/cyolo_ot
    

配置参数

替换以下占位符:

  • 接收器配置:

    • listen_address:要监听的 IP 地址和端口:
      • 0.0.0.0 在所有接口上监听(推荐)
      • 端口 514 是标准 syslog 端口(在 Linux 上需要 root 权限;对于非 root 用户,请使用 1514)
  • 导出器配置:

    • creds_file_path:服务账号 JSON 密钥文件的完整路径(选项 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:从 Google SecOps 控制台复制的客户 ID
    • location:将 <LOCATION> 替换为 Google SecOps 实例所在的区域(例如 us、europe 或 asia-southeast1)。导出工具会在此值前面加上 chronicle.googleapis.com。如需查看完整列表,请参阅区域级端点。
    • project:将 <PROJECT_NUMBER> 替换为“IAM 和管理”>“设置”中的项目编号。
    • endpoint:保持设置为 chronicle.googleapis.com。

旧版提取 API

  • 如果您使用选项 2 中的提取身份验证文件,请将 exporters 代码块替换为以下内容。将 creds_file_path 设置为数据注入身份验证文件的路径,如果您的实例位于美国境外,请将 malachiteingestion-pa.googleapis.com 替换为您的区域端点(例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/cyolo_ot:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: CYOLO_OT
        raw_log_field: body
    

保存配置文件

  • 修改后,保存文件:
    • Linux:依次按 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
    1. 验证服务是否正在运行:

      sudo systemctl status observiq-otel-collector
      
    2. 检查日志中是否存在错误:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:

    • 以管理员身份运行命令提示符或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • “服务”控制台:

      1. 按 Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry 收集器。
      3. 右键点击,然后选择重新启动。
      4. 验证服务是否正在运行:

        sc query observiq-otel-collector
        
      5. 检查日志中的错误:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

在 Cyolo 上配置 syslog

  1. 登录 Cyolo 管理控制台。
  2. 前往监控 > 设置。
  3. 开启将日志导出到系统日志记录协议 (Syslog)。
  4. 前往集成 > Syslog 服务器。
  5. 提供以下配置详细信息:
    • 服务器名称:为此服务器输入一个有意义的名称(例如 Google SecOps Bindplane)。
    • 网站:从下拉菜单中选择单个网站或多个网站。
    • IP 地址:输入 Bindplane 代理 IP 地址。
    • 端口:输入用于 UDP 连接的 Bindplane 代理端口号。
  6. 点击保存。

UDM 映射表

日志字段 UDM 映射 逻辑
_field additional.fields 已合并
authority_id_label additional.fields 已合并
authority_kind_label additional.fields 已合并
authority_name_label additional.fields 已合并
data_field additional.fields 已合并
duration_label additional.fields 已合并
kind_label additional.fields 已合并
log_level_label additional.fields 已合并
object_id_label additional.fields 已合并
object_kind_label additional.fields 已合并
object_name_label additional.fields 已合并
rules_label additional.fields 已合并
site_id_label additional.fields 已合并
subject_id_label additional.fields 已合并
subject_kind_label additional.fields 已合并
message extensions.auth.type 已映射:user disconnected → MACHINE
syslog_object_name extensions.auth.type 已映射:login → MACHINE
inter_host intermediary.asset.hostname 直接映射
inter_host intermediary.hostname 直接映射
message metadata.description 直接映射
msg metadata.description 直接映射
syslog_message metadata.description 直接映射
syslog_timestamp metadata.event_timestamp 已解析为 ISO8601
time metadata.event_timestamp 已解析为 MMM d HH:mm:ss
timestamp metadata.event_timestamp 已解析为 ISO8601
event_type metadata.event_type 直接映射
kind metadata.product_event_type 直接映射
prod_type metadata.product_event_type 直接映射
id metadata.product_log_id 直接映射
syslog_event_id metadata.product_log_id 直接映射
product_version metadata.product_version 直接映射
message network.application_protocol 已映射:rdp → RDP
client network.http.parsed_user_agent 直接映射
cyolouagent network.http.parsed_user_agent 直接映射
client network.http.user_agent 直接映射
cyolouagent network.http.user_agent 直接映射
syslog_client network.http.user_agent 直接映射
cyolosessionid network.session_id 直接映射
session_id network.session_id 直接映射
hostname observer.hostname 直接映射
container_id_label observer.resource.attribute.labels 已合并
internal_event_id_label observer.resource.attribute.labels 已合并
log_source_label observer.resource.attribute.labels 已合并
site_id_label observer.resource.attribute.labels 已合并
site_name_label observer.resource.attribute.labels 已合并
transaction_id_label observer.resource.attribute.labels 已合并
node_id observer.resource.product_object_id 直接映射
syslog_hostname principal.asset.hostname 直接映射
remote_address principal.asset.ip 已合并
syslog_remote_address principal.asset.ip 已合并
syslog_hostname principal.hostname 直接映射
remote_address principal.ip 已合并
syslog_remote_address principal.ip 已合并
country_code principal.location.country_or_region 直接映射
cyolocountrycode principal.location.country_or_region 直接映射
syslog_country_code principal.location.country_or_region 直接映射
node_id_label principal.resource.attribute.labels 已合并
site_name_label principal.resource.attribute.labels 已合并
transaction_id_label principal.resource.attribute.labels 已合并
cyolosubjectkind principal.resource.resource_subtype 直接映射
credentials_id_label principal.user.attribute.labels 已合并
credentials_name_label principal.user.attribute.labels 已合并
credentials_origin_label principal.user.attribute.labels 已合并
cyolosubjectid principal.user.product_object_id 直接映射
subject_id principal.user.product_object_id 直接映射
syslog_session_id principal.user.product_object_id 直接映射
cyolosubjectname principal.user.userid 直接映射
subject_name principal.user.userid 直接映射
syslog_id principal.user.userid 直接映射
action security_result.action 已合并
result security_result.action 已映射:failure → sr_action,success → sr_action
sr_action security_result.action 已合并
syslog_result security_result.action_details 直接映射
_field security_result.detection_fields 已合并
field security_result.detection_fields 已合并
key security_result.detection_fields 已映射:"cyoloauthkind", "cyolokind","cyoloresult" → _field
result security_result.outcome 已映射:failure → FAIL,success → PASS
authority_id security_result.rule_id 直接映射
cyoloauthid security_result.rule_id 直接映射
authority_name security_result.rule_name 直接映射
cyoloauthname security_result.rule_name 直接映射
severity security_result.severity 已映射:1 → LOW
cyoloobjname target.application 直接映射
object_name target.application 直接映射
asset_id target.asset.asset_id 直接映射
destination_host target.asset.hostname 直接映射
dst target.asset.ip 已合并
asset_name target.asset.product_object_id 直接映射
destination_host target.hostname 直接映射
dst target.ip 已合并
destination_port target.port 直接映射
_field target.resource.attribute.labels 已合并
key target.resource.attribute.labels 已映射:cyolodstid → _field
cyoloobjid target.resource.product_object_id 直接映射
object_id target.resource.product_object_id 直接映射
cyoloobjkind target.resource.resource_subtype 直接映射
syslog_subject_name target.user.userid 直接映射
不适用 extensions.auth.type 常量:MACHINE
不适用 metadata.product_name 常量:CYOLO_OT
不适用 metadata.vendor_name 常量:CYOLO_OT
不适用 network.application_protocol 常量:RDP
不适用 network.http.parsed_user_agent 常量:parseduseragent
不适用 security_result.outcome 常量:FAIL
不适用 security_result.severity 常量:LOW
inter_host event.idm.read_only_udm.intermediary.hostname和event.idm.read_only_udm.intermediary.asset.hostname之间 从更新日志映射
cyolosubjectname event.idm.read_only_udm.principal.user.userid 从更新日志映射
cyolocountrycode event.idm.read_only_udm.principal.location.country_or_region 从更新日志映射
cyolosubjectid event.idm.read_only_udm.principal.user.product_object_id 从更新日志映射
dst event.idm.read_only_udm.target.ip和event.idm.read_only_udm.target.asset.ip 从更新日志映射
cyoloobjname event.idm.read_only_udm.target.application 从更新日志映射
cyoloobjid event.idm.read_only_udm.target.resource.product_object_id 从更新日志映射
cyolosessionid event.idm.read_only_udm.network.session_id 从更新日志映射
cyolouagent event.idm.read_only_udm.network.http.user_agent和event.idm.read_only_udm.network.http.parsed_user_agent之间 从更新日志映射
cyoloauthid event.idm.read_only_udm.security_result.rule_id 从更新日志映射
cyoloauthname event.idm.read_only_udm.security_result.rule_name 从更新日志映射
cyolosubjectkind event.idm.read_only_udm.principal.resource.resource_subtype 从更新日志映射
cyoloobjkind event.idm.read_only_udm.target.resource.resource_subtype 从更新日志映射
prod_type event.idm.read_only_udm.metadata.product_event_type 从更新日志映射
cyoloauthkind event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
cyolokind event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
cyoloresult event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
cyolodstid event.idm.read_only_udm.target.resource.attribute.labels 从更新日志映射
cef_version event.idm.read_only_udm.additional.fields 从更新日志映射
Signature_id event.idm.read_only_udm.additional.fields 从更新日志映射
cef_severity event.idm.read_only_udm.additional.fields 从更新日志映射
start event.idm.read_only_udm.additional.fields 从更新日志映射
act event.idm.read_only_udm.additional.fields 从更新日志映射
cyolotransid event.idm.read_only_udm.additional.fields 从更新日志映射
cyolocredentialsorigin event.idm.read_only_udm.additional.fields 从更新日志映射
cyolocredentialsid event.idm.read_only_udm.additional.fields 从更新日志映射
cyolocredentialsname event.idm.read_only_udm.additional.fields 从更新日志映射
time event.idm.read_only_udm.metadata.event_timestamp 从更新日志映射
id event.idm.read_only_udm.metadata.product_log_id 从更新日志映射
remote_address event.idm.read_only_udm.principal.ip 从更新日志映射
remote_address event.idm.read_only_udm.principal.asset.ip 从更新日志映射
country_code event.idm.read_only_udm.principal.location.country_or_region 从更新日志映射
destination_host event.idm.read_only_udm.target.hostname 从更新日志映射
destination_host event.idm.read_only_udm.target.asset.hostname 从更新日志映射
destination_port event.idm.read_only_udm.target.port 从更新日志映射
message event.idm.read_only_udm.metadata.description 从更新日志映射
subject_name event.idm.read_only_udm.principal.user.userid 从更新日志映射
subject_id event.idm.read_only_udm.principal.user.product_object_id 从更新日志映射
timestamp event.idm.read_only_udm.metadata.event_timestamp 从更新日志映射
object_name event.idm.read_only_udm.target.application 从更新日志映射
object_id event.idm.read_only_udm.target.resource.product_object_id 从更新日志映射
session_id event.idm.read_only_udm.network.session_id 从更新日志映射
duration_str event.idm.read_only_udm.additional.fields 从更新日志映射
message event.idm.read_only_udm.additional.fields 从更新日志映射
subject_kind event.idm.read_only_udm.additional.fields 从更新日志映射
authority_kind event.idm.read_only_udm.additional.fields 从更新日志映射
log_level event.idm.read_only_udm.additional.fields 从更新日志映射
object_kind event.idm.read_only_udm.additional.fields 从更新日志映射
client event.idm.read_only_udm.network.http.user_agent 从更新日志映射
client event.idm.read_only_udm.network.http.parsed_user_agent 从更新日志映射
authority_id event.idm.read_only_udm.security_result.rule_id 从更新日志映射
authority_name event.idm.read_only_udm.security_result.rule_name 从更新日志映射
severity event.idm.read_only_udm.security_result.severity 从更新日志映射
rules event.idm.read_only_udm.security_result.detection_fields 从更新日志映射
hostname event.idm.read_only_udm.observer.hostname 从更新日志映射
node_id event.idm.read_only_udm.observer.resource.product_object_id 从更新日志映射
site_id event.idm.read_only_udm.observer.resource.attribute.labels 从更新日志映射
log_source event.idm.read_only_udm.observer.resource.attribute.labels 从更新日志映射
site_name event.idm.read_only_udm.observer.resource.attribute.labels 从更新日志映射
container_id event.idm.read_only_udm.observer.resource.attribute.labels 从更新日志映射
transaction_id event.idm.read_only_udm.observer.resource.attribute.labels 从更新日志映射
event_id event.idm.read_only_udm.observer.resource.attribute.labels 从更新日志映射
kind event.idm.read_only_udm.metadata.product_event_type 从更新日志映射
syslog_timestamp event.idm.read_only_udm.metadata.collected_timestamp 从更新日志映射

更新日志

查看此解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。