收集 Cyolo OT 記錄

剖析器版本:3.0

支援的服務:

本文說明如何使用 Bindplane 代理程式,將 Cyolo Secure Remote Access for OT 記錄擷取至 Google Security Operations。

Cyolo 為營運技術 (OT) 環境提供安全的遠端存取權。這個平台會針對存取事件、驗證和工作階段活動產生系統記錄訊息。剖析器會擷取欄位,並將其對應至統一資料模型 (UDM)。

事前準備

請確認您符合下列必要條件:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Cyolo 平台之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • Cyolo 管理控制台的特殊權限存取權

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
  1. 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 提供下列設定詳細資料:
    • 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如 bindplane-ingest)。
    • 「服務帳戶說明」:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存路徑相符。
  12. 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。設定匯出工具時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」 > 「設定檔」。
  3. 複製並儲存「機構詳細資料」專區中的「客戶 ID」。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟命令提示字元或 PowerShell。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」。

Linux 安裝

  1. 開啟具有根層級或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為「active (running)」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/cyolo_ot:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: CYOLO_OT
        raw_log_field: body
    
    service:
      pipelines:
        logs/cyolo_ot_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/cyolo_ot
    

設定參數

替換下列預留位置:

  • 接收器設定:

    • listen_address:要接聽的 IP 位址和通訊埠:
      • 0.0.0.0 在所有介面接聽電話 (建議)
      • 通訊埠 514 是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用 1514)
  • 匯出工具設定:

    • creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:從 Google SecOps 控制台複製的客戶 ID
    • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會在這個值前面加上 chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。
    • project:將 <PROJECT_NUMBER> 替換為「IAM 與管理」>「設定」中的專案編號。
    • endpoint:請將此值設為 chronicle.googleapis.com。

舊版 Ingestion API 匯出工具

  • 如果您使用方式 2 的擷取驗證檔案,請將 exporters 區塊替換成下列內容。將 creds_file_path 設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/cyolo_ot:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: CYOLO_OT
        raw_log_field: body
    

儲存設定檔

  • 編輯完成後,請儲存檔案:
    • Linux:依序按下 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依序點選「檔案」 > 「儲存」

重新啟動 Bindplane 代理程式,套用變更

  • 如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 檢查記錄是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R 鍵,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
      4. 確認服務是否正在執行:

        sc query observiq-otel-collector
        
      5. 查看記錄檔是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

在 Cyolo 上設定系統記錄檔

  1. 登入 Cyolo 管理控制台。
  2. 依序前往「監控」>「設定」。
  3. 將「將記錄匯出至系統記錄通訊協定 (Syslog)」切換為「開啟」。
  4. 依序前往 「整合」 > 「Syslog 伺服器」。
  5. 請提供下列設定詳細資料:
    • 伺服器名稱:輸入這個伺服器的名稱 (例如 Google SecOps Bindplane)。
    • 網站:從下拉式選單中選取單一網站或多個網站。
    • IP 位址:輸入 Bindplane 代理程式 IP 位址。
    • 通訊埠:輸入 UDP 連線的 Bindplane 代理程式通訊埠編號。
  6. 按一下 [儲存]。

UDM 對應表

記錄欄位 UDM 對應 邏輯
_field additional.fields 已合併
authority_id_label additional.fields 已合併
authority_kind_label additional.fields 已合併
authority_name_label additional.fields 已合併
data_field additional.fields 已合併
duration_label additional.fields 已合併
kind_label additional.fields 已合併
log_level_label additional.fields 已合併
object_id_label additional.fields 已合併
object_kind_label additional.fields 已合併
object_name_label additional.fields 已合併
rules_label additional.fields 已合併
site_id_label additional.fields 已合併
subject_id_label additional.fields 已合併
subject_kind_label additional.fields 已合併
message extensions.auth.type 對應:user disconnected → MACHINE
syslog_object_name extensions.auth.type 已對應:login → MACHINE
inter_host intermediary.asset.hostname 直接對應
inter_host intermediary.hostname 直接對應
message metadata.description 直接對應
msg metadata.description 直接對應
syslog_message metadata.description 直接對應
syslog_timestamp metadata.event_timestamp 已剖析為 ISO8601
time metadata.event_timestamp 剖析為 MMM d HH:mm:ss
timestamp metadata.event_timestamp 已剖析為 ISO8601
event_type metadata.event_type 直接對應
kind metadata.product_event_type 直接對應
prod_type metadata.product_event_type 直接對應
id metadata.product_log_id 直接對應
syslog_event_id metadata.product_log_id 直接對應
product_version metadata.product_version 直接對應
message network.application_protocol 已對應:rdp → RDP
client network.http.parsed_user_agent 直接對應
cyolouagent network.http.parsed_user_agent 直接對應
client network.http.user_agent 直接對應
cyolouagent network.http.user_agent 直接對應
syslog_client network.http.user_agent 直接對應
cyolosessionid network.session_id 直接對應
session_id network.session_id 直接對應
hostname observer.hostname 直接對應
container_id_label observer.resource.attribute.labels 已合併
internal_event_id_label observer.resource.attribute.labels 已合併
log_source_label observer.resource.attribute.labels 已合併
site_id_label observer.resource.attribute.labels 已合併
site_name_label observer.resource.attribute.labels 已合併
transaction_id_label observer.resource.attribute.labels 已合併
node_id observer.resource.product_object_id 直接對應
syslog_hostname principal.asset.hostname 直接對應
remote_address principal.asset.ip 已合併
syslog_remote_address principal.asset.ip 已合併
syslog_hostname principal.hostname 直接對應
remote_address principal.ip 已合併
syslog_remote_address principal.ip 已合併
country_code principal.location.country_or_region 直接對應
cyolocountrycode principal.location.country_or_region 直接對應
syslog_country_code principal.location.country_or_region 直接對應
node_id_label principal.resource.attribute.labels 已合併
site_name_label principal.resource.attribute.labels 已合併
transaction_id_label principal.resource.attribute.labels 已合併
cyolosubjectkind principal.resource.resource_subtype 直接對應
credentials_id_label principal.user.attribute.labels 已合併
credentials_name_label principal.user.attribute.labels 已合併
credentials_origin_label principal.user.attribute.labels 已合併
cyolosubjectid principal.user.product_object_id 直接對應
subject_id principal.user.product_object_id 直接對應
syslog_session_id principal.user.product_object_id 直接對應
cyolosubjectname principal.user.userid 直接對應
subject_name principal.user.userid 直接對應
syslog_id principal.user.userid 直接對應
action security_result.action 已合併
result security_result.action 已對應:failure → sr_action、success → sr_action
sr_action security_result.action 已合併
syslog_result security_result.action_details 直接對應
_field security_result.detection_fields 已合併
field security_result.detection_fields 已合併
key security_result.detection_fields 已對應:"cyoloauthkind", "cyolokind","cyoloresult" → _field
result security_result.outcome 對應:failure → FAIL、success → PASS
authority_id security_result.rule_id 直接對應
cyoloauthid security_result.rule_id 直接對應
authority_name security_result.rule_name 直接對應
cyoloauthname security_result.rule_name 直接對應
severity security_result.severity 對應:1 → LOW
cyoloobjname target.application 直接對應
object_name target.application 直接對應
asset_id target.asset.asset_id 直接對應
destination_host target.asset.hostname 直接對應
dst target.asset.ip 已合併
asset_name target.asset.product_object_id 直接對應
destination_host target.hostname 直接對應
dst target.ip 已合併
destination_port target.port 直接對應
_field target.resource.attribute.labels 已合併
key target.resource.attribute.labels 對應:cyolodstid → _field
cyoloobjid target.resource.product_object_id 直接對應
object_id target.resource.product_object_id 直接對應
cyoloobjkind target.resource.resource_subtype 直接對應
syslog_subject_name target.user.userid 直接對應
不適用 extensions.auth.type 常數:MACHINE
不適用 metadata.product_name 常數:CYOLO_OT
不適用 metadata.vendor_name 常數:CYOLO_OT
不適用 network.application_protocol 常數:RDP
不適用 network.http.parsed_user_agent 常數:parseduseragent
不適用 security_result.outcome 常數:FAIL
不適用 security_result.severity 常數:LOW
inter_host event.idm.read_only_udm.intermediary.hostname 和 event.idm.read_only_udm.intermediary.asset.hostname 從變更記錄對應
cyolosubjectname event.idm.read_only_udm.principal.user.userid 從變更記錄對應
cyolocountrycode event.idm.read_only_udm.principal.location.country_or_region 從變更記錄對應
cyolosubjectid event.idm.read_only_udm.principal.user.product_object_id 從變更記錄對應
dst event.idm.read_only_udm.target.ip和event.idm.read_only_udm.target.asset.ip 從變更記錄對應
cyoloobjname event.idm.read_only_udm.target.application 從變更記錄對應
cyoloobjid event.idm.read_only_udm.target.resource.product_object_id 從變更記錄對應
cyolosessionid event.idm.read_only_udm.network.session_id 從變更記錄對應
cyolouagent event.idm.read_only_udm.network.http.user_agent 和 event.idm.read_only_udm.network.http.parsed_user_agent 從變更記錄對應
cyoloauthid event.idm.read_only_udm.security_result.rule_id 從變更記錄對應
cyoloauthname event.idm.read_only_udm.security_result.rule_name 從變更記錄對應
cyolosubjectkind event.idm.read_only_udm.principal.resource.resource_subtype 從變更記錄對應
cyoloobjkind event.idm.read_only_udm.target.resource.resource_subtype 從變更記錄對應
prod_type event.idm.read_only_udm.metadata.product_event_type 從變更記錄對應
cyoloauthkind event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
cyolokind event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
cyoloresult event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
cyolodstid event.idm.read_only_udm.target.resource.attribute.labels 從變更記錄對應
cef_version event.idm.read_only_udm.additional.fields 從變更記錄對應
Signature_id event.idm.read_only_udm.additional.fields 從變更記錄對應
cef_severity event.idm.read_only_udm.additional.fields 從變更記錄對應
start event.idm.read_only_udm.additional.fields 從變更記錄對應
act event.idm.read_only_udm.additional.fields 從變更記錄對應
cyolotransid event.idm.read_only_udm.additional.fields 從變更記錄對應
cyolocredentialsorigin event.idm.read_only_udm.additional.fields 從變更記錄對應
cyolocredentialsid event.idm.read_only_udm.additional.fields 從變更記錄對應
cyolocredentialsname event.idm.read_only_udm.additional.fields 從變更記錄對應
time event.idm.read_only_udm.metadata.event_timestamp 從變更記錄對應
id event.idm.read_only_udm.metadata.product_log_id 從變更記錄對應
remote_address event.idm.read_only_udm.principal.ip 從變更記錄對應
remote_address event.idm.read_only_udm.principal.asset.ip 從變更記錄對應
country_code event.idm.read_only_udm.principal.location.country_or_region 從變更記錄對應
destination_host event.idm.read_only_udm.target.hostname 從變更記錄對應
destination_host event.idm.read_only_udm.target.asset.hostname 從變更記錄對應
destination_port event.idm.read_only_udm.target.port 從變更記錄對應
message event.idm.read_only_udm.metadata.description 從變更記錄對應
subject_name event.idm.read_only_udm.principal.user.userid 從變更記錄對應
subject_id event.idm.read_only_udm.principal.user.product_object_id 從變更記錄對應
timestamp event.idm.read_only_udm.metadata.event_timestamp 從變更記錄對應
object_name event.idm.read_only_udm.target.application 從變更記錄對應
object_id event.idm.read_only_udm.target.resource.product_object_id 從變更記錄對應
session_id event.idm.read_only_udm.network.session_id 從變更記錄對應
duration_str event.idm.read_only_udm.additional.fields 從變更記錄對應
message event.idm.read_only_udm.additional.fields 從變更記錄對應
subject_kind event.idm.read_only_udm.additional.fields 從變更記錄對應
authority_kind event.idm.read_only_udm.additional.fields 從變更記錄對應
log_level event.idm.read_only_udm.additional.fields 從變更記錄對應
object_kind event.idm.read_only_udm.additional.fields 從變更記錄對應
client event.idm.read_only_udm.network.http.user_agent 從變更記錄對應
client event.idm.read_only_udm.network.http.parsed_user_agent 從變更記錄對應
authority_id event.idm.read_only_udm.security_result.rule_id 從變更記錄對應
authority_name event.idm.read_only_udm.security_result.rule_name 從變更記錄對應
severity event.idm.read_only_udm.security_result.severity 從變更記錄對應
rules event.idm.read_only_udm.security_result.detection_fields 從變更記錄對應
hostname event.idm.read_only_udm.observer.hostname 從變更記錄對應
node_id event.idm.read_only_udm.observer.resource.product_object_id 從變更記錄對應
site_id event.idm.read_only_udm.observer.resource.attribute.labels 從變更記錄對應
log_source event.idm.read_only_udm.observer.resource.attribute.labels 從變更記錄對應
site_name event.idm.read_only_udm.observer.resource.attribute.labels 從變更記錄對應
container_id event.idm.read_only_udm.observer.resource.attribute.labels 從變更記錄對應
transaction_id event.idm.read_only_udm.observer.resource.attribute.labels 從變更記錄對應
event_id event.idm.read_only_udm.observer.resource.attribute.labels 從變更記錄對應
kind event.idm.read_only_udm.metadata.product_event_type 從變更記錄對應
syslog_timestamp event.idm.read_only_udm.metadata.collected_timestamp 從變更記錄對應

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。