收集 Dell CyberSense 日志
解析器版本: 2.0
本文档介绍了如何使用 Bindplane 代理将 Dell CyberSense 日志注入 Google Security Operations。
Dell CyberSense(Dell PowerProtect 的一部分)是一种网络恢复解决方案,可检测勒索软件和数据损坏。该系统以标准 syslog 和 CEF 格式生成 syslog 消息,用于审核事件、索引作业和感染检测。解析器会提取字段并将其映射到统一数据模型 (UDM)。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 Dell PowerProtect 系统之间的网络连接
- 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于打开状态
- 对 Dell PowerProtect 系统的 CLI 访问权限
获取 Google SecOps 注入身份验证文件
- 登录 Google SecOps 控制台。
- 前往 SIEM 设置 > 收集代理。
- 下载注入身份验证文件 。
将该文件安全地保存在将安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 前往 SIEM 设置 > 个人资料。
从组织详细信息 部分复制并保存客户 ID 。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符 或 PowerShell 。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector该服务应显示为 RUNNING 。
Linux 安装
- 打开具有 root 或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector该服务应显示为 active (running) 。
其他安装资源
如需了解其他安装选项和问题排查,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 syslog 并发送到 Google SecOps
找到配置文件
Linux:
sudo nano /etc/bindplane-agent/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/dell_cybersense: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: DELL_CYBERSENSE raw_log_field: body service: pipelines: logs/dell_cybersense_to_chronicle: receivers: - udplog exporters: - chronicle/dell_cybersense
配置参数
替换以下占位符:
接收器配置:
listen_address:要监听的 IP 地址和端口:0.0.0.0以监听所有接口(推荐)- 端口
514是标准 syslog 端口(在 Linux 上需要 root;对于非 root 用户,请使用1514)
导出器配置:
creds_file_path:注入身份验证文件的完整路径:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:从 Google SecOps 控制台复制的客户 IDendpoint:区域级端点网址:- 美国:
malachiteingestion-pa.googleapis.com - 欧洲:
europe-malachiteingestion-pa.googleapis.com - 亚洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需查看完整列表,请参阅区域级端点
- 美国:
保存配置文件
- 修改后,保存文件:
- Linux:按
Ctrl+O,然后按Enter,再按Ctrl+X - Windows:依次点击文件 > 保存
- Linux:按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务正在运行:
sudo systemctl status observiq-otel-collector检查日志中的错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:
以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector“服务”控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry Collector 。
- 右键点击并选择重启 。
验证服务正在运行:
sc query observiq-otel-collector检查日志中的错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按
为 Dell CyberSense 配置 syslog
- 使用 CLI 登录 Dell PowerProtect 。
- 修改
/etc/audisp/plugins.d/syslog.conf文件,使active = yes,然后保存并退出该文件。 使用
vi打开 rsyslog 配置文件,输入以下内容,然后保存并退出该文件 (:wq):$ModLoad imfile $InputFileName /var/log/audit/audit.log $InputFileTag tag_audit_log: $InputFileStateFile audit_log $InputFileSeverity info $InputFileFacility local6 $InputRunFileMonitor *.* @<Bindplane_IP>:514- 将
<Bindplane_IP>替换为 Bindplane 代理 IP 地址。
- 将
重启 rsyslog 服务:
service rsyslog restart
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
crjobids_label |
additional.fields |
已合并 |
crpolicy_label |
additional.fields |
已合并 |
infected_list |
additional.fields |
已合并 |
lanjobdefname_label |
additional.fields |
已合并 |
lanjobinstid_label |
additional.fields |
已合并 |
tty_label |
additional.fields |
已合并 |
msg |
metadata.description |
直接映射 |
ts |
metadata.event_timestamp |
解析为 ISO8601 |
event_type |
metadata.event_type |
直接映射 |
device_event_class_id |
metadata.product_event_type |
直接映射 |
event_name |
metadata.product_event_type |
直接映射 |
device_product |
metadata.product_name |
直接映射 |
device_version |
metadata.product_version |
直接映射 |
device_vendor |
metadata.vendor_name |
直接映射 |
session |
network.session_id |
直接映射 |
client_IP |
principal.asset.hostname |
直接映射 |
hostname |
principal.asset.hostname |
直接映射 |
%{client_IP} |
principal.asset.ip |
已合并 |
client_IP |
principal.asset.ip |
当 client_IP != `` 时映射 |
path |
principal.file.full_path |
直接映射 |
client_IP |
principal.hostname |
直接映射 |
hostname |
principal.hostname |
直接映射 |
%{client_IP} |
principal.ip |
已合并 |
client_IP |
principal.ip |
当 client_IP != `` 时映射 |
cradmin |
principal.process.command_line |
直接映射 |
URL |
principal.url |
直接映射 |
crjobids_label |
security_result.detection_fields |
已合并 |
engine_id_label |
security_result.detection_fields |
已合并 |
severity |
security_result.severity |
已映射:"EMERGENCY","ALERT","CRITICAL" → CRITICAL,WARN → HIGH,NOTICE → MEDIUM,... |
host |
target.asset.hostname |
直接映射 |
host |
target.hostname |
直接映射 |
dbname |
target.resource.name |
直接映射 |
dbuuid |
target.resource.product_object_id |
直接映射 |
| 不适用 | metadata.product_name |
常量:DELL_CYBERSENSE |
| 不适用 | metadata.vendor_name |
常量:DELL_CYBERSENSE |
| 不适用 | security_result.severity |
常量:CRITICAL |
更新日志
需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。