收集 Dell EMC Isilon NAS 日志
解析器版本: 1.0
本文档介绍了如何使用 Bindplane 代理将 Dell EMC Isilon NAS 日志注入到 Google Security Operations。
Dell EMC Isilon(现为 Dell PowerScale)是一个横向扩容 NAS 平台,可为文件访问审核、协议事件和系统操作生成 syslog 消息。解析器会提取字段并将其映射到统一数据模型 (UDM)。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 Dell EMC Isilon 系统之间的网络连接
- 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于打开状态
- 对 Dell EMC Isilon (CLI) 的特权访问权限
获取 Bindplane 代理的 Google SecOps 凭据
如需向 Google SecOps 验证 Bindplane 代理的身份,请选择以下方法之一:
- 新部署:使用 Chronicle API(方法 1)。
- 旧版部署:继续使用注入身份验证文件(方法 2),直到注入 API 于 2027 年 7 月 20 日停用为止。
方法 1:为 Chronicle API 创建服务帐号(推荐)
- 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
- 依次前往 IAM 和管理 > 服务账号。
- 点击创建服务账号 。
- 提供以下配置详细信息:
- 服务账号名称:输入账号的名称(例如
bindplane-ingest)。 - 服务账号说明:输入说明(例如
Bindplane agent log ingestion)。
- 服务账号名称:输入账号的名称(例如
- 点击创建并继续 。
- 在向此服务帐号授予对项目的访问权限 部分,点击选择角色 ,然后选择 Chronicle Editor 。
- 点击继续 ,然后点击完成 。
- 点击您创建的服务帐号,然后前往密钥 标签页。
- 依次点击添加密钥 > 创建新密钥。
- 选择 JSON ,然后点击创建 。密钥文件会下载到您的计算机上。
- 将密钥文件另存为 Bindplane 收集器目录中的
ingestion-auth.json(在 Linux 上为/opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或者更新creds_file_path在config.yaml中以与您保存该文件的路径匹配。 - 依次前往 IAM 和管理 > 设置 ,然后复制项目编号 。您需要此编号进行导出器配置。
方法 2:下载注入身份验证文件(旧版)
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
- 下载注入身份验证文件 。
- 将该文件安全地保存在将安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 个人资料。
从组织详细信息 部分复制并保存客户 ID 。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符 或 PowerShell 。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector该服务应显示为 RUNNING 。
Linux 安装
- 使用 root 或 sudo 权限打开终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector该服务应显示为 active (running) 。
其他安装资源
如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 syslog 并发送到 Google SecOps
找到配置文件
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/dell_emc_nas: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: DELL_EMC_NAS raw_log_field: body service: pipelines: logs/dell_emc_nas_to_chronicle: receivers: - udplog exporters: - chronicle/dell_emc_nas
配置参数
替换以下占位符:
接收器配置:
listen_address:要监听的 IP 地址和端口:0.0.0.0以监听所有接口(推荐)- 端口
514是标准 syslog 端口(在 Linux 上需要 root;对于非 root 用户,请使用1514)
导出器配置:
creds_file_path:服务帐号 JSON 密钥文件的完整路径(方法 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:从 Google SecOps 控制台复制的客户 IDlocation:将<LOCATION>替换为 Google SecOps 实例的区域(例如us、europe或asia-southeast1)。导出器会使用此值为chronicle.googleapis.com添加前缀。如需查看完整列表,请参阅区域级端点。project:将<PROJECT_NUMBER>替换为 IAM 和管理 > 设置 中的项目编号。endpoint:保持设置为chronicle.googleapis.com。
旧版注入 API 导出器
如果您使用方法 2 中的注入身份验证文件,请将
exporters代码块替换为以下内容。将creds_file_path设置为注入身份验证文件的路径,并且如果您的实例位于美国境外,请将malachiteingestion-pa.googleapis.com替换为您的 区域级端点(例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/dell_emc_nas: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: DELL_EMC_NAS raw_log_field: body
保存配置文件
- 修改后,保存文件:
- Linux:按
Ctrl+O,然后按Enter,再按Ctrl+X - Windows:点击File > Save
- Linux:按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志中的错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:
以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector“服务”控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry Collector 。
- 右键点击并选择重启 。
验证服务是否正在运行:
sc query observiq-otel-collector检查日志中的错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按
为 OneFS 版本 7.x 配置 syslog
- 使用 CLI 登录 Dell Isilon 。
使用以下命令启用审核(将
zone_name替换为实际区域名称):isi audit settings modify --protocol-auditing-enabled yes --audited-zones <zone_names> isi zone zones modify <zone_name> --audit-success create,delete,read,rename,set_security,write isi zone zones modify <zone_name> --audit-failure create,delete,read,rename,set_security,write isi zone zones modify <zone_name> --syslog-audit-events create,delete,read,rename,set_security,write使用以下命令启用 syslog 转发:
isi zone zones modify <zone_name> --syslog-forwarding-enabled=yes使用 SSH 客户端连接到 Isilon 节点。
使用
vi打开syslog.conf文件,该文件位于/etc/mcp/templates目录中:vi syslog.conf找到
!audit_protocol行并添加以下行(将<bindplane-ip>替换为实际 Bindplane 代理 IP 地址):*.* @<bindplane-ip>保存
syslog.conf文件::wq
为 OneFS 版本 8.0 和 8.1 配置 syslog
- 使用 CLI 登录 Dell Isilon 。
使用以下命令启用审核(将
zone_name替换为实际区域名称):isi audit settings global modify --protocol-auditing-enabled yes --audited-zones <zone_names> isi audit settings modify --zone <zone_name> --audit-success create,delete,read,rename,set_security,write isi audit settings modify --zone <zone_name> --audit-failure create,delete,read,rename,set_security,write isi audit settings modify --zone <zone_name> --syslog-audit-events create,delete,read,rename,set_security,write使用以下命令启用 syslog 转发:
isi audit settings modify --syslog-forwarding-enabled=yes --zone=<zone_name>使用 SSH 客户端连接到 Isilon 节点。
使用
vi打开syslog.conf文件,该文件位于/etc/mcp/templates目录中:vi syslog.conf找到
!audit_protocol行并添加以下行(将<bindplane-ip>替换为实际 Bindplane 代理 IP 地址):*.* @<bindplane-ip>保存
syslog.conf文件::wq
为 OneFS 版本 8.2 到 9.4 配置 syslog
使用以下命令启用审核(将
<bindplane-ip>替换为 Bindplane 代理 IP 地址,并将zone_name替换为实际区域名称):isi audit settings global modify --protocol-auditing-enabled yes --audited-zones <zone_name> --protocol-syslog-servers <bindplane-ip> isi audit settings modify --zone <zone_name> --audit-success create,delete,read,rename,set_security,write isi audit settings modify --zone <zone_name> --audit-failure create,delete,read,rename,set_security,write isi audit settings modify --zone <zone_name> --syslog-audit-events create,delete,read,rename,set_security,write使用以下命令启用 syslog 转发:
isi audit settings modify --syslog-forwarding-enabled yes --zone <zone_name>
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
| COMMAND | target.process.command_line | 原始日志字段 COMMAND 映射到此 UDM 字段。 |
| PWD | target.file.full_path | 当 message 不包含 command not allowed 时,原始日志字段 PWD 映射到此 UDM 字段。 |
| USER | principal.user.userid | 原始日志字段 USER 映射到此 UDM 字段。 |
| action_done | 用于解析逻辑的临时变量。 | |
| application | target.application | 原始日志字段 application 映射到此 UDM 字段。 |
| data | 此字段未映射到 UDM。 | |
| description | metadata.description | 原始日志字段 description 映射到此 UDM 字段。此外,当 message 包含 command not allowed 时,command not allowed 会映射到此字段。 |
| file_name | target.file.full_path | 原始日志字段 file_name 映射到此 UDM 字段,移除所有 ` |
| intermediary_ip | intermediary.ip | 原始日志字段 intermediary_ip 映射到此 UDM 字段。 |
| kv_data | 用于解析逻辑的临时变量。 | |
| method | 用于解析逻辑的临时变量。 | |
| pid | target.process.pid | 当原始日志字段 pid 不为空或 - 时,该字段会映射到此 UDM 字段。 |
| resource_type | target.resource.type | 原始日志字段 resource_type 映射到此 UDM 字段。 |
| src_host | principal.hostname | 原始日志字段 src_host 映射到此 UDM 字段。 |
| src_ip | principal.ip | 原始日志字段 src_ip 映射到此 UDM 字段。您还可以使用 Grok 模式从 description 字段中提取该字段。 |
| status | 用于解析逻辑的临时变量。 | |
| ts | metadata.event_timestamp.seconds | 原始日志字段 ts 经过解析,其秒数值会映射到此 UDM 字段。 |
| user | principal.user.userid | 如果 USER 为空,则原始日志字段 user 映射到此 UDM 字段。 |
| wsid | principal.user.windows_sid | 原始日志字段 wsid 映射到此 UDM 字段,移除 ` |
| 不适用 | metadata.event_type | 此 UDM 字段派生自解析器逻辑,具体取决于 action_done、method 和 PWD 的值。它可以是以下值之一:PROCESS_UNCATEGORIZED、PROCESS_OPEN、FILE_CREATION、FILE_OPEN、FILE_DELETION、FILE_MODIFICATION、FILE_UNCATEGORIZED 或 STATUS_SHUTDOWN(默认)。 |
| 不适用 | security_result.action | 此 UDM 字段派生自解析器逻辑,具体取决于 status 的值。它可以是 ALLOW 或 BLOCK。 |
| 不适用 | security_result.summary | 此 UDM 字段派生自解析器逻辑,并使用 action_done 的值填充。 |
| 不适用 | security_result.description | 此 UDM 字段派生自解析器逻辑,方法是将 method 和 status 的值与 - 分隔符连接起来。 |
| 不适用 | metadata.vendor_name | 此 UDM 字段硬编码为 DELL。 |
| 不适用 | metadata.product_name | 此 UDM 字段硬编码为 DELL_EMC_NAS。 |
| 不适用 | metadata.log_type | 此 UDM 字段硬编码为 DELL_EMC_NAS。 |
更新日志
需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。