收集 Dell EMC Isilon NAS 記錄
剖析器版本:1.0
本文說明如何使用 Bindplane 代理程式,將 Dell EMC Isilon NAS 記錄檔擷取至 Google Security Operations。
Dell EMC Isilon (現為 Dell PowerScale) 是可擴充的 NAS 平台,會產生用於稽核檔案存取、通訊協定事件和系統作業的系統記錄訊息。剖析器會擷取欄位,並將其對應至統一資料模型 (UDM)。
事前準備
請確認您符合下列必要條件:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 Dell EMC Isilon 系統之間的網路連線
- 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
- Dell EMC Isilon 的特殊存取權 (CLI)
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:在 2027 年 7 月 20 日停用 Ingestion API 前,請繼續使用擷取驗證檔案 (選項 2)。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 服務帳戶名稱:輸入帳戶名稱 (例如
bindplane-ingest)。 - 「服務帳戶說明」:輸入說明 (例如
Bindplane agent log ingestion)。
- 服務帳戶名稱:輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 上的/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存路徑相符。 - 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。匯出工具設定時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」 > 「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」 > 「設定檔」。
複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟命令提示字元或 PowerShell。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
安裝 Linux
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理,擷取系統記錄檔並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/dell_emc_nas: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: DELL_EMC_NAS raw_log_field: body service: pipelines: logs/dell_emc_nas_to_chronicle: receivers: - udplog exporters: - chronicle/dell_emc_nas
設定參數
替換下列預留位置:
接收器設定:
listen_address:要監聽的 IP 位址和通訊埠:0.0.0.0:在所有介面上監聽 (建議)- 通訊埠
514是標準的系統記錄通訊埠 (在 Linux 上需要根層級權限;如果沒有根層級權限,請使用1514)
Exporter 設定:
creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:從 Google SecOps 控制台複製的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會在這個值前面加上chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。project:依序前往「IAM 與管理」>「設定」,然後將<PROJECT_NUMBER>替換為專案編號。endpoint:請將此值設為chronicle.googleapis.com。
舊版 Ingestion API 匯出工具
如果您使用方式 2 的擷取驗證檔案,請將
exporters區塊替換成下列內容。將creds_file_path設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/dell_emc_nas: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: DELL_EMC_NAS raw_log_field: body
儲存設定檔
- 編輯完畢後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」>「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector查看記錄檔是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R鍵,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務是否正在執行:
sc query observiq-otel-collector檢查記錄是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
設定 OneFS 7.x 版的系統記錄
- 使用 CLI 登入 Dell Isilon。
使用下列指令啟用稽核功能 (將
zone_name替換成實際區域名稱):isi audit settings modify --protocol-auditing-enabled yes --audited-zones <zone_names> isi zone zones modify <zone_name> --audit-success create,delete,read,rename,set_security,write isi zone zones modify <zone_name> --audit-failure create,delete,read,rename,set_security,write isi zone zones modify <zone_name> --syslog-audit-events create,delete,read,rename,set_security,write使用下列指令啟用系統記錄轉送功能:
isi zone zones modify <zone_name> --syslog-forwarding-enabled=yes使用 SSH 用戶端連線至 Isilon 節點。
使用
vi開啟/etc/mcp/templates目錄中的syslog.conf檔案:vi syslog.conf找出
!audit_protocol行,並在下方加入以下指令行 (將<bindplane-ip>替換為實際的 Bindplane 代理程式 IP 位址):*.* @<bindplane-ip>儲存
syslog.conf檔案::wq
為 OneFS 8.0 和 8.1 版設定系統記錄
- 使用 CLI 登入 Dell Isilon。
使用下列指令啟用稽核功能 (將
zone_name替換成實際區域名稱):isi audit settings global modify --protocol-auditing-enabled yes --audited-zones <zone_names> isi audit settings modify --zone <zone_name> --audit-success create,delete,read,rename,set_security,write isi audit settings modify --zone <zone_name> --audit-failure create,delete,read,rename,set_security,write isi audit settings modify --zone <zone_name> --syslog-audit-events create,delete,read,rename,set_security,write使用下列指令啟用系統記錄轉送功能:
isi audit settings modify --syslog-forwarding-enabled=yes --zone=<zone_name>使用 SSH 用戶端連線至 Isilon 節點。
使用
vi開啟/etc/mcp/templates目錄中的syslog.conf檔案:vi syslog.conf找出
!audit_protocol行,並在下方加入以下指令行 (將<bindplane-ip>替換為實際的 Bindplane 代理程式 IP 位址):*.* @<bindplane-ip>儲存
syslog.conf檔案::wq
為 OneFS 8.2 至 9.4 版設定 syslog
執行下列指令啟用稽核功能 (將
<bindplane-ip>替換為 Bindplane 代理程式 IP 位址,zone_name替換為實際可用區名稱):isi audit settings global modify --protocol-auditing-enabled yes --audited-zones <zone_name> --protocol-syslog-servers <bindplane-ip> isi audit settings modify --zone <zone_name> --audit-success create,delete,read,rename,set_security,write isi audit settings modify --zone <zone_name> --audit-failure create,delete,read,rename,set_security,write isi audit settings modify --zone <zone_name> --syslog-audit-events create,delete,read,rename,set_security,write使用下列指令啟用 syslog 轉送功能:
isi audit settings modify --syslog-forwarding-enabled yes --zone <zone_name>
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
| COMMAND | target.process.command_line | 原始記錄欄位 COMMAND 會對應至這個 UDM 欄位。 |
| PWD | target.file.full_path | 如果 message 不含 command not allowed,原始記錄欄位 PWD 會對應至這個 UDM 欄位。 |
| 使用者 | principal.user.userid | 原始記錄欄位 USER 會對應至這個 UDM 欄位。 |
| action_done | 用於剖析邏輯的暫時變數。 | |
| 調度應用程式資源 | target.application | 原始記錄欄位 application 會對應至這個 UDM 欄位。 |
| 資料 | 這個欄位未對應至 UDM。 | |
| 說明 | metadata.description | 原始記錄欄位 description 會對應至這個 UDM 欄位。此外,如果 message 包含 command not allowed,command not allowed 會對應至這個欄位。 |
| file_name | target.file.full_path | 移除任何 `file_name |
| intermediary_ip | intermediary.ip | 原始記錄欄位 intermediary_ip 會對應至這個 UDM 欄位。 |
| kv_data | 用於剖析邏輯的暫時變數。 | |
| 方法 | 用於剖析邏輯的暫時變數。 | |
| pid | target.process.pid | 如果原始記錄欄位 pid 不是空白或 -,就會對應至這個 UDM 欄位。 |
| resource_type | target.resource.type | 原始記錄欄位 resource_type 會對應至這個 UDM 欄位。 |
| src_host | principal.hostname | 原始記錄欄位 src_host 會對應至這個 UDM 欄位。 |
| src_ip | principal.ip | 原始記錄欄位 src_ip 會對應至這個 UDM 欄位。您也可以使用 Grok 模式,從 description 欄位擷取這項資訊。 |
| 狀態 | 用於剖析邏輯的暫時變數。 | |
| ts | metadata.event_timestamp.seconds | 系統會剖析原始記錄欄位 ts,並將其秒數值對應至這個 UDM 欄位。 |
| 使用者 | principal.user.userid | 如果 USER 為空,原始記錄欄位 user 會對應至這個 UDM 欄位。 |
| wsid | principal.user.windows_sid | 移除 ` 之後的所有字元後,原始記錄欄位 wsid 會對應至這個 UDM 欄位 |
| 不適用 | metadata.event_type | 這個 UDM 欄位是根據 action_done、method 和 PWD 的值,從剖析器邏輯衍生而來。可以是下列其中一項:PROCESS_UNCATEGORIZED、PROCESS_OPEN、FILE_CREATION、FILE_OPEN、FILE_DELETION、FILE_MODIFICATION、FILE_UNCATEGORIZED 或 STATUS_SHUTDOWN (預設)。 |
| 不適用 | security_result.action | 這個 UDM 欄位是根據 status 的值,從剖析器邏輯衍生而來。可以是 ALLOW 或 BLOCK。 |
| 不適用 | security_result.summary | 這個 UDM 欄位衍生自剖析器邏輯,並填入 action_done 的值。 |
| 不適用 | security_result.description | 這個 UDM 欄位衍生自剖析器邏輯,方法是使用 - 分隔符串連 method 和 status 的值。 |
| 不適用 | metadata.vendor_name | 這個 UDM 欄位已硬式編碼為 DELL。 |
| 不適用 | metadata.product_name | 這個 UDM 欄位已硬式編碼為 DELL_EMC_NAS。 |
| 不適用 | metadata.log_type | 這個 UDM 欄位已硬式編碼為 DELL_EMC_NAS。 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。