收集 DigitalArts i-Filter 日志

解析器版本: 2.0

支持范围:

本文档介绍了如何使用 Bindplane 代理将 DigitalArts i-Filter 日志注入 Google Security Operations。

DigitalArts i-Filter 是一种 Web 过滤和网址分类解决方案,用于控制和监控整个组织内的 Web 访问。它会针对 Web 访问事件、被屏蔽的网址和违规行为生成日志。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 DigitalArts i-Filter 服务器之间的网络连接
  • 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于打开状态
  • 对 DigitalArts i-Filter 管理控制台的特权访问权限

获取 Bindplane 代理的 Google SecOps 凭据

如需向 Google SecOps 验证 Bindplane 代理的身份,请选择以下方法之一:

  • 新部署:使用 Chronicle API(方法 1)。
  • 旧版部署:继续使用注入身份验证文件(方法 2),直到注入 API 于 2027 年 7 月 20 日停用为止。
  1. 登录 Google Cloud Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
  2. 依次前往 IAM 和管理 > 服务账号。
  3. 点击创建服务账号 。
  4. 提供以下配置详细信息:
    • 服务账号名称:输入账号的名称(例如 bindplane-ingest)。
    • 服务账号说明:输入说明(例如 Bindplane agent log ingestion)。
  5. 点击创建并继续 。
  6. 在向此服务帐号授予对项目的访问权限 部分,点击选择角色 ,然后选择 Chronicle Editor 。
  7. 点击继续 ,然后点击完成 。
  8. 点击您创建的服务帐号,然后前往密钥 标签页。
  9. 依次点击添加密钥 > 创建新密钥。
  10. 选择 JSON ,然后点击创建 。密钥文件会下载到您的计算机上。
  11. 将密钥文件另存为 Bindplane 收集器目录中的 ingestion-auth.json(在 Linux 上为 /opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或者更新 creds_file_path 在 config.yaml 中以与您保存该文件的路径匹配。
  12. 依次前往 IAM 和管理 > 设置 ,然后复制项目编号 。您需要此编号进行导出器配置。

方法 2:下载注入身份验证文件(旧版)

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 收集代理。
  3. 下载注入身份验证文件 。
  4. 将该文件安全地保存在将安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 个人资料。
  3. 从组织详细信息 部分复制并保存客户 ID 。

安装 Bindplane 代理

按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符 或 PowerShell 。
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

    该服务应显示为正在运行 。

Linux 安装

  1. 打开具有根权限或 sudo 权限的终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

    该服务应显示为活跃 (正在运行) 。

其他安装资源

如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。

配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps

找到配置文件

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • 将 config.yaml 的全部内容替换为以下配置:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/digitalarts_ifilter:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: DIGITALARTS_IFILTER
        raw_log_field: body
        ingestion_labels:
          env: production
    
    service:
      pipelines:
        logs/ifilter_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/digitalarts_ifilter
    

配置参数

替换以下占位符:

  • 接收器配置:

    • udplog:基于协议的接收器类型:
      • UDP syslog 的 udplog
      • TCP syslog 的 tcplog
    • 0.0.0.0:要监听的 IP 地址:
      • 0.0.0.0,用于监听所有接口(推荐)
      • 用于监听一个接口的特定 IP 地址
    • 514:要监听的端口号(例如 514、1514、6514)
  • 导出器配置:

    • digitalarts_ifilter:导出器的描述性名称
    • creds_file_path:服务帐号 JSON 密钥文件的完整路径(方法 1):
      • Linux: /opt/observiq-otel-collector/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • <customer_id>:上一步中的客户 ID
    • location:将 <LOCATION> 替换为 Google SecOps 实例的区域(例如 us、europe 或 asia-southeast1)。导出器会使用此值为 chronicle.googleapis.com 添加前缀。如需查看完整列表,请参阅区域级端点。
    • project:将 <PROJECT_NUMBER> 替换为 IAM 和管理 > 设置 中的项目编号。
    • endpoint:保持设置为 chronicle.googleapis.com。
    • DIGITALARTS_IFILTER:日志类型,与 Chronicle 中显示的内容完全一致
    • ingestion_labels:YAML 格式的可选标签(例如 env: production)
  • 流水线配置:

    • ifilter_to_chronicle:流水线的描述性名称

旧版注入 API 导出器

  • 如果您使用方法 2 中的注入身份验证文件,请将 exporters 代码块替换为以下内容。将 creds_file_path 设置为注入身份验证文件的路径,并且如果您的实例位于美国境外,请将 malachiteingestion-pa.googleapis.com 替换为您的 区域级端点(例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/digitalarts_ifilter:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: DIGITALARTS_IFILTER
        raw_log_field: body
        ingestion_labels:
          env: production
    

保存配置文件

  • 修改后,请保存该文件:
    • Linux:按 Ctrl+O,然后按 Enter,再按 Ctrl+X
    • Windows:点击File > Save

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
    1. 验证服务是否正在运行:

      sudo systemctl status observiq-otel-collector
      
    2. 检查日志中是否存在错误:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:

    • 以管理员身份运行命令提示符或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • “服务”控制台:

      1. 按 Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry Collector 。
      3. 右键点击并选择重启 。
      4. 验证服务是否正在运行:

        sc query observiq-otel-collector
        
      5. 检查日志中是否存在错误:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

配置 DigitalArts i-Filter syslog 转发

  1. 使用管理员凭据登录 DigitalArts i-Filter 管理控制台。
  2. 依次前往系统设置 > 日志输出设置。
  3. 启用 Syslog 输出 。
  4. 提供以下配置详细信息:
    • Syslog 服务器地址:输入 Bindplane 代理主机(例如 192.168.1.100)的 IP 地址。
    • 端口:输入 514(必须与 Bindplane 代理接收器端口匹配)。
    • 协议:选择 UDP。
    • 格式:选择 Syslog (RFC 3164)。
  5. 选择要转发的日志类型:
    • Web 访问日志
    • 屏蔽日志(过滤后的网址请求)
    • 违规日志
  6. 点击应用 以保存配置。
  7. 通过检查 Bindplane 代理日志,验证是否收到了 syslog 消息。

UDM 映射表

日志字段 UDM 映射 逻辑
map_field additional.fields 已合并
inter_host intermediary.hostname 已直接映射
inter_host_data intermediary.ip 已合并
access_time metadata.event_timestamp 解析为 dd/MMM/yyyy:HH:mm:ss Z
request_method network.http.method 已直接映射
user_agent network.http.parsed_user_agent 已重命名/映射
referral_url network.http.referral_url 已直接映射
response_code network.http.response_code 已直接映射
user_agent network.http.user_agent 已直接映射
response_bytes network.received_bytes 已直接映射
request_bytes network.sent_bytes 已直接映射
request_version network.tls.version_protocol 已直接映射
client_name principal.hostname 已直接映射
client_ip principal.ip 已合并
src_ip principal.nat_ip 已合并
process_id principal.process.product_specific_process_id 已直接映射
group_name principal.user.group_identifiers 已合并
user_name principal.user.userid 已直接映射
sec_result security_result 已合并
target_ip target.ip 已合并
target_port target.port 已直接映射
key target.resource.attribute.labels 已映射:webservice_id → map_field
map_field target.resource.attribute.labels 已合并
request_url target.url 已直接映射
不适用 metadata.description 常量:i-FILTER proxy
不适用 metadata.event_type 常量:NETWORK_CONNECTION
不适用 metadata.product_name 常量:i-FILTER
不适用 metadata.vendor_name 常量:DigitalArts Inc.
不适用 network.ip_protocol 常量:TCP
不适用 target.hostname 常量:unspecified

更新日志

查看此解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。