收集 DigitalArts i-Filter 記錄
剖析器版本:2.0
本文說明如何使用 Bindplane 代理程式,將 DigitalArts i-Filter 記錄擷取至 Google Security Operations。
DigitalArts i-Filter 是網頁篩選和網址分類解決方案,可控管及監控整個組織的網頁存取。這項服務會產生網路存取事件、封鎖網址和違反政策的記錄。
事前準備
請確認您符合下列必要條件:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 DigitalArts i-Filter 伺服器之間的網路連線
- 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
- DigitalArts i-Filter 管理控制台的特殊權限存取權
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
bindplane-ingest)。 - 「服務帳戶說明」:輸入說明 (例如
Bindplane agent log ingestion)。
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 為/opt/observiq-otel-collector/ingestion-auth.json,Windows 為C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存檔案的路徑相符。 - 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。匯出工具設定時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」 > 「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」 > 「設定檔」。
複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有根層級或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/digitalarts_ifilter: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: DIGITALARTS_IFILTER raw_log_field: body ingestion_labels: env: production service: pipelines: logs/ifilter_to_chronicle: receivers: - udplog exporters: - chronicle/digitalarts_ifilter
設定參數
請替換下列預留位置:
接收器設定:
udplog:依通訊協定區分的接收端類型:- UDP syslog 的
udplog tcplog(適用於 TCP syslog)
- UDP syslog 的
0.0.0.0:要監聽的 IP 位址:0.0.0.0:在所有介面上監聽 (建議)- 在一個介面上接聽的特定 IP 位址
514:要監聽的通訊埠編號 (例如514、1514、6514)
匯出工具設定:
digitalarts_ifilter:匯出工具的說明名稱creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<customer_id>:上一步取得的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會在這個值前面加上chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。project:依序前往「IAM 與管理」>「設定」,然後將<PROJECT_NUMBER>替換為專案編號。endpoint:請將此值設為chronicle.googleapis.com。DIGITALARTS_IFILTER:記錄類型,與 Chronicle 中顯示的完全相同ingestion_labels:YAML 格式的選用標籤 (例如env: production)
管道設定:
ifilter_to_chronicle:管道的說明名稱
舊版 Ingestion API 匯出工具
如果您使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/digitalarts_ifilter: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: DIGITALARTS_IFILTER raw_log_field: body ingestion_labels: env: production
儲存設定檔
- 編輯完畢後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」>「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務是否正在執行:
sudo systemctl status observiq-otel-collector查看記錄檔是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R鍵,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector查看記錄檔是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
設定 DigitalArts i-Filter 系統記錄檔轉送功能
- 使用管理員憑證登入 DigitalArts i-Filter 管理控制台。
- 依序前往「System Settings」 >「Log Output Settings」。
- 啟用「Syslog Output」。
- 提供下列設定詳細資料:
- 系統記錄伺服器位址:輸入 Bindplane 代理程式主機的 IP 位址 (例如
192.168.1.100)。 - 「Port」(通訊埠):輸入
514(必須與 Bindplane 代理接收器通訊埠相符)。 - 「通訊協定」:選取「UDP」。
- 格式:選取「Syslog」 (RFC 3164)。
- 系統記錄伺服器位址:輸入 Bindplane 代理程式主機的 IP 位址 (例如
- 選取要轉送的記錄類型:
- 網路存取記錄
- 封鎖記錄 (已篩選的網址要求)
- 違反政策記錄
- 按一下「套用」,儲存設定。
檢查 Bindplane 代理程式記錄,確認系統是否收到 Syslog 訊息。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
map_field |
additional.fields |
已合併 |
inter_host |
intermediary.hostname |
直接對應 |
inter_host_data |
intermediary.ip |
已合併 |
access_time |
metadata.event_timestamp |
剖析為 dd/MMM/yyyy:HH:mm:ss Z |
request_method |
network.http.method |
直接對應 |
user_agent |
network.http.parsed_user_agent |
已重新命名/對應 |
referral_url |
network.http.referral_url |
直接對應 |
response_code |
network.http.response_code |
直接對應 |
user_agent |
network.http.user_agent |
直接對應 |
response_bytes |
network.received_bytes |
直接對應 |
request_bytes |
network.sent_bytes |
直接對應 |
request_version |
network.tls.version_protocol |
直接對應 |
client_name |
principal.hostname |
直接對應 |
client_ip |
principal.ip |
已合併 |
src_ip |
principal.nat_ip |
已合併 |
process_id |
principal.process.product_specific_process_id |
直接對應 |
group_name |
principal.user.group_identifiers |
已合併 |
user_name |
principal.user.userid |
直接對應 |
sec_result |
security_result |
已合併 |
target_ip |
target.ip |
已合併 |
target_port |
target.port |
直接對應 |
key |
target.resource.attribute.labels |
對應:webservice_id → map_field |
map_field |
target.resource.attribute.labels |
已合併 |
request_url |
target.url |
直接對應 |
| 不適用 | metadata.description |
常數:i-FILTER proxy |
| 不適用 | metadata.event_type |
常數:NETWORK_CONNECTION |
| 不適用 | metadata.product_name |
常數:i-FILTER |
| 不適用 | metadata.vendor_name |
常數:DigitalArts Inc. |
| 不適用 | network.ip_protocol |
常數:TCP |
| 不適用 | target.hostname |
常數:unspecified |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。