收集 DMP Entre 記錄

剖析器版本:1.0

支援的服務:

本文說明如何使用 Bindplane 代理程式,將 DMP Entre 記錄檔擷取至 Google Security Operations。

DMP Entre 是 Digital Monitoring Products (DMP) 的入侵警報監控和存取控管軟體。可管理出入口、訪客和實體存取事件。應用程式會將事件資料 (徽章刷卡、存取權授予/拒絕、設防狀態變更和警報事件) 儲存在 Microsoft SQL Server 資料庫中。

事前準備

請確認您符合下列必要條件:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本
  • Bindplane 代理程式與 DMP Entre 伺服器之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • DMP Entre 系統的管理員權限
  • 存取 Entre SQL Server 資料庫,或匯出活動報表

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
  1. 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 提供下列設定詳細資料:
    • 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如 bindplane-ingest)。
    • 「服務帳戶說明」:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 為 /opt/observiq-otel-collector/ingestion-auth.json,Windows 為 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存檔案的路徑相符。
  12. 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。設定匯出工具時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」 > 「設定檔」。
  3. 複製並儲存「機構詳細資料」部分的客戶 ID。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟命令提示字元或 PowerShell。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理程式,擷取記錄並傳送至 Google SecOps

找出設定檔

  • 找出設定檔,方法如下:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      filelog:
        include:
          - 'C:\DMP\Entre\Exports\*.csv'
        start_at: beginning
        poll_interval: 5s
    
    exporters:
      chronicle/dmp_entre:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: 'C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: DMP_ENTRE
        raw_log_field: body
        ingestion_labels:
          env: production
    
    service:
      pipelines:
        logs/dmp_entre_to_chronicle:
          receivers:
            - filelog
          exporters:
            - chronicle/dmp_entre
    

設定參數

替換下列預留位置:

  • 接收器設定:

    • include:DMP Entre 匯出檔案的路徑:
      • Windows:C:\DMP\Entre\Exports\*.csv
      • 根據匯出 Entre 活動報表的位置調整路徑
    • start_at:設為 beginning 可讀取現有記錄,設為 end 則只讀取新項目
    • poll_interval:檢查新記錄資料的頻率 (預設值:5s)
  • 匯出工具設定:

    • dmp_entre:匯出工具的說明名稱
    • creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • <customer_id>:上一步取得的客戶 ID
    • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會在這個值前面加上 chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。
    • project:依序前往「IAM 與管理」>「設定」,然後將 <PROJECT_NUMBER> 替換為專案編號。
    • endpoint:維持設為 chronicle.googleapis.com。
    • DMP_ENTRE:記錄類型,與 Chronicle 中顯示的完全相同
    • ingestion_labels:YAML 格式的選用標籤 (例如 env: production)
  • 管道設定:

    • dmp_entre_to_chronicle::管道的說明名稱

舊版 Ingestion API 匯出工具

  • 如果您使用選項 2 的擷取驗證檔案,請將 exporters 區塊替換為下列內容。將 creds_file_path 設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/dmp_entre:
        compression: gzip
        creds_file_path: 'C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: DMP_ENTRE
        raw_log_field: body
        ingestion_labels:
          env: production
    

儲存設定檔

  • 編輯完畢後,請儲存檔案:
    • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,套用變更

  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列任一選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
      4. 確認服務正在執行:

        sc query observiq-otel-collector
        
      5. 查看記錄檔是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

匯出 DMP Entre 事件資料

DMP Entre 會將事件資料儲存在 Microsoft SQL Server 資料庫中。您必須將事件匯出為 Bindplane 代理程式可讀取的 CSV 檔案。

從 DMP Entre GUI 匯出事件報表

  1. 登入 Entre 伺服器上的 DMP Entre 應用程式。
  2. 前往 Entre 選單列中的「報表」。
  3. 選取適當的事件報表類型:
    • 事件記錄報表:包含所有系統事件,包括門禁、警報事件和設防狀態變更。
    • 存取活動報表:包含刷卡事件,以及使用者、門和時間戳記詳細資料。
    • 警報活動報告:包含警報、故障和監控事件。
  4. 設定報表篩選條件:
    • 日期範圍:選取要匯出事件的日期範圍。
    • 面板/裝置:選取特定面板或所有面板。
    • 事件類型:選取要納入的事件類別。
  5. 按一下「產生」 (或「執行」) 即可產生報表。
  6. 將報表匯出為 CSV 檔案,並儲存至匯出目錄 (例如 `C:\DMP\Entre\Exports`)。

替代方案:自動匯出資料庫

如要自動匯出,您可以透過排定的 SQL Server Agent 工作或 Windows 工作排程器,直接查詢 Entre SQL Server 資料庫:

  1. 連線至 Entre SQL Server 資料庫。
  2. 使用 bcp 公用程式匯出事件資料:

    bcp "SELECT date, time, event_type, p_event_title, p_event_action, user_display_name, userid, device_data, principal_host, data, log_level FROM [EntreDB].[dbo].[EventHistory] WHERE date >= DATEADD(day, -1, GETDATE())" queryout "C:\DMP\Entre\Exports\entre_events.csv" -c -t"," -S localhost -T
    
  3. 使用 Windows 工作排程器,排定定期執行這項指令 (例如每小時),讓 Bindplane 代理程式持續擷取新的匯出檔案。

UDM 對應表

記錄欄位 UDM 對應 邏輯
日期、時間 metadata.event_timestamp 由日期和時間串連而成,並使用 M/d/yyyy HH:mm:ss、MM/d/yyyy HH:mm:ss 等格式剖析。
event_type metadata.event_type 直接複製值
p_event_type metadata.description 如果 event_type ==「GENERIC_EVENT」,則設為 p_event_type
metadata.product_name 設為「ENTRE」
metadata.vendor_name 設為「DMP」
p_event_title, p_event_action event_type 預設為「GENERIC_EVENT」;如果 p_event_title ==「arming status」或 p_event_action ==「set time」,則為「SETTING_MODIFICATION」;如果 p_event_action ==「automatic recall test ok」或符合門鎖定/解鎖或區域開啟/關閉/強制開啟,則為「STATUS_HEARTBEAT」;如果 p_event_title ==「door access」且 p_event_action ==「door access granted」,則為「USER_BADGE_IN」
extensions.auth.mechanism USER_BADGE_IN 事件設為「BADGE_READER」
extensions.auth.type USER_BADGE_IN 事件設為「PHYSICAL」
inter_host intermediary.hostname 如果 inter_host 無法轉換為 IP,請設定
inter_host intermediary.ip 設定 inter_host 是否可轉換為 IP
principal_host、inter_host principal.hostname 如果存在 device_data 且 principal_host 無法轉換為 IP,則取自 principal_host;否則如果 principal 為空且 inter_host 無法轉換為 IP,則取自 inter_host
principal_host、inter_host principal.ip 如果 principal_host 可轉換為 IP,則為該欄位的值;如果 principal 為空白,則為 inter_ip 的值
device_data principal.location.name 直接複製值
user_display_name principal.user.user_display_name 直接複製值
userid principal.user.userid 直接複製值
資料 security_result.description 直接複製值
log_level security_result.severity 如果為「INFO」,請設為「LOW」;如果為「WARNING」,請設為「MEDIUM」;如果為「ERROR」,請設為「HIGH」
log_level security_result.severity_details 直接複製值
p_event_type security_result.summary 直接複製值
device_data target.location.name 為 USER_BADGE_IN 事件設定
target.resource.name 如果 p_event_title == "arming status",則設為「Arming status」;如果 p_event_action == "set time",則設為「Panel command」
target.resource.type 如果是 SETTING_MODIFICATION 事件,請設為「SETTING」

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。