收集 Elastic Windows 事件記錄 Beats 記錄
剖析器版本:19.0
本文說明如何使用 Bindplane 代理,將 Elastic Windows 事件記錄 Beats 記錄擷取至 Google Security Operations。
Winlogbeat 是 Elastic 的 Windows 專用事件記錄傳送代理程式,可收集 Windows 事件記錄並轉送至各種目的地。在 Windows 系統上,它會以 Windows 服務的形式執行,並可從應用程式、安全性、系統和其他 Windows 事件記錄管道收集事件。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機,用於執行 Bindplane 代理程式 - Bindplane 代理程式與 Logstash 伺服器之間的網路連線
- Logstash 與 Bindplane 代理程式之間的網路連線
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- 要安裝 Winlogbeat 以收集事件記錄的 Windows 系統
- 具備 Windows 系統的管理員存取權,可安裝 Winlogbeat
- Logstash 伺服器 (7.x 或 8.x 版),用於中介處理
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:在 2027 年 7 月 20 日停用 Ingestion API 前,請繼續使用擷取驗證檔案 (選項 2)。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
bindplane-ingest)。 - 「服務帳戶說明」:輸入說明 (例如
Bindplane agent log ingestion)。
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 上的/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存路徑相符。 - 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。設定匯出工具時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM Settings」 > 「Collection Agents」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」 > 「設定檔」。
複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟命令提示字元或 PowerShell。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務狀態應為「RUNNING」。
安裝 Linux
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務狀態應為「有效 (執行中)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: tcplog: listen_address: "0.0.0.0:1514" exporters: chronicle/winlogbeat: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '<CREDS_FILE_PATH>' customer_id: '<CUSTOMER_ID>' endpoint: chronicle.googleapis.com log_type: ELASTIC_WINLOGBEAT raw_log_field: body ingestion_labels: env: production source: winlogbeat service: pipelines: logs/winlogbeat_to_chronicle: receivers: - tcplog exporters: - chronicle/winlogbeat替換下列預留位置:
接收器設定:
listen_address:設為0.0.0.0:1514,即可監聽通訊埠 1514 (TCP) 上的所有介面。您可以視需要變更通訊埠編號,但請務必與 Logstash syslog 輸出設定相符。
匯出工具設定:
<CREDS_FILE_PATH>:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<CUSTOMER_ID>:上一步中的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會在這個值前面加上chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。project:將<PROJECT_NUMBER>替換為「IAM 與管理」>「設定」中的專案編號。endpoint:請將此值設為chronicle.googleapis.com。
設定範例:
receivers:
tcplog:
listen_address: "0.0.0.0:1514"
exporters:
chronicle/winlogbeat:
protocol: https
# Region of your instance, for example us, europe, asia-southeast1
location: <LOCATION>
# Project number of the Google Cloud project linked to the instance
project: '<PROJECT_NUMBER>'
compression: gzip
creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
customer_id: 'a1b2c3d4-e5f6-g7h8-i9j0-k1l2m3n4o5p6'
endpoint: chronicle.googleapis.com
log_type: ELASTIC_WINLOGBEAT
raw_log_field: body
ingestion_labels:
env: production
source: winlogbeat
service:
pipelines:
logs/winlogbeat_to_chronicle:
receivers:
- tcplog
exporters:
- chronicle/winlogbeat
舊版 Ingestion API 匯出工具
如果您使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/winlogbeat: compression: gzip creds_file_path: '<CREDS_FILE_PATH>' customer_id: '<CUSTOMER_ID>' endpoint: malachiteingestion-pa.googleapis.com log_type: ELASTIC_WINLOGBEAT raw_log_field: body ingestion_labels: env: production source: winlogbeat
儲存設定檔
編輯完畢後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」 > 「儲存」
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 重新啟動 Bindplane 代理程式,請按照下列步驟操作:
執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務是否正在執行:
sudo systemctl status observiq-otel-collector檢查記錄是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 重新啟動 Bindplane 代理程式,請按照下列步驟操作:
您可以選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
- 按下
確認服務是否正在執行:
sc query observiq-otel-collector查看記錄檔是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
安裝及設定 Logstash
您必須使用 Logstash 做為中介,才能接收 Winlogbeat 的事件,並透過 syslog 將事件轉送至 Bindplane 代理程式。Winlogbeat 沒有原生 syslog 輸出功能。
安裝 Logstash
- 從 Elastic 下載頁面下載 Logstash。
- 在 Windows 或 Linux 伺服器上安裝 Logstash:
Linux (Debian/Ubuntu):
wget -qO - https://artifacts.elastic.co/GPG-KEY-elasticsearch | sudo apt-key add - sudo apt-get install apt-transport-https echo "deb https://artifacts.elastic.co/packages/8.x/apt stable main" | sudo tee -a /etc/apt/sources.list.d/elastic-8.x.list sudo apt-get update && sudo apt-get install logstashLinux (RHEL/CentOS):
sudo rpm --import https://artifacts.elastic.co/GPG-KEY-elasticsearch sudo tee /etc/yum.repos.d/logstash.repo <<EOF [logstash-8.x] name=Elastic repository for 8.x packages baseurl=https://artifacts.elastic.co/packages/8.x/yum gpgcheck=1 gpgkey=https://artifacts.elastic.co/GPG-KEY-elasticsearch enabled=1 autorefresh=1 type=rpm-md EOF sudo yum install logstashWindows:
- 從 Elastic 下載頁面下載 ZIP 檔案。
- 解壓縮至
C:\logstash。
設定 Logstash 管道
建立新的管道設定檔:
Linux:
sudo nano /etc/logstash/conf.d/winlogbeat-to-syslog.confWindows:
notepad "C:\logstash\config\winlogbeat-to-syslog.conf"
新增下列設定:
input { beats { port => 5044 } } output { syslog { host => "<BINDPLANE_AGENT_IP>" port => 1514 protocol => "tcp" rfc => "rfc5424" appname => "winlogbeat" facility => "user-level" severity => "informational" } }將
<BINDPLANE_AGENT_IP>替換為執行 Bindplane 代理程式的伺服器 IP 位址。
Logstash 設定範例
input {
beats {
port => 5044
}
}
output {
syslog {
host => "192.168.1.100"
port => 1514
protocol => "tcp"
rfc => "rfc5424"
appname => "winlogbeat"
facility => "user-level"
severity => "informational"
}
}
啟動 Logstash
Linux:
啟動 Logstash:
sudo systemctl start logstash sudo systemctl enable logstash確認 Logstash 正在執行:
sudo systemctl status logstash查看 Logstash 記錄:
sudo tail -f /var/log/logstash/logstash-plain.log
Windows:
cd C:\logstash\bin logstash.bat -f C:\logstash\config\winlogbeat-to-syslog.conf如要在正式環境中使用,請使用 NSSM 或類似工具,將 Logstash 安裝為 Windows 服務。
在 Windows 系統上安裝 Winlogbeat
下載 Winlogbeat
- 從 Elastic 下載頁面下載 Winlogbeat。
- 選擇 Windows 適用的 ZIP 或 MSI 安裝程式。
安裝 Winlogbeat
使用 MSI 安裝程式:
- 執行 MSI 安裝程式。
- 按照安裝精靈的指示操作。
- 安裝至預設位置:
C:\Program Files\Winlogbeat。
使用 ZIP 檔案:
- 將 ZIP 檔案解壓縮至
C:\Program Files\Winlogbeat。 - 以管理員身分開啟 PowerShell。
前往 Winlogbeat 目錄:
cd 'C:\Program Files\Winlogbeat'執行安裝指令碼:
.\install-service-winlogbeat.ps1
- 將 ZIP 檔案解壓縮至
設定 Winlogbeat,將記錄傳送至 Logstash
開啟 Winlogbeat 設定檔:
notepad "C:\Program Files\Winlogbeat\winlogbeat.yml"設定要收集的事件記錄。找出
winlogbeat.event_logs區段,並按照下列方式設定:winlogbeat.event_logs: - name: Application ignore_older: 72h - name: System - name: Security - name: Microsoft-Windows-Sysmon/Operational ignore_older: 72h - name: Windows PowerShell event_id: 400, 403, 600, 800 - name: Microsoft-Windows-PowerShell/Operational event_id: 4103, 4104, 4105, 4106 - name: ForwardedEvents tags: [forwarded]在每行開頭加上
#,將 Elasticsearch 輸出區段設為註解,加以排除:#output.elasticsearch: # hosts: ["localhost:9200"]取消註解並設定 Logstash 輸出區段:
output.logstash: hosts: ["<LOGSTASH_SERVER_IP>:5044"]將
<LOGSTASH_SERVER_IP>替換為 Logstash 伺服器的 IP 位址。
Winlogbeat 設定範例
winlogbeat.event_logs:
- name: Application
ignore_older: 72h
- name: System
- name: Security
- name: Microsoft-Windows-Sysmon/Operational
ignore_older: 72h
output.logstash:
hosts: ["192.168.1.50:5044"]
儲存設定檔
儲存並關閉檔案。
啟動 Winlogbeat 服務
- 以管理員身分開啟 PowerShell。
啟動 Winlogbeat 服務:
Start-Service winlogbeat確認服務正在執行:
Get-Service winlogbeat狀態應顯示為「執行中」。
檢查 Winlogbeat 記錄檔是否有錯誤:
Get-Content "C:\ProgramData\winlogbeat\Logs\winlogbeat" -Tail 50
驗證記錄流程
驗證 Winlogbeat 與 Logstash 的連線
在 Logstash 伺服器上,檢查 Logstash 記錄:
Linux:
sudo tail -f /var/log/logstash/logstash-plain.logWindows:
type C:\logstash\logs\logstash-plain.log
尋找顯示 Beats 連線的訊息:
[INFO ][logstash.inputs.beats] Beats inputs: Starting input listener {:address=>"0.0.0.0:5044"}
驗證 Logstash 到 Bindplane 代理程式的連線
在 Bindplane 代理程式伺服器上,檢查代理程式記錄:
Linux:
sudo journalctl -u observiq-otel-collector -fWindows:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
尋找表示記錄檔擷取成功的訊息。
在 Google SecOps 中驗證記錄
- 登入 Google SecOps 控制台。
- 前往「搜尋」。
執行搜尋查詢,確認 Winlogbeat 記錄檔是否已擷取:
metadata.log_type = "ELASTIC_WINLOGBEAT"確認搜尋結果中顯示 Windows 事件記錄。
疑難排解
Winlogbeat 無法連線至 Logstash
驗證 Winlogbeat 和 Logstash 之間的網路連線:
Test-NetConnection -ComputerName <LOGSTASH_IP> -Port 5044確認 Windows 防火牆規則允許通訊埠 5044 的傳出連線。
確認 Logstash 正在監聽通訊埠 5044:
Linux:
sudo netstat -tulpn | grep 5044Windows:
netstat -an | findstr 5044
Logstash 未轉送至 Bindplane 代理
驗證 Logstash 和 Bindplane 代理程式之間的網路連線:
Linux:
telnet <BINDPLANE_IP> 1514Windows:
Test-NetConnection -ComputerName <BINDPLANE_IP> -Port 1514
確認防火牆規則允許通訊埠 1514 上的 TCP 連線。
確認 Bindplane 代理程式正在監聽通訊埠 1514:
Linux:
sudo netstat -tulpn | grep 1514Windows:
netstat -an | findstr 1514
Google SecOps 未顯示記錄
- 確認客戶 ID 和擷取驗證檔案正確無誤。
- 查看 Bindplane 代理記錄,瞭解是否有驗證錯誤。
- 確認區域端點與 Google SecOps 執行個體區域相符。
- 確認
log_type已設為ELASTIC_WINLOGBEAT,如圖所示。
UDM 對應表
| winlog.event_data.powershell.HostApplication | event.idm.read_only_udm.target.process.command_line | Mapped from changelog |
| winlog.event_data.powershell.ScriptName | event.idm.read_only_udm.target.process.file.full_path | Mapped from changelog |
| winlog.event_data.powershell.UserId | event.idm.read_only_udm.principal.user.userid | Mapped from changelog |
| host.mac | event.idm.read_only_udm.principal.mac and event.idm.read_only_udm.principal.asset.mac | Mapped from changelog |
| _event.created | event.idm.read_only_udm.metadata.collected_timestamp | Mapped from changelog |
| agent.name | event.idm.read_only_udm.principal.hostname and event.idm.read_only_udm.principal.asset.hostname | Mapped from changelog |
| host.domain | event.idm.read_only_udm.principal.administrative_domain | Mapped from changelog |
| winlog.event_data.powershell.CommandName | event.idm.read_only_udm.security_result.detection_fields | Mapped from changelog |
| winlog.event_data.powershell.CommandLine | event.idm.read_only_udm.security_result.detection_fields | Mapped from changelog |
| winlog.event_data.powershell.HostVersion | event.idm.read_only_udm.security_result.detection_fields | Mapped from changelog |
| winlog.event_data.powershell.DetailSequence | event.idm.read_only_udm.security_result.detection_fields | Mapped from changelog |
| winlog.event_data.powershell.DetailTotal | event.idm.read_only_udm.security_result.detection_fields | Mapped from changelog |
| winlog.event_data.powershell.HostId | event.idm.read_only_udm.security_result.detection_fields | Mapped from changelog |
| winlog.event_data.powershell.HostName | event.idm.read_only_udm.security_result.detection_fields | Mapped from changelog |
| winlog.event_data.powershell.PipelineId | event.idm.read_only_udm.security_result.detection_fields | Mapped from changelog |
| winlog.event_data.powershell.RunspaceId | event.idm.read_only_udm.security_result.detection_fields | Mapped from changelog |
| winlog.event_data.powershell.SequenceNumber | event.idm.read_only_udm.security_result.detection_fields | Mapped from changelog |
| winlog.keywords | event.idm.read_only_udm.security_result.detection_fields | Mapped from changelog |
| winlog.event_data.powershell.EngineVersion | event.idm.read_only_udm.security_result.detection_fields | Mapped from changelog |
| winlog.event_data.TaskName | event.idm.read_only_udm.target.resource.name | Mapped from changelog |
| winlog.event_data.ClientProcessId | event.idm.read_only_udm.target.process.pid | Mapped from changelog |
| winlog.event_data.ParentProcessId | event.idm.read_only_udm.target.process.parent_process.pid | Mapped from changelog |
| winlog.event_data.ClientProcessStartKey | event.idm.read_only_udm.target.process.product_specific_process_id | Mapped from changelog |
| TimeTriggerStartBoundary | event.idm.read_only_udm.additional.fields | Mapped from changelog |
| EventVersion | event.idm.read_only_udm.additional.fields | Mapped from changelog |
| winlog.version | event.idm.read_only_udm.additional.fields | Mapped from changelog |
| RegistrationInfoSecurityDescriptor | event.idm.read_only_udm.additional.fields | Mapped from changelog |
| winlog.event_data.RpcCallClientLocality | event.idm.read_only_udm.additional.fields | Mapped from changelog |
| winlog.provider_guid | event.idm.read_only_udm.additional.fields | Mapped from changelog |
| winlog.event_data.param1 | event.idm.read_only_udm.target.application | Mapped from changelog |
| DestinationIp | target.ip | Mapped from changelog |
| source_network_address | src.ip | Mapped from changelog |
| source_port | src.port | Mapped from changelog |
| winlog.event_data.TaskContent | additional.fields | Mapped from changelog |
| principal_user_id | principal.user.userid | Mapped from changelog |
| principal_command_line | principal.process.command_line | Mapped from changelog |
| run_level", "arguments", "RegistrationInfoURI", "WnfStateChangeTriggerEnabled", "WnfStateChangeTriggerStateName", "WnfStateChangeTriggerData", "WnfStateChangeTriggerDataOffset", "IdleSettingsRestartOnIdle", "IdleSettingsStopOnIdleEnd", "IdleSettingsWaitTimeout", "IdleSettingsDuration", "Priority", "ExecutionTimeLimit", "RunOnlyIfIdle", "DisallowStartOnRemoteAppSession", "UseUnifiedSchedulingEngine", "DisallowStartIfOnBatteries", "MultipleInstancesPolicy", "StopIfGoingOnBatteries", "AllowHardTerminate", "StartWhenAvailable", "RunOnlyIfNetworkAvailable", "AllowStartOnDemand", "Enabled", "Hidden", and "WakeToRun | additional.fields | Mapped from changelog |
| winlog.event_data.ObjectServer | target.resource.attribute.labels | Mapped from changelog |
| process.executable | principal.process.file.full_path | Mapped from changelog |
| process.parent.executable | principal.process.parent_process.file.full_path | Mapped from changelog |
| process.name | principal.process.file.names | Mapped from changelog |
| process.parent.name | principal.process.parent_process.file.names | Mapped from changelog |
| process.entity_id | target.process.product_specific_process_id | Mapped from changelog |
| process.pid | principal.resource.attribute.labels | Mapped from changelog |
| winlog.logon.failure.sub_status", "winlog.logon.failure.reason" and "winlog.logon.failure.status | security_result.detection_fields | Mapped from changelog |
| winlog.event_data.GroupMembership | principal.user.group_identifiers | Mapped from changelog |
| client_ip | principal.asset.ip | Mapped from changelog |
| ip | principal.asset.ip | Mapped from changelog |
| winlog.event_data.SourceIp | principal.asset.ip | Mapped from changelog |
| destination.ip | target.asset.ip | Mapped from changelog |
| winlog.event_data.DestinationIp | target.asset.ip | Mapped from changelog |
| agent.hostname | target.asset.hostname | Mapped from changelog |
| winlog.event_data.IpAddress | principal.asset.ip | Mapped from changelog |
| source.ip | principal.asset.ip | Mapped from changelog |
| winlog.event_data.Binary", "winlog.event_data.process.thread.id", "winlog.event_data.param1", "winlog.event_data.param2", "winlog.event_data.param3", "winlog.event_data.param4", "winlog.event_data.param5", "winlog.event_data.param6", "winlog.event_data.param7", "winlog.event_data.param8", "winlog.event_data.param9", "winlog.event_data.param10", "winlog.event_data.param11", "winlog.event_data.param12", "winlog.event_data.param13", "winlog.channel", "winlog.opcode | security_result.detection_fields | Mapped from changelog |
| host.ip | principal.ip | Mapped from changelog |
| winlog.process.pid | principal.process.pid | Mapped from changelog |
| message | metadata.description | Mapped from changelog |
| message | security_result.detection_fields | Mapped from changelog |
| metadata.event_type | SERVICE_STOP | Mapped from changelog |
| metadata.event_type | SERVICE_START | Mapped from changelog |
| winlog.event_data.HandleId | resource_ancestors.product_object_id | Mapped from changelog |
| winlog.event_data.ObjectType | target.resource.resource_subtype | Mapped from changelog |
| winlog.event_data.OperationType | security_result.summary | Mapped from changelog |
| object_server | resource_ancestors.name | Mapped from changelog |
| Accesses | target.resource.attribute.labels | Mapped from changelog |
| Properties | security_result.detection_fields | Mapped from changelog |
| event_data.param1 | target.application | Mapped from changelog |
| event_data.param2 | security_result.action | Mapped from changelog |
| event_data.param1 | target.resource.attribute.permissions | Mapped from changelog |
| event_data.param5 | target.resource.product_object_id | Mapped from changelog |
| event_data.param6 | target.user.userid | Mapped from changelog |
| event_data.param7 | target.administrative_domain | Mapped from changelog |
| event_data.param8 | target.user.windows_sid | Mapped from changelog |
| event_data.param10 | target.application | Mapped from changelog |
| event_data.param1 | target.user.userid | Mapped from changelog |
| client_ip | principal.ip | Mapped from changelog |
| database_name | target.hostname | Mapped from changelog |
| summary | security_result.summary | Mapped from changelog |
| event_id | metadata.product_event_type | Mapped from changelog |
| computer_name | principal.hostname | Mapped from changelog |
| type | observer.application | Mapped from changelog |
| task | target.resource.attribute.labels | Mapped from changelog |
| source_name | security_result.about.labels | Mapped from changelog |
| process_id | principal.process.pid | Mapped from changelog |
| provider_guid | additional.fields | Mapped from changelog |
| level | security_result.severity | Mapped from changelog |
| thread_id | security_result.about.resource.attribute.labels | Mapped from changelog |
| beat.version | principal.platform_version | Mapped from changelog |
| message | security_result.description | Mapped from changelog |
| winlog.event_data.LmPackageName | target.resource.attribute.labels | Mapped from changelog |
| winlog.event_data.AuthenticationPackageName | target.resource.attribute.labels | Mapped from changelog |
| winlog.event_data.LogonProcessName | target.resource.attribute.labels | Mapped from changelog |
| winlog.event_data.WorkstationName | target.resource.attribute.labels | Mapped from changelog |
| winlog.event_data.TargetOutboundUserName | target.resource.attribute.labels | Mapped from changelog |
| CN" from "winlog.event_data.MemberName | target.user.userid | Mapped from changelog |
| metadata.event_type | GROUP_MODIFICATION | Mapped from changelog |
| winlog.event_data.Image | target.process.file.full_path | Mapped from changelog |
| winlog.event_data.ProcessGuid | target.process.product_specific_process_id | Mapped from changelog |
| winlog.event_data.ProcessId | target.process.pid | Mapped from changelog |
| winlog.event_data.TargetObject | target.registry.registry_value_name | Mapped from changelog |
| winlog.event_data.EventType | metadata.product_event_type | Mapped from changelog |
| winlog.event_data.Subject | security_result.detection_fields | Mapped from changelog |
| winlog.event_data.Requester | principal.user.userid | Mapped from changelog |
| winlog.event_data.LogonType | extensions.auth.auth_details | Mapped from changelog |
| winlog.event_data.ParentProcessId | principal.process.pid | Mapped from changelog |
| winlog.event_data.ParentProcessGuid | principal.process.product_specific_process_id | Mapped from changelog |
| winlog.event_data.ParentCommandLine | principal.process.command_line | Mapped from changelog |
| winlog.event_data.ParentUser | principal.user.userid | Mapped from changelog |
| winlog.event_data.CommandLine | target.process.command_line | Mapped from changelog |
| winlog.event_data.User | target.user.userid | Mapped from changelog |
| winlog.event_data.LogonGuid | target.resource.product_object_id | Mapped from changelog |
| winlog.event_data.Hashes.SHA1 | target.process.file.sha1 | Mapped from changelog |
| winlog.event_data.Hashes.SHA256 | target.process.file.sha256 | Mapped from changelog |
| winlog.event_data.Hashes.MD5 | target.process.file.md5 | Mapped from changelog |
| host.mac | principal.mac | Mapped from changelog |
| winlog.event_data.ImageLoaded | target.process.file.full_path | Mapped from changelog |
| winlog.opcode | security_result.description | Mapped from changelog |
| winlog.event_data.MemberName | target.user.userid | Mapped from changelog |
| winlog.event_data.MemberSid | target.user.windows_sid | Mapped from changelog |
| winlog.event_data.TargetUserName | target.user.userid | Mapped from changelog |
| winlog.event_data.TicketOptions", "winlog.event_data.TicketEncryptionType", "winlog.event_data.TicketEncryptionTypeDescription", "winlog.event_data.TransmittedServices", "winlog.event_data.TicketOptionsDescription | security_result.about.resource.attribute.labels | Mapped from changelog |
| winlog.event_data.ServiceSid | target.user.windows_sid | Mapped from changelog |
| winlog.event_data.TargetDomainName | target.administrative_domain | Mapped from changelog |
| winlog.event_data.ServiceName | target.application | Mapped from changelog |
| Failure Code" and "TicketOptions | security_result.about.labels | Mapped from changelog |
| winlog.event_data.Status | security_result.action_details | Mapped from changelog |
| winlog.event_data.Status" and "winlog.event_data.StatusDescription | metadata.description | Mapped from changelog |
| winlog.event_data.RelativeTargetName | target.process.file.full_path | Mapped from changelog |
| event.original | security_result.detection_fields | Mapped from changelog |
| ip | principal.ip | Mapped from changelog |
| mac | principal.mac | Mapped from changelog |
| Account Domain | principal.administrative-domain | Mapped from changelog |
| metadata.event_type | USER_CHANGE_PASSWORD | Mapped from changelog |
| event.outcome | security_result.outcomes | Mapped from changelog |
| event.action and event.outcome | security_result.summary | Mapped from changelog |
| log.level | security_result.severity_details | Mapped from changelog |
| User Account control | security_result.description | Mapped from changelog |
| winlog.event_data.ObjectValueName | target.registry.registry_value_name | Mapped from changelog |
| Operation Type | security_result.summary | Mapped from changelog |
| metadata.event_type | REGISTRY_MODIFICATION | Mapped from changelog |
| winlog.event_data.ProcessName | target.process.file.full_path | Mapped from changelog |
| winlog.event_data.ObjectName | target.resource.name | Mapped from changelog |
| winlog.event_data.OldValue | target.resource.attribute.labels | Mapped from changelog |
| winlog.event_data.NewValue | target.resource.attribute.labels | Mapped from changelog |
| winlog.computer_name | target.hostname | Mapped from changelog |
| winlog.provider_name | metadata.product_name | Mapped from changelog |
| winlog.event_data.OpCorrelationID | network.session_id | Mapped from changelog |
| winlog.api","winlog.event_data.AttributeValue","winlog.provider_guid","winlog.event_data.ObjectDN","winlog.event_data.SubjectLogonId","event_data.AttributeSyntaxOID | additional.fields | Mapped from changelog |
| winlog.record_id | metadata.product_log_id | Mapped from changelog |
| winlog.event_data.AttributeLDAPDisplayName | target.resource.type | Mapped from changelog |
| winlog.event_data.ObjectGUID | target.group.product_object_id | Mapped from changelog |
| winlog.channel","winlog.process.thread.id","winlog.event_data.DSType","winlog.event_data.ObjectClass | security_result.about.resource.attribute.labels | Mapped from changelog |
| winlog.event_data.DSName | target.hostname | Mapped from changelog |
| winlog.event_id | metadata.product_event_type | Mapped from changelog |
| source.ip | principal.ip | Mapped from changelog |
| source.port | principal.port | Mapped from changelog |
| user.name | principal.user.user_display_name | Mapped from changelog |
| related.user | principal.user.group_identifiers | Mapped from changelog |
這個剖析器沒有欄位對應資訊。
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。