收集 Endpoint Protector DLP 日志

解析器版本: 2.0

支持范围:

本文档介绍了如何使用 Bindplane 代理将 Netwrix Endpoint Protector DLP 日志注入 Google Security Operations。

Netwrix Endpoint Protector 是一种数据泄露防护 (DLP) 解决方案,可针对设备控制、内容感知保护和文件传输事件生成 syslog 消息。解析器使用 grok 模式提取字段,并将这些字段映射到统一数据模型 (UDM)。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 Endpoint Protector 服务器之间的网络连接
  • 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于打开状态
  • 对 Netwrix Endpoint Protector 的特权访问权限

获取 Bindplane 代理的 Google SecOps 凭据

如需向 Google SecOps 验证 Bindplane 代理的身份,请选择以下方法之一:

  • 新部署:使用 Chronicle API(方法 1)。
  • 旧版部署:继续使用注入身份验证文件(方法 2),直到注入 API 于 2027 年 7 月 20 日停用为止。
  1. 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
  2. 依次前往 IAM 和管理 > 服务账号。
  3. 点击创建服务账号 。
  4. 提供以下配置详细信息:
    • 服务账号名称:输入账号的名称(例如 bindplane-ingest)。
    • 服务账号说明:输入说明(例如 Bindplane agent log ingestion)。
  5. 点击创建并继续 。
  6. 在向此服务帐号授予对项目的访问权限 部分,点击选择角色 ,然后选择 Chronicle Editor 。
  7. 点击继续 ,然后点击完成 。
  8. 点击您创建的服务帐号,然后前往密钥 标签页。
  9. 依次点击添加密钥 > 创建新密钥。
  10. 选择 JSON ,然后点击创建 。密钥文件会下载到您的计算机上。
  11. 将密钥文件另存为 Bindplane 收集器目录中的 ingestion-auth.json(在 Linux 上为 /opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或者更新 creds_file_path 在 config.yaml 中以与您保存该文件的路径匹配。
  12. 依次前往 IAM 和管理 > 设置 ,然后复制项目编号 。您需要此编号进行导出器配置。

方法 2:下载注入身份验证文件(旧版)

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 收集代理。
  3. 下载注入身份验证文件 。
  4. 将该文件安全地保存在将安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 个人资料。
  3. 从组织详细信息 部分复制并保存客户 ID 。

安装 Bindplane 代理

按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符 或 PowerShell 。
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

    该服务应显示为 RUNNING 。

Linux 安装

  1. 使用 root 或 sudo 权限打开终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

    该服务应显示为 active (running) 。

其他安装资源

如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。

配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps

找到配置文件

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • 将 config.yaml 的全部内容替换为以下配置:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/endpoint_protector_dlp:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: ENDPOINT_PROTECTOR_DLP
        raw_log_field: body
    
    service:
      pipelines:
        logs/endpoint_protector_dlp_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/endpoint_protector_dlp
    

配置参数

替换以下占位符:

  • 接收器配置:

    • listen_address:要监听的 IP 地址和端口:
      • 0.0.0.0,用于监听所有接口(推荐)
      • 端口 514 是标准 syslog 端口(在 Linux 上需要 root 权限;对于非 root 用户,请使用 1514)
  • 导出器配置:

    • creds_file_path:服务帐号 JSON 密钥文件的完整路径(方法 1):
      • Linux: /opt/observiq-otel-collector/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:从 Google SecOps 控制台复制的客户 ID
    • location:将 <LOCATION> 替换为 Google SecOps 实例的区域(例如 us、europe 或 asia-southeast1)。导出器会使用此值为 chronicle.googleapis.com 添加前缀。如需查看完整列表,请参阅区域级端点。
    • project:将 <PROJECT_NUMBER> 替换为 IAM 和管理 > 设置 中的项目编号。
    • endpoint:保持设置为 chronicle.googleapis.com。

旧版注入 API 导出器

  • 如果您使用方法 2 中的注入身份验证文件,请将 exporters 代码块替换为以下内容。将 creds_file_path 设置为注入身份验证文件的路径,并且如果您的实例位于美国境外,请将 malachiteingestion-pa.googleapis.com 替换为您的 区域级端点(例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/endpoint_protector_dlp:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: ENDPOINT_PROTECTOR_DLP
        raw_log_field: body
    

保存配置文件

  • 修改后,保存文件:
    • Linux:按 Ctrl+O,然后按 Enter,再按 Ctrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
    1. 验证服务是否正在运行:

      sudo systemctl status observiq-otel-collector
      
    2. 检查日志中的错误:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:

    • 以管理员身份运行命令提示符或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服务控制台:

      1. 按 Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry Collector 。
      3. 右键点击并选择重启 。
      4. 验证服务是否正在运行:

        sc query observiq-otel-collector
        
      5. 检查日志中的错误:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

在 Netwrix Endpoint Protector 上配置 syslog

  1. 登录 Endpoint Protector Web 界面。
  2. 依次前往 Appliance > SIEM Integration。
  3. 点击 Add New 。
  4. 提供以下配置详细信息:
    • SIEM Status:切换开关以启用 SIEM 服务器。
    • Disable Logging:切换开关以启用 日志记录。
    • 服务器名称:输入一个唯一且有意义的服务器名称。
    • 服务器描述:为此集成添加说明。
    • 服务器 IP 或 DNS:输入 Bindplane 代理 IP 地址。
    • 服务器协议:选择 UDP。
    • Server Port:输入 Bindplane 代理端口号(例如,对于 UDP,为 514)。
    • Exclude Headers:切换开关以启用 日志标头。
    • 日志类型:选择要发送到 SIEM 的可用日志。
  5. 点击保存 。

UDM 映射表

日志字段 UDM 映射 逻辑
Client Computer principal.asset.asset_id 在添加“Client Computer: ”前缀后,Client Computer 的值会分配给 principal.asset.asset_id。
Client User principal.user.userid Client User 的值会分配给 principal.user.userid。
Content Policy security_result.rule_name Content Policy 的值会分配给 security_result.rule_name。
Content Policy Type security_result.rule_id Content Policy Type 的值会分配给 security_result.rule_id。
Destination metadata.ingestion_labels.value Destination 的值会分配给 ingestion_labels 对象的 value 字段,其中 key 为“Destination”。
Destination Type metadata.ingestion_labels.value Destination Type 的值会分配给 ingestion_labels 对象的 value 字段,其中 key 为“Destination Type”。
Device PID metadata.ingestion_labels.value Device PID 的值会分配给 ingestion_labels 对象的 value 字段,其中 key 为“Device PID”。
Device Serial metadata.ingestion_labels.value Device Serial 的值会分配给 ingestion_labels 对象的 value 字段,其中 key 为“Device Serial”。只有当 Device Serial 不为空时,才会执行此操作。
Device VID metadata.ingestion_labels.value Device VID 的值会分配给 ingestion_labels 对象的 value 字段,其中 key 为“Device VID”。
File Name target.file.full_path File Name 的值会分配给 target.file.full_path。
File Size target.file.size File Size 的值会分配给 target.file.size 并转换为无符号整数。
IP Address principal.ip IP Address 的值会分配给 principal.ip。
Item Details metadata.ingestion_labels.value Item Details 的值会分配给 ingestion_labels 对象的 value 字段,其中 key 为“作品详情”。
Log ID metadata.product_log_id Log ID 的值会分配给 metadata.product_log_id。
MAC Address principal.mac 在将所有连字符替换为英文冒号后,MAC Address 的值会分配给 principal.mac。
Matched Item metadata.ingestion_labels.value Matched Item 的值会分配给 ingestion_labels 对象的 value 字段,其中 key 为“Matched Item”。
Message security_result.summary Message 的值会分配给 security_result.summary。
OS principal.platform OS 的值用于确定 principal.platform 的值。如果 OS 包含“Windows”,则 principal.platform 会设置为“WINDOWS”。如果 OS 包含“Mac”,则 principal.platform 会设置为“MAC”。如果 OS 包含“Lin”,则 principal.platform 会设置为“LINUX”。
Serial Number principal.asset.hardware.serial_number Serial Number 的值会分配给 principal.asset.hardware.serial_number。使用 grok 从消息字段中提取,并分配给 intermediary.hostname。使用 grok 从消息字段中提取,并分配给 metadata.description。系统会解析 syslog 消息中的时间戳,并将其分配给 metadata.event_timestamp。值“SCAN_UNCATEGORIZED”会分配给 metadata.event_type。值“ENDPOINT_PROTECTOR_DLP”会分配给 metadata.log_type。值“ENDPOINT_PROTECTOR_DLP”会分配给 metadata.product_name。值“ENDPOINT_PROTECTOR_DLP”会分配给 metadata.vendor_name。使用 grok 从消息字段中提取,并分配给 principal.hostname。使用 grok 从消息字段中提取,并分配给 principal.ip。系统会解析 syslog 消息中的时间戳,并将其分配给顶级 timestamp 字段。
Destination event.idm.read_only_udm.target.application 从变更日志映射
Matched Item event.idm.read_only_udm.target.file.mime_type 从变更日志映射
intermediary_ip event.idm.read_only_udm.intermediary.ip 从变更日志映射
server_date event.idm.read_only_udm.additional.fields 从变更日志映射
client_date event.idm.read_only_udm.additional.fields 从变更日志映射
server_date_utc event.idm.read_only_udm.additional.fields 从变更日志映射
client_date_utc event.idm.read_only_udm.additional.fields 从变更日志映射
pid event.idm.read_only_udm.principal.process.pid 从变更日志映射
OS event.idm.read_only_udm.principal.platform_version 从变更日志映射

更新日志

查看此解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。