收集 Endpoint Protector 資料遺失防護記錄

剖析器版本:2.0

支援的服務:

本文說明如何使用 Bindplane 代理程式,將 Netwrix Endpoint Protector DLP 記錄檔擷取至 Google Security Operations。

Netwrix Endpoint Protector 是資料遺失防護 (DLP) 解決方案,可針對裝置控制、內容感知保護和檔案移轉事件產生系統記錄訊息。剖析器會使用 grok 模式擷取欄位,並將這些欄位對應至統合式資料模型 (UDM)。

事前準備

請確認您符合下列必要條件:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Endpoint Protector 伺服器之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • Netwrix Endpoint Protector 的特殊存取權

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
  1. 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 請提供下列設定詳細資料:
    • 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如 bindplane-ingest)。
    • 「服務帳戶說明」:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存路徑相符。
  12. 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。匯出工具設定時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM Settings」 > 「Collection Agents」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」。
  3. 複製並儲存「機構詳細資料」部分的客戶 ID。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟命令提示字元或 PowerShell。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」。

Linux 安裝

  1. 開啟具有 root 或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為「active (running)」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/endpoint_protector_dlp:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: ENDPOINT_PROTECTOR_DLP
        raw_log_field: body
    
    service:
      pipelines:
        logs/endpoint_protector_dlp_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/endpoint_protector_dlp
    

設定參數

請替換下列預留位置:

  • 接收器設定:

    • listen_address:要接聽的 IP 位址和通訊埠:
      • 0.0.0.0:在所有介面上監聽 (建議)
      • 通訊埠 514 是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用 1514)
  • 匯出工具設定:

    • creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:從 Google SecOps 控制台複製的客戶 ID
    • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會在這個值前面加上 chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。
    • project:將 <PROJECT_NUMBER> 替換為「IAM 與管理」>「設定」中的專案編號。
    • endpoint:維持設為 chronicle.googleapis.com。

舊版 Ingestion API 匯出工具

  • 如果您使用選項 2 的擷取驗證檔案,請將 exporters 區塊替換為下列內容。將 creds_file_path 設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/endpoint_protector_dlp:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: ENDPOINT_PROTECTOR_DLP
        raw_log_field: body
    

儲存設定檔

  • 編輯完成後,請儲存檔案:
    • Linux:依序按下 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,套用變更

  • 如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 查看記錄檔是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列任一選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R 鍵,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
      4. 確認服務是否正在執行:

        sc query observiq-otel-collector
        
      5. 查看記錄檔是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

在 Netwrix Endpoint Protector 上設定系統記錄

  1. 登入 Endpoint Protector 網頁版 UI。
  2. 依序前往「Appliance」>「SIEM Integration」。
  3. 按一下 [Add New] (新增)。
  4. 請提供下列設定詳細資料:
    • SIEM 狀態:切換切換鈕,啟用 SIEM 伺服器。
    • 停用記錄功能:切換為啟用記錄功能。
    • 伺服器名稱:輸入不重複且有意義的伺服器名稱。
    • 伺服器說明:新增這項整合功能的說明。
    • 伺服器 IP 或 DNS:輸入 Bindplane 代理程式 IP 位址。
    • 伺服器通訊協定:選取「UDP」。
    • 伺服器通訊埠:輸入 Bindplane 代理程式通訊埠編號 (例如 UDP 的 514)。
    • 排除標頭:切換按鈕可啟用記錄檔標頭。
    • 記錄類型:選取要傳送至 SIEM 的可用記錄。
  5. 按一下 [儲存]。

UDM 對應表

記錄欄位 UDM 對應 邏輯
Client Computer principal.asset.asset_id 在 Client Computer 的值前面加上「Client Computer: 」後,再指派給 principal.asset.asset_id。
Client User principal.user.userid Client User 的值會指派給 principal.user.userid。
Content Policy security_result.rule_name Content Policy 的值會指派給 security_result.rule_name。
Content Policy Type security_result.rule_id Content Policy Type 的值會指派給 security_result.rule_id。
Destination metadata.ingestion_labels.value Destination 的值會指派給 ingestion_labels 物件的 value 欄位,其中 key 為「Destination」。
Destination Type metadata.ingestion_labels.value Destination Type 的值會指派給 ingestion_labels 物件的 value 欄位,其中 key 為「Destination Type」。
Device PID metadata.ingestion_labels.value Device PID 的值會指派給 ingestion_labels 物件的 value 欄位,其中 key 為「裝置 PID」。
Device Serial metadata.ingestion_labels.value Device Serial 的值會指派給 ingestion_labels 物件的 value 欄位,其中 key 為「Device Serial」。只有在 Device Serial 不為空值時,系統才會執行這項操作。
Device VID metadata.ingestion_labels.value Device VID 的值會指派給 ingestion_labels 物件的 value 欄位,其中 key 為「Device VID」。
File Name target.file.full_path File Name 的值會指派給 target.file.full_path。
File Size target.file.size File Size 的值會指派給 target.file.size,並轉換為不帶正負號的整數。
IP Address principal.ip IP Address 的值會指派給 principal.ip。
Item Details metadata.ingestion_labels.value Item Details 的值會指派給 ingestion_labels 物件的 value 欄位,其中 key 為「作品詳細資料」。
Log ID metadata.product_log_id Log ID 的值會指派給 metadata.product_log_id。
MAC Address principal.mac 將所有連字號替換為冒號後,系統會將 MAC Address 的值指派給 principal.mac。
Matched Item metadata.ingestion_labels.value Matched Item 的值會指派給 ingestion_labels 物件的 value 欄位,其中 key 為「Matched Item」。
Message security_result.summary Message 的值會指派給 security_result.summary。
OS principal.platform OS 的值會用來決定 principal.platform 的值。如果 OS 包含「Windows」,principal.platform 會設為「WINDOWS」。如果 OS 包含「Mac」,principal.platform 會設為「MAC」。如果 OS 包含「Lin」,principal.platform 會設為「LINUX」。
Serial Number principal.asset.hardware.serial_number Serial Number 的值會指派給 principal.asset.hardware.serial_number。使用 grok 從郵件欄位擷取,並指派給 intermediary.hostname。使用 grok 從郵件欄位擷取,並指派給 metadata.description。系統會剖析系統記錄訊息中的時間戳記,並指派給 metadata.event_timestamp。「SCAN_UNCATEGORIZED」值會指派給 metadata.event_type。「ENDPOINT_PROTECTOR_DLP」值會指派給 metadata.log_type。「ENDPOINT_PROTECTOR_DLP」值會指派給 metadata.product_name。「ENDPOINT_PROTECTOR_DLP」值會指派給 metadata.vendor_name。使用 grok 從郵件欄位擷取,並指派給 principal.hostname。使用 grok 從郵件欄位擷取,並指派給 principal.ip。系統會剖析 syslog 訊息的時間戳記,並指派給頂層 timestamp 欄位。
Destination event.idm.read_only_udm.target.application 從變更記錄對應
Matched Item event.idm.read_only_udm.target.file.mime_type 從變更記錄對應
intermediary_ip event.idm.read_only_udm.intermediary.ip 從變更記錄對應
server_date event.idm.read_only_udm.additional.fields 從變更記錄對應
client_date event.idm.read_only_udm.additional.fields 從變更記錄對應
server_date_utc event.idm.read_only_udm.additional.fields 從變更記錄對應
client_date_utc event.idm.read_only_udm.additional.fields 從變更記錄對應
pid event.idm.read_only_udm.principal.process.pid 從變更記錄對應
OS event.idm.read_only_udm.principal.platform_version 從變更記錄對應

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。