收集 Extreme Wireless 記錄

剖析器版本:2.0

支援:

本文說明如何使用 Bindplane 代理程式,將 Extreme Wireless 記錄擷取至 Google Security Operations。

Extreme Networks 無線控制器會產生系統記錄訊息,用於記錄用戶端關聯和取消關聯事件、驗證、RADIUS 互動,以及存取點狀態變更。剖析器會使用 grok 模式擷取欄位,並對應至統合式資料模型 (UDM)。

事前準備

請確認您符合下列必要條件:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Extreme Networks CloudIQ 控制器之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • Extreme Networks CloudIQ 的特殊存取權

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
  1. 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 提供下列設定詳細資料:
    • 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如 bindplane-ingest)。
    • 「服務帳戶說明」:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存路徑相符。
  12. 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。設定匯出工具時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM Settings」 > 「Collection Agents」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」。
  3. 複製並儲存「機構詳細資料」專區中的「客戶 ID」。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟命令提示字元或 PowerShell。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」。

Linux 安裝

  1. 開啟具有 root 或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為「active (running)」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/extreme_wireless:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: EXTREME_WIRELESS
        raw_log_field: body
    
    service:
      pipelines:
        logs/extreme_wireless_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/extreme_wireless
    

設定參數

請替換下列預留位置:

  • 接收器設定:

    • listen_address:要監聽的 IP 位址和通訊埠:
      • 0.0.0.0:在所有介面上監聽 (建議)
      • 通訊埠 514 是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用 1514)
  • 匯出工具設定:

    • creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:從 Google SecOps 控制台複製的客戶 ID
    • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會在這個值前面加上 chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。
    • project:將 <PROJECT_NUMBER> 替換為「IAM 與管理」>「設定」中的專案編號。
    • endpoint:請將此值設為 chronicle.googleapis.com。

舊版 Ingestion API 匯出工具

  • 如果您使用方式 2 的擷取驗證檔案,請將 exporters 區塊替換成下列內容。將 creds_file_path 設為擷取驗證檔案的路徑,如果您的執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/extreme_wireless:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: EXTREME_WIRELESS
        raw_log_field: body
    

儲存設定檔

  • 編輯完成後,請儲存檔案:
    • Linux:依序按下 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依序點選「檔案」 > 「儲存」

重新啟動 Bindplane 代理程式,套用變更

  • 如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 檢查記錄是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R 鍵,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
      4. 確認服務是否正在執行:

        sc query observiq-otel-collector
        
      5. 查看記錄檔是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

在 Extreme Networks CloudIQ 上設定系統記錄

  1. 登入 CloudIQ 網頁版 UI。
  2. 依序前往「Configure」(設定) >「Common Objects」(通用物件) >「Management」(管理) >「Syslog Servers」(系統記錄伺服器)。
  3. 按一下 [+]。
  4. 提供下列設定詳細資料:
    • 名稱:為伺服器提供專屬名稱。
    • 嚴重程度:選取「資訊」。
    • 從「選取」選單中選取現有的系統記錄 IP 位址,或按一下「+」。
    • 輸入 Bindplane 代理程式 IP 位址。
    • 輸入 Bindplane 代理程式通訊埠編號。
    • 點選「新增」。
  5. 按一下「儲存系統記錄伺服器」。

UDM 對應表

記錄欄位 UDM 對應 邏輯
action security_result.detection_fields.key 原始記錄中 action 欄位的值會對應至 security_result.detection_fields.key。
action security_result.detection_fields.value 原始記錄中 action 欄位的值會對應至 security_result.detection_fields.value。
BSSID principal.resource.attribute.labels.key 字串「BSSID」會指派給 principal.resource.attribute.labels.key。
BSSID principal.resource.attribute.labels.value 原始記錄中的 BSSID 欄位值會對應至 principal.resource.attribute.labels.value。
collection_time.nanos metadata.event_timestamp.nanos 原始記錄中的 collection_time.nanos 值會對應至 metadata.event_timestamp.nanos。
collection_time.seconds metadata.event_timestamp.seconds 原始記錄中的 collection_time.seconds 值會對應至 metadata.event_timestamp.seconds。
collection_time.seconds timestamp.seconds 原始記錄中的 collection_time.seconds 值會對應至 timestamp.seconds。
collection_time.nanos timestamp.nanos 原始記錄中的 collection_time.nanos 值會對應至 timestamp.nanos。
data security_result.description 原始記錄中 data 欄位的值經過多次 gsub 轉換,移除不必要的字元和「不適用」值後,會對應至 security_result.description 欄位。
description security_result.description grok 剖析器擷取的 description 欄位值會對應至 security_result.description 欄位。
first security_result.detection_fields.key 字串「first」會指派給 security_result.detection_fields.key。
first security_result.detection_fields.value 原始記錄中 first 欄位的值會對應至 security_result.detection_fields.value。
hostname principal.asset.hostname 原始記錄中 hostname 欄位的值會對應至 principal.asset.hostname 和 principal.hostname 欄位。
hostname principal.hostname 原始記錄中 hostname 欄位的值會對應至 principal.asset.hostname 和 principal.hostname 欄位。
IP principal.asset.ip 原始記錄中的 IP 欄位值會對應至 principal.asset.ip 和 principal.ip 欄位。
IP principal.ip 原始記錄中 IP 欄位的值會對應至 principal.asset.ip 和 principal.ip 欄位。
MAC principal.resource.attribute.labels.key 字串「MAC」會指派給 principal.resource.attribute.labels.key。
MAC principal.resource.attribute.labels.value 原始記錄中的 MAC 欄位值會對應至 principal.resource.attribute.labels.value。
medium security_result.detection_fields.key 字串「medium」會指派給 security_result.detection_fields.key。
medium security_result.detection_fields.value 原始記錄中 medium 欄位的值會對應至 security_result.detection_fields.value。metadata.event_type 是由剖析器中的邏輯決定。如果同時存在 principal 和 target 機器 ID,則會設為 NETWORK_CONNECTION。如果 principal 或 target 使用者 ID 存在,則會設為 USER_UNCATEGORIZED。如果只有 principal 機器 ID,則會設為 STATUS_UPDATE。否則,預設值為 GENERIC_EVENT。字串「EXTREME WIRELESS」已指派給 metadata.product_name。
prod_event_type metadata.product_event_type 原始記錄中的 prod_event_type 欄位值會對應至 metadata.product_event_type 欄位。
port principal.port 原始記錄中的 port 欄位值會轉換為整數,並對應至 principal.port 欄位。
problem_summary security_result.summary 原始記錄中 problem_summary 欄位的值會對應至 security_result.summary 欄位。
SSID principal.resource.attribute.labels.key 字串「SSID」會指派給 principal.resource.attribute.labels.key。
SSID principal.resource.attribute.labels.value 原始記錄中的 SSID 欄位值會對應至 principal.resource.attribute.labels.value。
station principal.asset.hostname 原始記錄中的 station 欄位值會對應至 principal.asset.hostname 和 principal.hostname 欄位。
station principal.hostname 原始記錄中的 station 欄位值會對應至 principal.asset.hostname 和 principal.hostname 欄位。
target_host target.asset.hostname 原始記錄中 target_host 欄位的值會對應至 target.asset.hostname 和 target.hostname 欄位。
target_host target.hostname 原始記錄中 target_host 欄位的值會對應至 target.asset.hostname 和 target.hostname 欄位。
target_ip target.asset.ip 原始記錄中 target_ip 欄位的值會對應至 target.asset.ip 和 target.ip 欄位。
target_ip target.ip 原始記錄中的 target_ip 欄位值會對應至 target.asset.ip 和 target.ip 欄位。
target_port target.port 原始記錄中 target_port 欄位的值會轉換為整數,並對應至 target.port 欄位。
target_user target.user.userid 原始記錄中 target_user 欄位的值會對應至 target.user.userid 欄位。
user-profile security_result.detection_fields.key 字串「user profile」會指派給 security_result.detection_fields.key。
user-profile security_result.detection_fields.value 原始記錄中的 user-profile 欄位值會對應至 security_result.detection_fields.value。
username principal.user.userid 原始記錄中 username 欄位的值會對應至 principal.user.userid 欄位。字串「EXTREME_WIRELESS」會指派給 metadata.vendor_name。

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。