收集 F5 VPN 記錄
剖析器版本:2.0
本文說明如何使用 Bindplane 代理程式,將 F5 VPN 記錄檔擷取至 Google Security Operations。
F5 BIG-IP Access Policy Manager (APM) 是 VPN 和存取管理解決方案,可針對使用者驗證、工作階段管理、政策評估、通道建立和網路存取事件,產生 syslog 訊息。剖析器會從 syslog 格式的記錄中擷取欄位,並對應至統合式資料模型 (UDM)。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 F5 BIG-IP 設備之間的網路連線
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- F5 BIG-IP tmsh (11.x 以上版本) 的特殊存取權
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往 「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 請提供下列設定詳細資料:
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
bindplane-ingest)。 - 「服務帳戶說明」:輸入說明 (例如
Bindplane agent log ingestion)。
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 為/opt/observiq-otel-collector/ingestion-auth.json,Windows 為C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存檔案的路徑相符。 - 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。設定匯出工具時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「收集代理程式」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」 > 「設定檔」。
複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
安裝 Linux
- 開啟具有根層級或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理,擷取系統記錄檔並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/f5_vpn: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: F5_VPN raw_log_field: body service: pipelines: logs/f5_vpn_to_chronicle: receivers: - udplog exporters: - chronicle/f5_vpn
設定參數
替換下列預留位置:
接收器設定:
listen_address:要接聽的 IP 位址和通訊埠:0.0.0.0在所有介面接聽電話 (建議)- 通訊埠
514是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用1514)
匯出工具設定:
creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:從 Google SecOps 控制台複製的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會在這個值前面加上chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。project:將<PROJECT_NUMBER>替換為「IAM 與管理」>「設定」中的專案編號。endpoint:請將此值設為chronicle.googleapis.com。
舊版 Ingestion API 匯出工具
如果您使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/f5_vpn: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: F5_VPN raw_log_field: body
儲存設定檔
- 編輯完畢後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」 > 「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務是否正在執行:
sudo systemctl status observiq-otel-collector查看記錄檔是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector查看記錄檔是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
在 F5 BIG-IP APM 設定 syslog 轉送
- 連線至 F5 BIG-IP 指令列。
開啟 tmsh 殼層:
tmsh執行下列指令,設定遠端 Syslog 伺服器:
modify sys syslog remote-servers add { <Name> { host <bindplane-ip> remote-port <bindplane-port> } }更改下列內容:
<Name>:這個系統記錄目的地的不重複名稱 (例如bindplane_server)。<bindplane-ip>:Bindplane 代理程式主機的 IP 位址。<bindplane-port>:Bindplane 代理程式接收器中設定的通訊埠 (預設:514)。
儲存設定:
save sys config partitions all
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
cmd_data |
principal.process.command_line |
值是從 msg 欄位擷取 |
errdefs_msgno |
additional.fields.errdefs_msgno.string_value |
值是從 msg 欄位擷取 |
event_time |
metadata.event_timestamp |
系統會剖析該值並轉換為時間戳記 |
hostname |
principal.hostname,、observer.hostname,、principal.asset.hostname,、observer.asset.hostname, |
系統會從訊息欄位擷取值,並填入 UDM 的主機名稱欄位。也用於填入 hostip 欄位 |
msg |
security_result.description |
系統會從訊息欄位擷取值,並填入 security_result 物件的說明欄位 |
prin_ip |
principal.ip,、principal.asset.ip |
系統會從訊息欄位擷取值,並填入 UDM 的 IP 位址欄位 |
additional.fields.Canonical_Info.string_value |
這個值衍生自記錄訊息 | |
additional.fields.IDP.string_value |
這個值衍生自記錄訊息 | |
additional.fields.Plugin_Support.string_value |
這個值是從記錄訊息衍生而來 | |
additional.fields.SMB、Stage.string_value |
這個值是從記錄訊息衍生而來 | |
additional.fields.SP.string_value |
這個值衍生自記錄訊息 | |
additional.fields.Timezone.string_value |
這個值衍生自記錄訊息 | |
additional.fields.Tunnel、Type.string_value |
這個值衍生自記錄訊息 | |
additional.fields.UI_Mode.string_value |
這個值衍生自記錄訊息 | |
additional.fields.Version.string_value |
這個值衍生自記錄訊息 | |
additional.fields.from_rule_item.string_value |
這個值衍生自記錄訊息 | |
additional.fields.policy_result.string_value |
這個值衍生自記錄訊息 | |
additional.fields.ppp_id.string_value |
這個值衍生自記錄訊息 | |
additional.fields.resource.string_value |
這個值衍生自記錄訊息 | |
additional.fields.rule.string_value |
這個值衍生自記錄訊息 | |
additional.fields.server_vip_ip.string_value |
這個值衍生自記錄訊息 | |
additional.fields.server_vip_name.string_value |
這個值衍生自記錄訊息 | |
additional.fields.to_rule_item.string_value |
這個值衍生自記錄訊息 | |
additional.fields.tunnel_resource.string_value |
這個值衍生自記錄訊息 | |
metadata.description |
這個值衍生自記錄訊息 | |
metadata.event_type |
部分事件的值會以硬式編碼方式加到剖析器程式碼中,其他事件的值則會從記錄訊息衍生而來 | |
metadata.log_type |
此值會設為批次類型 | |
metadata.product_event_type |
這個值衍生自記錄訊息 | |
metadata.product_name |
剖析器程式碼中的值是硬式編碼 | |
metadata.vendor_name |
值是以硬式編碼方式寫入剖析器程式碼中 | |
network.application_protocol |
這個值衍生自記錄訊息 | |
network.direction |
這個值衍生自記錄訊息 | |
network.http.method |
這個值衍生自記錄訊息 | |
network.http.parsed_user_agent |
這個值衍生自 network.http.user_agent 欄位 | |
network.http.referral_url |
這個值衍生自記錄訊息 | |
network.http.response_code |
這個值衍生自記錄訊息 | |
network.http.user_agent |
這個值衍生自記錄訊息 | |
network.ip_protocol |
這個值衍生自記錄訊息 | |
network.received_bytes |
這個值衍生自記錄訊息 | |
network.sent_bytes |
這個值衍生自記錄訊息 | |
network.session_id |
這個值衍生自記錄訊息 | |
network.tls.cipher |
這個值衍生自記錄訊息 | |
network.tls.version |
這個值是從記錄訊息衍生而來 | |
observer.asset.hostname |
這個值會設為主機名稱欄位 | |
observer.asset.ip |
此值會設為 hostip 欄位 | |
observer.hostname |
此值會設為主機名稱欄位 | |
observer.ip |
這個值會設為 hostip 欄位 | |
principal.application |
這個值是從記錄訊息衍生而來 | |
principal.asset.hostname |
此值會設為主機名稱欄位 | |
principal.asset.ip |
該值會設為 hostip 欄位或 prin_ip 欄位 (如果存在) | |
principal.asset.product_object_id |
這個值衍生自記錄訊息 | |
principal.hostname |
此值會設為主機名稱欄位 | |
principal.ip |
該值會設為 hostip 欄位或 prin_ip 欄位 (如果存在) | |
principal.location.country_or_region |
這個值是從記錄訊息衍生而來 | |
principal.platform |
這個值衍生自記錄訊息 | |
principal.port |
這個值衍生自記錄訊息 | |
principal.process.command_line |
這個值衍生自記錄訊息 | |
principal.process.pid |
這個值衍生自記錄訊息 | |
principal.resource.name |
這個值衍生自記錄訊息 | |
principal.resource.type |
部分事件的值會硬式編碼在剖析器程式碼中,其他事件的值則衍生自記錄訊息 | |
principal.user.email_addresses |
這個值衍生自記錄訊息 | |
principal.user.userid |
這個值衍生自記錄訊息 | |
security_result.action |
這個值衍生自記錄訊息 | |
security_result.description |
這個值衍生自記錄訊息 | |
security_result.rule_name |
這個值衍生自記錄訊息 | |
security_result.severity |
這個值衍生自記錄訊息 | |
security_result.severity_details |
這個值衍生自記錄訊息 | |
security_result.summary |
這個值衍生自記錄訊息 | |
src.ip |
這個值衍生自記錄訊息 | |
src.location.country_or_region |
這個值衍生自記錄訊息 | |
src.port |
這個值衍生自記錄訊息 | |
target.asset.hostname |
這個值衍生自記錄訊息 | |
target.asset.ip |
這個值衍生自記錄訊息 | |
target.hostname |
這個值衍生自記錄訊息 | |
target.ip |
這個值衍生自記錄訊息 | |
target.port |
這個值衍生自記錄訊息 | |
target.process.command_line |
這個值衍生自記錄訊息 | |
target.process.pid |
這個值衍生自記錄訊息 | |
target.resource.id |
這個值衍生自記錄訊息 | |
target.url |
這個值衍生自記錄訊息 | |
target.user.userid |
這個值衍生自記錄訊息 | |
Hostname |
target.hostname |
從變更記錄對應 |
sess_id |
network.session_id |
從變更記錄對應 |
internal_ip |
target.ip |
從變更記錄對應 |
file_path |
principal.resource.name |
從變更記錄對應 |
useragent |
network.http.user_agent |
從變更記錄對應 |
User-Agent" and "useragent |
network.http.parsed_user_agent |
從變更記錄對應 |
username |
target.user.userid |
從變更記錄對應 |
sid |
target.user.windows_sid |
從變更記錄對應 |
bytes_out |
network.sent_bytes |
從變更記錄對應 |
bytes_in |
network.received_bytes |
從變更記錄對應 |
Platform |
principal.platform |
從變更記錄對應 |
Platform_Version |
principal.platform_version |
從變更記錄對應 |
Javascript_Support", "ActiveX_Support", "Plugin_Support", "Version", "Model", "CPU", "UI_Mode", "SP", "IDP", "to_rule_item", "from_rule_item", "policy_result", "rule", "resource", "ppp_id", "tunnel_resource", "server_vip_ip", "server_vip_name", and "Canonical_Info |
additional.fields |
從變更記錄對應 |
uri_path |
target.url |
從變更記錄對應 |
User-Agent |
network.http.user_agent |
從變更記錄對應 |
s_ip |
src.ip |
從變更記錄對應 |
t_ip |
target.ip |
從變更記錄對應 |
t_port |
target.port |
從變更記錄對應 |
s_nat_ip |
target.nat_ip |
從變更記錄對應 |
cipher_name |
network.tls.cipher |
從變更記錄對應 |
tls_version |
network.tls.version |
從變更記錄對應 |
resource_id |
target.resource.id |
從變更記錄對應 |
src_ip |
principal.ip |
從變更記錄對應 |
status |
network.http.response_code |
從變更記錄對應 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。