收集 Trellix (舊稱 FireEye) 警示記錄

剖析器版本:10.0

支援:

本文說明如何使用 Bindplane 代理程式,將 Trellix (舊稱 FireEye) 警報記錄檔擷取至 Google Security Operations。

Trellix 是網路安全平台,可偵測進階威脅、惡意軟體和零時差攻擊。並會針對偵測到的威脅、惡意活動和安全性事件,產生 CEF、JSON 和 XML 格式的警告記錄。

事前準備

請確認您符合下列必要條件:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Trellix 設備之間的網路連線
  • 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
  • 具備管理員權限,可對 Trellix 設備執行特殊操作

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
  1. 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 請提供下列設定詳細資料:
    • 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如 bindplane-ingest)。
    • 「服務帳戶說明」:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存路徑相符。
  12. 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。設定匯出工具時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」。
  3. 複製並儲存「機構詳細資料」部分的客戶 ID。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟命令提示字元或 PowerShell。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」。

Linux 安裝

  1. 開啟具有根層級或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為「active (running)」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      tcplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/fireeye_alert:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: FIREEYE_ALERT
        raw_log_field: body
        ingestion_labels:
          env: production
    
    service:
      pipelines:
        logs/fireeye_to_chronicle:
          receivers:
            - tcplog
          exporters:
            - chronicle/fireeye_alert
    

設定參數

請替換下列預留位置:

接收器設定:

  • tcplog:根據通訊協定的接收器類型:
    • UDP syslog 的 udplog
    • tcplog (適用於 TCP Syslog)
  • 0.0.0.0:要接聽的 IP 位址:
    • 0.0.0.0:在所有介面上監聽 (建議)
    • 監聽單一介面的特定 IP 位址
  • 514:要接聽的通訊埠號碼 (例如 514、1514、6514)

Exporter 設定:

  • fireeye_alert:匯出工具的說明名稱
  • creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):
    • Linux:/opt/observiq-otel-collector/ingestion-auth.json
    • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
  • <customer_id>:上一步取得的客戶 ID
  • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會在這個值前面加上 chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。
  • project:將 <PROJECT_NUMBER> 替換為「IAM 與管理」>「設定」中的專案編號。
  • endpoint:維持設為 chronicle.googleapis.com。
  • FIREEYE_ALERT:記錄類型,與 Google SecOps 中顯示的完全相同
  • ingestion_labels:YAML 格式的選用標籤 (例如 env: production)

管道設定:

  • fireeye_to_chronicle::管道的說明名稱

舊版擷取 API 匯出工具

  • 如果您使用選項 2 的擷取驗證檔案,請將 exporters 區塊替換為下列內容。將 creds_file_path 設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/fireeye_alert:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: FIREEYE_ALERT
        raw_log_field: body
        ingestion_labels:
          env: production
    

儲存設定檔

  • 編輯完成後,請儲存檔案:
    • Linux:依序按下 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依序點選「檔案」 > 「儲存」

重新啟動 Bindplane 代理程式,套用變更

  • 如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務正在執行:

      ```bash
      sudo systemctl status observiq-otel-collector
      ```
      
    2. 檢查記錄是否有錯誤:

      ```bash
      sudo journalctl -u observiq-otel-collector -f
      ```
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R 鍵,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
      4. 確認服務正在執行:

        ```cmd
        sc query observiq-otel-collector
        ```
        
      5. 查看記錄檔是否有錯誤:

        ```cmd
        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        ```
        

設定 FireEye syslog 轉送

FireEye (Trellix) 設備會以 rsyslog 通知形式轉送警示。您可以透過設備網頁 UI 或設備指令列介面進行設定。這兩種方法會產生相同的結果,因此請視您的作業模式選擇合適的方法。

方法 1:使用網頁版 UI 設定 rsyslog 通知

  1. 使用具備管理員或操作員存取權的帳戶,登入 FireEye 設備網頁 UI。
  2. 依序前往「設定」 > 「通知」。
  3. 選取「RSYSLOG」RSYSLOG分頁標籤。
  4. 選用:在「Rsyslog Settings」(Rsyslog 設定) 區域中,設定設為「Default」(預設) 的伺服器會繼承的值,然後按一下「Apply Settings」(套用設定):
    • 預設格式:選取「CEF」。
    • 預設傳送:選取「每個事件」。
    • 「預設寄件者」:選取「快訊」。
  5. 在「查看及新增 Rsyslog 伺服器」下方,按一下「新增 Rsyslog 伺服器」。
  6. 提供下列設定詳細資料:
    • 伺服器名稱:輸入項目的描述性名稱 (例如 secops-bindplane)。
    • IP 位址:輸入 Bindplane 代理程式主機的 IP 位址 (例如 192.168.1.100)。
    • 已啟用:勾選這個核取方塊,設備就會傳送通知到這個伺服器。
    • 傳送:選取「每次事件」,在每次產生快訊時傳送通知。
    • 通知:選取「所有事件」,或選取要轉寄的特定快訊類型。
    • 格式:選取「CEF」。如果選取「JSON」,請一併選取詳細程度:「Normal」(一般)、「Concise」(精簡) 或「Extended」(詳細)。
    • 傳送方式:選取「快訊」。
    • 「Protocol」(通訊協定):選取「TCP」,與先前設定的 tcplog 接收器相符。只有在將接收器變更為 udplog 時,才選取「UDP」UDP(設備預設值)。
  7. 按一下「Add New Rsyslog Server」(新增 Rsyslog 伺服器)。

方法 2:使用 CLI 設定 rsyslog 通知

  1. 使用具備管理員或操作員存取權的帳戶,登入 FireEye 設備指令列介面。
  2. 進入設定模式:

    hostname > enable
    hostname # configure terminal
    
  3. 啟用 rsyslog 通知:

    hostname (config) # fenotify rsyslog enable
    
  4. 為 Bindplane 代理建立陷阱接收器並啟用:

    hostname (config) # fenotify rsyslog trap-sink secops-bindplane
    hostname (config) # fenotify rsyslog trap-sink secops-bindplane enable
    
  5. 設定目的地地址、傳輸通訊協定和通訊埠:

    hostname (config) # fenotify rsyslog trap-sink secops-bindplane address <BINDPLANE_IP>
    hostname (config) # fenotify rsyslog trap-sink secops-bindplane protocol tcp
    hostname (config) # fenotify rsyslog trap-sink secops-bindplane port 514
    
    • <BINDPLANE_IP>:Bindplane 代理主機的 IP 位址或網域名稱。
  6. 設定訊息格式、傳送時間表和嚴重程度:

    hostname (config) # fenotify rsyslog trap-sink secops-bindplane prefer message format cef
    hostname (config) # fenotify rsyslog trap-sink secops-bindplane prefer message delivery per-event
    hostname (config) # fenotify rsyslog trap-sink secops-bindplane prefer message send-as alert
    
    • prefer message format:使用 cef。如果是 JSON,請使用 json-normal、json-concise 或 json-extended。請勿使用 csv、leef 或任何 text- 或 xml- 值。
    • prefer message delivery:使用 per-event,在事件觸發時傳送每個事件的相關資訊。
    • prefer message send-as:使用 alert,嚴重程度為 1。
  7. 選取要為這個陷阱接收器產生通知的快訊:

    hostname (config) # fenotify rsyslog trap-sink secops-bindplane prefer notification all-events
    
    • all-events:除了風險軟體以外的所有事件。
    • all-riskware:riskware-object 和 riskware-callback 事件。
    • 個別類型:domain-match、infection-match、malware-callback、malware-object、riskware-callback、riskware-object、web-infection 和 ips-event (在啟用 IPS 的設備上)。
  8. 儲存設定:

    hostname (config) # write memory
    

驗證設定

  1. 如要查看有效的 rsyslog 設定,請在啟用模式下執行下列指令:

    hostname # show fenotify rsyslog
    

    輸出內容會列出全域「設定」值、已啟用的「快訊」類型,以及每個伺服器的「消費者」值。

  2. 如要透過網頁使用者介面產生測試事件,請依序前往「設定」>「通知」,在表格下方的下拉式清單中選取事件類型,然後按一下「測試觸發」。

  3. 如要改用 CLI 產生測試事件,請在設定模式下執行下列指令:

    hostname (config) # fenotify test-fire <EVENT_TYPE>
    
  4. 確認 Bindplane 代理程式主機收到訊息,然後確認事件是否顯示在 Google SecOps 中。

如要瞭解這些步驟遵循的供應商程序,請參閱「使用網頁介面新增系統記錄伺服器」、「使用 CLI 新增系統記錄伺服器」、「使用 CLI 自訂系統記錄伺服器通知」和「測試 IPS 事件通知」。如需每個 fenotify rsyslog 指令的完整語法和可接受的值,請參閱 CLI 指令參考資料。

UDM 對應表

記錄欄位 UDM 對應 邏輯
additional_source additional.fields 已合併
appliance_id_label additional.fields 已合併
appliance_id_label_2nd additional.fields 已合併
appliance_label additional.fields 已合併
begin_label additional.fields 已合併
cache_control_label additional.fields 已合併
channel_label additional.fields 已合併
content_length_label additional.fields 已合併
content_type_label additional.fields 已合併
cost_label additional.fields 已合併
end_label additional.fields 已合併
match_count_label additional.fields 已合併
msg_label additional.fields 已合併
success_label additional.fields 已合併
dvc intermediary.asset.hostname 直接對應
dvc intermediary.asset.ip 已合併
msg intermediary.email 直接對應
dvc intermediary.hostname 直接對應
sensor intermediary.hostname 直接對應
dvc intermediary.ip 已合併
intermediary_host intermediary.labels 已合併
dvcmac intermediary.mac 已合併
desc metadata.description 直接對應
description metadata.description 直接對應
name metadata.description 直接對應
alert.occurred metadata.event_timestamp 已剖析為 yyyy-MM-dd HH:mm:ss.SSS
end metadata.event_timestamp 剖析為 MMM dd yyyy HH:mm:ss ZZZ
rt metadata.event_timestamp 剖析為 MMM dd yyyy HH:mm:ss ZZZ
start metadata.event_timestamp 剖析為 MMM dd yyyy HH:mm:ss ZZZ
event_type metadata.event_type 已對應:filewriteevent → FILE_MODIFICATION、"processevent","urlmonitorevent" → `SCAN_P...
event_type1 metadata.event_type 直接對應
file_event_subtype metadata.event_type 對應:FILE_OPERATION_CLOSED → SCAN_PROCESS
has_email_info metadata.event_type 對應:true → EMAIL_TRANSACTION
has_principal metadata.event_type 對應:true → NETWORK_CONNECTION、true → EMAIL_TRANSACTION、true → STATUS_UPDATE
type metadata.event_type 已對應:"Event::Endpoint::UpdateSuccess","Event::Endpoint::UpdateFailure" → STATUS_UPDATE
event_type metadata.product_event_type 直接對應
type metadata.product_event_type 直接對應
externalId metadata.product_log_id 直接對應
product metadata.product_name 直接對應
version metadata.product_version 直接對應
applicationProtocol network.application_protocol 直接對應
ver_proto network.application_protocol 對應:HTTP/1.1 → HTTP
alert.src.smtp-mail-from network.email.from 直接對應
mails network.email.to 已合併
httpmethod network.http.method 直接對應
method network.http.method 直接對應
urlMonitorEvent_urlMethod network.http.method 直接對應
User-Agent network.http.parsed_user_agent 已重新命名/對應
http_user_agent network.http.parsed_user_agent 已重新命名/對應
Referer network.http.referral_url 直接對應
urlMonitorEvent_requestUrl network.http.referral_url 直接對應
User-Agent network.http.user_agent 直接對應
http_user_agent network.http.user_agent 直接對應
urlMonitorEvent_userAgent network.http.user_agent 直接對應
alert.explanation.cnc-services.cnc-service.protocol network.ip_protocol 直接對應
alert.explanation.protocol network.ip_protocol 直接對應
ver_proto network.tls.version_protocol 直接對應
devicePayloadId principal.application 直接對應
process principal.application 直接對應
principal_hostname principal.asset.hostname 直接對應
sourceDnsDomain principal.asset.hostname 直接對應
agent_info.primary_ip_address principal.asset.ip 已合併
alert.src.ip principal.asset.ip 已合併
host_name principal.asset.ip 直接對應
source_info.ip principal.asset.ip 已合併
src principal.asset.ip 已合併
src_ip principal.asset.ip 已合併
type principal.asset.ip 對應:"Event::Endpoint::UpdateSuccess","Event::Endpoint::UpdateFailure" → source_info.ip
vulnerability principal.asset.vulnerabilities 已合併
path principal.file.full_path 直接對應
alert.explanation.os-changes.file.processinfo.md5sum principal.file.md5 直接對應
alert.explanation.os-changes.file.processinfo.sha1sum principal.file.sha1 直接對應
filesize principal.file.size 直接對應
Host principal.hostname 直接對應
principal_hostname principal.hostname 直接對應
sourceDnsDomain principal.hostname 直接對應
agent_info.primary_ip_address principal.ip 已合併
alert.src.ip principal.ip 已合併
host_name principal.ip 直接對應
source_info.ip principal.ip 已合併
src principal.ip 已合併
src_ip principal.ip 已合併
type principal.ip 對應:"Event::Endpoint::UpdateSuccess","Event::Endpoint::UpdateFailure" → source_info.ip
prinicipal_vlan principal.labels 已合併
country principal.location.country_or_region 直接對應
agent_info.primary_mac principal.mac 已合併
alert.src.mac principal.mac 已合併
appliance-id principal.mac 已合併
smac principal.mac 已合併
os_platform principal.platform 對應:"linux","LINUX","lin" → LINUX、"windows","WINDOWS","win" → WINDOWS、`"mac","...
os_kernel_version principal.platform_patch_level 直接對應
alert.explanation.os-changes.osinfo principal.platform_version 直接對應
alert.src.port principal.port 直接對應
src_port principal.port 直接對應
alert.explanation.os-changes.file.processinfo.ppid principal.process.parent_process.pid 直接對應
alert.explanation.os-changes.file.processinfo.pid principal.process.pid 直接對應
process_id principal.process.pid 直接對應
id principal.resource.id 直接對應
email principal.user.email_addresses 已對應:^.+@.+$ → email
s_result security_result 已合併
sec_result security_result 已合併
alert_smtp_header security_result.about.labels 已合併
alert_smtp_last_malware security_result.about.labels 已合併
alert_smtp_queue_id security_result.about.labels 已合併
alert_smtp_subject security_result.about.labels 已合併
endpoint_type_label security_result.about.labels 已合併
type security_result.about.labels 對應:"Event::Endpoint::UpdateSuccess","Event::Endpoint::UpdateFailure" → `endpoint_type...
proto security_result.about.network.application_protocol 直接對應
http_method security_result.about.network.http.method 直接對應
alert.smtp-message.id security_result.about.resource.id 直接對應
alert.src.url security_result.about.url 直接對應
temp_url security_result.about.url 直接對應
action security_result.action 已合併
alert.action security_result.action_details 直接對應
threat_attribution security_result.action_details 直接對應
category security_result.category 已合併
category_details security_result.category_details 已合併
group security_result.category_details 已合併
indicator.category security_result.category_details 已合併
type security_result.category_details 對應:"Event::Endpoint::UpdateSuccess","Event::Endpoint::UpdateFailure" → group
act security_result.description 直接對應
indicator.name security_result.description 直接對應
ack_field security_result.detection_fields 已合併
analysis_field security_result.detection_fields 已合併
attack_mode_label security_result.detection_fields 已合併
build_field security_result.detection_fields 已合併
bytes_available_label security_result.detection_fields 已合併
chunk_id_label security_result.detection_fields 已合併
chunk_len_label security_result.detection_fields 已合併
chunks_label security_result.detection_fields 已合併
classtype_label security_result.detection_fields 已合併
cn1_label security_result.detection_fields 已合併
cnc_service_type security_result.detection_fields 已合併
cs1_label security_result.detection_fields 已合併
cs3_label security_result.detection_fields 已合併
cs4_label security_result.detection_fields 已合併
data_label security_result.detection_fields 已合併
detection_infection_type security_result.detection_fields 已合併
display_msg_label security_result.detection_fields 已合併
dpt_label security_result.detection_fields 已合併
flex_string1_Label security_result.detection_fields 已合併
flex_string1_label security_result.detection_fields 已合併
flex_string2_Label security_result.detection_fields 已合併
flex_string2_label security_result.detection_fields 已合併
header security_result.detection_fields 已合併
id_field security_result.detection_fields 已合併
job_id_label security_result.detection_fields 已合併
mode_field security_result.detection_fields 已合併
mvx_status_label security_result.detection_fields 已合併
qid_label security_result.detection_fields 已合併
request_label security_result.detection_fields 已合併
retroactive_field security_result.detection_fields 已合併
sc_version_field security_result.detection_fields 已合併
sequence_field security_result.detection_fields 已合併
sig_id_label security_result.detection_fields 已合併
sig_name_label security_result.detection_fields 已合併
sig_revision_label security_result.detection_fields 已合併
spt_label security_result.detection_fields 已合併
sub_id_label security_result.detection_fields 已合併
tests_downloaded_at_field security_result.detection_fields 已合併
tests_executed_at_field security_result.detection_fields 已合併
tests_name_field security_result.detection_fields 已合併
tests_original_field security_result.detection_fields 已合併
tests_sha512_field security_result.detection_fields 已合併
tests_sid_field security_result.detection_fields 已合併
tests_stype_field security_result.detection_fields 已合併
tests_submitted_at_field security_result.detection_fields 已合併
tests_type_field security_result.detection_fields 已合併
tid_label security_result.detection_fields 已合併
timestamp_field security_result.detection_fields 已合併
url_field security_result.detection_fields 已合併
value_field security_result.detection_fields 已合併
written_size_label security_result.detection_fields 已合併
alert.uuid security_result.rule_id 直接對應
alert.version security_result.rule_version 直接對應
severity security_result.severity 對應:"low","NOTICE" → LOW、INFO → INFORMATIONAL、medium → MEDIUM、high → `H...
action_taken security_result.summary 直接對應
risk_summary security_result.summary 直接對應
alert.id security_result.threat_id 直接對應
alert.name security_result.threat_name 直接對應
ele.infection.infection-name security_result.threat_name 直接對應
threat_name security_result.threat_name 直接對應
alert.alert-url security_result.url_back_to_product 直接對應
url security_result.url_back_to_product 直接對應
dst_hostname target.asset.hostname 直接對應
dvchost target.asset.hostname 直接對應
target_hostname target.asset.hostname 直接對應
alert.dst.ip target.asset.ip 已合併
dst target.asset.ip 已合併
dst_ip target.asset.ip 已合併
urlMonitorEvent_remoteIpAddress target.asset.ip 已合併
alert.explanation.os-changes.file.processinfo.imagepath target.file.full_path 直接對應
file_fullpath target.file.full_path 直接對應
fname target.file.full_path 直接對應
agent_info.md5values target.file.md5 直接對應
ele.action.actioned-object.file-object.md5sum target.file.md5 直接對應
file_md5 target.file.md5 直接對應
fileType target.file.mime_type 直接對應
ele.action.actioned-object.file-object.sha1sum target.file.sha1 直接對應
ele.action.actioned-object.file-object.sha256sum target.file.sha256 直接對應
fileHash target.file.sha256 直接對應
file_size target.file.size 直接對應
fsize target.file.size 直接對應
dst_hostname target.hostname 直接對應
dvchost target.hostname 直接對應
target_hostname target.hostname 直接對應
alert.dst.ip target.ip 已合併
dst target.ip 已合併
dst_ip target.ip 已合併
urlMonitorEvent_remoteIpAddress target.ip 已合併
alert.explanation.cnc-services.cnc-service.location target.location.country_or_region 直接對應
alert.dst.mac target.mac 已合併
dmac target.mac 已合併
alert.dst.port target.port 直接對應
dst_port target.port 已重新命名/對應
urlMonitorEvent_remotePort target.port 直接對應
cmd target.process.command_line 直接對應
ele.action.actioned-object.file-object.file-path target.process.file.full_path 直接對應
file_event_filepath target.process.file.full_path 直接對應
process_event_process_path target.process.file.full_path 直接對應
process_path target.process.file.full_path 直接對應
urlMonitorEvent_processPath target.process.file.full_path 直接對應
md5sum_data target.process.file.md5 直接對應
process_md5 target.process.file.md5 已重新命名/對應
sha1_data target.process.file.sha1 直接對應
sha256_data target.process.file.sha256 直接對應
file_event_actor_process_path target.process.parent_process.file.full_path 直接對應
parent_process_path target.process.parent_process.file.full_path 直接對應
process_event_parent_path target.process.parent_process.file.full_path 直接對應
file_event_actor_process_pid target.process.parent_process.pid 直接對應
parent_process_pid target.process.parent_process.pid 直接對應
process_event_parentPid target.process.parent_process.pid 直接對應
alert.explanation.os-changes.file.processinfo.tid target.process.pid 直接對應
process_event_pid target.process.pid 直接對應
process_pid target.process.pid 直接對應
urlMonitorEvent_pid target.process.pid 直接對應
scanned_registry_key target.registry.registry_key 直接對應
scanned_registry_value target.registry.registry_value_data 直接對應
customer_id target.resource.id 直接對應
alert.explanation.cnc-services.cnc-service.url target.url 直接對應
email target.user.email_addresses 已對應:^.+@.+$ → email
tar_email target.user.email_addresses 已合併
file_event_actor_process_username target.user.user_display_name 直接對應
process_event_username target.user.user_display_name 直接對應
urlMonitorEvent_username target.user.user_display_name 直接對應
不適用 metadata.event_type 常數:GENERIC_EVENT
不適用 metadata.product_name 常數:FIREEYE_ALERT
不適用 metadata.vendor_name 常數:FIREEYE_ALERT
不適用 network.application_protocol 常數:SMTP
不適用 principal.platform 常數:WINDOWS
不適用 security_result.about.resource.type 常數:Email
不適用 security_result.confidence 常數:HIGH_CONFIDENCE
不適用 security_result.severity 常數:LOW

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。