收集 Trellix (舊稱 FireEye) PX 記錄

剖析器版本:1.0

支援:

本文說明如何使用 Bindplane 代理程式,將 FireEye (現稱 Trellix) PX 記錄檔擷取至 Google Security Operations。

Trellix PX (網路鑑識) 會擷取完整網路封包,並產生有關擷取工作階段、偵測到的威脅和網路構件的中繼資料記錄檔。剖析器會將這些記錄對應至統合式資料模型 (UDM),擷取網路連線詳細資料、DNS 查詢和回應、HTTP 中繼資料,以及流量層級屬性。

事前準備

請確認您符合下列必要條件:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式和 Trellix PX 設備之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • 具備管理員角色的 Trellix PX 設備特殊存取權

取得 Bindplane 代理程式的 Google SecOps 憑證

如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:

  • 新部署作業:使用 Chronicle API (選項 1)。
  • 舊版部署作業:在 2027 年 7 月 20 日停用 Ingestion API 前,請繼續使用擷取驗證檔案 (選項 2)。
  1. 登入 Google Cloud 控制台,然後選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
  2. 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
  3. 按一下「建立服務帳戶」。
  4. 提供下列設定詳細資料:
    • 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如 bindplane-ingest)。
    • 服務帳戶說明:輸入說明 (例如 Bindplane agent log ingestion)。
  5. 點按「Create and continue」(建立並繼續)。
  6. 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
  7. 依序點選「繼續」和「完成」。
  8. 按一下您建立的服務帳戶,然後前往「金鑰」分頁標籤。
  9. 依序點選「新增金鑰」>「建立新的金鑰」。
  10. 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
  11. 將金鑰檔案儲存為 Bindplane 收集器目錄中的 ingestion-auth.json (Linux 為 /opt/observiq-otel-collector/ingestion-auth.json,Windows 為 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新 config.yaml 中的 creds_file_path,使其與儲存檔案的路徑相符。
  12. 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。匯出工具設定時會用到。

方法 2:下載擷取驗證檔案 (舊版)

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」。
  3. 下載擷取驗證檔案。
  4. 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統中。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」 > 「設定檔」。
  3. 複製並儲存「機構詳細資料」部分的客戶 ID。

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟命令提示字元或 PowerShell。
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」。

Linux 安裝

  1. 開啟具有 root 或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為「active (running)」。

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。

設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • 將 config.yaml 的全部內容替換為下列設定:

    receivers:
      tcplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/fireeye_px:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: FIREEYE_PX
        raw_log_field: body
    
    service:
      pipelines:
        logs/fireeye_px_to_chronicle:
          receivers:
            - tcplog
          exporters:
            - chronicle/fireeye_px
    

設定參數

替換下列預留位置:

  • 接收器設定:

    • listen_address:要接聽的 IP 位址和通訊埠:
      • 0.0.0.0:在所有介面上監聽 (建議)
      • 通訊埠 514 是標準 syslog 通訊埠 (在 Linux 上需要根目錄;非根目錄請使用 1514)
  • 匯出工具設定:

    • creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:從 Google SecOps 控制台複製的客戶 ID
    • location:將 <LOCATION> 替換為 Google SecOps 執行個體的區域 (例如 us、europe 或 asia-southeast1)。匯出工具會在這個值前面加上 chronicle.googleapis.com。如需完整清單,請參閱「區域性端點」。
    • project:依序前往「IAM 與管理」>「設定」,然後將 <PROJECT_NUMBER> 替換為專案編號。
    • endpoint:維持設為 chronicle.googleapis.com。

舊版擷取 API 匯出工具

  • 如果您使用選項 2 的擷取驗證檔案,請將 exporters 區塊替換為下列內容。將 creds_file_path 設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將 malachiteingestion-pa.googleapis.com 替換為區域端點 (例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/fireeye_px:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: FIREEYE_PX
        raw_log_field: body
    

儲存設定檔

  • 編輯完畢後,請儲存檔案:
    • Linux:依序按下 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,套用變更

  • 如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務是否正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 檢查記錄是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列任一選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R 鍵,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出「observIQ OpenTelemetry Collector」。
      3. 按一下滑鼠右鍵,然後選取「重新啟動」。
      4. 確認服務是否正在執行:

        sc query observiq-otel-collector
        
      5. 查看記錄檔是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

設定 FireEye PX 系統記錄轉送

  1. 登入 FireEye PX 網頁管理介面。
  2. 依序前往「設定」>「通知」>「系統記錄」。
  3. 按一下「新增系統記錄伺服器」 (或編輯現有項目)。
  4. 提供下列設定詳細資料:
    • 「Server」(伺服器):輸入 Bindplane 代理程式主機的 IP 位址 (例如 192.168.1.100)。
    • 「Port」(通訊埠):輸入 514。
    • 通訊協定:選取「TCP」。
  5. 選取要轉送的事件類型:
    • 工作階段中繼資料
    • 偵測到的威脅
    • 網路構件
    • DNS 查詢和回應
    • HTTP 中繼資料
  6. 按一下 [儲存]。
  7. 檢查 Bindplane 代理程式記錄,確認是否收到記錄。

UDM 對應表

記錄欄位 UDM 對應 邏輯
dns.authorities.0.rrname dns_answers.name 如果值不為空,則直接複製
dns.authorities.0.ttl dns_answers.ttl 如果不是空白,則會先轉換為字串,再轉換為 uinteger
dns.authorities.0.rrtype dns_answers.type 根據 rrtype 字串 (A=1、AAAA=28 等) 對應至數值,然後轉換為 uinteger (如不為空)
dns.dnsQName dns_question.name 如果值不為空,則直接複製
dns.dnsQRType dns_question.type 根據 rrtype 字串 (A=1、AAAA=28 等) 對應至數值,然後轉換為 uinteger (如不為空)
dns.dnsFlags、pxflow.octetDeltaCount、pxflow.octetDeltaCountReverse event.idm.read_only_udm.additional.fields 如果不是空白,則合併為標籤 (flags_label、octetDeltaCount_label、octetDeltaCountReverse_label)
event_type metadata.event_type 如果 event_type == "http" 且有主體和目標,則設為 NETWORK_HTTP;如果 event_type == "dns" 且有主體和目標,則設為 NETWORK_DNS;如果沒有主體和目標,則設為 NETWORK_CONNECTION;如果沒有,則設為 GENERIC_EVENT
pxuuid metadata.product_log_id 如果不是空白,則直接複製值
dns_answers network.dns.answers 如果不是空白,則直接合併
dns.dnsId network.dns.id 如果不是空白,則重新命名並轉換為 uinteger
dns_question network.dns.questions 如果不是空白,則直接合併
dns.rcode network.dns.response_code 根據 rcode 字串 (NOERROR=0、FORMERR=1 等) 對應至數字回應代碼,然後轉換為 uinteger
http.httpMethod network.http.method 如果不是空白,則直接複製值
http.http_user_agent network.http.user_agent 如果不是空白,則直接複製值
protocolIdentifierName network.ip_protocol 如果值不為空,則直接複製
flow_id network.session_id 轉換為字串,如果不是空白,則直接複製
pxflow.egressInterface principal.asset.attribute.labels 如果不是空白,則合併為 egress_interface 標籤
http.httpHost principal.hostname 直接複製值,如果值不為空,則將 has_principal 設為 true
sourceIPv4Address principal.ip 使用 grok 模式 %{IP:ip} 擷取,如果 grok 成功,則合併
pxflow.sourceEtherAddress principal.mac 直接合併,如果不是空白,則將 has_principal 設為 true
sourceTransportPort principal.port 重新命名並轉換為整數 (如果不是空白)
感應器 security_result.about.labels 如果不是空白,則合併為 sensor_label
in_iface security_result.rule_labels 如果不是空白,則合併為 in_iface_label
pxflow.ingressInterface target.asset.attribute.labels 如果不是空白,則合併為 ingress_interface 標籤
destinationIPv4Address target.ip 使用 grok 模式「%{IP:ip}」擷取,如果 grok 成功,則合併
pxflow.destinationEtherAddress target.mac 直接合併,並在不為空白時將 has_target 設為 true
destinationTransportPort target.port 重新命名並轉換為整數 (如不為空)
http.httpURL target.url 如果值不為空,則直接複製
metadata.vendor_name 設為「Fireeye」
metadata.product_name 設為「PX」

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。