收集 Forescout eyeInspect 日志

解析器版本:12.0

支持的语言:

本文档介绍了如何使用 Bindplane 代理将 Forescout eyeInspect 日志注入到 Google Security Operations。

Forescout eyeInspect 是一个 OT/ICS 网络监控平台,可在运营技术环境中提供工业协议深度数据包检测、资产发现和威胁检测。它会以 CEF 格式生成工业网络事件的提醒和审核日志。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 Forescout eyeInspect Command Center 之间的网络连接
  • 如果在代理后面运行,请确保按照 Bindplane 代理要求打开防火墙端口
  • 具有管理员权限的 Forescout eyeInspect Command Center 特权访问权限

获取 Bindplane 代理的 Google SecOps 凭证

如需向 Google SecOps 验证 Bindplane 代理,请选择以下方法之一:

  • 新部署:使用 Chronicle API(选项 1)。
  • 旧版部署:继续使用提取身份验证文件(方法 2),直到提取 API 于 2027 年 7 月 20 日停用。
  1. 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
  2. 前往 IAM 和管理 > 服务账号。
  3. 点击创建服务账号。
  4. 提供以下配置详细信息:
    • 服务账号名称:输入账号的名称(例如 bindplane-ingest)。
    • 服务账号说明:输入说明(例如 Bindplane agent log ingestion)。
  5. 点击创建并继续。
  6. 在向此服务账号授予对项目的访问权限部分,点击选择角色,然后选择 Chronicle Editor。
  7. 点击继续,然后点击完成。
  8. 点击您创建的服务账号,然后前往密钥标签页。
  9. 依次点击添加密钥 > 创建新密钥。
  10. 选择 JSON,然后点击创建。密钥文件会下载到您的计算机上。
  11. 将密钥文件另存为 Bindplane 收集器目录(Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)中的 ingestion-auth.json,或更新 config.yaml 中的 creds_file_path 以匹配您保存该文件的路径。
  12. 前往 IAM 和管理 > 设置,然后复制项目编号。您在配置导出器时需要用到该名称。

方法 2:下载数据注入身份验证文件(旧版)

  1. 登录 Google SecOps 控制台。
  2. 前往 SIEM 设置> 收集代理。
  3. 下载数据注入身份验证文件。
  4. 将文件安全地保存在将安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 前往 SIEM 设置 > 个人资料。
  3. 复制并保存组织详细信息部分中的客户 ID。

安装 Bindplane 代理

按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符或 PowerShell。
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

    该服务应显示为 RUNNING。

Linux 安装

  1. 打开具有 root 或 sudo 权限的终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

    该服务应显示为 active (running)。

其他安装资源

如需了解其他安装选项和问题排查,请参阅 Bindplane 代理安装指南。

配置 Bindplane 代理以注入 Syslog 并发送到 Google SecOps

找到配置文件

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • 将 config.yaml 的全部内容替换为以下配置:

    receivers:
      tcplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/forescout_eyeinspect:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: FORESCOUT_EYEINSPECT
        raw_log_field: body
        ingestion_labels:
          env: production
    
    service:
      pipelines:
        logs/eyeinspect_to_chronicle:
          receivers:
            - tcplog
          exporters:
            - chronicle/forescout_eyeinspect
    

配置参数

替换以下占位符:

  • 接收器配置:

    • tcplog:基于协议的接收器类型:
      • udplog(适用于 UDP syslog)
      • tcplog(适用于 TCP syslog)
    • 0.0.0.0:要监听的 IP 地址:
      • 0.0.0.0 在所有接口上监听(推荐)
      • 要在一个接口上监听的特定 IP 地址
    • 514:要监听的端口号(例如 514、1514、6514)
  • 导出器配置:

    • forescout_eyeinspect:导出器的描述性名称
    • creds_file_path:服务账号 JSON 密钥文件的完整路径(选项 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • <customer_id>:上一步中的客户 ID
    • location:将 <LOCATION> 替换为 Google SecOps 实例所在的区域(例如 us、europe 或 asia-southeast1)。导出工具会在此值前面加上 chronicle.googleapis.com。如需查看完整列表,请参阅区域级端点。
    • project:将 <PROJECT_NUMBER> 替换为“IAM 和管理”>“设置”中的项目编号。
    • endpoint:保持设置为 chronicle.googleapis.com。
    • FORESCOUT_EYEINSPECT:日志类型,与 Chronicle 中显示的完全一致
    • ingestion_labels:YAML 格式的可选标签(例如 env: production)
  • 流水线配置:

    • eyeinspect_to_chronicle:流水线的描述性名称

旧版提取 API

  • 如果您使用选项 2 中的提取身份验证文件,请将 exporters 代码块替换为以下内容。将 creds_file_path 设置为数据注入身份验证文件的路径,如果您的实例位于美国境外,请将 malachiteingestion-pa.googleapis.com 替换为您的区域端点(例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/forescout_eyeinspect:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: FORESCOUT_EYEINSPECT
        raw_log_field: body
        ingestion_labels:
          env: production
    

保存配置文件

  • 修改后,保存文件:
    • Linux:依次按 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
    1. 验证服务是否正在运行:

      sudo systemctl status observiq-otel-collector
      
    2. 检查日志中的错误:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:

    • 以管理员身份运行命令提示符或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服务控制台:

      1. 按 Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry 收集器。
      3. 右键点击并选择重启。
      4. 验证服务是否正在运行:

        sc query observiq-otel-collector
        
      5. 检查日志中的错误:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

配置 Forescout eyeInspect syslog 转发

  1. 登录 Forescout eyeInspect Command Center Web 控制台。
  2. 前往提醒转发配置部分。
  3. 点击添加以创建新的提醒转发目的地。
  4. 提供以下配置详细信息:
    • 主机:输入 Bindplane 代理主机(例如 192.168.1.100)的 IP 地址。
    • 端口:输入 514(必须与 Bindplane 代理接收器端口匹配)。
    • 协议:选择 TCP(推荐)或 UDP。
    • 格式:选择 CEF(通用事件格式)。
    • 严重程度:选择信息或更低级别,以捕获所有事件,包括提醒和审核日志。
  5. 点击保存。
  6. 通过检查 Bindplane 代理日志,验证是否正在接收 syslog 消息。

UDM 映射表

日志字段 UDM 映射 逻辑
message about 已映射:CEF: → about
deviceNtDomain about.administrative_domain 已重命名/映射
deviceExternalId about.asset.asset_id 直接映射
device_product about.asset.asset_id 直接映射
device_vendor about.asset.asset_id 直接映射
fileHash about.file.full_path 直接映射
filePath about.file.full_path 已重命名/映射
_hash about.file.sha256 已重命名/已映射
fileHash about.file.sha256 已重命名/已映射
fsize about.file.size 已重命名/已映射
dvchost about.hostname 已重命名/已映射
ips about.ip 已合并
message about.ip 已映射:CEF: → ips
dvc_mac about.mac 已映射:slot → mac_address
dvcmac about.mac 已合并
mac_address about.mac 已合并
message about.mac 已映射:CEF: → mac_address,CEF: → dvcmac
deviceTranslatedAddress about.nat_ip 已合并
message about.nat_ip 已映射:CEF: → deviceTranslatedAddress
Emne about.process.command_line 直接映射
Path about.process.command_line 直接映射
Subject about.process.command_line 直接映射
deviceProcessName about.process.command_line 已重命名/映射
dvcpid about.process.pid 已重命名/映射
message about.resource.attribute.permissions 已映射:CEF: → permissions
permissions about.resource.attribute.permissions 已合并
Assigned_hosts_label additional.fields 已合并
Available_memory_label additional.fields 已合并
Available_swap_label additional.fields 已合并
Connected_clients_label additional.fields 已合并
EM_connection_status_label additional.fields 已合并
Engine_status_label additional.fields 已合并
Installed_Plugins_label additional.fields 已合并
Used_memory_label additional.fields 已合并
Used_swap_label additional.fields 已合并
additional_cfp1 additional.fields 已合并
additional_cfp2 additional.fields 已合并
additional_cfp3 additional.fields 已合并
additional_cfp4 additional.fields 已合并
additional_cn1 additional.fields 已合并
additional_cn2 additional.fields 已合并
additional_cn3 additional.fields 已合并
additional_cs1 additional.fields 已合并
additional_cs2 additional.fields 已合并
additional_cs3 additional.fields 已合并
additional_cs4 additional.fields 已合并
additional_cs5 additional.fields 已合并
additional_cs6 additional.fields 已合并
additional_cs7 additional.fields 已合并
additional_devicePayloadId additional.fields 已合并
additional_eventId additional.fields 已合并
additional_flexString1 additional.fields 已合并
additional_fname additional.fields 已合并
application_status_label additional.fields 已合并
cnt_label additional.fields 已合并
cpu_usage_label additional.fields 已合并
cs2 additional.fields 已映射:arc_test → additional_cs2
cs5_label additional.fields 已合并
event_type additional.fields 映射的值(共 11 个,例如 System statistics → cpu_usage_label、System statistics →…
message additional.fields 映射的值(共 32 个,例如 CEF: → additional_eventId、CEF: → `additional_devicePayl…
type_label additional.fields 已合并
act extensions.auth.type 已映射:(?i)LOGIN → MACHINE
app_protocol extensions.auth.type 已映射:CounterACT → AUTHTYPE_UNSPECIFIED
kv_data extensions.auth.type 已映射:Log: Login → AUTHTYPE_UNSPECIFIED,logged out → AUTHTYPE_UNSPECIFIED
message extensions.auth.type 已映射:CEF: → MACHINE,CEF: → AUTHTYPE_UNSPECIFIED
message intermediary 已映射:CEF: → intermediary
iporhost intermediary.asset.hostname 直接映射
middle_ip intermediary.asset.ip 已合并
deviceDnsDomain intermediary.hostname 直接映射
iporhost intermediary.hostname 直接映射
middle_ip intermediary.ip 已合并
pid intermediary.process.pid 直接映射
desc metadata.description 直接映射
event_type metadata.description 直接映射
msg metadata.description 已重命名/映射
Generated metadata.event_timestamp 已解析为 yyyy-MM-ddTHH:mm:ss
Received metadata.event_timestamp 已解析为 yyyy-MM-ddTHH:mm:ss
rt metadata.event_timestamp 解析为 yyyy-MM-ddTHH:mm:ssZ
time metadata.event_timestamp 已解析为 ISO8601
timestamp metadata.event_timestamp 解析为 ISO8601
ts_syslog metadata.event_timestamp 已解析为 MMM dd HH:mm:ss
act metadata.event_type 已映射:(?i)LOGIN → USER_LOGIN
app_protocol metadata.event_type Mapped: CounterACT → USER_LOGIN, CounterACT → USER_LOGOUT, CounterACT → `GENERIC_E…
app_protocol_output metadata.event_type 已映射:SSH → STATUS_UPDATE
data metadata.event_type 已映射:Target: → NETWORK_CONNECTION
et_lower metadata.event_type Mapped: nac policy log → SCAN_HOST, port bite → SCAN_NETWORK, block event → `NETWO…
event_name metadata.event_type 已映射:"LogSpyware","LogPredictiveMachineLearning" → SCAN_UNCATEGORIZED
has_principal metadata.event_type 已映射:true → NETWORK_CONNECTION
has_target metadata.event_type 已映射:true → USER_UNCATEGORIZED
kv_data metadata.event_type Mapped: Log: Login → USER_LOGIN, logged out → USER_LOGOUT, `RADIUS Authentication re…
message metadata.event_type 映射的值(共 12 个,例如 CEF: → USER_LOGIN、CEF: → USER_RESOURCE_ACCESS、CEF:…
meta_event_type metadata.event_type Mapped: GENERIC_EVENT → NETWORK_CONNECTION, GENERIC_EVENT → STATUS_UPDATE, `GENERIC_…
device_event_class_id metadata.product_event_type 直接映射
engineName metadata.product_event_type 直接映射
event_name metadata.product_event_type 直接映射
eventtype metadata.product_event_type 直接映射
alertId metadata.product_log_id 直接映射
externalId metadata.product_log_id 直接映射
device_product metadata.product_name 直接映射
message metadata.product_name 已映射:CEF: → FORESCOUT EYEINSPECT
product metadata.product_name 直接映射
device_version metadata.product_version 直接映射
device_vendor metadata.vendor_name 已重命名/已映射
message metadata.vendor_name 已映射:CEF: → FORESCOUT
vendor_name metadata.vendor_name 直接映射
app_protocol_output network.application_protocol 直接映射
deviceDirection network.direction 已映射:0 → INBOUND,1 → OUTBOUND
message network.direction 已映射:CEF: → INBOUND,CEF: → OUTBOUND
answers network.dns.answers 已合并
app network.dns.answers 已映射:DNS → answers
message network.dns.answers 已映射:CEF: → answers
app network.dns.questions 已映射:DNS → questions
message network.dns.questions 已映射:CEF: → questions
questions network.dns.questions 已合并
mail_from network.email.from 直接映射
et_lower network.email.subject 映射:mail (anomaly/infection) (attempt/sender/server/amount/attachment/receipeint) → `m…
mail_subject network.email.subject 已合并
message network.email.subject 已映射:CEF: → mail_subject
et_lower network.email.to 已映射:mail (anomaly/infection) (attempt/sender/server/amount/attachment/receipeint) → `m…
mail_to network.email.to 已合并
message network.email.to 已映射:CEF: → mail_to
requestMethod network.http.method 已重命名/已映射
requestClientApplication network.http.user_agent 已重命名/映射
ip_protocol_out network.ip_protocol 直接映射
l4Proto network.ip_protocol 直接映射
protocol network.ip_protocol 直接映射
protocol1 network.ip_protocol 直接映射
downDataLength network.received_bytes 直接映射
in network.received_bytes 已重命名/已映射
message network.received_bytes 已映射:CEF: → uinteger
message network.sent_bytes 已映射:CEF: → uinteger
out network.sent_bytes 已重命名/映射
upDataLength network.sent_bytes 直接映射
session_id network.session_id 直接映射
sensorName observer.hostname 直接映射
sntdom principal.administrative_domain 已重命名/映射
sourceServiceName principal.application 已重命名/映射
Host principal.asset.hostname 直接映射
Hostname principal.asset.hostname 直接映射
Source principal.asset.hostname 直接映射
srcHostName principal.asset.hostname 直接映射
app_protocol principal.asset.ip 已映射:CounterACT → source_ip
app_protocol_output principal.asset.ip 已映射:SSH → source_ip
et_lower principal.asset.ip 已映射:block event → host_ip,(?i)Property change detected → source_ip
host_ip principal.asset.ip 已合并
kv_data principal.asset.ip 已映射:Log: Login → source_ip,logged out → source_ip
message principal.asset.ip 映射:CEF: → srcIp、CEF: → source_ip、CEF: → host_ip、CEF: → src_ip
source_ip principal.asset.ip 已合并
srcIp principal.asset.ip 已合并
src_ip principal.asset.ip 已合并
message principal.asset.mac 已映射:CEF: → srcMac
srcMac principal.asset.mac 已合并
pcapSha1 principal.file.sha1 直接映射
Group_name principal.group.group_display_name 直接映射
Gruppenavn principal.group.group_display_name 直接映射
Device_name principal.hostname 直接映射
Enhetsnavn principal.hostname 直接映射
Host principal.hostname 直接映射
Hostname principal.hostname 直接映射
Source principal.hostname 直接映射
shost principal.hostname 已重命名/映射
srcHostName principal.hostname 直接映射
app_protocol principal.ip 已映射:CounterACT → source_ip
app_protocol_output principal.ip 已映射:SSH → source_ip
et_lower principal.ip 已映射:block event → host_ip,(?i)Property change detected → source_ip
host_ip principal.ip 已合并
kv_data principal.ip 已映射:Log: Login → source_ip,logged out → source_ip
message principal.ip 映射的值(共 6 个,例如 CEF: → principal_ip、CEF: → shost、CEF: → srcIp)
principal_ip principal.ip 已合并
shost principal.ip 已合并
source_ip principal.ip 已合并
srcIp principal.ip 已合并
src_ip principal.ip 已合并
MAC principal.mac 已合并
et_lower principal.mac 已映射:(?i)Property change detected → MAC
mac principal.mac 已合并
message principal.mac 映射:CEF: → mac、CEF: → srcMac、CEF: → MAC、CEF: → src_mac
srcMac principal.mac 已合并
src_mac principal.mac 已合并
message principal.nat_ip 已映射:CEF: → sourceTranslatedAddress
sourceTranslatedAddress principal.nat_ip 已合并
sourceTranslatedPort principal.nat_port 已重命名/映射
source_port principal.port 已重命名/已映射
spt principal.port 已重命名/映射
srcPort principal.port 直接映射
src_port principal.port 直接映射
command principal.process.command_line 直接映射
sproc principal.process.command_line 已重命名/映射
spid principal.process.pid 已重命名/映射
resource principal.resource.name 直接映射
message principal.user.attribute.roles 已映射:CEF: → principal_role
principal_role principal.user.attribute.roles 已合并
suser principal.user.user_display_name 直接映射
User principal.user.userid 直接映射
suid principal.user.userid 已重命名/映射
user_id principal.user.userid 直接映射
user_name principal.user.userid 直接映射
username principal.user.userid 直接映射
app_protocol security_result 已映射:CounterACT → sec_result
data security_result 已映射:Target: → sec_result
kv_data security_result 已映射:Log: Login → sec_result、logged out → sec_result、`RADIUS 身份验证结果`
message security_result 已映射:CEF: → security_result,CEF: → sec_result
sec_result security_result 已合并
message security_result.about.resource.attribute.labels 已映射:CEF: → res_label
res_label security_result.about.resource.attribute.labels 已合并
_action security_result.action 已合并
act security_result.action 已映射:accept → _action,deny → _action
action_status security_result.action 已映射:"success", "successful" → sec_action
app_protocol security_result.action 已映射:CounterACT → sec_action
et_lower security_result.action 已映射:block event → security_result_action
kv_data security_result.action 已映射:Log: Login → sec_action
message security_result.action 映射:CEF: → _action、CEF: → sec_action、CEF: → security_result_action
sec_action security_result.action 已合并
security_result_action security_result.action 已合并
Action_Taken security_result.action_details 直接映射
act security_result.action_details 直接映射
cat security_result.alert_state 已映射:alert → ALERTING
message security_result.alert_state 已映射:CEF: → ALERTING,CEF: → NOT_ALERTING
message security_result.attack_details.tactics 已映射:CEF: → tactics
tactics security_result.attack_details.tactics 已合并
message security_result.attack_details.techniques 已映射:CEF: → techniques
techniques security_result.attack_details.techniques 已合并
alertCategory security_result.category_details 已合并
cat security_result.category_details 已合并
message security_result.category_details 已映射:CEF: → cat,CEF: → alertCategory
Category security_result.description 直接映射
Reason security_result.description 直接映射
Scan_Type security_result.description 直接映射
Type security_result.description 直接映射
act security_result.description 直接映射
description security_result.description 直接映射
details security_result.description 直接映射
et_lower security_result.description 直接映射
event_type security_result.description 直接映射
kv_data security_result.description 直接映射
msg_data_2 security_result.description 直接映射
policy_details security_result.description 直接映射
rnmsg security_result.description 直接映射
dstMacVendor_label security_result.detection_fields 已合并
infection_channel_label security_result.detection_fields 已合并
l2Proto_label security_result.detection_fields 已合并
l3Proto_label security_result.detection_fields 已合并
message security_result.detection_fields 映射值(总共 13 个,例如 CEF: → operation_label、CEF: → operasjon_label、CEF:…
operasjon_label security_result.detection_fields 已合并
operation_label security_result.detection_fields 已合并
permission_label security_result.detection_fields 已合并
protocol_label security_result.detection_fields 已合并
protocol_type security_result.detection_fields 已映射:IP → protocol_label
spyware_Grayware_Type_label security_result.detection_fields 已合并
srcMacVendor_label security_result.detection_fields 已合并
status_label security_result.detection_fields 已合并
threat_probability_label security_result.detection_fields 已合并
tillatelse_label security_result.detection_fields 已合并
Rule security_result.rule_id 直接映射
alert_id security_result.rule_id 直接映射
device_event_class_id security_result.rule_id 直接映射
typeId security_result.rule_id 直接映射
Match security_result.rule_name 直接映射
et_lower security_result.rule_name 已映射:block event → Virtual Firewall blocking
is_fw_blocking security_result.rule_name 已映射:true → Virtual Firewall blocking
message security_result.rule_name 已映射:CEF: → Virtual Firewall blocking
mwProfile security_result.rule_name 直接映射
name security_result.rule_name 直接映射
message security_result.severity 映射的值(总共 6 个,例如 CEF: → LOW、CEF: → MEDIUM、CEF: → HIGH)
severity security_result.severity 映射的值(共 13 个,例如 "0", "1", "2", "3", "LOW" → LOW、`“4”“5”“6”“MEDIUM”…
severity security_result.severity_details 直接映射
Result security_result.summary 直接映射
appcategory security_result.summary 直接映射
event_name security_result.summary 直接映射
event_type security_result.summary 直接映射
log_description security_result.summary 直接映射
reason security_result.summary 已重命名/映射
Spyware security_result.threat_name 直接映射
Unknown_Threat security_result.threat_name 直接映射
Virus_Malware_Name security_result.threat_name 直接映射
threat security_result.threat_name 直接映射
oldFilePath src.file.full_path 已重命名/映射
oldFileSize src.file.size 已重命名/映射
message src.resource.attribute.permissions 已映射:CEF: → old_permissions
old_permissions src.resource.attribute.permissions 已合并
dntdom target.administrative_domain 已重命名/映射
destinationServiceName target.application 已重命名/映射
Destination target.asset.hostname 直接映射
Target target.asset.hostname 直接映射
computer_name target.asset.hostname 直接映射
dstHostName target.asset.hostname 直接映射
Destination target.asset.ip 已合并
app_protocol target.asset.ip 已映射:CounterACT → target_ip,CounterACT → Destination
data target.asset.ip 已映射:Target: → Destination
dest_ip target.asset.ip 已合并
destination_ip target.asset.ip 已合并
dstIp target.asset.ip 已合并
et_lower target.asset.ip 已映射:port bite → destination_ip,block event → target_ip
kv_data target.asset.ip 已映射:Log: Login → target_ip
message target.asset.ip 映射的值(共 5 个,例如 CEF: → dstIp、CEF: → target_ip、CEF: → Destination)
target_ip target.asset.ip 已合并
dstMac target.asset.mac 已合并
message target.asset.mac 已映射:CEF: → dstMac
Destination target.hostname 直接映射
Target target.hostname 直接映射
computer_name target.hostname 直接映射
dstHostName target.hostname 直接映射
temp_dhost target.hostname 直接映射
Destination target.ip 已合并
IPv6_Address target.ip 已合并
app_protocol target.ip 已映射:CounterACT → target_ip,CounterACT → Destination
data target.ip 已映射:Target: → Destination
dest_ip target.ip 已合并
destination_ip target.ip 已合并
dstIp target.ip 已合并
dst_ip target.ip 已合并
et_lower target.ip 已映射:port bite → destination_ip,block event → target_ip
ipv6 target.ip 已映射:- → IPv6_Address
kv_data target.ip 已映射:Log: Login → target_ip
message target.ip 映射的值(共 7 个,例如 CEF: → dst_ip、CEF: → IPv6_Address、CEF: → dstIp)
target_ip target.ip 已合并
dest_mac target.mac 已合并
dstMac target.mac 已合并
mac_address target.mac 已合并
message target.mac 映射:CEF: → mac_address、CEF: → dstMac、CEF: → dest_mac
destination_translated_address target.nat_ip 已合并
message target.nat_ip 已映射:CEF: → destination_translated_address
destinationTranslatedPort target.nat_port 已重命名/映射
dest_port target.port 直接映射
dpt target.port 已重命名/映射
dstPort target.port 直接映射
port target.port 已重命名/映射
dproc target.process.command_line 已重命名/映射
File_name target.process.file.full_path 直接映射
Infected_Resource target.process.file.full_path 直接映射
Object target.process.file.full_path 直接映射
Objekt target.process.file.full_path 直接映射
dpid target.process.pid 已重命名/映射
message target.resource.attribute.labels 已映射:CEF: → resource_Type_label
resource_Type_label target.resource.attribute.labels 已合并
request target.url 直接映射
message target.user.attribute.roles 已映射:CEF: → target_role
target_role target.user.attribute.roles 已合并
CustomerName target.user.user_display_name 直接映射
temp_duser target.user.user_display_name 直接映射
Bruker target.user.userid 直接映射
User_value target.user.userid 直接映射
temp_duid target.user.userid 直接映射
username target.user.userid 直接映射
不适用 extensions.auth.type 常量:MACHINE
不适用 metadata.event_type 常量:USER_LOGIN
不适用 metadata.product_name 常量:FORESCOUT EYEINSPECT
不适用 metadata.vendor_name 常量:FORESCOUT
不适用 network.direction 常量:INBOUND
不适用 security_result.alert_state 常量:ALERTING
不适用 security_result.rule_name 常量:Virtual Firewall blocking
不适用 security_result.severity 常量:LOW
app_protocol_src network.application_protocol 从更新日志映射
Category" and "policy_details security_result.description 从更新日志映射
CPU_usage", "Available_memory", "Used_memory", "Available_swap", "Used_swap additional.fields 从更新日志映射
application_status", "Connected_clients", "EM_connection_status", "Assigned_hosts", "Engine_status", "Installed_Plugins additional.fields 从更新日志映射
alart_id security_result.rule_id 从更新日志映射
protocol2 security_result.detection_fields 从更新日志映射

更新日志

查看相应解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。