收集 Forescout eyeInspect 記錄

剖析器版本:12.0

支援的國家/地區:

本文說明如何使用 Bindplane 代理程式,將 Forescout eyeInspect 記錄擷取至 Google Security Operations。

Forescout eyeInspect 是 OT/ICS 網路監控平台,可深入檢查工業通訊協定封包、探索資產,以及偵測營運技術環境中的威脅。並以 CEF 格式產生工業網路事件的快訊和稽核記錄。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 Forescout eyeInspect Command Center 之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • 具備管理員權限,可存取 Forescout eyeInspect Command Center

取得 Google SecOps 擷取驗證檔案

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」
  3. 下載擷取驗證檔案
  4. 將檔案安全地儲存在要安裝 Bindplane 的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」
  3. 複製並儲存「機構詳細資料」部分中的客戶 ID

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟「命令提示字元」或「PowerShell」
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」

Linux 安裝

  1. 開啟具有根層級或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為有效 (執行中)

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南

設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • config.yaml 的所有內容替換為下列設定:

    receivers:
        tcplog:
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/forescout_eyeinspect:
            compression: gzip
            creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
            customer_id: '<customer_id>'
            endpoint: malachiteingestion-pa.googleapis.com
            log_type: FORESCOUT_EYEINSPECT
            raw_log_field: body
            ingestion_labels:
                env: production
    
    service:
        pipelines:
            logs/eyeinspect_to_chronicle:
                receivers:
                    - tcplog
                exporters:
                    - chronicle/forescout_eyeinspect
    

設定參數

替換下列預留位置:

  • 接收器設定:

    • tcplog:根據通訊協定的接收器類型:
      • udplog (適用於 UDP 系統記錄檔)
      • tcplog (適用於 TCP Syslog)
    • 0.0.0.0:要接聽的 IP 位址:
      • 0.0.0.0,監聽所有介面 (建議)
      • 在一個介面上接聽的特定 IP 位址
    • 514:要接聽的通訊埠號碼 (例如 51415146514)
  • 匯出工具設定:

    • forescout_eyeinspect:匯出工具的說明名稱
    • creds_file_path:擷取驗證檔案的完整路徑:
      • Linux/etc/bindplane-agent/ingestion-auth.json
      • WindowsC:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • <customer_id>:上一步中的客戶 ID
    • endpoint:區域端點網址:
      • 美國malachiteingestion-pa.googleapis.com
      • 歐洲europe-malachiteingestion-pa.googleapis.com
      • 亞洲asia-southeast1-malachiteingestion-pa.googleapis.com
      • 如需完整清單,請參閱「區域端點
    • FORESCOUT_EYEINSPECT:記錄類型,與 Chronicle 中顯示的完全相同
    • ingestion_labels:YAML 格式的選用標籤 (例如 env: production)
  • 管道設定:

    • eyeinspect_to_chronicle:管道的說明名稱

儲存設定檔

  • 編輯完成後,請儲存檔案:
    • Linux:依序按下 Ctrl+OEnterCtrl+X
    • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,以套用變更

  • 如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 檢查記錄中是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出 observIQ OpenTelemetry Collector
      3. 按一下滑鼠右鍵,然後選取「重新啟動」
      4. 確認服務正在執行:

        sc query observiq-otel-collector
        
      5. 檢查記錄中是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

設定 Forescout eyeInspect 系統記錄檔轉送功能

  1. 登入 Forescout eyeInspect Command Center 網路主控台。
  2. 前往「快訊轉送」設定部分。
  3. 按一下「新增」,建立新的快訊轉送目的地。
  4. 請提供下列設定詳細資料:
    • 主機:輸入 Bindplane 代理程式主機的 IP 位址 (例如 192.168.1.100)。
    • 「Port」(通訊埠):輸入 514 (必須與 Bindplane 代理程式接收器通訊埠一致)。
    • 通訊協定:選取「TCP」 (建議) 或「UDP」
    • 格式:選取「CEF」(通用事件格式)
    • 嚴重性:選取「資訊」或更低的嚴重性,即可擷取所有事件,包括快訊和稽核記錄。
  5. 按一下 [儲存]
  6. 查看 Bindplane 代理程式記錄,確認是否收到系統記錄訊息。

UDM 對應表

記錄欄位 UDM 對應 邏輯
message about 已對應:CEF:about
deviceNtDomain about.administrative_domain 已重新命名/對應
deviceExternalId about.asset.asset_id 直接對應
device_product about.asset.asset_id 直接對應
device_vendor about.asset.asset_id 直接對應
fileHash about.file.full_path 直接對應
filePath about.file.full_path 已重新命名/對應
_hash about.file.sha256 已重新命名/對應
fileHash about.file.sha256 已重新命名/對應
fsize about.file.size 已重新命名/對應
dvchost about.hostname 已重新命名/對應
ips about.ip 已合併
message about.ip 已對應:CEF:ips
dvc_mac about.mac 已對應:slotmac_address
dvcmac about.mac 已合併
mac_address about.mac 已合併
message about.mac 已對應:CEF:mac_addressCEF:dvcmac
deviceTranslatedAddress about.nat_ip 已合併
message about.nat_ip 已對應:CEF:deviceTranslatedAddress
Emne about.process.command_line 直接對應
Path about.process.command_line 直接對應
Subject about.process.command_line 直接對應
deviceProcessName about.process.command_line 已重新命名/對應
dvcpid about.process.pid 已重新命名/對應
message about.resource.attribute.permissions 已對應:CEF:permissions
permissions about.resource.attribute.permissions 已合併
Assigned_hosts_label additional.fields 已合併
Available_memory_label additional.fields 已合併
Available_swap_label additional.fields 已合併
Connected_clients_label additional.fields 已合併
EM_connection_status_label additional.fields 已合併
Engine_status_label additional.fields 已合併
Installed_Plugins_label additional.fields 已合併
Used_memory_label additional.fields 已合併
Used_swap_label additional.fields 已合併
additional_cfp1 additional.fields 已合併
additional_cfp2 additional.fields 已合併
additional_cfp3 additional.fields 已合併
additional_cfp4 additional.fields 已合併
additional_cn1 additional.fields 已合併
additional_cn2 additional.fields 已合併
additional_cn3 additional.fields 已合併
additional_cs1 additional.fields 已合併
additional_cs2 additional.fields 已合併
additional_cs3 additional.fields 已合併
additional_cs4 additional.fields 已合併
additional_cs5 additional.fields 已合併
additional_cs6 additional.fields 已合併
additional_cs7 additional.fields 已合併
additional_devicePayloadId additional.fields 已合併
additional_eventId additional.fields 已合併
additional_flexString1 additional.fields 已合併
additional_fname additional.fields 已合併
application_status_label additional.fields 已合併
cnt_label additional.fields 已合併
cpu_usage_label additional.fields 已合併
cs2 additional.fields 已對應:arc_testadditional_cs2
cs5_label additional.fields 已合併
event_type additional.fields 對應值 (共 11 個,例如 System statisticscpu_usage_labelSystem statistics →...
message additional.fields 對應值 (共 32 個,例如 CEF:additional_eventIdCEF: → `additional_devicePayl...
type_label additional.fields 已合併
act extensions.auth.type 已對應:(?i)LOGINMACHINE
app_protocol extensions.auth.type 已對應:CounterACTAUTHTYPE_UNSPECIFIED
kv_data extensions.auth.type 已對應:Log: LoginAUTHTYPE_UNSPECIFIEDlogged outAUTHTYPE_UNSPECIFIED
message extensions.auth.type 已對應:CEF:MACHINECEF:AUTHTYPE_UNSPECIFIED
message intermediary 已對應:CEF:intermediary
iporhost intermediary.asset.hostname 直接對應
middle_ip intermediary.asset.ip 已合併
deviceDnsDomain intermediary.hostname 直接對應
iporhost intermediary.hostname 直接對應
middle_ip intermediary.ip 已合併
pid intermediary.process.pid 直接對應
desc metadata.description 直接對應
event_type metadata.description 直接對應
msg metadata.description 已重新命名/對應
Generated metadata.event_timestamp 已剖析為 yyyy-MM-ddTHH:mm:ss
Received metadata.event_timestamp 已剖析為 yyyy-MM-ddTHH:mm:ss
rt metadata.event_timestamp 已剖析為 yyyy-MM-ddTHH:mm:ssZ
time metadata.event_timestamp 已剖析為 ISO8601
timestamp metadata.event_timestamp 已剖析為 ISO8601
ts_syslog metadata.event_timestamp 已剖析為 MMM dd HH:mm:ss
act metadata.event_type 已對應:(?i)LOGINUSER_LOGIN
app_protocol metadata.event_type 已對應:CounterACTUSER_LOGINCounterACTUSER_LOGOUTCounterACT → `GENERIC_E...
app_protocol_output metadata.event_type 已對應:SSHSTATUS_UPDATE
data metadata.event_type 已對應:Target:NETWORK_CONNECTION
et_lower metadata.event_type 對應:nac policy logSCAN_HOSTport biteSCAN_NETWORKblock event → `NETWO...
event_name metadata.event_type 已對應:"LogSpyware","LogPredictiveMachineLearning"SCAN_UNCATEGORIZED
has_principal metadata.event_type 已對應:trueNETWORK_CONNECTION
has_target metadata.event_type 已對應:trueUSER_UNCATEGORIZED
kv_data metadata.event_type 已對應:Log: LoginUSER_LOGINlogged outUSER_LOGOUT、`RADIUS Authentication re...
message metadata.event_type 對應值 (共 12 個,例如 CEF:USER_LOGINCEF:USER_RESOURCE_ACCESSCEF:...
meta_event_type metadata.event_type 已對應:GENERIC_EVENTNETWORK_CONNECTIONGENERIC_EVENTSTATUS_UPDATE、`GENERIC_...
device_event_class_id metadata.product_event_type 直接對應
engineName metadata.product_event_type 直接對應
event_name metadata.product_event_type 直接對應
eventtype metadata.product_event_type 直接對應
alertId metadata.product_log_id 直接對應
externalId metadata.product_log_id 直接對應
device_product metadata.product_name 直接對應
message metadata.product_name 已對應:CEF:FORESCOUT EYEINSPECT
product metadata.product_name 直接對應
device_version metadata.product_version 直接對應
device_vendor metadata.vendor_name 已重新命名/對應
message metadata.vendor_name 已對應:CEF:FORESCOUT
vendor_name metadata.vendor_name 直接對應
app_protocol_output network.application_protocol 直接對應
deviceDirection network.direction 已對應:0INBOUND1OUTBOUND
message network.direction 已對應:CEF:INBOUNDCEF:OUTBOUND
answers network.dns.answers 已合併
app network.dns.answers 已對應:DNSanswers
message network.dns.answers 已對應:CEF:answers
app network.dns.questions 已對應:DNSquestions
message network.dns.questions 已對應:CEF:questions
questions network.dns.questions 已合併
mail_from network.email.from 直接對應
et_lower network.email.subject 已對應:mail (anomaly/infection) (attempt/sender/server/amount/attachment/receipeint) → `m...
mail_subject network.email.subject 已合併
message network.email.subject 已對應:CEF:mail_subject
et_lower network.email.to 已對應:mail (anomaly/infection) (attempt/sender/server/amount/attachment/receipeint) → `m...
mail_to network.email.to 已合併
message network.email.to 已對應:CEF:mail_to
requestMethod network.http.method 已重新命名/對應
requestClientApplication network.http.user_agent 已重新命名/對應
ip_protocol_out network.ip_protocol 直接對應
l4Proto network.ip_protocol 直接對應
protocol network.ip_protocol 直接對應
protocol1 network.ip_protocol 直接對應
downDataLength network.received_bytes 直接對應
in network.received_bytes 已重新命名/對應
message network.received_bytes 已對應:CEF:uinteger
message network.sent_bytes 已對應:CEF:uinteger
out network.sent_bytes 已重新命名/對應
upDataLength network.sent_bytes 直接對應
session_id network.session_id 直接對應
sensorName observer.hostname 直接對應
sntdom principal.administrative_domain 已重新命名/對應
sourceServiceName principal.application 已重新命名/對應
Host principal.asset.hostname 直接對應
Hostname principal.asset.hostname 直接對應
Source principal.asset.hostname 直接對應
srcHostName principal.asset.hostname 直接對應
app_protocol principal.asset.ip 已對應:CounterACTsource_ip
app_protocol_output principal.asset.ip 已對應:SSHsource_ip
et_lower principal.asset.ip 已對應:block eventhost_ip(?i)Property change detectedsource_ip
host_ip principal.asset.ip 已合併
kv_data principal.asset.ip 已對應:Log: Loginsource_iplogged outsource_ip
message principal.asset.ip 已對應:CEF:srcIpCEF:source_ipCEF:host_ipCEF:src_ip
source_ip principal.asset.ip 已合併
srcIp principal.asset.ip 已合併
src_ip principal.asset.ip 已合併
message principal.asset.mac 已對應:CEF:srcMac
srcMac principal.asset.mac 已合併
pcapSha1 principal.file.sha1 直接對應
Group_name principal.group.group_display_name 直接對應
Gruppenavn principal.group.group_display_name 直接對應
Device_name principal.hostname 直接對應
Enhetsnavn principal.hostname 直接對應
Host principal.hostname 直接對應
Hostname principal.hostname 直接對應
Source principal.hostname 直接對應
shost principal.hostname 已重新命名/對應
srcHostName principal.hostname 直接對應
app_protocol principal.ip 已對應:CounterACTsource_ip
app_protocol_output principal.ip 已對應:SSHsource_ip
et_lower principal.ip 已對應:block eventhost_ip(?i)Property change detectedsource_ip
host_ip principal.ip 已合併
kv_data principal.ip 已對應:Log: Loginsource_iplogged outsource_ip
message principal.ip 對應值 (共 6 個,例如 CEF:principal_ipCEF:shostCEF:srcIp)
principal_ip principal.ip 已合併
shost principal.ip 已合併
source_ip principal.ip 已合併
srcIp principal.ip 已合併
src_ip principal.ip 已合併
MAC principal.mac 已合併
et_lower principal.mac 已對應:(?i)Property change detectedMAC
mac principal.mac 已合併
message principal.mac 已對應:CEF:macCEF:srcMacCEF:MACCEF:src_mac
srcMac principal.mac 已合併
src_mac principal.mac 已合併
message principal.nat_ip 已對應:CEF:sourceTranslatedAddress
sourceTranslatedAddress principal.nat_ip 已合併
sourceTranslatedPort principal.nat_port 已重新命名/對應
source_port principal.port 已重新命名/對應
spt principal.port 已重新命名/對應
srcPort principal.port 直接對應
src_port principal.port 直接對應
command principal.process.command_line 直接對應
sproc principal.process.command_line 已重新命名/對應
spid principal.process.pid 已重新命名/對應
resource principal.resource.name 直接對應
message principal.user.attribute.roles 已對應:CEF:principal_role
principal_role principal.user.attribute.roles 已合併
suser principal.user.user_display_name 直接對應
User principal.user.userid 直接對應
suid principal.user.userid 已重新命名/對應
user_id principal.user.userid 直接對應
user_name principal.user.userid 直接對應
username principal.user.userid 直接對應
app_protocol security_result 已對應:CounterACTsec_result
data security_result 已對應:Target:sec_result
kv_data security_result 已對應:Log: Loginsec_resultlogged outsec_result、`RADIUS Authentication res...
message security_result 已對應:CEF:security_resultCEF:sec_result
sec_result security_result 已合併
message security_result.about.resource.attribute.labels 已對應:CEF:res_label
res_label security_result.about.resource.attribute.labels 已合併
_action security_result.action 已合併
act security_result.action 已對應:accept_actiondeny_action
action_status security_result.action 已對應:"success", "successful"sec_action
app_protocol security_result.action 已對應:CounterACTsec_action
et_lower security_result.action 已對應:block eventsecurity_result_action
kv_data security_result.action 已對應:Log: Loginsec_action
message security_result.action 對應:CEF:_actionCEF:sec_actionCEF:security_result_action
sec_action security_result.action 已合併
security_result_action security_result.action 已合併
Action_Taken security_result.action_details 直接對應
act security_result.action_details 直接對應
cat security_result.alert_state 已對應:alertALERTING
message security_result.alert_state 已對應:CEF:ALERTINGCEF:NOT_ALERTING
message security_result.attack_details.tactics 已對應:CEF:tactics
tactics security_result.attack_details.tactics 已合併
message security_result.attack_details.techniques 已對應:CEF:techniques
techniques security_result.attack_details.techniques 已合併
alertCategory security_result.category_details 已合併
cat security_result.category_details 已合併
message security_result.category_details 已對應:CEF:catCEF:alertCategory
Category security_result.description 直接對應
Reason security_result.description 直接對應
Scan_Type security_result.description 直接對應
Type security_result.description 直接對應
act security_result.description 直接對應
description security_result.description 直接對應
details security_result.description 直接對應
et_lower security_result.description 直接對應
event_type security_result.description 直接對應
kv_data security_result.description 直接對應
msg_data_2 security_result.description 直接對應
policy_details security_result.description 直接對應
rnmsg security_result.description 直接對應
dstMacVendor_label security_result.detection_fields 已合併
infection_channel_label security_result.detection_fields 已合併
l2Proto_label security_result.detection_fields 已合併
l3Proto_label security_result.detection_fields 已合併
message security_result.detection_fields 對應值 (共 13 個,例如 CEF:operation_labelCEF:operasjon_labelCEF:...
operasjon_label security_result.detection_fields 已合併
operation_label security_result.detection_fields 已合併
permission_label security_result.detection_fields 已合併
protocol_label security_result.detection_fields 已合併
protocol_type security_result.detection_fields 已對應:IPprotocol_label
spyware_Grayware_Type_label security_result.detection_fields 已合併
srcMacVendor_label security_result.detection_fields 已合併
status_label security_result.detection_fields 已合併
threat_probability_label security_result.detection_fields 已合併
tillatelse_label security_result.detection_fields 已合併
Rule security_result.rule_id 直接對應
alert_id security_result.rule_id 直接對應
device_event_class_id security_result.rule_id 直接對應
typeId security_result.rule_id 直接對應
Match security_result.rule_name 直接對應
et_lower security_result.rule_name 已對應:block eventVirtual Firewall blocking
is_fw_blocking security_result.rule_name 已對應:trueVirtual Firewall blocking
message security_result.rule_name 已對應:CEF:Virtual Firewall blocking
mwProfile security_result.rule_name 直接對應
name security_result.rule_name 直接對應
message security_result.severity 對應值 (共 6 個,例如 CEF:LOWCEF:MEDIUMCEF:HIGH)
severity security_result.severity 對應值 (共 13 個,例如 "0", "1", "2", "3", "LOW"LOW、「4」、「5」、「6」、「MEDIUM」等)
severity security_result.severity_details 直接對應
Result security_result.summary 直接對應
appcategory security_result.summary 直接對應
event_name security_result.summary 直接對應
event_type security_result.summary 直接對應
log_description security_result.summary 直接對應
reason security_result.summary 已重新命名/對應
Spyware security_result.threat_name 直接對應
Unknown_Threat security_result.threat_name 直接對應
Virus_Malware_Name security_result.threat_name 直接對應
threat security_result.threat_name 直接對應
oldFilePath src.file.full_path 已重新命名/對應
oldFileSize src.file.size 已重新命名/對應
message src.resource.attribute.permissions 已對應:CEF:old_permissions
old_permissions src.resource.attribute.permissions 已合併
dntdom target.administrative_domain 已重新命名/對應
destinationServiceName target.application 已重新命名/對應
Destination target.asset.hostname 直接對應
Target target.asset.hostname 直接對應
computer_name target.asset.hostname 直接對應
dstHostName target.asset.hostname 直接對應
Destination target.asset.ip 已合併
app_protocol target.asset.ip 已對應:CounterACTtarget_ipCounterACTDestination
data target.asset.ip 已對應:Target:Destination
dest_ip target.asset.ip 已合併
destination_ip target.asset.ip 已合併
dstIp target.asset.ip 已合併
et_lower target.asset.ip 已對應:port bitedestination_ipblock eventtarget_ip
kv_data target.asset.ip 已對應:Log: Logintarget_ip
message target.asset.ip 對應值 (共 5 個,例如 CEF:dstIpCEF:target_ipCEF:Destination)
target_ip target.asset.ip 已合併
dstMac target.asset.mac 已合併
message target.asset.mac 已對應:CEF:dstMac
Destination target.hostname 直接對應
Target target.hostname 直接對應
computer_name target.hostname 直接對應
dstHostName target.hostname 直接對應
temp_dhost target.hostname 直接對應
Destination target.ip 已合併
IPv6_Address target.ip 已合併
app_protocol target.ip 已對應:CounterACTtarget_ipCounterACTDestination
data target.ip 已對應:Target:Destination
dest_ip target.ip 已合併
destination_ip target.ip 已合併
dstIp target.ip 已合併
dst_ip target.ip 已合併
et_lower target.ip 已對應:port bitedestination_ipblock eventtarget_ip
ipv6 target.ip 已對應:-IPv6_Address
kv_data target.ip 已對應:Log: Logintarget_ip
message target.ip 對應值 (共 7 個,例如 CEF:dst_ipCEF:IPv6_AddressCEF:dstIp)
target_ip target.ip 已合併
dest_mac target.mac 已合併
dstMac target.mac 已合併
mac_address target.mac 已合併
message target.mac 對應:CEF:mac_addressCEF:dstMacCEF:dest_mac
destination_translated_address target.nat_ip 已合併
message target.nat_ip 已對應:CEF:destination_translated_address
destinationTranslatedPort target.nat_port 已重新命名/對應
dest_port target.port 直接對應
dpt target.port 已重新命名/對應
dstPort target.port 直接對應
port target.port 已重新命名/對應
dproc target.process.command_line 已重新命名/對應
File_name target.process.file.full_path 直接對應
Infected_Resource target.process.file.full_path 直接對應
Object target.process.file.full_path 直接對應
Objekt target.process.file.full_path 直接對應
dpid target.process.pid 已重新命名/對應
message target.resource.attribute.labels 已對應:CEF:resource_Type_label
resource_Type_label target.resource.attribute.labels 已合併
request target.url 直接對應
message target.user.attribute.roles 已對應:CEF:target_role
target_role target.user.attribute.roles 已合併
CustomerName target.user.user_display_name 直接對應
temp_duser target.user.user_display_name 直接對應
Bruker target.user.userid 直接對應
User_value target.user.userid 直接對應
temp_duid target.user.userid 直接對應
username target.user.userid 直接對應
不適用 extensions.auth.type 常數:MACHINE
不適用 metadata.event_type 常數:USER_LOGIN
不適用 metadata.product_name 常數:FORESCOUT EYEINSPECT
不適用 metadata.vendor_name 常數:FORESCOUT
不適用 network.direction 常數:INBOUND
不適用 security_result.alert_state 常數:ALERTING
不適用 security_result.rule_name 常數:Virtual Firewall blocking
不適用 security_result.severity 常數:LOW
app_protocol_src network.application_protocol 從變更記錄對應
Category" and "policy_details security_result.description 從變更記錄對應
CPU_usage", "Available_memory", "Used_memory", "Available_swap", "Used_swap additional.fields 從變更記錄對應
application_status", "Connected_clients", "EM_connection_status", "Assigned_hosts", "Engine_status", "Installed_Plugins additional.fields 從變更記錄對應
alart_id security_result.rule_id 從變更記錄對應
protocol2 security_result.detection_fields 從變更記錄對應

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。