收集 Fortinet DHCP 日志

解析器版本:2.0

支持:

本文档介绍了如何使用 Bindplane 代理将 Fortinet DHCP 日志注入 Google Security Operations。

Fortinet FortiGate DHCP 服务器日志会捕获 FortiGate 防火墙基础设施中的 IP 地址分配、租用事件和 DHCP 中继操作。日志由本地 FortiGate 设备以键值对格式生成。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 FortiGate 设备之间的网络连接
  • 如果在代理后面运行,请确保按照 Bindplane 代理要求打开防火墙端口
  • 对 Fortinet FortiGate 管理员界面的特权访问权限

获取 Bindplane 代理的 Google SecOps 凭证

如需向 Google SecOps 验证 Bindplane 代理,请选择以下方法之一:

  • 新部署:使用 Chronicle API(选项 1)。
  • 旧版部署:继续使用数据注入身份验证文件(方法 2),直到 Ingestion API 于 2027 年 7 月 20 日停用。
  1. 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
  2. 前往 IAM 和管理 > 服务账号。
  3. 点击创建服务账号。
  4. 提供以下配置详细信息:
    • 服务账号名称:输入账号的名称(例如 bindplane-ingest)。
    • 服务账号说明:输入说明(例如 Bindplane agent log ingestion)。
  5. 点击创建并继续。
  6. 在向此服务账号授予对项目的访问权限部分,点击选择角色,然后选择 Chronicle Editor。
  7. 点击继续,然后点击完成。
  8. 点击您创建的服务账号,然后前往密钥标签页。
  9. 依次点击添加密钥 > 创建新密钥。
  10. 选择 JSON,然后点击创建。密钥文件会下载到您的计算机上。
  11. 将密钥文件另存为 Bindplane 收集器目录(Linux 上的 /opt/observiq-otel-collector/ingestion-auth.json 或 Windows 上的 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)中的 ingestion-auth.json,或更新 config.yaml 中的 creds_file_path 以匹配您保存该文件的路径。
  12. 前往 IAM 和管理 > 设置,然后复制项目编号。您在配置导出器时需要用到该名称。

方法 2:下载数据注入身份验证文件(旧版)

  1. 登录 Google SecOps 控制台。
  2. 前往 SIEM 设置> 收集代理。
  3. 下载数据注入身份验证文件。
  4. 将文件安全地保存在将要安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 前往 SIEM 设置 > 个人资料。
  3. 复制并保存组织详细信息部分中的客户 ID。

安装 Bindplane 代理

按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符或 PowerShell。
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

    该服务应显示为正在运行。

Linux 安装

  1. 打开具有 root 或 sudo 权限的终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

    该服务应显示为有效(正在运行)。

其他安装资源

如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。

配置 Bindplane 代理以注入 Syslog 并发送到 Google SecOps

找到配置文件

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • 将 config.yaml 的全部内容替换为以下配置:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/fortinet_dhcp:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: FORTINET_DHCP
        raw_log_field: body
    
    service:
      pipelines:
        logs/fortinet_dhcp_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/fortinet_dhcp
    

配置参数

替换以下占位符:

  • 接收器配置:

    • listen_address:要监听的 IP 地址和端口:
      • 0.0.0.0,以监听所有接口(推荐)
      • 端口 514 是标准 syslog 端口(在 Linux 上需要 root 权限;对于非 root 用户,请使用 1514)
  • 导出器配置:

    • creds_file_path:服务账号 JSON 密钥文件的完整路径(选项 1):
      • Linux:/opt/observiq-otel-collector/ingestion-auth.json
      • Windows:C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:从 Google SecOps 控制台复制的客户 ID
    • location:将 <LOCATION> 替换为 Google SecOps 实例的区域(例如 us、europe 或 asia-southeast1)。导出器会使用此值作为 chronicle.googleapis.com 的前缀。如需查看完整列表,请参阅区域级端点。
    • project:将 <PROJECT_NUMBER> 替换为“IAM 和管理”>“设置”中的项目编号。
    • endpoint:保持设置为 chronicle.googleapis.com。

旧版提取 API

  • 如果您使用选项 2 中的提取身份验证文件,请将 exporters 代码块替换为以下内容。将 creds_file_path 设置为数据注入身份验证文件的路径,如果您的实例位于美国境外,请将 malachiteingestion-pa.googleapis.com 替换为您的区域端点(例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/fortinet_dhcp:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: FORTINET_DHCP
        raw_log_field: body
    

保存配置文件

  • 修改后,保存文件:
    • Linux:依次按 Ctrl+O、Enter 和 Ctrl+X
    • Windows:依次点击文件 > 保存

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
    1. 验证服务是否正在运行:

      sudo systemctl status observiq-otel-collector
      
    2. 检查日志中的错误:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:

    • 以管理员身份运行命令提示符或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • “服务”控制台:

      1. 按 Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry 收集器。
      3. 右键点击并选择重启。
      4. 验证服务是否正在运行:

        sc query observiq-otel-collector
        
      5. 检查日志中的错误:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

配置 Fortinet FortiGate DHCP syslog 转发

  1. 登录 FortiGate 网页界面。
  2. 依次前往日志和报告 > 日志设置。
  3. 向下滚动到远程日志记录和归档部分。
  4. 在将日志发送到 Syslog 下,启用 syslog 转发。
  5. 提供以下配置详细信息:
    • IP 地址/FQDN:输入 Bindplane 代理主机 IP 地址。
    • 端口:输入 514。
    • 最低日志级别:选择信息或通知。
    • 设施:选择 local7。
  6. 或者,您也可以通过 FortiGate CLI 配置 syslog 转发:

    config log syslogd setting
        set status enable
        set server "<bindplane-ip>"
        set port 514
        set facility local7
        set source-ip ""
        set format default
    end
    
    • 将 <bindplane-ip> 替换为 Bindplane 代理主机的 IP 地址。
  7. 为确保包含 DHCP 日志,请验证日志过滤条件设置:

    config log syslogd filter
        set severity information
        set forward-traffic enable
        set local-traffic enable
        set event enable
    end
    
  8. 通过检查 Bindplane 代理日志,验证日志是否正在发送。

UDM 映射表

日志字段 UDM 映射 逻辑
appcat_label additional.fields 已合并
received_packets_field additional.fields 已合并
sent_packets_field additional.fields 已合并
host_name intermediary.hostname 直接映射
description metadata.description 直接映射
logdesc metadata.description 直接映射
msg metadata.description 直接映射
subtype metadata.description 直接映射
type metadata.description 直接映射
logtime metadata.event_timestamp 已解析为 yyyy-MM-dd HH:mm:ss
event_type metadata.event_type 已重命名/已映射
subtype metadata.product_event_type 直接映射
type metadata.product_event_type 直接映射
logid metadata.product_log_id 直接映射
logdesc network.application_protocol 已映射:Release/Ack → DHCP
service network.application_protocol 直接映射
mac network.dhcp.chaddr 直接映射
ip network.dhcp.ciaddr 直接映射
lease network.dhcp.lease_time_seconds 已重命名/映射
logdesc network.dhcp.type 已映射:Ack → ACK,Release → RELEASE
ip network.dhcp.yiaddr 直接映射
direction network.direction 已映射:"incoming", "inbound" → INBOUND,"outgoing", "outbound" → OUTBOUND
ip_protocol_out network.ip_protocol 直接映射
rcvdbyte network.received_bytes 已重命名/映射
sentbyte network.sent_bytes 已重命名/映射
duration network.session_duration.seconds 直接映射
sessionid network.session_id 直接映射
hostname principal.hostname 直接映射
interface principal.hostname 直接映射
ip principal.ip 已合并
srcip principal.ip 已合并
srccountry principal.location.country_or_region 直接映射
mac principal.mac 已合并
srcport principal.port 直接映射
devid principal.resource.id 直接映射
devname principal.resource.name 直接映射
srcuuid principal.user.product_object_id 直接映射
user_name principal.user.user_display_name 直接映射
vd principal.user.userid 直接映射
security_result_action security_result.action 已合并
action security_result.action_details 直接映射
category_details security_result.category_details 已合并
craction_labels security_result.detection_fields 已合并
dstintf_labels security_result.detection_fields 已合并
dstintfrole_labels security_result.detection_fields 已合并
srcintf_label security_result.detection_fields 已合并
srcintfrole_label security_result.detection_fields 已合并
policyid security_result.rule_id 直接映射
policyname security_result.rule_name 直接映射
policytype security_result.rule_type 直接映射
level security_result.severity 已映射:information → INFORMATIONAL
crscore security_result.severity_details 直接映射
level security_result.severity_details 直接映射
application target.application 直接映射
service target.application 直接映射
dstip target.ip 已合并
dstcountry target.location.country_or_region 直接映射
dstport target.port 直接映射
profile target.resource.name 直接映射
url target.url 直接映射
dstuuid target.user.product_object_id 直接映射
不适用 metadata.product_name 常量:FORTINET_DHCP
不适用 metadata.vendor_name 常量:FORTINET
不适用 network.application_protocol 常量:DHCP
不适用 network.dhcp.type 常量:ACK
不适用 network.direction 常量:INBOUND
不适用 principal.resource.resource_type 常量:DEVICE
不适用 security_result.severity 常量:INFORMATIONAL
不适用 target.resource.resource_type 常量:ACCESS_POLICY

更新日志

查看此解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。