收集 Fortinet DHCP 記錄

剖析器版本:2.0

支援的國家/地區:

本文說明如何使用 Bindplane 代理程式,將 Fortinet DHCP 記錄擷取至 Google Security Operations。

Fortinet FortiGate DHCP 伺服器記錄會擷取 FortiGate 防火牆基礎架構內的 IP 位址指派、租用事件和 DHCP 中繼作業。記錄檔是由地端部署 FortiGate 裝置以鍵/值格式產生。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 FortiGate 設備之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • Fortinet FortiGate 管理員介面的特殊存取權

取得 Google SecOps 擷取驗證檔案

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」
  3. 下載擷取驗證檔案
  4. 將檔案安全地儲存在要安裝 Bindplane 的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」
  3. 複製並儲存「機構詳細資料」部分中的客戶 ID

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟「命令提示字元」或「PowerShell」
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」

Linux 安裝

  1. 開啟具有根層級或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為有效 (執行中)

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南

設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • config.yaml 的所有內容替換為下列設定:

    receivers:
        udplog:
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/fortinet_dhcp:
            compression: gzip
            creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
            customer_id: '<customer_id>'
            endpoint: malachiteingestion-pa.googleapis.com
            log_type: FORTINET_DHCP
            raw_log_field: body
    
    service:
        pipelines:
            logs/fortinet_dhcp_to_chronicle:
                receivers:
                    - udplog
                exporters:
                    - chronicle/fortinet_dhcp
    

設定參數

替換下列預留位置:

  • 接收器設定:

    • listen_address:要接聽的 IP 位址和通訊埠:
      • 0.0.0.0,監聽所有介面 (建議)
      • 通訊埠 514 是標準的系統記錄通訊埠 (在 Linux 上需要根層級權限;非根層級權限請使用 1514)
  • 匯出工具設定:

    • creds_file_path:擷取驗證檔案的完整路徑:
      • Linux/etc/bindplane-agent/ingestion-auth.json
      • WindowsC:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:從 Google SecOps 控制台複製的客戶 ID
    • endpoint:區域端點網址:
      • 美國malachiteingestion-pa.googleapis.com
      • 歐洲europe-malachiteingestion-pa.googleapis.com
      • 亞洲asia-southeast1-malachiteingestion-pa.googleapis.com
      • 如需完整清單,請參閱「區域端點

儲存設定檔

  • 編輯完成後,請儲存檔案:
    • Linux:依序按下 Ctrl+OEnterCtrl+X
    • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,以套用變更

  • 如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 檢查記錄中是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出 observIQ OpenTelemetry Collector
      3. 按一下滑鼠右鍵,然後選取「重新啟動」
      4. 確認服務正在執行:

        sc query observiq-otel-collector
        
      5. 檢查記錄中是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

設定 Fortinet FortiGate DHCP 系統記錄轉送

  1. 登入 FortiGate 網頁介面。
  2. 依序前往「記錄和報告」>「記錄設定」
  3. 向下捲動至「遠端記錄和封存」部分。
  4. 在「將記錄傳送至系統記錄檔」下方,啟用系統記錄檔轉送功能。
  5. 請提供下列設定詳細資料:
    • IP 位址/FQDN:輸入 Bindplane 代理程式主機的 IP 位址。
    • 「Port」(通訊埠):輸入 514
    • 最低記錄層級:選取「資訊」或「通知」
    • 設施:選取「local7」
  6. 或者,您也可以透過 FortiGate CLI 設定系統記錄轉送:

    config log syslogd setting
        set status enable
        set server "<bindplane-ip>"
        set port 514
        set facility local7
        set source-ip ""
        set format default
    end
    
    • <bindplane-ip> 替換為 Bindplane 代理程式主機的 IP 位址。
  7. 如要確保系統會納入 DHCP 記錄,請確認記錄篩選器設定:

    config log syslogd filter
        set severity information
        set forward-traffic enable
        set local-traffic enable
        set event enable
    end
    
  8. 檢查 Bindplane 代理程式記錄,確認記錄是否已傳送。

UDM 對應表

記錄欄位 UDM 對應 邏輯
appcat_label additional.fields 已合併
received_packets_field additional.fields 已合併
sent_packets_field additional.fields 已合併
host_name intermediary.hostname 直接對應
description metadata.description 直接對應
logdesc metadata.description 直接對應
msg metadata.description 直接對應
subtype metadata.description 直接對應
type metadata.description 直接對應
logtime metadata.event_timestamp 已剖析為 yyyy-MM-dd HH:mm:ss
event_type metadata.event_type 已重新命名/對應
subtype metadata.product_event_type 直接對應
type metadata.product_event_type 直接對應
logid metadata.product_log_id 直接對應
logdesc network.application_protocol 已對應:Release/AckDHCP
service network.application_protocol 直接對應
mac network.dhcp.chaddr 直接對應
ip network.dhcp.ciaddr 直接對應
lease network.dhcp.lease_time_seconds 已重新命名/對應
logdesc network.dhcp.type 已對應:AckACKReleaseRELEASE
ip network.dhcp.yiaddr 直接對應
direction network.direction 已對應:"incoming", "inbound"INBOUND"outgoing", "outbound"OUTBOUND
ip_protocol_out network.ip_protocol 直接對應
rcvdbyte network.received_bytes 已重新命名/對應
sentbyte network.sent_bytes 已重新命名/對應
duration network.session_duration.seconds 直接對應
sessionid network.session_id 直接對應
hostname principal.hostname 直接對應
interface principal.hostname 直接對應
ip principal.ip 已合併
srcip principal.ip 已合併
srccountry principal.location.country_or_region 直接對應
mac principal.mac 已合併
srcport principal.port 直接對應
devid principal.resource.id 直接對應
devname principal.resource.name 直接對應
srcuuid principal.user.product_object_id 直接對應
user_name principal.user.user_display_name 直接對應
vd principal.user.userid 直接對應
security_result_action security_result.action 已合併
action security_result.action_details 直接對應
category_details security_result.category_details 已合併
craction_labels security_result.detection_fields 已合併
dstintf_labels security_result.detection_fields 已合併
dstintfrole_labels security_result.detection_fields 已合併
srcintf_label security_result.detection_fields 已合併
srcintfrole_label security_result.detection_fields 已合併
policyid security_result.rule_id 直接對應
policyname security_result.rule_name 直接對應
policytype security_result.rule_type 直接對應
level security_result.severity 已對應:informationINFORMATIONAL
crscore security_result.severity_details 直接對應
level security_result.severity_details 直接對應
application target.application 直接對應
service target.application 直接對應
dstip target.ip 已合併
dstcountry target.location.country_or_region 直接對應
dstport target.port 直接對應
profile target.resource.name 直接對應
url target.url 直接對應
dstuuid target.user.product_object_id 直接對應
不適用 metadata.product_name 常數:FORTINET_DHCP
不適用 metadata.vendor_name 常數:FORTINET
不適用 network.application_protocol 常數:DHCP
不適用 network.dhcp.type 常數:ACK
不適用 network.direction 常數:INBOUND
不適用 principal.resource.resource_type 常數:DEVICE
不適用 security_result.severity 常數:INFORMATIONAL
不適用 target.resource.resource_type 常數:ACCESS_POLICY

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。