收集 Fortinet FortiAuthenticator 日志

解析器版本: 1.0

支持范围:

本文档介绍了如何使用 Bindplane 代理将 Fortinet FortiAuthenticator 日志注入 Google Security Operations。

Fortinet FortiAuthenticator 是一种集中式身份验证管理设备,可为用户身份验证、RADIUS/LDAP 事件、证书操作和系统活动生成 Syslog 消息。解析器会从 Syslog 格式的日志中提取字段,并将这些字段映射到统一数据模型 (UDM)。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机
  • Bindplane 代理与 Fortinet FortiAuthenticator 之间的网络连接
  • 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于打开状态
  • 对 Fortinet FortiAuthenticator 的特权访问权限

获取 Bindplane 代理的 Google SecOps 凭据

如需向 Google SecOps 验证 Bindplane 代理的身份,请选择以下方法之一:

  • 新部署:使用 Chronicle API(方法 1)。
  • 旧版部署:继续使用注入身份验证文件(方法 2),直到注入 API 于 2027 年 7 月 20 日停用为止。
  1. 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
  2. 依次前往 IAM 和管理 > 服务账号。
  3. 点击创建服务账号 。
  4. 提供以下配置详细信息:
    • 服务账号名称:输入账号的名称(例如 bindplane-ingest)。
    • 服务账号说明:输入说明(例如 Bindplane agent log ingestion)。
  5. 点击创建并继续 。
  6. 在向此服务帐号授予对项目的访问权限 部分,点击选择角色 ,然后选择 Chronicle Editor 。
  7. 点击继续 ,然后点击完成 。
  8. 点击您创建的服务帐号,然后前往密钥 标签页。
  9. 依次点击添加密钥 > 创建新密钥。
  10. 选择 JSON ,然后点击创建 。密钥文件会下载到您的计算机上。
  11. 将密钥文件另存为 Bindplane 收集器目录中的 ingestion-auth.json(在 Linux 上为 /opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为 C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或者更新 creds_file_path 在 config.yaml 中以与您保存该文件的路径匹配。
  12. 依次前往 IAM 和管理 > 设置 ,然后复制项目编号 。您需要此编号进行导出器配置。

方法 2:下载注入身份验证文件(旧版)

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 收集代理。
  3. 下载注入身份验证文件 。
  4. 将该文件安全地保存在将安装 Bindplane 代理的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 个人资料。
  3. 从组织详细信息 部分复制并保存客户 ID 。

安装 Bindplane 代理

请按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。

Windows 安装

  1. 以管理员身份打开命令提示符 或 PowerShell 。
  2. 运行以下命令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sc query observiq-otel-collector
    

    该服务应显示为正在运行 。

Linux 安装

  1. 使用 root 或 sudo 权限打开终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安装完成。

  4. 运行以下命令,验证安装是否成功:

    sudo systemctl status observiq-otel-collector
    

    该服务应显示为活跃 (正在运行) 。

其他安装资源

如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。

配置 Bindplane 代理以注入 Syslog 并将其发送到 Google SecOps

找到配置文件

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

修改配置文件

  • 将 config.yaml 的全部内容替换为以下配置:

    receivers:
      udplog:
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/fortinet_fortiauthenticator:
        protocol: https
        # Region of your instance, for example us, europe, asia-southeast1
        location: <LOCATION>
        # Project number of the Google Cloud project linked to the instance
        project: '<PROJECT_NUMBER>'
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: chronicle.googleapis.com
        log_type: FORTINET_FORTIAUTHENTICATOR
        raw_log_field: body
    
    service:
      pipelines:
        logs/fortinet_fortiauthenticator_to_chronicle:
          receivers:
            - udplog
          exporters:
            - chronicle/fortinet_fortiauthenticator
    

配置参数

替换以下占位符:

  • 接收器配置:

    • listen_address:要监听的 IP 地址和端口:
      • 0.0.0.0 以监听所有接口(推荐)
      • 端口 514 是标准 Syslog 端口(在 Linux 上需要 root 权限;对于非 root 用户,请使用 1514)
  • 导出器配置:

    • creds_file_path:服务帐号 JSON 密钥文件的完整路径(方法 1):
      • Linux: /opt/observiq-otel-collector/ingestion-auth.json
      • Windows: C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • customer_id:从 Google SecOps 控制台复制的客户 ID
    • location:将 <LOCATION> 替换为 Google SecOps 实例的区域(例如 us、europe 或 asia-southeast1)。导出器会使用此值为 chronicle.googleapis.com 添加前缀。如需查看完整列表,请参阅区域级端点。
    • project:将 <PROJECT_NUMBER> 替换为 IAM 和管理 > 设置 中的项目编号。
    • endpoint:保持设置为 chronicle.googleapis.com。

旧版注入 API 导出器

  • 如果您使用方法 2 中的注入身份验证文件,请将 exporters 块替换为以下内容。将 creds_file_path 设置为注入身份验证文件的路径,并且如果您的实例位于美国境外,请将 malachiteingestion-pa.googleapis.com 替换为您的 区域级端点(例如 europe-malachiteingestion-pa.googleapis.com)。

    exporters:
      chronicle/fortinet_fortiauthenticator:
        compression: gzip
        creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
        customer_id: '<customer_id>'
        endpoint: malachiteingestion-pa.googleapis.com
        log_type: FORTINET_FORTIAUTHENTICATOR
        raw_log_field: body
    

保存配置文件

  • 修改后,请保存该文件:
    • Linux:按 Ctrl+O,然后按 Enter,再按 Ctrl+X
    • Windows:点击File > Save

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    
    1. 验证服务是否正在运行:

      sudo systemctl status observiq-otel-collector
      
    2. 检查日志中是否存在错误:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:

    • 以管理员身份运行命令提示符或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服务控制台:

      1. 按 Win+R,输入 services.msc,然后按 Enter 键。
      2. 找到 observIQ OpenTelemetry Collector 。
      3. 右键点击并选择重启 。
      4. 验证服务是否正在运行:

        sc query observiq-otel-collector
        
      5. 检查日志中是否存在错误:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

在 FortiAuthenticator 中配置 Syslog 服务器

  1. 登录 FortiAuthenticator 网页界面。
  2. 依次选择日志记录 > 日志配置 > Syslog 服务器。
  3. 在 Syslog 服务器 列表中,选择创建新服务器 。
  4. 指定以下配置详细信息:
    • 名称:为 Syslog 服务器输入一个唯一名称;例如 Google SecOps。
    • 服务器名称/IP:输入 Bindplane 代理的 IP 地址。
    • 端口:输入 Bindplane 代理端口号;例如 514。
    • 级别:选择信息。
    • 设施:选择一个设施。
  5. 选择确定 以添加 Syslog 服务器。

在 FortiAuthenticator 中配置远程 Syslog

  1. 添加 Syslog 服务器后,依次选择日志记录 > 日志配置 > 日志设置。
  2. 在远程 Syslog 会话中,点击以启用将日志发送到远程 Syslog 服务器 。
  3. 选择之前创建的服务器名称,然后将其移至所选 Syslog 服务器 列表。
  4. 点击确定 。

UDM 映射表

日志字段 UDM 映射 逻辑
action_label additional.fields 已合并
category_label additional.fields 已合并
has_user_login extensions.auth.type 已映射:true → MACHINE
has_user_logout extensions.auth.type 已映射:true → MACHINE
date_time metadata.event_timestamp 解析为 yyyy-MM-dd HH:mm:ss Z
has_principal metadata.event_type 已映射:true → USER_UNCATEGORIZED,true → STATUS_UPDATE
has_target_user metadata.event_type 已映射:true → USER_UNCATEGORIZED
has_user_login metadata.event_type 已映射:true → USER_LOGIN
has_user_logout metadata.event_type 已映射:true → USER_LOGOUT
logid metadata.product_log_id 直接映射
devid principal.asset.asset_id 直接映射
devname principal.asset.hostname 直接映射
prin_ip principal.asset.ip 已合并
user_ip principal.asset.ip 已合并
devname principal.hostname 直接映射
prin_ip principal.ip 已合并
user_ip principal.ip 已合并
nas_ip principal.nat_ip 已合并
prin_user principal.user.userid 直接映射
subtype security_result.about.resource.resource_subtype 直接映射
sec_action security_result.action 已合并
status security_result.action_details 直接映射
logdesc security_result.description 直接映射
subcategory security_result.description 直接映射
index_label security_result.detection_fields 已合并
nas_label security_result.detection_fields 已合并
type_label security_result.detection_fields 已合并
userip_label security_result.detection_fields 已合并
typeid security_result.rule_id 直接映射
level security_result.severity 已映射:warning → HIGH,notice → MEDIUM,"information", "info" → LOW,error ...
vd target.user.user_display_name 直接映射
user target.user.userid 直接映射
vd target.user.userid 直接映射
不适用 extensions.auth.type 常量:MACHINE
不适用 metadata.event_type 常量:USER_LOGIN
不适用 metadata.product_name 常量:FortiAuthenticator
不适用 metadata.vendor_name 常量:Fortinet
不适用 security_result.severity 常量:HIGH
prin_hostname event.idm.read_only_udm.intermediary.hostname 从变更日志映射

更新日志

查看此解析器的更新日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。