收集 Fortinet FortiSandbox 記錄

剖析器版本:1.0

支援的國家/地區:

本文說明如何使用 Bindplane 代理程式,將 Fortinet FortiSandbox 記錄擷取至 Google Security Operations。

Fortinet FortiSandbox 是一種進階威脅偵測裝置,可在沙箱環境中分析可疑檔案和網址,偵測零時差惡意軟體和 APT。並以 Syslog 格式產生記錄,內容包括沙箱分析結果、判決、系統狀態和行為指標。

事前準備

請確認您已完成下列事前準備事項:

  • Google SecOps 執行個體
  • Windows Server 2016 以上版本,或搭載 systemd 的 Linux 主機
  • Bindplane 代理程式與 FortiSandbox 設備之間的網路連線
  • 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
  • 具備管理員權限的 FortiSandbox 設備特殊存取權

取得 Google SecOps 擷取驗證檔案

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「收集代理程式」
  3. 下載擷取驗證檔案
  4. 將檔案安全地儲存在要安裝 Bindplane 的系統上。

取得 Google SecOps 客戶 ID

  1. 登入 Google SecOps 控制台。
  2. 依序前往「SIEM 設定」>「設定檔」
  3. 複製並儲存「機構詳細資料」部分中的客戶 ID

安裝 Bindplane 代理程式

請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。

Windows 安裝

  1. 以管理員身分開啟「命令提示字元」或「PowerShell」
  2. 執行下列指令:

    msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sc query observiq-otel-collector
    

    服務應顯示為「RUNNING」

Linux 安裝

  1. 開啟具有根層級或 sudo 權限的終端機。
  2. 執行下列指令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    
  3. 等待安裝完成。

  4. 執行下列指令,確認安裝成功:

    sudo systemctl status observiq-otel-collector
    

    服務應顯示為有效 (執行中)

其他安裝資源

如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南

設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps

找出設定檔

  • Linux:

    sudo nano /opt/observiq-otel-collector/config.yaml
    
  • Windows:

    notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
    

編輯設定檔

  • config.yaml 的所有內容替換為下列設定:

    receivers:
        udplog:
            listen_address: "0.0.0.0:514"
    
    exporters:
        chronicle/fortisandbox:
            compression: gzip
            creds_file_path: '/etc/bindplane-agent/ingestion-auth.json'
            customer_id: '<customer_id>'
            endpoint: malachiteingestion-pa.googleapis.com
            log_type: FORTINET_SANDBOX
            raw_log_field: body
            ingestion_labels:
                env: production
    
    service:
        pipelines:
            logs/fortisandbox_to_chronicle:
                receivers:
                    - udplog
                exporters:
                    - chronicle/fortisandbox
    

設定參數

替換下列預留位置:

  • 接收器設定:

    • udplog:根據通訊協定的接收器類型:
      • udplog (適用於 UDP 系統記錄檔)
      • tcplog (適用於 TCP Syslog)
    • 0.0.0.0:要接聽的 IP 位址:
      • 0.0.0.0,監聽所有介面 (建議)
      • 在一個介面上接聽的特定 IP 位址
    • 514:要接聽的通訊埠號碼 (例如 51415146514)
  • 匯出工具設定:

    • fortisandbox:匯出工具的說明名稱
    • creds_file_path:擷取驗證檔案的完整路徑:
      • Linux/etc/bindplane-agent/ingestion-auth.json
      • WindowsC:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
    • <customer_id>:上一步中的客戶 ID
    • endpoint:區域端點網址:
      • 美國malachiteingestion-pa.googleapis.com
      • 歐洲europe-malachiteingestion-pa.googleapis.com
      • 亞洲asia-southeast1-malachiteingestion-pa.googleapis.com
      • 如需完整清單,請參閱「區域端點
    • FORTINET_SANDBOX:記錄類型,與 Chronicle 中顯示的完全相同
    • ingestion_labels:YAML 格式的選用標籤 (例如 env: production)
  • 管道設定:

    • fortisandbox_to_chronicle:管道的說明名稱

儲存設定檔

  • 編輯完成後,請儲存檔案:
    • Linux:依序按下 Ctrl+OEnterCtrl+X
    • Windows:依序點選「檔案」>「儲存」

重新啟動 Bindplane 代理程式,以套用變更

  • 如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:

    sudo systemctl restart observiq-otel-collector
    
    1. 確認服務正在執行:

      sudo systemctl status observiq-otel-collector
      
    2. 檢查記錄中是否有錯誤:

      sudo journalctl -u observiq-otel-collector -f
      
  • 如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:

    • 以管理員身分開啟命令提示字元或 PowerShell:

      net stop observiq-otel-collector && net start observiq-otel-collector
      
    • 服務控制台:

      1. 按下 Win+R,輸入 services.msc,然後按下 Enter 鍵。
      2. 找出 observIQ OpenTelemetry Collector
      3. 按一下滑鼠右鍵,然後選取「重新啟動」
      4. 確認服務正在執行:

        sc query observiq-otel-collector
        
      5. 檢查記錄中是否有錯誤:

        type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
        

設定 Fortinet FortiSandbox 系統記錄轉送

  1. 登入 FortiSandbox 網頁介面。
  2. 依序前往「記錄和報告」>「記錄伺服器」
  3. 按一下「新增」,建立新的記錄伺服器項目。
  4. 請提供下列設定詳細資料:
    • 名稱:輸入描述性名稱 (例如 Chronicle-Bindplane)。
    • IP 位址:輸入 Bindplane 代理程式主機的 IP 位址 (例如 192.168.1.100)。
    • 「Port」(通訊埠):輸入 514 (必須與 Bindplane 代理程式接收器通訊埠一致)。
    • 「通訊協定」:選取「UDP」
  5. 選取要轉送的記錄類型:
    • 沙箱分析結果
    • 惡意軟體判定結果
    • 系統事件
    • 管理動作
  6. 按一下「確定」儲存設定。
  7. 查看 Bindplane 代理程式記錄,確認是否收到系統記錄訊息。

UDM 對應表

記錄欄位 UDM 對應 邏輯
letype、logver、reason、cpu、mem、disk、pending、cpu_usage、mem_usage、disk_usage、pending_jobs additional.fields 如果欄位不為空白,則會合併為各欄位的標籤
msg metadata.description 直接複製值
時間 metadata.event_timestamp 轉換為 ISO8601 格式的時間戳記
metadata.event_type 如果 msg 包含「工作階段逾時」,請設為「USER_LOGOUT」;如果 has_principal 和 has_target 都是「true」,請設為「NETWORK_CONNECTION」;如果 has_principal 是「true」,請設為「STATUS_UPDATE」;否則請設為「GENERIC_EVENT」
logid metadata.product_log_id 直接複製值
管理員 principal.administrative_domain 直接複製值
devhost principal.asset.hostname 直接複製值
principal_ip、msg_ip principal.asset.ip 如果 principal_ip 不是空白,則為該值,否則為 msg_ip
devid principal.asset.product_object_id 直接複製值
devhost principal.hostname 直接複製值
principal_ip、msg_ip principal.ip 如果 principal_ip 不是空白,則為該值,否則為 msg_ip
動作 security_result.action_details 直接複製值
狀態、ui security_result.detection_fields 如果狀態和 UI 不為空白,則會合併為標籤
level security_result.severity 從大寫後的層級對應:如果是「CRITICAL」,則為 CRITICAL;如果是「ERROR」,則為 ERROR;如果是「ALERT」或「EMERGENCY」,則為 HIGH;如果是「INFO」或「NOTICE」,則為 INFORMATIONAL;如果是「DEBUG」,則為 LOW;如果是「WARNING」,則為 MEDIUM;否則為 UNKNOWN_SEVERITY
ip target.asset.ip 直接複製值
ip target.ip 直接複製值
使用者 target.user.userid 直接複製值

變更記錄

查看這個剖析器的變更記錄

還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。