收集 Fortinet Switch 日志
解析器版本: 1.0
本指南介绍了如何使用 Bindplane 代理将 Fortinet Switch 日志注入 Google Security Operations。
Fortinet Switch 是一系列安全、高性能的以太网交换机,专为企业网络而设计。FortiSwitch 提供第 2 层和第 3 层交换功能、VLAN 支持、链路聚合、以太网供电 (PoE) 和集成安全功能。FortiSwitch 单元可以独立运行,也可以通过 FortiLink 由 FortiGate 防火墙进行管理。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例。
- Windows Server 2016 或更高版本,或者具有 systemd 的 Linux 主机。
- Bindplane 代理与 Fortinet Switch 之间的网络连接。
- 如果通过代理运行,请确保防火墙端口根据 Bindplane 代理要求处于打开状态。
- 对 Fortinet Switch 管理控制台或 FortiGate 控制台(对于受管交换机)的特权访问权限。
- 运行 FortiSwitchOS 7.0 或更高版本的 Fortinet Switch。
获取 Bindplane 代理的 Google SecOps 凭据
如需向 Google SecOps 验证 Bindplane 代理,请选择以下方法之一:
- 新部署:使用 Chronicle API(方法 1)。
- 旧版部署:继续使用注入身份验证文件(方法 2),直到注入 API 于 2027 年 7 月 20 日停用为止。
方法 1:为 Chronicle API 创建服务帐号(推荐)
- 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
- 依次前往 IAM 和管理 > 服务账号。
- 点击创建服务账号 。
- 提供以下配置详细信息:
- 服务账号名称:输入账号的名称(例如
bindplane-ingest)。 - 服务账号说明:输入说明(例如
Bindplane agent log ingestion)。
- 服务账号名称:输入账号的名称(例如
- 点击创建并继续 。
- 在向此服务帐号授予对项目的访问权限 部分,点击选择角色 ,然后选择 Chronicle Editor 。
- 点击继续 ,然后点击完成 。
- 点击您创建的服务帐号,然后前往密钥 标签页。
- 依次点击添加密钥 > 创建新密钥。
- 选择 JSON ,然后点击创建 。密钥文件会下载到您的计算机上。
- 将密钥文件另存为 Bindplane 收集器目录中的
ingestion-auth.json(在 Linux 上为/opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或者更新creds_file_path在config.yaml中以与您保存该文件的路径匹配。 - 依次前往 IAM 和管理 > 设置 ,然后复制项目编号 。您需要此编号进行导出器配置。
方法 2:下载注入身份验证文件(旧版)
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
- 下载注入身份验证文件 。
- 将该文件安全地保存在将安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 个人资料。
从组织详细信息 部分复制并保存客户 ID 。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符 或 PowerShell 。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector该服务应显示为正在运行 。
Linux 安装
- 使用 root 或 sudo 权限打开终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector该服务应显示为活跃 (running) 。
其他安装资源
如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 syslog 并发送到 Google SecOps
找到配置文件
Linux:
sudo nano /opt/observiq-otel-collector/config.yaml
Windows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将 config.yaml 的全部内容替换为以下配置:
receivers:
udplog:
listen_address: "0.0.0.0:514"
exporters:
chronicle/fortiswitch:
protocol: https
# Region of your instance, for example us, europe, asia-southeast1
location: <LOCATION>
# Project number of the Google Cloud project linked to the instance
project: '<PROJECT_NUMBER>'
compression: gzip
creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json'
customer_id: 'YOUR_CUSTOMER_ID'
endpoint: chronicle.googleapis.com
log_type: FORTINET_SWITCH
raw_log_field: body
ingestion_labels:
env: production
service:
pipelines:
logs/fortiswitch_to_chronicle:
receivers:
- udplog
exporters:
- chronicle/fortiswitch
配置参数
替换以下占位符:
接收器配置:
- 接收器配置为监听 UDP 端口 514,以接收来自 Fortinet Switch 的 syslog 消息。
- 如需监听所有接口,请使用
0.0.0.0:514。 - 如需在 Linux 上使用非特权端口,请更改为
0.0.0.0:1514,并将 Fortinet Switch 配置为发送到端口 1514。
导出器配置:
creds_file_path:服务帐号 JSON 密钥文件的完整路径(方法 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
customer_id:上一步中的客户 ID。location:将<LOCATION>替换为 Google SecOps 实例的区域(例如us、europe或asia-southeast1)。导出器会以此值作为chronicle.googleapis.com的前缀。如需查看完整列表,请参阅区域级端点。project:将<PROJECT_NUMBER>替换为 IAM 和管理 > 设置 中的项目编号。endpoint:保持设置为chronicle.googleapis.com。log_type:必须完全为FORTINET_SWITCH。ingestion_labels:YAML 格式的可选标签(例如env: production)。
旧版注入 API 导出器
如果您使用方法 2 中的注入身份验证文件,请将
exporters块替换为以下内容。将creds_file_path设置为注入身份验证文件的路径,如果您的实例位于美国境外,请将malachiteingestion-pa.googleapis.com替换为您的 区域级端点(例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/fortiswitch: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: 'YOUR_CUSTOMER_ID' endpoint: malachiteingestion-pa.googleapis.com log_type: FORTINET_SWITCH raw_log_field: body ingestion_labels: env: production
保存配置文件
修改后,保存文件:
- Linux:按
Ctrl+O,然后按Enter,再按Ctrl+X。 - Windows:点击文件 > 保存。
重启 Bindplane 代理以应用更改
Linux
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志中的错误:
sudo journalctl -u observiq-otel-collector -f
Windows
选择以下选项之一:
以管理员身份使用命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector使用“服务”控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry Collector 。
右键点击并选择重启 。
验证服务是否正在运行:
sc query observiq-otel-collector检查日志中的错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按
配置 Fortinet Switch syslog 转发
配置 Fortinet Switch 以将日志发送到 Bindplane 代理。配置步骤因交换机是独立运行还是由 FortiGate 管理而异。
对于独立 FortiSwitch(GUI 配置)
- 登录 FortiSwitch 网页界面。
- 依次前往日志 > 配置。
- 在 Syslog 下,选择 启用。
- 选择要记录的事件的严重程度(例如信息 或更高)。
- 在服务器 字段中,输入 Bindplane 代理主机 IP 地址或完全限定域名。
- 在端口 字段中,输入
514(或在 Bindplane 代理中配置的端口)。 - 在设施 下拉菜单中,选择 local7 。
- 点击应用 。
对于独立 FortiSwitch(CLI 配置)
- 通过 SSH 或控制台登录 FortiSwitch CLI。
输入以下命令:
config log syslogd setting set status enable set server <BINDPLANE_AGENT_IP> set port 514 set facility local7 end config log syslogd filter set severity information end将
<BINDPLANE_AGENT_IP>替换为 Bindplane 代理主机的 IP 地址。验证配置:
show log syslogd setting
对于由 FortiGate 管理的 FortiSwitch
当 FortiSwitch 由 FortiGate 管理时,请从 FortiGate CLI 配置 syslog 转发。
- 通过 SSH 或控制台登录 FortiGate CLI。
输入以下命令,为受管 FortiSwitch 配置远程 syslog:
config switch-controller remote-log edit "chronicle-syslog" set status enable set server <BINDPLANE_AGENT_IP> set port 514 set severity information set facility local7 next end将
<BINDPLANE_AGENT_IP>替换为 Bindplane 代理主机的 IP 地址。验证配置:
show switch-controller remote-log确保 FortiGate 防火墙政策允许从 FortiLink 接口到 Bindplane 代理所在接口的 syslog 流量。如果需要,请创建政策:
config firewall policy edit 0 set srcintf <fortilink_interface> set dstintf <bindplane_interface> set srcaddr "all" set dstaddr "all" set action accept set schedule "always" set service "SYSLOG" next end将
<fortilink_interface>替换为 FortiLink 接口名称,并将<bindplane_interface>替换为 Bindplane 代理可访问的接口。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
| metadata.event_type | 此记录表示的事件类型。 | |
| event | metadata.product_event_type | 产品报告的事件类型。 |
| log_id | metadata.product_log_id | 产品分配的日志条目的唯一标识符。 |
| device_id | principal.asset.asset_id | 资产的唯一标识符。 |
| devname | principal.asset.hostname | 与主体关联的资产的主机名。 |
| devname | principal.hostname | 与主体关联的主机名。 |
| vd | principal.user.attribute.labels | 与用户关联的标签列表。 |
| oldrole | principal.user.attribute.roles | 与用户关联的角色列表。 |
| unit | principal.user.role_description | 用户角色的说明。 |
| user | principal.user.userid | 用户的唯一标识符。 |
| action | security_result.action_details | 所采取行动的详细信息。 |
| msg | security_result.description | 安全结果的说明。 |
| type, subtype, switch.physical-port, instanceid | security_result.detection_fields | 用于检测的字段列表。 |
| pri | security_result.priority_details | 事件优先级的详细信息。 |
| status | security_result.summary | 安全结果的摘要。 |
| newrole | target.user.attribute.roles | 与目标用户关联的角色列表。 |
| metadata.product_name | 生成事件的产品的名称。 | |
| metadata.vendor_name | 生产产品的供应商的名称。 |
更新日志
需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。