收集 HP Linux 記錄
本文說明如何使用 Bindplane 代理程式,將 HP-UX 作業系統記錄擷取至 Google Security Operations。
HP-UX 是適用於 HP Integrity 和 PA-RISC 伺服器的企業 UNIX 作業系統。HP-UX 系統記錄會擷取驗證事件、程序執行、安全稽核資料和一般系統活動。Syslog 檔案會儲存在 /var/adm/syslog/ 底下的本機。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 HP-UX 伺服器之間的網路連線
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- HP-UX 伺服器的特殊權限 (root) 存取權
取得 Google SecOps 擷取驗證檔案
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「收集代理程式」。
- 下載擷取驗證檔案。
將檔案安全地儲存在要安裝 Bindplane 的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「設定檔」。
複製並儲存「機構詳細資料」部分中的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有根層級或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為有效 (執行中)。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的所有內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/hp_linux: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: HP_LINUX raw_log_field: body ingestion_labels: env: production service: pipelines: logs/hpux_to_chronicle: receivers: - udplog exporters: - chronicle/hp_linux
設定參數
替換下列預留位置:
接收器設定:
udplog:根據通訊協定的接收器類型:udplog(適用於 UDP 系統記錄檔)tcplog適用於 TCP Syslog
0.0.0.0:要接聽的 IP 位址:0.0.0.0,監聽所有介面 (建議)- 在一個介面上接聽的特定 IP 位址
514:要接聽的通訊埠號碼 (例如514、1514、6514)
匯出工具設定:
hp_linux:匯出工具的說明名稱creds_file_path:擷取驗證檔案的完整路徑:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<customer_id>:上一步中的客戶 IDendpoint:區域端點網址:- 美國:
malachiteingestion-pa.googleapis.com - 歐洲:
europe-malachiteingestion-pa.googleapis.com - 亞洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需完整清單,請參閱「區域端點」
- 美國:
HP_LINUX:記錄類型,與 Chronicle 中顯示的完全相同ingestion_labels:YAML 格式的選用標籤 (例如env: production)
管道設定:
hpux_to_chronicle:管道的說明名稱
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」>「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,以套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector檢查記錄中是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出 observIQ OpenTelemetry Collector。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector檢查記錄中是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
設定 HP-UX 系統記錄轉送
- 使用 Root 權限登入 HP-UX 伺服器。
編輯系統記錄設定檔:
vi /etc/syslog.conf新增下列指令行,將所有系統記錄訊息轉送至 Bindplane 代理程式:
*.* @<BINDPLANE_AGENT_IP>- 將
<BINDPLANE_AGENT_IP>替換為 Bindplane 代理程式主機的 IP 位址。 @前置字串會透過 UDP 傳送記錄。HP-UX 系統記錄檔預設使用 UDP。
- 將
如要只轉送特定設施,請使用個別行:
auth.* @<BINDPLANE_AGENT_IP> kern.* @<BINDPLANE_AGENT_IP> *.err @<BINDPLANE_AGENT_IP>儲存並關閉檔案。
重新啟動系統記錄精靈,以套用變更:
/sbin/init.d/syslogd stop /sbin/init.d/syslogd start查看 Bindplane 代理程式記錄,確認是否收到系統記錄訊息。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
audit_type_label |
additional.fields |
已合併 |
auth_failures_label |
additional.fields |
已合併 |
ctladdr_label |
additional.fields |
已合併 |
da_instance_label |
additional.fields |
已合併 |
delay_label |
additional.fields |
已合併 |
dsn_label |
additional.fields |
已合併 |
event_code_label |
additional.fields |
已合併 |
mailer_label |
additional.fields |
已合併 |
msg_id_label |
additional.fields |
已合併 |
pri_label |
additional.fields |
已合併 |
raw_severity_label |
additional.fields |
已合併 |
ssh_version_label |
additional.fields |
已合併 |
stat_label |
additional.fields |
已合併 |
suite_label |
additional.fields |
已合併 |
syslog_priority_label |
additional.fields |
已合併 |
to_label |
additional.fields |
已合併 |
tty_label |
additional.fields |
已合併 |
xdelay_label |
additional.fields |
已合併 |
process |
extensions.auth.type |
已對應:"sshd", "login" → AUTHTYPE_UNSPECIFIED |
msg |
metadata.description |
直接對應 |
ts |
metadata.event_timestamp |
剖析為 MMM d HH:mm:ss |
utc |
metadata.event_timestamp |
剖析為 UNIX_MS |
event_type |
metadata.event_type |
直接對應 |
action_type |
metadata.product_event_type |
直接對應 |
centrifyEventID |
metadata.product_log_id |
直接對應 |
version |
metadata.product_version |
直接對應 |
message |
network.application_protocol |
已對應:(?i)ssh → SSH |
proto |
network.ip_protocol |
已對應:tcp → TCP |
DASessID |
network.session_id |
直接對應 |
process |
principal.application |
直接對應 |
host |
principal.asset.hostname |
直接對應 |
src_ip |
principal.asset.ip |
已合併 |
host |
principal.hostname |
直接對應 |
src_ip |
principal.ip |
已合併 |
src_port |
principal.port |
直接對應 |
p_id |
principal.process.pid |
直接對應 |
principal_user |
principal.user.userid |
直接對應 |
user |
principal.user.userid |
直接對應 |
security_result_action |
security_result.action |
已合併 |
ruleset |
security_result.rule_name |
直接對應 |
log_level |
security_result.severity |
已對應:INFO → INFORMATIONAL |
sev |
security_result.severity |
已對應:(?i)ERROR → ERROR |
log_level |
security_result.severity_details |
直接對應 |
t_domain |
target.administrative_domain |
直接對應 |
t_app |
target.application |
直接對應 |
t_hostname |
target.asset.hostname |
直接對應 |
target_hostname |
target.asset.hostname |
直接對應 |
t_hostname |
target.hostname |
直接對應 |
target_hostname |
target.hostname |
直接對應 |
target_user |
target.user.userid |
直接對應 |
user |
target.user.userid |
直接對應 |
| 不適用 | extensions.auth.type |
常數:AUTHTYPE_UNSPECIFIED |
| 不適用 | metadata.product_name |
常數:HP Linux |
| 不適用 | metadata.vendor_name |
常數:HP Linux |
| 不適用 | network.application_protocol |
常數:SSH |
| 不適用 | network.ip_protocol |
常數:TCP |
| 不適用 | security_result.severity |
常數:INFORMATIONAL |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。