收集 IBM QRadar 日志
本文档介绍了如何使用 Bindplane 代理将 IBM Security QRadar SIEM 日志注入到 Google Security Operations。
IBM Security QRadar 是一个安全信息和事件管理平台,可关联整个企业的事件以检测威胁。它会生成违规提醒、事件日志和流数据。QRadar 支持以 LEEF 和 JSON 格式转发违规和事件的 syslog。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 IBM QRadar 控制台之间的网络连接
- 如果在代理后面运行,请确保按照 Bindplane 代理要求打开防火墙端口
- 具有管理员或日志导出权限的 IBM QRadar 特权访问权限
获取 Bindplane 代理的 Google SecOps 凭据
如需向 Google SecOps 验证 Bindplane 代理,请选择以下方法之一:
- 新部署:使用 Chronicle API(选项 1)。
- 旧版部署:继续使用提取身份验证文件(方法 2),直到提取 API 于 2027 年 7 月 20 日停用。
方法 1:为 Chronicle API 创建服务账号(推荐)
- 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
- 前往 IAM 和管理 > 服务账号。
- 点击创建服务账号。
- 提供以下配置详细信息:
- 服务账号名称:输入账号的名称(例如
bindplane-ingest)。 - 服务账号说明:输入说明(例如
Bindplane agent log ingestion)。
- 服务账号名称:输入账号的名称(例如
- 点击创建并继续。
- 在向此服务账号授予对项目的访问权限部分,点击选择角色,然后选择 Chronicle Editor。
- 点击继续,然后点击完成。
- 点击您创建的服务账号,然后前往密钥标签页。
- 依次点击添加密钥 > 创建新密钥。
- 选择 JSON,然后点击创建。密钥文件会下载到您的计算机上。
- 将密钥文件另存为 Bindplane 收集器目录(在 Linux 上为
/opt/observiq-otel-collector/ingestion-auth.json,在 Windows 上为C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)中的ingestion-auth.json,或更新config.yaml中的creds_file_path以与您保存密钥文件的路径相匹配。 - 前往 IAM 和管理 > 设置,然后复制项目编号。您需要此信息才能配置导出器。
方法 2:下载数据注入身份验证文件(旧版)
- 登录 Google SecOps 控制台。
- 前往 SIEM 设置> 收集代理。
- 下载数据注入身份验证文件。
- 将文件安全地保存在将安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 前往 SIEM 设置 > 个人资料。
复制并保存组织详细信息部分中的客户 ID。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符或 PowerShell。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector该服务应显示为 RUNNING。
Linux 安装
- 打开具有 root 或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector该服务应显示为 active (running)。
其他安装资源
如需了解其他安装选项和问题排查,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps
找到配置文件
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/ibm_qradar: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: IBM_QRADAR raw_log_field: body ingestion_labels: env: production service: pipelines: logs/qradar_to_chronicle: receivers: - tcplog exporters: - chronicle/ibm_qradar
配置参数
替换以下占位符:
接收器配置:
tcplog:基于协议的接收器类型:udplog(适用于 UDP syslog)tcplog(适用于 TCP syslog)
0.0.0.0:要监听的 IP 地址:0.0.0.0,以监听所有接口(推荐)- 要在一个接口上监听的特定 IP 地址
514:要监听的端口号(例如514、1514、6514)
导出器配置:
ibm_qradar:导出器的描述性名称creds_file_path:服务账号 JSON 密钥文件的完整路径(选项 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<customer_id>:上一步中的客户 IDlocation:将<LOCATION>替换为 Google SecOps 实例所在的区域(例如us、europe或asia-southeast1)。导出工具会在此值前面加上chronicle.googleapis.com。如需查看完整列表,请参阅区域级端点。project:将<PROJECT_NUMBER>替换为“IAM 和管理”>“设置”中的项目编号。endpoint:保持设置为chronicle.googleapis.com。IBM_QRADAR:日志类型,与在 Chronicle 中显示的完全一致ingestion_labels:YAML 格式的可选标签(例如env: production)
流水线配置:
qradar_to_chronicle:流水线的描述性名称
旧版提取 API
如果您使用选项 2 中的提取身份验证文件,请将
exporters代码块替换为以下内容。将creds_file_path设置为提取身份验证文件的路径,如果您的实例位于美国境外,请将malachiteingestion-pa.googleapis.com替换为您的区域端点(例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/ibm_qradar: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: IBM_QRADAR raw_log_field: body ingestion_labels: env: production
保存配置文件
- 修改后,保存文件:
- Linux:依次按
Ctrl+O、Enter和Ctrl+X - Windows:依次点击文件 > 保存
- Linux:依次按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志中的错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:
以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector“服务”控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry 收集器。
- 右键点击,然后选择重新启动。
验证服务是否正在运行:
sc query observiq-otel-collector检查日志中的错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按
配置 IBM QRadar syslog 转发
- 以管理员身份登录 QRadar 控制台。
- 依次前往管理 > 系统和许可管理 > 系统设置。
- 在转发目的地下,点击添加。
- 提供以下配置详细信息:
- 名称:输入一个描述性名称(例如
Chronicle-Bindplane)。 - IP 地址:输入 Bindplane 代理主机(例如
192.168.1.100)的 IP 地址。 - 端口:输入
514(必须与 Bindplane 代理接收器端口匹配)。 - 协议:选择 TCP(推荐,可确保可靠传输)。
- 格式:选择 LEEF(日志事件扩展格式)。
- 名称:输入一个描述性名称(例如
- 点击保存。
- 前往管理 > 转接配置文件,以创建或修改转接配置文件。
- 选择要转发的事件和流类型:
- 违规事件
- 标准化事件
- 流数据(可选)
- 分配在第 4 步中创建的转发目的地。
- 点击保存并部署更改。
通过检查 Bindplane 代理日志,验证是否正在接收 syslog 消息。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
application |
extensions.auth.type |
已映射:httpd → AUTHTYPE_UNSPECIFIED |
_source.message |
metadata.description |
直接映射 |
message_body |
metadata.description |
直接映射 |
_source.eventTime |
metadata.event_timestamp |
解析为 ISO8601 |
log_date |
metadata.event_timestamp |
已解析为 MMM dd HH:mm:ss |
application |
metadata.event_type |
已映射:httpd → USER_LOGIN、logger → NETWORK_HTTP、CROND → PROCESS_LAUNCH |
has_principal |
metadata.event_type |
映射:true → NETWORK_HTTP、true → NETWORK_CONNECTION、true → STATUS_UPDATE |
_source.eventType |
metadata.product_event_type |
直接映射 |
_source._id |
metadata.product_log_id |
直接映射 |
_source.typeURI |
metadata.url_back_to_product |
直接映射 |
_source.o_requestData.o_request_body.method |
network.http.method |
直接映射 |
response |
network.http.response_code |
已重命名/映射 |
response_code |
network.http.response_code |
已重命名/已映射 |
_source.o_requestData.o_headers.User-Agent |
network.http.user_agent |
直接映射 |
crypto_algorithm |
network.tls.cipher |
直接映射 |
tls_version |
network.tls.version |
直接映射 |
_source.o_observer.name |
observer.resource.name |
直接映射 |
application |
principal.application |
直接映射 |
_source._host |
principal.asset.hostname |
直接映射 |
_source._ip |
principal.asset.ip |
已合并 |
_source.o_initiator.o_host.address |
principal.asset.ip |
已合并 |
_source._file |
principal.file.full_path |
直接映射 |
_source._host |
principal.hostname |
直接映射 |
_source._ip |
principal.ip |
已合并 |
_source.o_initiator.o_host.address |
principal.ip |
已合并 |
log_ip |
principal.ip |
已合并 |
event_id |
principal.process.pid |
直接映射 |
o_credential |
principal.resource.attribute.labels |
已合并 |
_source.o_requestData.initiatorGUID |
principal.resource.product_object_id |
直接映射 |
_source.o_initiator.typeURI |
principal.url |
直接映射 |
_source.o_requestData.o_request_body.user_name |
principal.user.user_display_name |
直接映射 |
_source.o_initiator.authnId |
principal.user.userid |
直接映射 |
action |
security_result.action |
已合并 |
application |
security_result.action |
已映射:httpd → action |
auth_status |
security_result.action |
已映射:(?i)failed → action |
_source.o_requestData.o_request_body.action |
security_result.action_details |
直接映射 |
_source.o_responseData.response_body |
security_result.action_details |
直接映射 |
auth_status |
security_result.description |
直接映射 |
correlationId |
security_result.detection_fields |
已合并 |
dataEvent |
security_result.detection_fields |
已合并 |
platform |
security_result.detection_fields |
已合并 |
saveServiceCopy |
security_result.detection_fields |
已合并 |
scenario_type |
security_result.detection_fields |
已合并 |
log_level |
security_result.severity |
映射:(?i)(error/warning) → HIGH、(?i)notice → MEDIUM、(?i)(information/info) → … |
_source.severity |
security_result.severity_details |
直接映射 |
_source.o_target.o_host.address |
target.asset.hostname |
直接映射 |
_source.o_target.o_host.address |
target.hostname |
直接映射 |
application |
target.ip |
已映射:httpd → host_ip,logger → ip |
host_ip |
target.ip |
已合并 |
ip |
target.ip |
已合并 |
command |
target.process.command_line |
直接映射 |
clientid |
target.resource.attribute.labels |
已合并 |
_source.o_target.typeURI |
target.url |
直接映射 |
request |
target.url |
已重命名/映射 |
_source.o_target.name |
target.user.user_display_name |
直接映射 |
_source.o_target.id |
target.user.userid |
直接映射 |
auth |
target.user.userid |
已重命名/映射 |
target_host |
target.user.userid |
直接映射 |
user_id |
target.user.userid |
直接映射 |
| 不适用 | extensions.auth.type |
常量:AUTHTYPE_UNSPECIFIED |
| 不适用 | metadata.event_type |
常量:NETWORK_HTTP |
| 不适用 | metadata.product_name |
常量:IBM QRADAR |
| 不适用 | metadata.vendor_name |
常量:IBM QRADAR |
| 不适用 | security_result.severity |
常量:MEDIUM |
更新日志
需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。