收集 IBM QRadar 記錄
本文說明如何使用 Bindplane 代理程式,將 IBM Security QRadar SIEM 記錄檔擷取至 Google Security Operations。
IBM Security QRadar 是一種安全資訊與事件管理平台,可關聯企業中的事件來偵測威脅。並產生違規事項快訊、事件記錄和流程資料。QRadar 支援以 LEEF 和 JSON 格式轉送違規事項和事件的系統記錄。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 IBM QRadar 控制台之間的網路連線
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- 具備管理員或記錄匯出權限,可特殊存取 IBM QRadar
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 請提供下列設定詳細資料:
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
bindplane-ingest)。 - 服務帳戶說明:輸入說明 (例如
Bindplane agent log ingestion)。
- 「Service account name」(服務帳戶名稱):輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後按一下「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 上的/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存路徑相符。 - 依序前往「IAM 與管理」>「設定」,然後複製「專案編號」。匯出工具設定時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「收集代理程式」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」 > 「設定檔」。
複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有 root 或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/ibm_qradar: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: IBM_QRADAR raw_log_field: body ingestion_labels: env: production service: pipelines: logs/qradar_to_chronicle: receivers: - tcplog exporters: - chronicle/ibm_qradar
設定參數
替換下列預留位置:
接收器設定:
tcplog:依通訊協定區分的接收端類型:- UDP syslog 的
udplog tcplog(適用於 TCP syslog)
- UDP syslog 的
0.0.0.0:要監聽的 IP 位址:0.0.0.0:在所有介面上監聽 (建議)- 在一個介面上接聽的特定 IP 位址
514:要接聽的通訊埠號碼 (例如514、1514、6514)
Exporter 設定:
ibm_qradar:匯出工具的說明名稱creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<customer_id>:上一步中的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會以這個值做為chronicle.googleapis.com的前置字元。如需完整清單,請參閱「區域性端點」。project:依序前往「IAM 與管理」>「設定」,然後將<PROJECT_NUMBER>替換為專案編號。endpoint:維持設為chronicle.googleapis.com。IBM_QRADAR:記錄類型,與 Chronicle 中顯示的完全相同ingestion_labels:YAML 格式的選用標籤 (例如env: production)
管道設定:
qradar_to_chronicle::管道的說明名稱
舊版 Ingestion API 匯出工具
如果您使用方式 2 的擷取驗證檔案,請將
exporters區塊替換成下列內容。將creds_file_path設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/ibm_qradar: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: IBM_QRADAR raw_log_field: body ingestion_labels: env: production
儲存設定檔
- 編輯完畢後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」 > 「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector檢查記錄是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務是否正在執行:
sc query observiq-otel-collector檢查記錄是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
設定 IBM QRadar syslog 轉送
- 以管理員身分登入 QRadar 控制台。
- 依序前往「管理」>「系統和授權管理」>「系統設定」。
- 在「轉送目的地」下方,按一下「新增」。
- 提供下列設定詳細資料:
- 名稱:輸入描述性名稱 (例如
Chronicle-Bindplane)。 - IP 位址:輸入 Bindplane 代理程式主機的 IP 位址 (例如
192.168.1.100)。 - 「Port」(通訊埠):輸入
514(必須與 Bindplane 代理接收器通訊埠相符)。 - 通訊協定:選取「TCP」 (建議選取這個選項,確保訊息能可靠地傳送)。
- 格式:選取 LEEF (記錄事件擴充格式)。
- 名稱:輸入描述性名稱 (例如
- 按一下 [儲存]。
- 前往「管理」> 轉送設定檔,即可建立或編輯轉送設定檔。
- 選取要轉送的事件和流程類型:
- 違規事件
- 正規化事件
- 流程資料 (選用)
- 指派在步驟 4 中建立的轉送目的地。
- 按一下「儲存」並部署變更。
檢查 Bindplane 代理程式記錄,確認是否收到 syslog 訊息。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
application |
extensions.auth.type |
已對應:httpd → AUTHTYPE_UNSPECIFIED |
_source.message |
metadata.description |
直接對應 |
message_body |
metadata.description |
直接對應 |
_source.eventTime |
metadata.event_timestamp |
剖析為 ISO8601 |
log_date |
metadata.event_timestamp |
剖析為 MMM dd HH:mm:ss |
application |
metadata.event_type |
對應:httpd → USER_LOGIN、logger → NETWORK_HTTP、CROND → PROCESS_LAUNCH |
has_principal |
metadata.event_type |
對應:true → NETWORK_HTTP、true → NETWORK_CONNECTION、true → STATUS_UPDATE |
_source.eventType |
metadata.product_event_type |
直接對應 |
_source._id |
metadata.product_log_id |
直接對應 |
_source.typeURI |
metadata.url_back_to_product |
直接對應 |
_source.o_requestData.o_request_body.method |
network.http.method |
直接對應 |
response |
network.http.response_code |
已重新命名/對應 |
response_code |
network.http.response_code |
已重新命名/對應 |
_source.o_requestData.o_headers.User-Agent |
network.http.user_agent |
直接對應 |
crypto_algorithm |
network.tls.cipher |
直接對應 |
tls_version |
network.tls.version |
直接對應 |
_source.o_observer.name |
observer.resource.name |
直接對應 |
application |
principal.application |
直接對應 |
_source._host |
principal.asset.hostname |
直接對應 |
_source._ip |
principal.asset.ip |
已合併 |
_source.o_initiator.o_host.address |
principal.asset.ip |
已合併 |
_source._file |
principal.file.full_path |
直接對應 |
_source._host |
principal.hostname |
直接對應 |
_source._ip |
principal.ip |
已合併 |
_source.o_initiator.o_host.address |
principal.ip |
已合併 |
log_ip |
principal.ip |
已合併 |
event_id |
principal.process.pid |
直接對應 |
o_credential |
principal.resource.attribute.labels |
已合併 |
_source.o_requestData.initiatorGUID |
principal.resource.product_object_id |
直接對應 |
_source.o_initiator.typeURI |
principal.url |
直接對應 |
_source.o_requestData.o_request_body.user_name |
principal.user.user_display_name |
直接對應 |
_source.o_initiator.authnId |
principal.user.userid |
直接對應 |
action |
security_result.action |
已合併 |
application |
security_result.action |
已對應:httpd → action |
auth_status |
security_result.action |
對應:(?i)failed → action |
_source.o_requestData.o_request_body.action |
security_result.action_details |
直接對應 |
_source.o_responseData.response_body |
security_result.action_details |
直接對應 |
auth_status |
security_result.description |
直接對應 |
correlationId |
security_result.detection_fields |
已合併 |
dataEvent |
security_result.detection_fields |
已合併 |
platform |
security_result.detection_fields |
已合併 |
saveServiceCopy |
security_result.detection_fields |
已合併 |
scenario_type |
security_result.detection_fields |
已合併 |
log_level |
security_result.severity |
對應:(?i)(error/warning) → HIGH、(?i)notice → MEDIUM、(?i)(information/info) → ... |
_source.severity |
security_result.severity_details |
直接對應 |
_source.o_target.o_host.address |
target.asset.hostname |
直接對應 |
_source.o_target.o_host.address |
target.hostname |
直接對應 |
application |
target.ip |
對應:httpd → host_ip,logger → ip |
host_ip |
target.ip |
已合併 |
ip |
target.ip |
已合併 |
command |
target.process.command_line |
直接對應 |
clientid |
target.resource.attribute.labels |
已合併 |
_source.o_target.typeURI |
target.url |
直接對應 |
request |
target.url |
已重新命名/對應 |
_source.o_target.name |
target.user.user_display_name |
直接對應 |
_source.o_target.id |
target.user.userid |
直接對應 |
auth |
target.user.userid |
已重新命名/對應 |
target_host |
target.user.userid |
直接對應 |
user_id |
target.user.userid |
直接對應 |
| 不適用 | extensions.auth.type |
常數:AUTHTYPE_UNSPECIFIED |
| 不適用 | metadata.event_type |
常數:NETWORK_HTTP |
| 不適用 | metadata.product_name |
常數:IBM QRADAR |
| 不適用 | metadata.vendor_name |
常數:IBM QRADAR |
| 不適用 | security_result.severity |
常數:MEDIUM |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專家尋求解答。