收集 IBM Tivoli 日志
本文档介绍了如何使用 Bindplane 代理将 IBM Tivoli Monitoring 日志注入到 Google Security Operations。
IBM Tivoli Monitoring 是一款企业 IT 基础设施监控和管理套件,可为系统监控事件、资源阈值、工作负载自动化和安全审核事件生成日志。系统会生成 syslog 和键值对格式的事件日志,用于捕获 HTTP 活动、SSH 会话、用户身份验证和网络连接。事件集成设施 (EIF) 可以将情境事件转发到 syslog 接收器。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 IBM Tivoli Monitoring 服务器之间的网络连接
- 如果在代理后面运行,请确保按照 Bindplane 代理要求打开防火墙端口
- 对 IBM Tivoli Monitoring 环境 (TEMS) 的特权访问权限(具有管理员权限)
获取 Bindplane 代理的 Google SecOps 凭据
如需向 Google SecOps 验证 Bindplane 代理,请选择以下方法之一:
- 新部署:使用 Chronicle API(选项 1)。
- 旧版部署:继续使用数据注入身份验证文件(方法 2),直到 Ingestion API 于 2027 年 7 月 20 日停用。
方法 1:为 Chronicle API 创建服务账号(推荐)
- 登录 Google Cloud 控制台,然后选择与您的 Google SecOps 实例关联的 Google Cloud 项目。
- 前往 IAM 和管理 > 服务账号。
- 点击创建服务账号。
- 提供以下配置详细信息:
- 服务账号名称:输入账号的名称(例如
bindplane-ingest)。 - 服务账号说明:输入说明(例如
Bindplane agent log ingestion)。
- 服务账号名称:输入账号的名称(例如
- 点击创建并继续。
- 在向此服务账号授予对项目的访问权限部分,点击选择角色,然后选择 Chronicle Editor。
- 点击继续,然后点击完成。
- 点击您创建的服务账号,然后前往密钥标签页。
- 依次点击添加密钥> 创建新密钥。
- 选择 JSON,然后点击创建。密钥文件会下载到您的计算机上。
- 将密钥文件另存为 Bindplane 收集器目录(Linux 上的
/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json)中的ingestion-auth.json,或更新config.yaml中的creds_file_path以匹配您保存该文件的路径。 - 前往 IAM 和管理 > 设置,然后复制项目编号。您在配置导出器时需要用到该名称。
方法 2:下载数据注入身份验证文件(旧版)
- 登录 Google SecOps 控制台。
- 前往 SIEM 设置> 收集代理。
- 下载数据注入身份验证文件。
- 将文件安全地保存在将要安装 Bindplane 代理的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 前往 SIEM 设置 > 个人资料。
复制并保存组织详细信息部分中的客户 ID。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符或 PowerShell。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector该服务应显示为正在运行。
Linux 安装
- 打开具有 root 或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector该服务应显示为 active (running)。
其他安装资源
如需了解其他安装选项和问题排查,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps
找到配置文件
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/ibm_tivoli: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: IBM_TIVOLI raw_log_field: body ingestion_labels: env: production service: pipelines: logs/tivoli_to_chronicle: receivers: - udplog exporters: - chronicle/ibm_tivoli
配置参数
替换以下占位符:
接收器配置:
udplog:基于协议的接收器类型:udplog(适用于 UDP syslog)tcplog(适用于 TCP syslog)
0.0.0.0:要监听的 IP 地址:0.0.0.0,以监听所有接口(推荐)- 要在一个接口上监听的特定 IP 地址
514:要监听的端口号(例如514、1514、6514)
导出器配置:
ibm_tivoli:导出器的描述性名称creds_file_path:服务账号 JSON 密钥文件的完整路径(选项 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<customer_id>:上一步中的客户 IDlocation:将<LOCATION>替换为 Google SecOps 实例所在的区域(例如us、europe或asia-southeast1)。导出工具会在此值前面加上chronicle.googleapis.com。如需查看完整列表,请参阅区域级端点。project:将<PROJECT_NUMBER>替换为“IAM 和管理”>“设置”中的项目编号。endpoint:保持设置为chronicle.googleapis.com。IBM_TIVOLI:日志类型,与在 Chronicle 中显示的完全一致ingestion_labels:YAML 格式的可选标签(例如env: production)
流水线配置:
tivoli_to_chronicle:流水线的描述性名称
旧版提取 API 导出工具
如果您使用选项 2 中的数据注入身份验证文件,请将
exporters代码块替换为以下内容。将creds_file_path设置为数据注入身份验证文件的路径,如果您的实例位于美国境外,请将malachiteingestion-pa.googleapis.com替换为您的区域端点(例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/ibm_tivoli: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: IBM_TIVOLI raw_log_field: body ingestion_labels: env: production
保存配置文件
- 修改后,保存文件:
- Linux:依次按
Ctrl+O、Enter和Ctrl+X - Windows:依次点击文件 > 保存
- Linux:依次按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志中的错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请选择以下选项之一:
以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector“服务”控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry 收集器。
- 右键点击并选择重启。
验证服务是否正在运行:
sc query observiq-otel-collector检查日志中的错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按
配置 IBM Tivoli Monitoring syslog 转发
- 使用管理员凭证登录 IBM Tivoli Monitoring 服务器。
打开 Tivoli Enterprise Monitoring Server (TEMS) 环境配置文件:
/opt/IBM/ITM/config/<hostname>_ms_<instance>.config配置 Event Integration Facility (EIF),以将情境事件转发到 Bindplane 代理。使用以下参数添加或修改 EIF 配置:
设置 值 ServerLocation Bindplane 代理主机的 IP 地址(例如 192.168.1.100)ServerPort 514(必须与 Bindplane 代理接收器端口匹配)EventFormat SYSLOG重启 TEMS 服务以应用更改:
/opt/IBM/ITM/bin/itmcmd server stop <instance> /opt/IBM/ITM/bin/itmcmd server start <instance>通过检查 Bindplane 代理日志,验证是否正在接收 syslog 消息。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
| 机制 | extensions.auth.mechanism | 直接复制的值 |
| metadata.event_type | 如果设置了 target_hostname 或 target_ip,则设置为“NETWORK_HTTP”;如果设置了 sshd 中的 username 或扩展程序中的 flag_type,则设置为“USER_UNCATEGORIZED”;如果 sshd 接受了密码,则设置为“USER_LOGIN”;如果 sshd 收到了断开连接或控制台具有 product_log_id,则设置为“NETWORK_CONNECTION”;如果 sshd 断开了连接,则设置为“USER_LOGOUT”;如果 has_principal 为 true,则设置为“STATUS_UPDATE”;否则设置为“GENERIC_EVENT” | |
| product_event_type | metadata.product_event_type | 直接复制值 |
| product_log_id、action_code | metadata.product_log_id | 如果 product_log_id 不为空,则取自该值;否则,取自 action_code |
| 协议、proto、msg1 | network.application_protocol | 如果协议与 HTTP 匹配或 msg1 与 POST 匹配,则设置为“HTTP”;如果协议与 ssh 或 ssh2 匹配,则设置为“SSH” |
| method, msg1 | network.http.method | 如果方法不为空,则为方法中的值;如果 msg1 与 POST 匹配,则为“POST” |
| 网址 | network.http.referral_url | 如果不是“/”,则直接复制值 |
| response_code | network.http.response_code | 已转换为整数 |
| 代理 | network.http.user_agent | 直接复制的值 |
| 代理 | network.http.parsed_user_agent | 使用 parseduseragent 转换 |
| msg1 | network.ip_protocol | 如果 msg1 与 TCP/IP 匹配,则设置为“TCP” |
| session_id | network.session_id | 直接复制值 |
| hashing_algo | network.tls.client.supported_ciphers | 直接复制值 |
| tls_version | network.tls.version | 直接复制的值 |
| ServerName、hostname、dvc、host | principal.asset.hostname | 如果 ServerName 不为空,则为 ServerName 中的值;否则为主机名;否则为 dvc;否则为 host |
| SourceAddress、src_ip、srcIp | principal.asset.ip | 如果 SourceAddress 不为空,则返回 SourceAddress 中的值;否则返回 src_ip;否则返回 srcIp |
| ServerName、hostname、host | principal.hostname | 如果 ServerName 不为空,则使用 ServerName 中的值;否则使用主机名;否则使用主机 |
| SourceAddress、src_ip、srcIp | principal.ip | SourceAddress 的值(如果不为空),否则为 src_ip,否则为 srcIp |
| srcPort | principal.port | 已转换为整数 |
| source_file | principal.process.file.full_path | 直接复制的值 |
| SourceModuleName | principal.resource.name | 直接复制的值 |
| role_user | principal.user.attribute.roles | 已合并为数组,名称来自 role_user |
| UserCN | principal.user.group_identifiers | 直接复制值 |
| role_user | principal.user.role_name | 直接复制值 |
| username, flag_type | principal.user.userid | 如果 flag_type 不为空且不是“Session”,则取自 flag_type,否则取自用户名 |
| ConnectionID | security_result.about.labels | 合并为标签,键为“ConnectionID”,值为 ConnectionID 的值 |
| Outcome, response_code | security_result.action | 如果 Outcome ==“Success”或 response_code 在 100-399 范围内,则设置为“ALLOW”;如果 Outcome ==“Invalid credentials”或 response_code 不在 100-399 范围内,则设置为“BLOCK” |
| desc, action, reason, msg1, extension, msg2 | security_result.description | 如果存在说明和原因,则设置为说明 +“:”+ 操作 +“ - ”+ 原因;如果不存在说明和原因,则设置为操作;否则,设置为操作 +“ - ”+ 原因;或者根据上下文设置为 msg1、扩展程序或 msg2 |
| rule_name | security_result.rule_name | 直接复制的值 |
| 摘要 | security_result.summary | 直接复制值 |
| 原始事件 | target.application | 直接复制的值(适用于 sshd) |
| dvc、target_hostname、host | target.asset.hostname | 如果 dvc 中的值不为空,则使用该值;否则使用 target_hostname;否则使用 host |
| target_ip | target.asset.ip | 直接复制的值 |
| dvc、target_hostname、host | target.hostname | 如果 dvc 中的值不为空,则使用该值;否则使用 target_hostname;否则使用 host |
| target_ip | target.ip | 直接复制值 |
| pid | target.process.pid | 直接复制的值 |
| uid, username | target.user.userid | 从消息中提取的 UID 值,或从 sshd 接受的密码的用户名中提取的值 |
| metadata.product_name | 设置为“IBM_TIVOLI” | |
| metadata.vendor_name | 设置为“IBM” |
更新日志
需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。