收集 IBM Tivoli 記錄
本文說明如何使用 Bindplane 代理程式,將 IBM Tivoli Monitoring 記錄擷取至 Google Security Operations。
IBM Tivoli Monitoring 是企業 IT 基礎架構監控與管理套件,可產生系統監控事件、資源門檻、工作負載自動化和安全稽核事件的記錄。系統會以 syslog 和鍵值格式產生事件記錄,擷取 HTTP 活動、SSH 工作階段、使用者驗證和網路連線。事件整合設施 (EIF) 可將情況事件轉送至系統記錄接收器。
事前準備
請確認您已完成下列事前準備事項:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 IBM Tivoli Monitoring 伺服器之間的網路連線
- 如果透過 Proxy 執行,請確保防火牆通訊埠已根據 Bindplane 代理程式需求開啟
- 具備管理員權限的 IBM Tivoli Monitoring 環境 (TEMS) 特殊存取權
取得 Google SecOps 擷取驗證檔案
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「收集代理程式」。
- 下載擷取驗證檔案。
將檔案安全地儲存在要安裝 Bindplane 的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「設定檔」。
複製並儲存「機構詳細資料」部分中的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟「命令提示字元」或「PowerShell」。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
Linux 安裝
- 開啟具有根層級或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為有效 (執行中)。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄檔並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的所有內容替換為下列設定:receivers: udplog: listen_address: "0.0.0.0:514" exporters: chronicle/ibm_tivoli: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: IBM_TIVOLI raw_log_field: body ingestion_labels: env: production service: pipelines: logs/tivoli_to_chronicle: receivers: - udplog exporters: - chronicle/ibm_tivoli
設定參數
替換下列預留位置:
接收器設定:
udplog:根據通訊協定的接收器類型:udplog(適用於 UDP 系統記錄檔)tcplog適用於 TCP Syslog
0.0.0.0:要接聽的 IP 位址:0.0.0.0,監聽所有介面 (建議)- 在一個介面上接聽的特定 IP 位址
514:要接聽的通訊埠號碼 (例如514、1514、6514)
匯出工具設定:
ibm_tivoli:匯出工具的說明名稱creds_file_path:擷取驗證檔案的完整路徑:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<customer_id>:上一步中的客戶 IDendpoint:區域端點網址:- 美國:
malachiteingestion-pa.googleapis.com - 歐洲:
europe-malachiteingestion-pa.googleapis.com - 亞洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需完整清單,請參閱「區域端點」
- 美國:
IBM_TIVOLI:記錄類型,與 Chronicle 中顯示的完全相同ingestion_labels:YAML 格式的選用標籤 (例如env: production)
管道設定:
tivoli_to_chronicle:管道的說明名稱
儲存設定檔
- 編輯完成後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」>「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,以套用變更
如要在 Linux 中重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector檢查記錄中是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列其中一個選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R,輸入services.msc,然後按下 Enter 鍵。 - 找出 observIQ OpenTelemetry Collector。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務正在執行:
sc query observiq-otel-collector檢查記錄中是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
設定 IBM Tivoli Monitoring 系統記錄檔轉送
- 使用管理員憑證登入 IBM Tivoli Monitoring 伺服器。
開啟 Tivoli Enterprise Monitoring Server (TEMS) 環境設定檔:
/opt/IBM/ITM/config/<hostname>_ms_<instance>.config設定事件整合設施 (EIF),將情境事件轉送至 Bindplane 代理程式。使用下列參數新增或修改 EIF 設定:
設定 值 ServerLocation Bindplane 代理程式主機的 IP 位址 (例如 192.168.1.100)ServerPort 514(必須與 Bindplane 代理程式接收端埠相符)EventFormat SYSLOG重新啟動 TEMS 服務,以套用變更:
/opt/IBM/ITM/bin/itmcmd server stop <instance> /opt/IBM/ITM/bin/itmcmd server start <instance>查看 Bindplane 代理程式記錄,確認是否收到系統記錄訊息。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
| 機制 | extensions.auth.mechanism | 直接複製值 |
| metadata.event_type | 如果設定 target_hostname 或 target_ip,請設為「NETWORK_HTTP」;如果設定 sshd 中的使用者名稱或擴充功能中的 flag_type,請設為「USER_UNCATEGORIZED」;如果 sshd 接受密碼,請設為「USER_LOGIN」;如果 sshd 收到中斷連線或主控台有 product_log_id,請設為「NETWORK_CONNECTION」;如果 sshd 中斷連線,請設為「USER_LOGOUT」;如果 has_principal 為 true,請設為「STATUS_UPDATE」;否則請設為「GENERIC_EVENT」 | |
| product_event_type | metadata.product_event_type | 直接複製值 |
| product_log_id、action_code | metadata.product_log_id | 如果 product_log_id 不為空,則為該值,否則為 action_code |
| protocol、proto、msg1 | network.application_protocol | 如果通訊協定符合 HTTP 或 msg1 符合 POST,請設為「HTTP」;如果 proto 符合 ssh 或 ssh2,請設為「SSH」 |
| 方法、msg1 | network.http.method | 如果方法不為空,則為方法中的值;如果 msg1 符合 POST,則為「POST」 |
| 網址 | network.http.referral_url | 如果不是「/」,則直接複製值 |
| response_code | network.http.response_code | 已轉換為整數 |
| 代理程式 | network.http.user_agent | 直接複製值 |
| 代理程式 | network.http.parsed_user_agent | 使用 parseduseragent 轉換 |
| msg1 | network.ip_protocol | 如果 msg1 符合 TCP/IP,請設為「TCP」 |
| session_id | network.session_id | 直接複製值 |
| hashing_algo | network.tls.client.supported_ciphers | 直接複製值 |
| tls_version | network.tls.version | 直接複製值 |
| ServerName、hostname、dvc、host | principal.asset.hostname | 如果 ServerName 不為空白,則為 ServerName 的值;否則為主機名稱;否則為 dvc;否則為主機 |
| SourceAddress、src_ip、srcIp | principal.asset.ip | 如果 SourceAddress 不為空白,則為該值;否則為 src_ip;否則為 srcIp |
| ServerName、hostname、host | principal.hostname | 如果 ServerName 不為空白,則為 ServerName 的值;否則為主機名稱,否則為主機 |
| SourceAddress、src_ip、srcIp | principal.ip | 如果 SourceAddress 不為空白,則為該值;否則為 src_ip;否則為 srcIp |
| srcPort | principal.port | 已轉換為整數 |
| source_file | principal.process.file.full_path | 直接複製值 |
| SourceModuleName | principal.resource.name | 直接複製值 |
| role_user | principal.user.attribute.roles | 以來自 role_user 的名稱合併為陣列 |
| UserCN | principal.user.group_identifiers | 直接複製值 |
| role_user | principal.user.role_name | 直接複製值 |
| username、flag_type | principal.user.userid | 如果 flag_type 的值不為空白且不是「Session」,則為該值;否則為使用者名稱 |
| ConnectionID | security_result.about.labels | 合併為標籤,鍵為「ConnectionID」,值來自 ConnectionID |
| 結果、response_code | security_result.action | 如果 Outcome ==「Success」或 response_code 介於 100 到 399 之間,請設為「ALLOW」;如果 Outcome ==「Invalid credentials」或 response_code 不介於 100 到 399 之間,請設為「BLOCK」 |
| desc、action、reason、msg1、extension、msg2 | security_result.description | 如果 desc 和 reason 存在,則設為 desc + ": " + action + " - " + reason;如果 desc 和 reason 不存在,則設為 action;如果 desc 不存在但 reason 存在,則設為 action + " - " + reason;視情況設為 msg1、extension 或 msg2 |
| rule_name | security_result.rule_name | 直接複製值 |
| 摘要 | security_result.summary | 直接複製值 |
| 反向擴散程序 | target.application | 直接複製值 (適用於 sshd) |
| dvc、target_hostname、host | target.asset.hostname | 如果 dvc 不是空白,則為 dvc 中的值,否則為 target_hostname,否則為 host |
| target_ip | target.asset.ip | 直接複製值 |
| dvc、target_hostname、host | target.hostname | 如果 dvc 不是空白,則為 dvc 中的值,否則為 target_hostname,否則為 host |
| target_ip | target.ip | 直接複製值 |
| pid | target.process.pid | 直接複製值 |
| uid、使用者名稱 | target.user.userid | 從 Message 擷取的 uid 值,或 sshd Accepted password 的使用者名稱 |
| metadata.product_name | 設為「IBM_TIVOLI」 | |
| metadata.vendor_name | 設為「IBM」 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求答案。